Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 25-06-2013 09:27:55

julian7
Membre
Distrib. : Debian Jessie Server / Desktop
(G)UI : Gnome
Inscription : 25-06-2013

[Résolu] Problème avec le paquet nfs-common et apt-get

Bonjour tout le monde !! smile

J'ai un soucis avec le paquet nfs-common depuis quelque temps sur ma debian wheezy server : 

root@Debian7Serv:/home/julian# apt-get upgrade
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
0 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.
1 partiellement installés ou enlevés.
Après cette opération, 0 o d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer [O/n] ? o
Paramétrage de nfs-common (1:1.2.6-4) ...
insserv: warning: script 'K01firewall' missing LSB tags and overrides
insserv: Service rpcbind has to be enabled to start service nfs-common
insserv: exiting now!
update-rc.d: error: insserv rejected the script header
dpkg: erreur de traitement de nfs-common (--configure) :
 le sous-processus script post-installation installé a retourné une erreur de sortie d'état 1
Des erreurs ont été rencontrées pendant l'exécution :
 nfs-common
E: Sub-process /usr/bin/dpkg returned an error code (1)
root@Debian7Serv:/home/julian#
 



J'ai ces erreurs dès que je lance un apt-get install / upgrade / dist-upgrade .
J'ai essayé un :

apt-get remove nfs-common
apt-get remove portmap
apt-get install portmap
apt-get install nfs-common



Mais rien n'y change !

Je pensais à un problème de source mais mon sources.list est correct, j'ai regardé sur la documentation !

Merci pour votre futur aide smile

Julian

Dernière modification par julian7 (25-06-2013 13:22:06)

Hors ligne

#2 25-06-2013 09:40:59

freddec
homo-informaticus du genre linuxo-debianicum
Lieu : Saint Jean d'Y (17)
Distrib. : Branche Stable (Jessie)
Noyau : Linux 3.16.0-4-amd64
(G)UI : XFCE_4.1 (+/- Mate) (+/- Cinnamon)
Inscription : 09-01-2008

Re : [Résolu] Problème avec le paquet nfs-common et apt-get

Salut,

Je n'utilise pas NFS, mais dans les erreurs je lis ceci:



dpkg a écrit :

insserv: Service rpcbind has to be enabled to start service nfs-common





As tu vérifié sir le service RPCBind tourne ou non ?


Sinon, j'ai trouvé ceci qui pourra peut-être t'aider
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=657963


Desktop: Jessie (I5 - 16Go)
Laptop 1: Jessie (HP DV9000, 3Go)
Laptop 2: Jessie (PackardBell TS 44, Core I5, 4Go)
EeePC : Jessie (Atom N450, 2 Go)

Hors ligne

#3 25-06-2013 13:21:07

julian7
Membre
Distrib. : Debian Jessie Server / Desktop
(G)UI : Gnome
Inscription : 25-06-2013

Re : [Résolu] Problème avec le paquet nfs-common et apt-get

Merci beaucoup !!
J'ai eu juste à faire :

apt-get purge nfs-common
apt-get purge rpcbind
apt-get install rpcbind
apt-get install nfs-common



Et tout est rentré dans l'ordre ! Je ne comprends quand même pas trop pourquoi car je n'ai touché ni à l'un ni à l'autre paquet !

Encore merci !

Julian

Hors ligne

Pied de page des forums