Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 25-06-2013 10:23:06

lolo06
Membre
Distrib. : Debian 7.1.0 i386 Wheezy
Noyau : Linux 3.2.0-4-686-pae
(G)UI : Gnome 3.4.2
Inscription : 20-06-2013

[Résolu] Problème d'installation de Java

Bonjour,

je ne parviens pas à installer correctement le plugin Sun-Java6-plugin pour les applications java d'Iceweasel.
Openjdk-6-jre (6b27-1.12.5-1) et Iceadtea6-plugin sont installés sur le système et quand je lance l'installation de sun-java6-plugin, 1 message d'erreur m'indique:
"Erreur: la dépendance ne peut être satisfaite"
A priori, la version Openjdk-7-jre et ses dépendances ne sont pas installées alors que je suis sous debian 7 Wheezy et que la version 6 serait pour la version Squeeze, mais en fait je n'en sais rien.
D'après mes recherches sur le Net il s'agirait d'une incompatibilité entre cette version du plugin et les paquets installés mais je n'en suis pas sûr non plus.
Pouvez-vous m'aider à régler ce problème s'il vous plaît ?
Merci d'avance pour vos réponses.

Dernière modification par lolo06 (25-06-2013 20:25:39)


papa disait: " mieux 1 qui sait que 100 qui ne savent pas !"

Hors ligne

#2 25-06-2013 12:08:32

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : [Résolu] Problème d'installation de Java

Salut lolo06,

Essaie avec aptitude pour voir :
Problème de paquets. aptitude vous en dit plus ! Le tuto est ici. smile

Et rapporte ici ce que cette commande te propose.

"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#3 25-06-2013 13:22:08

lolo06
Membre
Distrib. : Debian 7.1.0 i386 Wheezy
Noyau : Linux 3.2.0-4-686-pae
(G)UI : Gnome 3.4.2
Inscription : 20-06-2013

Re : [Résolu] Problème d'installation de Java

Salut smolski et merci pour ton aide et le temps que tu m'accordes.

J'ai fait 3 commandes:
aptitude versions openjdk, aptitude versions java et aptitude versions sun.

Pour les paquets openjdk, 2 versions sont installées, la 6 et la 7 .... Ai-je installé la 6, franchement je ne me rappelle pas. A force de bidouiller (mais pas trop quand même), je m'y perds.


aptitude versions openjdk

donne:

Paquet openjdk-6-dbg :
p   6b27-1.12.5-1                                 stable                    500

Paquet openjdk-6-demo :
p   6b27-1.12.5-1                                 stable                    500

Paquet openjdk-6-doc :
p   6b27-1.12.5-1                                 stable                    500

Paquet openjdk-6-jdk :
p   6b27-1.12.5-1                                 <NULL>,stable             500

Paquet openjdk-6-jre :
i A 6b27-1.12.5-1                                 <NULL>,stable             500

Paquet openjdk-6-jre-headless :
i A 6b27-1.12.5-1                                 <NULL>,stable             500

Paquet openjdk-6-jre-lib :
i A 6b27-1.12.5-1                                 <NULL>,stable             500

Paquet openjdk-6-jre-zero :
p   6b27-1.12.5-1                                 stable                    500

Paquet openjdk-6-source :
p   6b27-1.12.5-1                                 stable                    500

Paquet openjdk-7-dbg :
p   7u3-2.1.7-1                                   stable                    500

Paquet openjdk-7-demo :
p   7u3-2.1.7-1                                   stable                    500

Paquet openjdk-7-doc :
p   7u3-2.1.7-1                                   stable                    500

Paquet openjdk-7-jdk :
p   7u3-2.1.7-1                                   stable                    500

Paquet openjdk-7-jre :
p   7u3-2.1.7-1                                   stable                    500

Paquet openjdk-7-jre-headless :
p   7u3-2.1.7-1                                   stable                    500

Paquet openjdk-7-jre-lib :
p   7u3-2.1.7-1                                   stable                    500

Paquet openjdk-7-jre-zero :
p   7u3-2.1.7-1                                   stable                    500

Paquet openjdk-7-source :
p   7u3-2.1.7-1                                   stable                    500

Paquet uwsgi-plugin-jvm-openjdk-6 :
p   1.2.3+dfsg-5                                  stable                    500

Paquet uwsgi-plugin-jwsgi-openjdk-6 :
p   1.2.3+dfsg-5                                  stable                    500


Les 2 autres renvoient de nombreuses données. J'attendrai, avant de les poster, que tu me le demandes.

Dernière modification par lolo06 (25-06-2013 13:22:35)


papa disait: " mieux 1 qui sait que 100 qui ne savent pas !"

Hors ligne

#4 25-06-2013 14:36:25

gKsam
Membre
Lieu : LAON
Distrib. : Debian 8 (jessie)
(G)UI : XFCE
Inscription : 06-08-2010

Re : [Résolu] Problème d'installation de Java

salut,

tu peux aussi tenter d'installer la vrai version de java (celle d'oracle) car openjdk n'est pas oracle java.

pour ça :
1 - télécharger la version RPM du JRE http://java.com/fr/download/linux_manual.jsp?locale=fr
2 - convertir le .rpm en .deb avec alien
3 - installer le paquets deb généré
4 - s'il y a toujours le bug jexec alors il faudra bidouiller un peu le fichier /etc/init.d/jexec
(ça marche avec le petit bug, c'est juste des messages d'alerte. mais ça n'est pas très joli)

ensuite, pour choisir le "java" que tu veux par défaut, il faudra aller voir du côte de update-alternative, mais là bonne chance car c'est vite le bordel.

c'est comme ça que je fais pour avoir la version de java d'oracle avec la wheezy.

Et oui, oracle ne fourni plus le paquet deb vu que debian ne le mets plus dans les dépôts.

pourquoi faire compliqué quand faire simple paraît plus compliqué.

Hors ligne

#5 25-06-2013 15:06:57

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : [Résolu] Problème d'installation de Java

lolo06

Tu peux mettre chaque résultat entre code, pas seulement la commande lancée.
En fait je désire voir ce qu'indique aptitude lorsque tu proposes l'installation des paquets avant que tu dises oui (y). cool

aptitude install ... les paquets...


Reste que la remarque de gKsam :

Et oui, oracle ne fourni plus le paquet deb vu que debian ne le mets plus dans les dépôts.


indique que tu n'auras pas d'installation possible de ces paquets directement par debian. roll


"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#6 25-06-2013 15:45:53

deuchdeb
Moderato ma non troppo
Lieu : Pays de Cocagne
Distrib. : Jessie 8 + backports
Noyau : linux-image-3.16
(G)UI : KDE4.14 - Mate
Inscription : 13-01-2010

Re : [Résolu] Problème d'installation de Java

Wheezy installe par défaut la version 6 de openjdk mais on peut installer la version 7.

Apt-get install openjdk-7-jre icedtea-7-plugin



http://packages.debian.org/fr/wheezy/openjdk-7-jre
http://packages.debian.org/fr/wheezy/icedtea-7-plugin

Cela installera avec toutes les dépendances nécessaires.

Dernière modification par deuchdeb (25-06-2013 19:39:03)

Hors ligne

#7 25-06-2013 17:19:11

Thuban
Modérateur
Distrib. : OpenBSD
Noyau : current
(G)UI : xfce ou dwm
Inscription : 09-01-2009
Site Web

Re : [Résolu] Problème d'installation de Java

gKsam a écrit :

salut,

tu peux aussi tenter d'installer la vrai version de java (celle d'oracle) car openjdk n'est pas oracle java.


Attention, cette solution n'est pas libre.


1 - télécharger la version RPM du JRE http://java.com/fr/download/linux_manual.jsp?locale=fr


Autant que possible, il est conseillé d'éviter d'utiliser des paquets tiers, qui n'ont pas été approuvés par les équipes de debian, et peuvent constituer des failles de sécurité.
Ou alors, il faut vraiment savoir ce que l'on fait (pas installation du paquet mais décompression dans un dossier utilisateur, pseudo-chrot... bref, bidouille)


YA3HGA-H

Hors ligne

#8 25-06-2013 17:58:42

lolo06
Membre
Distrib. : Debian 7.1.0 i386 Wheezy
Noyau : Linux 3.2.0-4-686-pae
(G)UI : Gnome 3.4.2
Inscription : 20-06-2013

Re : [Résolu] Problème d'installation de Java

Je viens de suivre la procédure de deuchdeb et tout fonctionne au poil cool
2 petites questions quand même:
La version 7 d'openjdk-7-jre n'était-elle pas déjà installée ? enfin est-il possible de désinstaller la version 6  ?
Le système tourne très bien sur ma vieille bécane, l'interface graphique ( Gnome 3.4.2) est très sympa et je la découvre à peine.

Merci pour vos réponses !

papa disait: " mieux 1 qui sait que 100 qui ne savent pas !"

Hors ligne

#9 25-06-2013 17:59:02

gKsam
Membre
Lieu : LAON
Distrib. : Debian 8 (jessie)
(G)UI : XFCE
Inscription : 06-08-2010

Re : [Résolu] Problème d'installation de Java

Autant que possible, il est conseillé d'éviter d'utiliser des paquets tiers, qui n'ont pas été approuvés par les équipes de debian, et peuvent constituer des failles de sécurité.



Je sais bien. sad

Mais parfois il faut bien en passer pas là. Le temps de migrer tout une application en java (oracle) vers openjdk.


pourquoi faire compliqué quand faire simple paraît plus compliqué.

Hors ligne

#10 25-06-2013 19:43:52

deuchdeb
Moderato ma non troppo
Lieu : Pays de Cocagne
Distrib. : Jessie 8 + backports
Noyau : linux-image-3.16
(G)UI : KDE4.14 - Mate
Inscription : 13-01-2010

Re : [Résolu] Problème d'installation de Java

La version 7 d'openjdk-7-jre n'était-elle pas déjà installée ? enfin est-il possible de désinstaller la version 6  ?



Non la version 7 n'est pas installée par défaut mais elle est présente dans les dépôts.

Dernière modification par deuchdeb (25-06-2013 19:45:13)

Hors ligne

#11 25-06-2013 20:24:55

lolo06
Membre
Distrib. : Debian 7.1.0 i386 Wheezy
Noyau : Linux 3.2.0-4-686-pae
(G)UI : Gnome 3.4.2
Inscription : 20-06-2013

Re : [Résolu] Problème d'installation de Java

Merci pour l'info et passez une bonne soirée.

papa disait: " mieux 1 qui sait que 100 qui ne savent pas !"

Hors ligne

Pied de page des forums