Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 26-06-2013 00:30:49

Muselaar
Adhérent(e)
Distrib. : Debian Jessie 8.2
Noyau : Linux 3.16.0-4-amd64
(G)UI : XFCE 4.10.1
Inscription : 20-05-2013

[Résolu] Ouvrir un dossier en tant que root

Bonsoir,

je découvre ce soir que j'ignore comment ouvrir un dossier en tant que root (il s'agit en fait d'un disque externe avec du contenu créé sous Mac Os X), pour avoir accès au contenu (en l'occurence, un film que je voulais voir), quand l'accès est refusé par manque de droits dessus.
J'avais le souvenir que dans Cinnamon, essayé quelques jours, il y avait un item de menu, dans le navigateur de fichiers, du genre « ouvrir en tant que root », mais je n'ai pas réussi à le retrouver avec Thunar, ni même avec Nautilus. J'ai installé le paquet gksu, mais cela n'a pas produit l'apparition tant attendue…

Comment fait-on, habituellement ? je suppose que si aucun item n'est trouvable, c'est qu'il y a un moyen beaucoup plus facile…

Dernière modification par Muselaar (27-06-2013 20:44:45)


MacBook Pro 7.1 de mi-2009 en dual boot depuis mai 2013 (Debian Jessie + Snow Leopard). Clavier TypeMatrix 2030 USB en bépo. Sauf rares cas, utilisation exclusive de la Debian. Mais je suis loin d'être un pro.

Hors ligne

#2 26-06-2013 09:35:56

jean-kiki
Membre
Distrib. : Debian jessie
Noyau : Linux 3.9-1-amd64
(G)UI : xfce 4.10 + compiz 0.8.4-5.2
Inscription : 18-09-2012

Re : [Résolu] Ouvrir un dossier en tant que root

bonjour,
alors pour ouvrir thunar il faut taper thunar dans un terminal cool
si tu le fais en tant que utilisateur normal il va te l'ouvrir comme normalement ! si tu te met d'abord en root (avec su ou sudo thunar) il va te l'ouvrir en mode superutilisateur !...Avec un beau message d'avertissement pour dire qu'on peut faire des bêtises car on peut bidouiller tout les fichiers système comme ça et que vaut mieux éviter.

Moi je dis rien car j'ai commencé comme ça aussi quand je trouvais pas roll

Mais une meilleur solution serai peut-être de regarder les droits des fichiers avec par exemple :
chmod : pour changer les droits d'accès aux fichiers et chown : pour changer de groupe utilisateur

sinon avec thunar en mode utilisateur normal essaye un clique droit sur le fichier-> propriétés-> permissions et regarde si ton nom utilisateur apparaît en tant que "propriétaire" l'accès doit alors être "lecture et écriture" puis : "lecteur seul" pour le "groupe" et pour "les autres".

En espérant avoir été clair car j'ai mis du temps à comprendre que les droits d'accès c'est une notion ESSENTIELLE qui te servira toujours smile bon courage...

Ça, ce sont les sources. Le mouton que tu veux est dedans.
Merci, c'est tout à fait comme ça que je le voulais ! Crois-tu qu'il faille beaucoup de ressources à ce mouton ? Parce que ma config est toute petite...
Ça devrait aller. Tu peux te compiler un petit mouton.
Pas si petit que ça. Tiens ! il s'est mis en veille...

Hors ligne

#3 26-06-2013 09:40:52

deuchdeb
Moderato ma non troppo
Lieu : Pays de Cocagne
Distrib. : Jessie 8 + backports
Noyau : linux-image-3.16
(G)UI : KDE4.14 - Mate
Inscription : 13-01-2010

Re : [Résolu] Ouvrir un dossier en tant que root

Est avec ce disque externe seulement que le problème est présent ou avec tous les diques externes?

En effet, si tu as installé debian à partir d'une clef usb tu peux avoir une ligne en trop dans ton fichier /etc/fstab et du coup les disques externes ne montent pas.

Dans ce cas la solution est ici: http://debian-facile.org/viewtopic.php?pid=28996#p28996

Hors ligne

#4 26-06-2013 21:53:23

bendia
Admin stagiaire
Distrib. : Jessie
Noyau : 3.16.0-4-amd64
(G)UI : Gnome + XFCE + Console
Inscription : 20-03-2012
Site Web

Re : [Résolu] Ouvrir un dossier en tant que root

jean-kiki a écrit :

(avec su ou sudo thunar)



Hum hmm , il me semble qu'il vaut mieux éviter d'utiliser su ou sudo pour des logiciels en mode graphique. Il vaut mieux utiliser gksu(do) ou kdesu(do) si il faut lancer un tel logiciel avec des droits root. Une sombre histoire de .Xauthority mal placé capable de planter ta session X si j'ai bien compris


Ben
___________________
La seule question bête, c'est celle qu'on ne pose pas.
file-Re06858991f6f328b4907296ac5cea283

En ligne

#5 26-06-2013 22:15:07

Muselaar
Adhérent(e)
Distrib. : Debian Jessie 8.2
Noyau : Linux 3.16.0-4-amd64
(G)UI : XFCE 4.10.1
Inscription : 20-05-2013

Re : [Résolu] Ouvrir un dossier en tant que root

deuchdeb a écrit :

Est avec ce disque externe seulement que le problème est présent ou avec tous les diques externes?

En effet, si tu as installé debian à partir d'une clef usb tu peux avoir une ligne en trop dans ton fichier /etc/fstab et du coup les disques externes ne montent pas.

Dans ce cas la solution est ici: http://debian-facile.org/viewtopic.php?pid=28996#p28996



En fait, le problème est présent avec tous les disques externes, et je n’ai pas fait mon installation depuis une clé USB, seulement depuis un DVD.
Mais ce n’est pas un problème d’accès au volume, mais seulement de droits d’accès. Ce qui me surprend (et je l’avais déjà remarqué lors de précédentes tentatives de switch), c’est que Linux tient compte des droits sur les volumes externes, alors que Mac Os X ne tient compte des droits qu’à l’intérieur du volume de démarrage. Du coup, ça rend un peu compliqué la gestion des disques externes qui contiennent des fichiers créés sous Mac Os X.

Je vais essayer de comprendre comment me dépatouiller grâce aux autres conseils, et je reviendrai dire ce que j’ai réussi à faire. Mais là, j’ai un problème plus grave et plus urgent sur lequel je vais poster tout de suite.


MacBook Pro 7.1 de mi-2009 en dual boot depuis mai 2013 (Debian Jessie + Snow Leopard). Clavier TypeMatrix 2030 USB en bépo. Sauf rares cas, utilisation exclusive de la Debian. Mais je suis loin d'être un pro.

Hors ligne

#6 27-06-2013 14:43:37

freddec
homo-informaticus du genre linuxo-debianicum
Lieu : Saint Jean d'Y (17)
Distrib. : Branche Stable (Jessie)
Noyau : Linux 3.16.0-4-amd64
(G)UI : XFCE_4.1 (+/- Mate) (+/- Cinnamon)
Inscription : 09-01-2008

Re : [Résolu] Ouvrir un dossier en tant que root

Salut

As tu installé pmount -> voir la page de l’excellent wiki de DF  ;-)) 

Cet utilitaire de montage en espace utilisateur pourrais bien te simplifier la vie !

Tient nous au courant

Desktop: Jessie (I5 - 16Go)
Laptop 1: Jessie (HP DV9000, 3Go)
Laptop 2: Jessie (PackardBell TS 44, Core I5, 4Go)
EeePC : Jessie (Atom N450, 2 Go)

Hors ligne

#7 27-06-2013 19:17:16

Muselaar
Adhérent(e)
Distrib. : Debian Jessie 8.2
Noyau : Linux 3.16.0-4-amd64
(G)UI : XFCE 4.10.1
Inscription : 20-05-2013

Re : [Résolu] Ouvrir un dossier en tant que root

pmount



Ce n'était pas installé, effectivement, mais mes connaissances en ligne de commande sont trop faibles pour que j'arrive à obtenir quelque chose d'autre que l'étalage de toutes les options possibles. Le tuto en particulier n'indique pas comment on peut forcer les permissions du volume externe, et c'est là mon problème. Car pour le montage proprement dit, il n'y aucun souci, il suffit juste de taper le mot de passe root à l'invite graphique. Mes volumes ont tous des noms avec des espaces, je ne sais pas si c'est là le problème…

Il y a aussi une autre contrainte à mon problème : s'agissant de la sauvegarde automatique effectuée par Time Machine sous Mac, je ne peux rien changer des droits, sans craindre le gros bazar si je veux continuer quelques temps à m'en servir sous Mac.

Un autre point qui demeure obscur pour moi, c'est comment on peut mixer la ligne de commande avec l'interface graphique… Il me semblait qu'on faisait soit l'un soit l'autre, mais passer de l'un à l'autre dans un processus, voilà qui m'est abscons.

En fait mon problème est tout con : j'ai un disque dur externe avec des fichiers dessus, et je veux les lire.

J'ai utilisé Cinnamon, et il y avait un item dans l'interface graphique « ouvrir le dossier en tant que root », qui me convenait très bien. Comment faire la même chose avec XFCE ?

Dernière modification par Muselaar (27-06-2013 19:20:04)


MacBook Pro 7.1 de mi-2009 en dual boot depuis mai 2013 (Debian Jessie + Snow Leopard). Clavier TypeMatrix 2030 USB en bépo. Sauf rares cas, utilisation exclusive de la Debian. Mais je suis loin d'être un pro.

Hors ligne

#8 27-06-2013 20:04:39

bendia
Admin stagiaire
Distrib. : Jessie
Noyau : 3.16.0-4-amd64
(G)UI : Gnome + XFCE + Console
Inscription : 20-03-2012
Site Web

Re : [Résolu] Ouvrir un dossier en tant que root

Bonsoir

J'ai utilisé Cinnamon, et il y avait un item dans l'interface graphique « ouvrir le dossier en tant que root », qui me convenait très bien. Comment faire la même chose avec XFCE ?



Oui, ça s'appelle les action personalisée Editer > Configurer les actions personalisées > Open folder as root

Tu y accèdes ensuite par un clic droit comme dans l'explorateur de fichier de Cinnamon smile

Un autre point qui demeure obscur pour moi, c'est comment on peut mixer la ligne de commande avec l'interface graphique… Il me semblait qu'on faisait soit l'un soit l'autre, mais passer de l'un à l'autre dans un processus, voilà qui m'est abscons.



Les interfaces graphique que nous utilisons sont, comme leurs nom l'indique des interfaces entre nous et la ligne de commande. Elles lancent donc pour nous des ligne de commandes. Pour illustrer mon propos, si tu édites l'action personalisée Open folder as root, tu verra la commande bash dont on parlait plus haut :

gksu Thunar %F

smile

Donc, on peut parfaitement lancer un logiciel graphique en ligne de commande (utiliser gksu | kdesu pour le lancer en tant que root ). Cela apporte d'ailleurs parfois des informations en cas de mauvais fonctionnement, puisqu'on à le code retour de la commande et la sortie d'erreur. On peut également passer des options que notre interface graphique ne passe pas.

Tu peux d'ailleurs regarder le manuel de tes logiciels habituels en ligne de commande avec

man ton_logiciel


Ben
___________________
La seule question bête, c'est celle qu'on ne pose pas.
file-Re06858991f6f328b4907296ac5cea283

En ligne

#9 27-06-2013 20:44:03

Muselaar
Adhérent(e)
Distrib. : Debian Jessie 8.2
Noyau : Linux 3.16.0-4-amd64
(G)UI : XFCE 4.10.1
Inscription : 20-05-2013

Re : [Résolu] Ouvrir un dossier en tant que root

Merci merci merci !

C'est exactement ce que je voulais retrouver… Heureusement que tes explications étaient assez exhaustives, et que tu m'as indiqué la commande, je ne l'aurais jamais inventée sinon.

Ça marche bien, merci aussi pour les éclaircissements, je vais finir par comprendre quelque chose, mais j'ai l'impression d'être entré dans le château par le fond de la cave, et j'ai un peu de mal à m'y retrouver, dans ce système GNU/Linux… (il faut dire que si j'avais pris Ubuntu comme tout le monde et que je me sois contenté de lire mes mails dans un webmail, et de faire un devoir dans libreoffice, j'aurais eu moins de souci… mais telle n'était pas mon intention)

MacBook Pro 7.1 de mi-2009 en dual boot depuis mai 2013 (Debian Jessie + Snow Leopard). Clavier TypeMatrix 2030 USB en bépo. Sauf rares cas, utilisation exclusive de la Debian. Mais je suis loin d'être un pro.

Hors ligne

#10 27-06-2013 21:45:55

deuchdeb
Moderato ma non troppo
Lieu : Pays de Cocagne
Distrib. : Jessie 8 + backports
Noyau : linux-image-3.16
(G)UI : KDE4.14 - Mate
Inscription : 13-01-2010

Re : [Résolu] Ouvrir un dossier en tant que root

Mais avec Ubuntu aussi tu peux user de la ligne de commande.

Mais trêve de bavardages, tu peux aussi  créer un lanceur et ensuite tu pourras ouvrir Thunar en tant que root par exemple.

Un tuto bien expliqué sur un site qui aime bien Debian et pour les débutants que nous sommes tous: http://www.linuxcore.fr/2011/11/creer-un-lanceur-xfce/

On dirais que tu arrive au rez de chaussée de ton château. cool

Dernière modification par deuchdeb (27-06-2013 21:47:24)

Hors ligne

Pied de page des forums