Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 01-08-2013 23:50:50

kaoz52
Membre
Inscription : 06-07-2013

Problèmes update tinytinyRSS

Bonjour,

Je viens de m'installer TinyTinyRSS, tout fonctionne correctement sauf l'update automatique.

Je ne comprend rien au wiki officiel et j'ai essayé différentes techniques de sites ou forums sans succès.

J'ai essayé d'exécuter :

php ./update.php --daemon



j'ai cette erreur :

PHP Deprecated:  Comments starting with '#' are deprecated in /etc/php5/cli/conf.d/ming.ini on line 1 in Unknown on line 0
PHP Deprecated:  Comments starting with '#' are deprecated in /etc/php5/cli/conf.d/ps.ini on line 1 in Unknown on line 0
PHP Warning:  Module 'OAuth' already loaded in Unknown on line 0
PHP Warning:  Module 'OAuth' already loaded in Unknown on line 0
PHP Warning:  Module 'OAuth' already loaded in Unknown on line 0
Could not open input file: ./update.php
 



J'ai aussi essayé :

php ./update_daemon2.php



et là j'ai cette erreur :

PHP Deprecated:  Comments starting with '#' are deprecated in /etc/php5/cli/conf.d/ming.ini on line 1 in Unknown on line 0
PHP Deprecated:  Comments starting with '#' are deprecated in /etc/php5/cli/conf.d/ps.ini on line 1 in Unknown on line 0
PHP Warning:  Module 'OAuth' already loaded in Unknown on line 0
PHP Warning:  Module 'OAuth' already loaded in Unknown on line 0
PHP Warning:  Module 'OAuth' already loaded in Unknown on line 0
Could not open input file: ./update_daemon2.php
Vous avez du nouveau courrier dans /var/mail/tonyo



Ca dépasse totalement mes (ridicules) compétences, je n'ai aucune idées du problème. Avrai je ne sais même pas ce que j'execute...

Pour infos, avant tinytinyrss j'ai tenté d'installer "Selfoss" et j'avais aussi cette erreur "Module 'OAuth' already loaded" et quand j'avais desinstallé "oAuth", j'avais une erreur m'indiquant qu'il n'était pas installé...

Je suis sous Debian 6.0 avec une dedibox et bien sur, je suis débutant !!!

Merci d'avance pour vos réponses

Hors ligne

#2 03-08-2013 15:16:00

Lunatic
Membre
Lieu : Lyon
Distrib. : Fedora 24
Noyau : Linux 4.6.5-300.fc24.x86_64
(G)UI : Gnome
Inscription : 03-08-2013
Site Web

Re : Problèmes update tinytinyRSS

Salut,

Sauf erreur de ma part, ce ne sont pas les différents “Warning” qui sont embêtants ici.

Peut-être s'agit-il d'un problème de droits. Que donne la commande ls -l dans le dossier où se situe le script ? Sous quel utilisateur es-tu loggé ?

Dernière modification par Lunatic (03-08-2013 15:17:58)


Je suis aussi sur Twitter et nouvellement sur Diaspora*
Mon blog de geekeries : HAL-9000

(J'applique la règle de proximité)

Hors ligne

#3 03-08-2013 20:08:43

kaoz52
Membre
Inscription : 06-07-2013

Re : Problèmes update tinytinyRSS

Effectivement, je n'ai pas tous les droits sur les fichiers, voila ce que j'ai :

-rw-rw-rw-  1 tonyo tonyo  5887 27 juil. 19:25 update_daemon2.php
-rw-rw-rw-  1 tonyo tonyo  9510 27 juil. 19:25 update.php



mon fichier de config :

-rw-r--r--  1 root  root   8429  1 août  15:53 config.php





Je fais un chmod 777 ?

sinon j'execute ça depuis mon utilisateur, il me semble avoir lu qu'il ne fallait pas l'executer en étant root.

Merci pour ton aide

Hors ligne

#4 03-08-2013 22:24:17

Lunatic
Membre
Lieu : Lyon
Distrib. : Fedora 24
Noyau : Linux 4.6.5-300.fc24.x86_64
(G)UI : Gnome
Inscription : 03-08-2013
Site Web

Re : Problèmes update tinytinyRSS

C'est bizarre que ton fichier config.php appartienne à root, ça ne me semble pas très normal.

Pour ma part, mon serveur nginx tourne avec l'utilisateur www-data et tous les fichiers appartiennent à cet utilisateur (chown www-data:www-data *). Lorsque je dois exécuter un script via la ligne de commande (j'ai d'ailleurs déjà eu à utiliser TinyTinyRss), je le fais avec cet utilisateur. En procédant ainsi ? et je crois que c'est la « bonne » façon de faire ? je n'ai jamais de soucis.

Peut-être, donc, devrais-tu :
- identifier sous quel utilisateur tourne ton serveur (sans doute www-data)
- changer les droits pour que tes fichiers (particulièrement les *.php) lui appartiennent
- et retenter l'exécution de la commande.

Je suis aussi sur Twitter et nouvellement sur Diaspora*
Mon blog de geekeries : HAL-9000

(J'applique la règle de proximité)

Hors ligne

#5 04-08-2013 17:41:05

kaoz52
Membre
Inscription : 06-07-2013

Re : Problèmes update tinytinyRSS

En fait je me connecte systématiquement en root pour installer les differents softs.
J'ai essayé de me connecter en tant qu'utilisateur www-data mais il me demande un mot de passe...

J'ai donc fait des Chown www-data:www-data sur mes fichier .php comme tu me l'as dit et cette fois ça a bien fonctionné, j'ai donc pu mettre en place mon crontab et avoir une mise à jour automatique.

En revanche, j'ai toujours cette erreur quand je lance le script :

PHP Deprecated:  Comments starting with '#' are deprecated in /etc/php5/cli/conf.d/ming.ini on line 1 in Unknown on line 0
PHP Deprecated:  Comments starting with '#' are deprecated in /etc/php5/cli/conf.d/ps.ini on line 1 in Unknown on line 0
PHP Warning:  Module 'OAuth' already loaded in Unknown on line 0
PHP Warning:  Module 'OAuth' already loaded in Unknown on line 0
PHP Warning:  Module 'OAuth' already loaded in Unknown on line 0
Could not open input file: ./update.php



Cela n'empêche pas le fonctionnement du script (encore une fois comme tu me l'avais dit...) mais j'aimerais bien savoir d'ou vient cette erreur.

EDIT : En fait j'ai une erreur qui s'affiche sur tiny tiny RSS : "Update daemon is not running." bon ça ne gène pas mais si il y avait moyen de l'enlever...

En tous les cas je te remercie beaucoup pour ton aide et tes informations, je n'y serais jamais arrivé sans toi.

Dernière modification par kaoz52 (04-08-2013 17:43:40)

Hors ligne

#6 07-08-2013 08:07:22

Lunatic
Membre
Lieu : Lyon
Distrib. : Fedora 24
Noyau : Linux 4.6.5-300.fc24.x86_64
(G)UI : Gnome
Inscription : 03-08-2013
Site Web

Re : Problèmes update tinytinyRSS

Désolé pour le délai de réponse.

kaoz52 a écrit :

En fait je me connecte systématiquement en root pour installer les differents softs.



Tu avais installé TinyTinyRss depuis apt ? J'avoue que je ne sais pas trop comment ça marche dans ces cas là (je suppose que les fichiers appartiennent du coup effectivement à root). En revanche, si jamais tu installes TinyTinyRSS (ou tout autre « appli web ») directement en téléchargeant l'archive sur le site officiel, alors mieux vaut ne pas le faire en tant que root.

J'ai essayé de me connecter en tant qu'utilisateur www-data mais il me demande un mot de passe...



As-tu essayé avec le mot de passe root ?

Sinon, il est également possible de t'ajouter (c'est-à-dire, ton utilisateur « normal ») au groupe www-data. Ainsi, tu peux rester sous ton compte pour télécharger des applis web / agir dessus, et tout ça devrait se passer sans problème de droits.

J'ai donc fait des Chown www-data:www-data sur mes fichier .php comme tu me l'as dit et cette fois ça a bien fonctionné, j'ai donc pu mettre en place mon crontab et avoir une mise à jour automatique.



Ah, bonne nouvelle smile

En revanche, j'ai toujours cette erreur quand je lance le script :

PHP Deprecated:  Comments starting with '#' are deprecated in /etc/php5/cli/conf.d/ming.ini on line 1 in Unknown on line 0
PHP Deprecated:  Comments starting with '#' are deprecated in /etc/php5/cli/conf.d/ps.ini on line 1 in Unknown on line 0
PHP Warning:  Module 'OAuth' already loaded in Unknown on line 0
PHP Warning:  Module 'OAuth' already loaded in Unknown on line 0
PHP Warning:  Module 'OAuth' already loaded in Unknown on line 0
Could not open input file: ./update.php



Cela n'empêche pas le fonctionnement du script (encore une fois comme tu me l'avais dit...) mais j'aimerais bien savoir d'ou vient cette erreur.

EDIT : En fait j'ai une erreur qui s'affiche sur tiny tiny RSS : "Update daemon is not running." bon ça ne gène pas mais si il y avait moyen de l'enlever...

En tous les cas je te remercie beaucoup pour ton aide et tes informations, je n'y serais jamais arrivé sans toi.



As-tu lu la page suivante concernant l'update des flux ? http://tt-rss.org/redmine/projects/tt-r … atingFeeds
Peut-être pourra-t-elle te renseigner.


Je suis aussi sur Twitter et nouvellement sur Diaspora*
Mon blog de geekeries : HAL-9000

(J'applique la règle de proximité)

Hors ligne

#7 09-08-2013 17:24:21

kaoz52
Membre
Inscription : 06-07-2013

Re : Problèmes update tinytinyRSS

Ok, oui j'ai regardé cette adresse mais ça ne m'a pas plus avancé.

Pour www-data le mdp root n'a pas marché mais je l'ai changé avec mes droit root justement. J'essaierai d'installer mes prochains packages sous cet user.

Encore merci pour ton aide

Hors ligne

Pied de page des forums