Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 08-08-2013 07:30:27

sechanbask
Membre
Inscription : 14-10-2009

[Résolu] Installation de flashplayer

Bonjour,

Je demande de l'aide pour l'installation d'un logiciel privateur sur debian 7. Je sais que le sujet a été mainte et mainte fois traité seulement, je ne trouve pas comment faire malgré plusieurs méthodes utilisés.
Je viens de migrer le 2ième PC de mon patron sous debian 7. Tout s'est bien passé pour le premier (64bits) mais pas pour le 2ème (32bits), impossible de faire fonctionner flash player. J'ai utilisé plusieurs méthodes :

La classique :


# aptitude update
# aptitude install flashplugin-nonfree
# update-flashplugin-nonfree --install
 



La sournoise :

modification des sources :


deb http://packages.linuxmint.com/ debian main upstream import backport
 



Puis


apt-get update
apt-get install linuxmint-keyring
apt-get update
apt-get install mint-flashplugin
 



Ensuite, il faut copier la bibliothèque DebianMint dans Debian.


cp /opt/mint-flashplugin-11/libflashplayer.so /usr/lib/mozilla/plugins
 



ou


ln -s /opt/mint-flashplugin-11/libflashplayer.so /usr/lib/mozilla/plugins/flashmint.so
 



La brutale :

Après la méthode précédente avec les bon chemin... :


cp flashmint.so libflashplayer.so
 



Les emplacements de flash reste vide (pas d'indication comme lorsque je le désactive)  dans iceweasl(firefox) et dans chromium, pourtant il apparait dans mes plugin FF et Chromium,

Petite vérificatione en ligne de commande :


# update-alternatives --display flash-mozilla.soflash-mozilla.so - mode automatique
le lien pointe actuellement sur /usr/lib/flashplugin-nonfree/libflashplayer.so
/usr/lib/flashplugin-nonfree/libflashplayer.so - priorité 50
La « meilleure » version actuelle est « /usr/lib/flashplugin-nonfree/libflashplayer.so ».
 

Dernière modification par sechanbask (20-08-2013 23:15:55)

Hors ligne

#2 08-08-2013 11:24:19

captnfab
Admin-Girafe
Lieu : /dev/random
Distrib. : Debian Stretch/Sid/Rc-Buggy
Noyau : Linux (≥ 4.3)
(G)UI : i3-wm (≥ 4.11)
Inscription : 07-07-2008
Site Web

Re : [Résolu] Installation de flashplayer

Salut,

La classique suffit car elle marche. S'il y a un problème après une installation propre de celle-ci (non polluée par les autres méthodes non conventionnelles), il vient de ton navigateur ou de ton profil.

Mélanger les méthodes est le plus dangereux, et en plus, ça transforme le diagnostic en enfer..

Pas besoin de mêler Mint à cela, limiter le nombre de dépôts est le plus sage et évite le plus de surprise

Commence par faire le ménage :

aptitude purge mint-flashplugin linuxmint-keyring flashplugin-nonfree


Enlève les dépôts Mint (ou commente-les), puis fait un update.

Vérifie que tu n'as plus de libflashplayer.so sur ton ordi

locate libflashplayer.so


et que tes répertoires de plugins mozilla ne contiennent pas de lien symbolique à la noix

ls -l /usr/lib/mozilla/plugins
ls -l ~/.mozilla/plugins
 



Une fois que tu t'es assuré de tout ça, vérifie que tu as une version d'iceweasel récente (la 17esr des dépôts security, ou la 23 des dépôts des mainteneurs mozilla - voir sources.list du wiki)

apt-cache policy iceweasel



Tu réinstalles la méthode classique :

aptitude install flashplugin-nonfree


Qui se met à jour toute seul à l'installation.

Tu relances ton navigateur et va voir dans la page des plugins si flash est reconnu et de quelle version de celui-ci il s'agit.

Tu regardes si flash marche, et sinon, on refait d'autres diagnostics smile


captnfab,
Association Debian-Facile, bépo.
TheDoctor: Your wish is my command… But be careful what you wish for.

Hors ligne

#3 08-08-2013 13:08:50

Haricophile
Adhérent(e)
Lieu : Pignans (Var)
Distrib. : SID
Noyau : 4.0.0-1-amd64
(G)UI : Mate / i3 selon...
Inscription : 14-09-2009

Re : [Résolu] Installation de flashplayer

En sachant que flashplayer c'est 1 (un)(01 en octal) fichier .so a coller dans le path des plugins (donc selon le navigateur, vérifier quel est le path et regarder ce qu'il y a ou pas dedans).

C'est incroyable comment, depuis l'origine, la simple copie d'un fichier fait blablater dans les forums. Je me demande si avoir fait des installateurs a été réellement judicieux, il aurait peut-être mieux valu apprendre aux utilisateurs à télécharger, décompresser une archive (superfétatoire) et copier un fichier, de préférence dans l'espace utilisateur (~/.mozilla/plugins/) comme ça s'il y a un bug ou un utilisateur qui n'en veut pas, c'est mieux.

Bon, je reconnais qu'il y a eu une transitions un poil plus complexe avec l'installation d'un wrapper dans la config 64/32 bits et quelques soucis de son OSS (vive le proprio et la ##### que ça génère...).

P.S. Installe en même temps un équivalent de betterprivacy dans firefox ou fait un script pour virer ~/.macromedia à intervalle régulier.

« Un optimiste, explique Raymond Aubrac, n’est pas un être satisfait, content de la situation actuelle. C’est quelqu’un qui pense qu’il peut faire quelque chose qui servira. »

Hors ligne

#4 08-08-2013 13:45:01

captnfab
Admin-Girafe
Lieu : /dev/random
Distrib. : Debian Stretch/Sid/Rc-Buggy
Noyau : Linux (≥ 4.3)
(G)UI : i3-wm (≥ 4.11)
Inscription : 07-07-2008
Site Web

Re : [Résolu] Installation de flashplayer

L'installateur de Debian apporte simplement les avantages d'un paquet : mise à jour auto, cohérence des versions, certification de l'origine, ne pas avoir à utiliser le navigateur… ce genre de chose.
Les complications apparaissent quand il y a d'autres player flash en concurrence… smile
Et je suis d'accord qu'une compréhension de base du fonctionnement du bouzin aiderait… mais bon… c'est valable partout ^^#

captnfab,
Association Debian-Facile, bépo.
TheDoctor: Your wish is my command… But be careful what you wish for.

Hors ligne

#5 09-08-2013 22:44:11

sechanbask
Membre
Inscription : 14-10-2009

Re : [Résolu] Installation de flashplayer

Tout d'abord, je tiens à vou remercier de vous êtes intéressés à mon problème.

Haricophile : j'aime debian pour sa facilité, et sa cohérence, je préférerais évidement me passer des problèmes lié à l'installation de plugin proprio, mais même si j'administre plusieurs serveur (relativement simple) je suis contente de la simplicité des gestionnaires de paquet qui m'on mis le pied à l'étrier et qui continue de le faire pour d'autre... et si ça venait d'adobe, est-ce que tu pourrais m'envoyer ton .so ?

captnfab : j'ai suivi tes instructions à la lettre. J'ai rajouté avant locate un

# updatedb



et le locate n'a rien trouvé, j'ai fait :


ls -l /usr/lib/mozilla/plugins
total 24
-rw-r--r-- 1 root root 13884 févr.  9 15:52 libgnome-shell-browser-plugin.so
-rw-r--r-- 1 root root  5464 juil. 28  2012 librhythmbox-itms-detection-plugin.so



puis

# ls -l /home/maison/.mozilla/
extensions/ firefox/
 



J'ai la dernière version de FF


# apt-cache policy iceweasel
iceweasel:
  Installé : 23.0-1~bpo70+1
  Candidat : 23.0-1~bpo70+1
 Table de version :
 *** 23.0-1~bpo70+1 0
        500 http://mozilla.debian.net/ wheezy-backports/iceweasel-release i386 Packages
        100 /var/lib/dpkg/status
     17.0.8esr-1~deb7u1 0
        500 http://security.debian.org/ wheezy/updates/main i386 Packages
     10.0.12esr-1 0
        500 http://ftp.fr.debian.org/debian/ wheezy/main i386 Packages
        500 http://http.debian.net/debian/ wheezy/main i386 Packages



Puis j'ai lancé :

# aptitude install flashplugin-nonfree



j'ai redémarrer FF sans en désactivant les modules complémentaires (pour vérifier que ça ne venait pas d'adblock) ça n'a rien fait puis j'ai fait "update-flashplugin-nonfree --install"

mais ça n'a rien changé, FF détecte bien le module, mais les animations restent vides.

Dernière modification par sechanbask (09-08-2013 22:44:54)

Hors ligne

#6 09-08-2013 22:56:19

johan
Membre
Lieu : Montpellier
Distrib. : Debian Wheezy Vers 7.1
Noyau : Linux 3.2.0-4-amd64
(G)UI : Gnome
Inscription : 29-07-2013

Re : [Résolu] Installation de flashplayer

Salut,

As-tu vérifié au niveau du navigateur l'application utilisée ?
Pour moi avec Iceweasel (ou firefox) il faut aller : Edition / Préférence / Application

Je sais que sous ubuntu j'avais eu un problème identique mais en supprimant GNASH puis en réinstallant flash player. Ca avait réglé mon problème.

++

Hors ligne

#7 09-08-2013 22:58:00

sechanbask
Membre
Inscription : 14-10-2009

Re : [Résolu] Installation de flashplayer

mjohan : le plugin est présent et reconnu dans Edition / Préférence / Application...

j'ai déjà eu des problèmes avec cette saleté mais comme ça...

Hors ligne

#8 09-08-2013 22:58:49

captnfab
Admin-Girafe
Lieu : /dev/random
Distrib. : Debian Stretch/Sid/Rc-Buggy
Noyau : Linux (≥ 4.3)
(G)UI : i3-wm (≥ 4.11)
Inscription : 07-07-2008
Site Web

Re : [Résolu] Installation de flashplayer

Oh, hum, intéressant... 
Et je vois que tu as de l'expérience et de bons réflexes smile

Maintenant que tu as fait l'installation, tu as bien le fichier .so dans /usr/lib/mozilla/plugins ? (sinon, c'est que la partie --install échoue)

Plutôt que les extensions, tu as essayé de désactiver les autres plugins ? (les extensions sont les .xpi les plugins sont les .so, il y a deux onglets différents… et souvent des conflits entre plugins)

Tu as essayé de créer un nouveau profil Firefox pour voir si cela fonctionnait ? (parfois, les profils prennent de mauvais plis)

Au cas où cela jouerait, tu peux virer les ~/.macromedia/ et ~/.adobe/

Tu as testé les animations Flash sur plusieurs sites ? (des fois qu'il y ait d'autres paramètres en jeu…)

Ça serait bête que la version 32bits de flash soit cassée…

captnfab,
Association Debian-Facile, bépo.
TheDoctor: Your wish is my command… But be careful what you wish for.

Hors ligne

#9 20-08-2013 22:22:49

sechanbask
Membre
Inscription : 14-10-2009

Re : [Résolu] Installation de flashplayer

Bonsoir à tous, j'ai enfin un peu de temps à consacré à ce problème.

alors voilà, j'ai bel et bien le fichier :


# ls -al /usr/lib/mozilla/plugins/
total 32
drwxr-xr-x 2 root root  4096 août   9 20:32 .
drwxr-xr-x 4 root root  4096 août   1 14:38 ..
lrwxrwxrwx 1 root root    34 août   9 20:32 flash-mozilla.so -> /etc/alternatives/flash-mozilla.so
-rw-r--r-- 1 root root 13884 févr.  9  2013 libgnome-shell-browser-plugin.so
-rw-r--r-- 1 root root  5464 juil. 28  2012 librhythmbox-itms-detection-plugin.so



j'ai tenté de changer de profil, désactiver plugin et extension, toujours le même problème.

j'ai lancé iceweasel en ligne de commande, et dès que je vais sur une page avec du flash, la ligne de commande me renvoie :

[Parent][RPCChannel] Error: Channel error: cannot send/recv



j'ai lu pas mal de chose à ce sujet mais je ne vois pas ce que je peux faire...

Hors ligne

#10 20-08-2013 23:15:12

sechanbask
Membre
Inscription : 14-10-2009

Re : [Résolu] Installation de flashplayer

je suis content, j'ai enfin trouvé, je viens de chercher sur mon ancien PC une vielle version, que je partage avec vous :

http://88.189.92.44/partage/libflashplayer.so

ça marche avec avertissement car c'est une version obsolète... Saleté de code propriétaire !!

Hors ligne

#11 20-08-2013 23:47:28

captnfab
Admin-Girafe
Lieu : /dev/random
Distrib. : Debian Stretch/Sid/Rc-Buggy
Noyau : Linux (≥ 4.3)
(G)UI : i3-wm (≥ 4.11)
Inscription : 07-07-2008
Site Web

Re : [Résolu] Installation de flashplayer

Attention, vieille version implique vieilles failles. Parois il vaut mieux se passer de quelque chose que d'introduire de nouveaux problèmes !
En tout cas, merci de ton retour.

captnfab,
Association Debian-Facile, bépo.
TheDoctor: Your wish is my command… But be careful what you wish for.

Hors ligne

#12 21-08-2013 06:25:14

sechanbask
Membre
Inscription : 14-10-2009

Re : [Résolu] Installation de flashplayer

même si cette version de flash possède des failles, personne peut nous confirmer que la dernière à jour n'en a pas non plus... pour l'instant je laisse celle ci, je vais voir par la suite, au moins je sais que celle ci marche. Je laisse l'avertissement, si l'utilisateur le voit souvent, je tenterais une version moins vielle.



et pour terminer, je pense que le plus gros problème, ce n'est pas les failles de flash, mais c'est de toujours devoir l'utiliser.

Dernière modification par sechanbask (21-08-2013 06:26:25)

Hors ligne

#13 21-08-2013 20:40:04

captnfab
Admin-Girafe
Lieu : /dev/random
Distrib. : Debian Stretch/Sid/Rc-Buggy
Noyau : Linux (≥ 4.3)
(G)UI : i3-wm (≥ 4.11)
Inscription : 07-07-2008
Site Web

Re : [Résolu] Installation de flashplayer

Ah ben c'est sûr, la dernière version de Flash en possède aussi, mais on peut espérer qu'elles soient encore inconnues des attaquants smile
Cela-dit, je suis bien d'accord avec toi, le plus gros problème reste la nécessité de l'utiliser.

captnfab,
Association Debian-Facile, bépo.
TheDoctor: Your wish is my command… But be careful what you wish for.

Hors ligne

Pied de page des forums