Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 15-08-2013 04:10:09

Patriboom
Membre
Lieu : Arctique canadien
Distrib. : Jessie
Noyau : Linux 3.16.0-4-686-pae
(G)UI : MATE
Inscription : 25-12-2008
Site Web

Pas de vidéo AVI avec Squeeze

Bonjour,

suite à la magie des réinstallations opérées sur ma carte réseau, je viens consulter les magiciens de nouveau.

Le problème est ancien.  Avec une version antérieure du noyau (Debian GNU/Linux, avec Linux 2.6.32-5-686), je ne pouvais pas avoir d'écran extrene à mon portable. De plus, la résolution était pourrie.  Cependant je pouvais voir et éditer mes vidéos.  J'ai gardé cette version en réserve, mais mon HP Probook 6360b roule désormais sous Debian GNU/Linux, avec Linux 3.2.0-4-486  Depuis la version 3.2, je puis afficher sur deux écrans (celui du portable et un écran externe), la résolution est meilleure et peut être modifiée, mais voilà: pas de vidéo possible.

Les symptômes: 
       - ouverture de Totem pour lecture de la vidéo
       - premiers sons de la vidéo, mais pas d'image
       - une seconde ou deux ainsi, puis gel temporaire de la machine
       - remise à zéro de la carte vidéo (les écrans allumés sont éteints, puis rallumés)

Il peut arriver aussi que la machine soit complètement gelée, mais qu'en faisant  Fn-F4  (redéfinition des écrans), ça revienne.

J'en conclus qu'il y a un problème de reconnaissance ou de gestion de ma carte vidéo.
J'ai néanmoins mis le blâme sur l'installation des logiciels et j'ai fait ceci:

  aptitude reinstall totem
  aptitude install mplayer
  aptitude reinstall ffmpeg
  aptitude remove ffmpeg
  aptitude install ffmpeg
  aptitude remove libav-tools   (car aptitude m'indiquait un conflit de paquets)
  aptitude install ffmpeg
  aptitude reinstall totem
  aptitude install mplayer
   shutdown -r 0
 



Lorsque je tente de démarrer ffmpeg (alt-F2 ), je n'obtiens rien.
Lorsque je tente de démarrer mplayer (alt-F2), je n'obtiens rien.
Lorsque je tente de démarrer totem (alt-F2), le logiciel s'ouvre bien.  Ctrl-O pour ouvrir un fichier provoque la femeture complète de totem dès la vidéo AVI choisie.

J'aimerais utiiliser OpenShot pour faire mon montage, mais une fenêtre d'erreur apparaît. 
Le trouble de la carte vidéo est tel que rien n'apparaît dans le fenêtre d'erreur (pas de message), puis l'écran devient tout noir, disparition du message d'erreur et de toute trace d'OpenShot (bref, redémarrage de la carte vidéo).


Avez-vous des pistes ?

Merci


Portez la paix
Patrick Allaire, ptre

Hors ligne

#2 15-08-2013 09:33:41

captnfab
Admin-Girafe
Lieu : /dev/random
Distrib. : Debian Stretch/Sid/Rc-Buggy
Noyau : Linux (≥ 4.3)
(G)UI : i3-wm (≥ 4.11)
Inscription : 07-07-2008
Site Web

Re : Pas de vidéo AVI avec Squeeze

Salut,
Tu as quoi comme carte vidéo ?

lspci | grep -i vga



Est-ce que l'extension glx est bien présente ?

glxinfo


(installer mesa-utils au besoin)


captnfab,
Association Debian-Facile, bépo.
TheDoctor: Your wish is my command… But be careful what you wish for.

Hors ligne

#3 31-08-2013 06:29:24

Patriboom
Membre
Lieu : Arctique canadien
Distrib. : Jessie
Noyau : Linux 3.16.0-4-686-pae
(G)UI : MATE
Inscription : 25-12-2008
Site Web

Re : Pas de vidéo AVI avec Squeeze

Merci captn, voici mes résultats

#lspci | grep -i vga
00:02.0 VGA compatible controller: Intel Corporation Sandy Bridge Integrated Graphics Controller (rev 09)
 



et

# glxinfo
name of display: :0.0
Unrecognized deviceID 126
X Error of failed request:  BadAlloc (insufficient resources for operation)
  Major opcode of failed request:  154 (GLX)
  Minor opcode of failed request:  3 (X_GLXCreateContext)
  Serial number of failed request:  21
  Current serial number in output stream:  24
 


Portez la paix
Patrick Allaire, ptre

Hors ligne

#4 31-08-2013 10:21:58

captnfab
Admin-Girafe
Lieu : /dev/random
Distrib. : Debian Stretch/Sid/Rc-Buggy
Noyau : Linux (≥ 4.3)
(G)UI : i3-wm (≥ 4.11)
Inscription : 07-07-2008
Site Web

Re : Pas de vidéo AVI avec Squeeze

Plop,
glxinfo doit être lancé en user smile

captnfab,
Association Debian-Facile, bépo.
TheDoctor: Your wish is my command… But be careful what you wish for.

Hors ligne

#5 31-08-2013 14:05:25

Patriboom
Membre
Lieu : Arctique canadien
Distrib. : Jessie
Noyau : Linux 3.16.0-4-686-pae
(G)UI : MATE
Inscription : 25-12-2008
Site Web

Re : Pas de vidéo AVI avec Squeeze

J'obtiens le même résultat

$ glxinfo
name of display: :0.0
Unrecognized deviceID 126
X Error of failed request:  BadAlloc (insufficient resources for operation)
  Major opcode of failed request:  154 (GLX)
  Minor opcode of failed request:  3 (X_GLXCreateContext)
  Serial number of failed request:  21
  Current serial number in output stream:  24
 


Portez la paix
Patrick Allaire, ptre

Hors ligne

Pied de page des forums