Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 23-08-2013 02:42:46

laguespa
Membre
Distrib. : Jessie
Noyau : 4.2.0-0.bpo.1-amd64
(G)UI : Mate
Inscription : 25-09-2009

[Résolu] Un wifi capricieux.

Bonjour.

Je viens d'installer Debian 7 sur le portable de ma copine. Sous Debian 6 je n'avais pas de problème de connexion wifi mais maintenant il se passe quelque chose de bizarre.

Je donne une explication avant d'entrer dans les détails :
si je ne renseigne pas le fichier /etc/network/interfaces manuellement avec wlan0 il m'est impossible d'activer matériellement le wifi et impossible donc de scanner le moindre réseau. Si ce fichier est renseigné le wifi est activé mais je ne peux me connecter qu'en ligne de commande. Je précise que j'utilise lightdm, Mate et wicd.



Dans les détails maintenant :

1 - Sans renseigner /etc/network/interfaces

# cat /etc/network/interfaces
# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
allow-hotplug eth0
iface eth0 inet dhcp



# lshw -c Network
  *-network DÉSACTIVÉ    
       description: Interface réseau sans fil
       produit: RTL8188CE 802.11b/g/n WiFi Adapter
       fabriquant: Realtek Semiconductor Co., Ltd.
       identifiant matériel: 0
       information bus: pci@0000:02:00.0
       nom logique: wlan0
       version: 01
       numéro de série: e0:b9:a5:4a:3e:dd
       bits: 64 bits
       horloge: 33MHz
       fonctionnalités: pm msi pciexpress bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=rtl8192ce driverversion=3.2.0-4-amd64 firmware=N/A latency=0 link=no multicast=yes wireless=IEEE 802.11bgn
       ressources: irq:18 portE/S:e000(taille=256) mémoire:f7d00000-f7d03fff
 



# iwconfig
lo        no wireless extensions.

wlan0     IEEE 802.11bgn  ESSID:off/any  
          Mode:Managed  Access Point: Not-Associated   Tx-Power=off  
          Retry  long limit:7   RTS thr=2347 B   Fragment thr:off
          Encryption key:off
          Power Management:on
         
eth0      no wireless extensions.
 



Le firmware est installé :

# aptitude show firmware-realtek
Paquet : firmware-realtek                    
Nouveau: oui
État: installé
Automatiquement installé: non
Multiarchitecture : étranger
Version : 0.36+wheezy.1
Priorité : optionnel
Section : non-free/kernel
Responsable : Debian Kernel Team <debian-kernel@lists.debian.org>
Architecture : all
Taille décompressée : 493 k
Suggère: initramfs-tools, linux-image
Description : Binary firmware for Realtek wired and wireless network adapters
 This package contains the binary firmware for some Ethernet adapters with the RTL8111/RTL8168 chips supported by the r8169 driver; and wireless network
 cards with the RTL8188, RTL8192 and RTL8712 chips supported by the r8192_pci, r8192s_usb, r8712u, rtl8192ce, rtl8192cu, rtl8192de and rtl8192se drivers.






2 - En renseignant /etc/network/interfaces de cette façon


# cat /etc/network/interfaces
# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
allow-hotplug eth0
iface eth0 inet dhcp

iface wlan0 inet dhcp
wpa-psk 309748b68d710879cce10696e68e426a456079739879c747896fcc99423c400c
wpa-driver wext
wpa-key-mgmt WPA-PSK
wpa-proto WPA
wpa-ssid freebox_vilarelle

auto wlan0
 



le wifi s'active et je peux scanner les réseaux. Par contre wicd reste muet et ne détecte aucun réseau.

# iwlist scan
lo        Interface doesn't support scanning.

wlan0     Scan completed :
          Cell 01 - Address: 8A:4C:E5:D0:81:C0
                    Channel:11
                    Frequency:2.462 GHz (Channel 11)
                    Quality=59/70  Signal level=-51 dBm  
                    Encryption key:on
                    ESSID:"freebox_vilarelle"
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 9 Mb/s
                              18 Mb/s; 36 Mb/s; 54 Mb/s
                    Bit Rates:6 Mb/s; 12 Mb/s; 24 Mb/s; 48 Mb/s
                    Mode:Master
                    Extra:tsf=0000000151f9e148
                    Extra: Last beacon: 40ms ago
                    IE: Unknown: 001166726565626F785F76696C6172656C6C65
                    IE: Unknown: 010882848B961224486C
                    IE: Unknown: 03010B
                    IE: Unknown: 2A0104
                    IE: Unknown: 32040C183060
                    IE: Unknown: 2D1A6E1017FFFF000001000000000000000000000000000000000000
                    IE: Unknown: 3D160B070700000000000000000000000000000000000000
                    IE: Unknown: 3E0100
                    IE: WPA Version 1
                        Group Cipher : TKIP
                        Pairwise Ciphers (2) : TKIP CCMP
                        Authentication Suites (1) : PSK
                    IE: Unknown: DD180050F2020101000003A4000027A4000042435E0062322F00
                    IE: Unknown: 7F0101
                    IE: Unknown: DD07000C4300000000
                    IE: Unknown: DD1E00904C336E1017FFFF000001000000000000000000000000000000000000
                    IE: Unknown: DD1A00904C340B070700000000000000000000000000000000000000

eth0      Interface doesn't support scanning.
 




Pour info j'utilise lightdm et j'ai mis MATE comme environnement de bureau.

A+

Dernière modification par laguespa (25-08-2013 08:10:35)


"Ce serait peut-être l’une des plus grandes opportunités manquées de notre époque si le logiciel libre ne libérait rien d’autre que du code."

Hors ligne

#2 23-08-2013 03:56:38

sogal
Black Metal Modo
Distrib. : Debian Testing
Noyau : 4.7
(G)UI : Gnome
Inscription : 09-05-2013
Site Web

Re : [Résolu] Un wifi capricieux.

Bonsoir,

As-tu vérifié à tout hasard que ta carte n'était pas bloquée par RFkill en faisant un:

rfkill list

? (en root)


Machine perso : Thinkpad x230 Debian Stretch | Machine pro : Thinpad T450 openSUSE Leap 42.2

Hors ligne

#3 23-08-2013 09:05:50

laguespa
Membre
Distrib. : Jessie
Noyau : 4.2.0-0.bpo.1-amd64
(G)UI : Mate
Inscription : 25-09-2009

Re : [Résolu] Un wifi capricieux.

# rfkill list
0: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: no

"Ce serait peut-être l’une des plus grandes opportunités manquées de notre époque si le logiciel libre ne libérait rien d’autre que du code."

Hors ligne

#4 23-08-2013 09:55:23

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : [Résolu] Un wifi capricieux.

je n'arrive pas à activer la carte wifi avec la combinaison de touches qui sert à ça


Ça doit être à configurer, sans doute.


I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

#5 23-08-2013 10:10:57

laguespa
Membre
Distrib. : Jessie
Noyau : 4.2.0-0.bpo.1-amd64
(G)UI : Mate
Inscription : 25-09-2009

Re : [Résolu] Un wifi capricieux.

Ouaip, je me demandais si en deuxième environnement de bureau je n'allais pas mettre xfce4 et voir si ça passait mieux pour le wifi... Ça me mettrait un autre gestionnaire de fenêtre et un gestionnaire de connexion par défaut.

Dernière modification par laguespa (23-08-2013 10:21:41)


"Ce serait peut-être l’une des plus grandes opportunités manquées de notre époque si le logiciel libre ne libérait rien d’autre que du code."

Hors ligne

#6 23-08-2013 16:26:47

lagrenouille
Adhérent(e)
Lieu : toulouse
Distrib. : debian stretch
Noyau : Debian -amd64 - noyau.4.6.0.1-
(G)UI : xfce4 - bépo_TypeMatrix
Inscription : 28-03-2012
Site Web

Re : [Résolu] Un wifi capricieux.

je vois pas pourquoi le gestionnaire de fenêtre aurait à voir avec le wifi ?

tu as bien installé tout ça pour voir
apt-get install firmware-iwlwifi  firmware-realtek  wifi-radar

Celui qui ignore l’histoire se retrouvera sur une rive solitaire,d’où il épiera en vain les lumières d’un bateau.
Ce bateau ne viendra pas.
---------------------------
auto-hébergement chezlagrenouille.fr

Hors ligne

#7 23-08-2013 19:35:32

laguespa
Membre
Distrib. : Jessie
Noyau : 4.2.0-0.bpo.1-amd64
(G)UI : Mate
Inscription : 25-09-2009

Re : [Résolu] Un wifi capricieux.

Bonjour et merci de ton attention.

$ aptitude show firmware-iwlwifi
Paquet : firmware-iwlwifi                    
Nouveau: oui
État: installé



$ aptitude show firmware-realtek
Paquet : firmware-realtek                    
Nouveau: oui
État: installé
Automatiquement installé: non



$ aptitude show wifi-radar
Paquet : wifi-radar                          
État: installé
Automatiquement installé: non



J'ai refait un essai. Si je n'ajoute pas manuellement wlan0 dans /etc/network/interfaces comme je l'indique dans mon premier message la carte wifi n'est pas active et je n'arrive pas à l'activer manuellement. roll

Dernière modification par laguespa (24-08-2013 14:47:21)


"Ce serait peut-être l’une des plus grandes opportunités manquées de notre époque si le logiciel libre ne libérait rien d’autre que du code."

Hors ligne

#8 24-08-2013 16:35:07

Lætitia
Modette
Lieu : Normandie du Nord
Distrib. : Stretch
Noyau : 4.6.0-1-amd64
(G)UI : Xfce4
Inscription : 14-04-2010
Site Web

Re : [Résolu] Un wifi capricieux.

salut,
si tu utilises wifi-radar ET wicd ensemble, tu peux avoir des incompatibilités. Essaie d'en désinstaller un pour voir.

@+

<titia> pas assez cuit; µonde  -> explosion
<captnfab> ^^
<captnfab> s/µ/bl/ wink

Hors ligne

#9 24-08-2013 17:46:04

laguespa
Membre
Distrib. : Jessie
Noyau : 4.2.0-0.bpo.1-amd64
(G)UI : Mate
Inscription : 25-09-2009

Re : [Résolu] Un wifi capricieux.

Non non, j'ai d'abord essayé WICD et comme ça ne marchait pas j'ai désinstallé et installé Wifi-radar qui lui voit le réseau mais lorsque je veux m'y connecter ne m'y connecte pas.

Je précise qu'en ligne de commande je me connecte sans problème. Si c'était ma machine et pour le peu que j'utilise le wifi ça ne me poserait pas de problème mais c'est celui de mon amie et ça va lui poser problème...

"Ce serait peut-être l’une des plus grandes opportunités manquées de notre époque si le logiciel libre ne libérait rien d’autre que du code."

Hors ligne

#10 24-08-2013 22:39:48

deuchdeb
Moderato ma non troppo
Lieu : Pays de Cocagne
Distrib. : Jessie 8 + backports
Noyau : linux-image-3.16
(G)UI : KDE4.14 - Mate
Inscription : 13-01-2010

Re : [Résolu] Un wifi capricieux.

Avec WICD as tu bien déclarer que tu voulais utiliser wlan0.
En effet, il ne le met pas tout seul il faut l'ajouter dans la liste des interfaces réseaux.

Il faut, de mémoire, aller dans le menu preferences et dans wireless interface mettre wlan0

Voir cette image: http://wicd.sourceforge.net/screenshot.php

De plus le fichier network/interfaces doit être presque vide: http://www.debian.org/doc/manuals/debia … tion_tools

Hors ligne

#11 25-08-2013 08:09:45

laguespa
Membre
Distrib. : Jessie
Noyau : 4.2.0-0.bpo.1-amd64
(G)UI : Mate
Inscription : 25-09-2009

Re : [Résolu] Un wifi capricieux.

deuchdeb a écrit :

Avec WICD as tu bien déclarer que tu voulais utiliser wlan0.
En effet, il ne le met pas tout seul il faut l'ajouter dans la liste des interfaces réseaux.

Il faut, de mémoire, aller dans le menu preferences et dans wireless interface mettre wlan0

Voir cette image: http://wicd.sourceforge.net/screenshot.php



Salut.

Effectivement l'interface réseau n'était pas déclarée dans les préférences de wicd.

Merci.


"Ce serait peut-être l’une des plus grandes opportunités manquées de notre époque si le logiciel libre ne libérait rien d’autre que du code."

Hors ligne

Pied de page des forums