Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 24-08-2013 15:35:17

unit
Adhérent(e)
Lieu : Marcq-en-baroeul
Distrib. : Jessie
Noyau : Linux 3.16.0-4-amd64
(G)UI : Xfce 4.10
Inscription : 11-03-2010

Grosse galère pour configurer mutt

Salut, j'essaie de configurer "mutt" en suivant ce tuto : http://debian-facile.org/doc:reseau:mutt mais je galère pour feichmail.
J'ai créer ~/.fetchmailrc j'y ai mis :

# ~/.fetchmailrc
# Fichier de configuration de fetchmail
# Formation Debian GNU/Linux par Alexis de Lattre
# http://formation-debian.via.ecp.fr/

# Pour plus de détails, consultez "man fetchmail", section "The run control
# file" et "Configuration Examples".
# ATTENTION, ce fichier doit avoir les permissions "600", sinon fetchmail
# refuse de fonctionner.

# Nom du serveur POP3
poll mail.numericable.fr  protocol pop3 user monadresse.fr
password xxxx
protocol pop3


# Décommentez la ligne suivante si vous voulez que vos mails ne soient
# pas effacés du serveur (c'est plus prudent pour des tests) :
#keep

# Si vous voulez que fetchmail rappatrie les mails d'un deuxième compte POP,
# il suffit de répéter les lignes "poll", "protocol", "username" et
# "password" dans un deuxième paragraphe.
 



puis: chmod 600 ~/.fetchmailrc, mais lorsque je veux tester ça me donne : fetchmail: aucun serveur de courrier n'a été spécifié et là j'y comprend rien, j'ai checher sur le net et le serveur pour numericable est bien pop.numericable.fr.
Help me


Exige beaucoup de toi-même et attends peu des autres. Ainsi beaucoup d'ennuis te seront épargnés.
Confucius.

Hors ligne

#2 24-08-2013 16:08:32

captnfab
Admin-Girafe
Lieu : /dev/random
Distrib. : Debian Stretch/Sid/Rc-Buggy
Noyau : Linux (≥ 4.3)
(G)UI : i3-wm (≥ 4.11)
Inscription : 07-07-2008
Site Web

Re : Grosse galère pour configurer mutt

Plop,

Tu devrais essayer

# ~/.fetchmailrc
poll mail.numericable.fr  proto pop3
     user ton_username password ton_password is ton_login_machine here
     ssl
keep
 



Si ton FAI ne prend pas en charge POP3s (ie, envoi du mot de passe et récupération des mails de manière chiffrée), enlève la ligne « ssl ».

Par exemple, si l'utilisateur jojo veut récupérer les mails de son compte toto@example.net, ton_username sera toto, ton_password sera le pass de ta boîte mail et ton_login_machine sera jojo.

Au passage, ça n'est pas la galère pour configurer mutt mais pour configurer fetchmail là smile


captnfab,
Association Debian-Facile, bépo.
TheDoctor: Your wish is my command… But be careful what you wish for.

Hors ligne

#3 24-08-2013 17:24:55

unit
Adhérent(e)
Lieu : Marcq-en-baroeul
Distrib. : Jessie
Noyau : Linux 3.16.0-4-amd64
(G)UI : Xfce 4.10
Inscription : 11-03-2010

Re : Grosse galère pour configurer mutt

J'ai essayé ta manip et j'ai toujours le même message

Exige beaucoup de toi-même et attends peu des autres. Ainsi beaucoup d'ennuis te seront épargnés.
Confucius.

Hors ligne

#4 24-08-2013 17:27:23

captnfab
Admin-Girafe
Lieu : /dev/random
Distrib. : Debian Stretch/Sid/Rc-Buggy
Noyau : Linux (≥ 4.3)
(G)UI : i3-wm (≥ 4.11)
Inscription : 07-07-2008
Site Web

Re : Grosse galère pour configurer mutt

Ça n'est pas une manip hein, c'est un remplacement de ton fichier ~/.fetchmailrc actuel.

Ensuite, tu lances le tout avec « fetchmail -f ~/.fetchmailrc »

captnfab,
Association Debian-Facile, bépo.
TheDoctor: Your wish is my command… But be careful what you wish for.

Hors ligne

#5 24-08-2013 18:12:03

unit
Adhérent(e)
Lieu : Marcq-en-baroeul
Distrib. : Jessie
Noyau : Linux 3.16.0-4-amd64
(G)UI : Xfce 4.10
Inscription : 11-03-2010

Re : Grosse galère pour configurer mutt

J'ai fait exactement comme tu m'a dit mais toujours le même message j'y comprend plus rien.

Exige beaucoup de toi-même et attends peu des autres. Ainsi beaucoup d'ennuis te seront épargnés.
Confucius.

Hors ligne

#6 24-08-2013 18:58:54

captnfab
Admin-Girafe
Lieu : /dev/random
Distrib. : Debian Stretch/Sid/Rc-Buggy
Noyau : Linux (≥ 4.3)
(G)UI : i3-wm (≥ 4.11)
Inscription : 07-07-2008
Site Web

Re : Grosse galère pour configurer mutt

Bon, si le pb ne vient pas du serveur où récupérer les mails, il vient du serveur où les envoyer. Tu as un MTP d'installé et de lancé ?

aptitude search ~i~Pmail-transport-agent



Si ça n'est pas le cas, je te suggère d'installer postfix.

apt-get install postfix


captnfab,
Association Debian-Facile, bépo.
TheDoctor: Your wish is my command… But be careful what you wish for.

Hors ligne

#7 24-08-2013 19:06:47

unit
Adhérent(e)
Lieu : Marcq-en-baroeul
Distrib. : Jessie
Noyau : Linux 3.16.0-4-amd64
(G)UI : Xfce 4.10
Inscription : 11-03-2010

Re : Grosse galère pour configurer mutt

J'ai déjà installé postfix

Exige beaucoup de toi-même et attends peu des autres. Ainsi beaucoup d'ennuis te seront épargnés.
Confucius.

Hors ligne

#8 24-08-2013 19:15:09

captnfab
Admin-Girafe
Lieu : /dev/random
Distrib. : Debian Stretch/Sid/Rc-Buggy
Noyau : Linux (≥ 4.3)
(G)UI : i3-wm (≥ 4.11)
Inscription : 07-07-2008
Site Web

Re : Grosse galère pour configurer mutt

Que se passe-t-il si tu lances fetchmail avec l'option « -v » ?

captnfab,
Association Debian-Facile, bépo.
TheDoctor: Your wish is my command… But be careful what you wish for.

Hors ligne

#9 24-08-2013 19:24:40

unit
Adhérent(e)
Lieu : Marcq-en-baroeul
Distrib. : Jessie
Noyau : Linux 3.16.0-4-amd64
(G)UI : Xfce 4.10
Inscription : 11-03-2010

Re : Grosse galère pour configurer mutt

captnfab a écrit :

Que se passe-t-il si tu lances fetchmail avec l'option « -v » ?


fetchmail: aucun serveur de courrier n'a été spécifié


Exige beaucoup de toi-même et attends peu des autres. Ainsi beaucoup d'ennuis te seront épargnés.
Confucius.

Hors ligne

#10 24-08-2013 19:28:20

captnfab
Admin-Girafe
Lieu : /dev/random
Distrib. : Debian Stretch/Sid/Rc-Buggy
Noyau : Linux (≥ 4.3)
(G)UI : i3-wm (≥ 4.11)
Inscription : 07-07-2008
Site Web

Re : Grosse galère pour configurer mutt

Si ton DD était un vinyle, je dirais que le disque est rayé… smile

Postfix marche bien ? tu arrives à t'envoyer des mails et à en recevoir ?

captnfab,
Association Debian-Facile, bépo.
TheDoctor: Your wish is my command… But be careful what you wish for.

Hors ligne

#11 24-08-2013 19:44:26

unit
Adhérent(e)
Lieu : Marcq-en-baroeul
Distrib. : Jessie
Noyau : Linux 3.16.0-4-amd64
(G)UI : Xfce 4.10
Inscription : 11-03-2010

Re : Grosse galère pour configurer mutt

J'adorai avoir encore un vinyle, mais sinon dans mutt je reçois mes mails mais lorsque j'en envoi un ça donne : gnutls_handshake: An unexpected TLS packet was received.

Exige beaucoup de toi-même et attends peu des autres. Ainsi beaucoup d'ennuis te seront épargnés.
Confucius.

Hors ligne

#12 24-08-2013 20:33:09

captnfab
Admin-Girafe
Lieu : /dev/random
Distrib. : Debian Stretch/Sid/Rc-Buggy
Noyau : Linux (≥ 4.3)
(G)UI : i3-wm (≥ 4.11)
Inscription : 07-07-2008
Site Web

Re : Grosse galère pour configurer mutt

Normalement, les envois de mails en local se font via des connexions claires sans authentification.
On dirait que postfix demande un tunnel chiffré TLS même en local. Tu as changé quelque chose dans la configuration de postfix ?

captnfab,
Association Debian-Facile, bépo.
TheDoctor: Your wish is my command… But be careful what you wish for.

Hors ligne

#13 24-08-2013 20:56:03

unit
Adhérent(e)
Lieu : Marcq-en-baroeul
Distrib. : Jessie
Noyau : Linux 3.16.0-4-amd64
(G)UI : Xfce 4.10
Inscription : 11-03-2010

Re : Grosse galère pour configurer mutt

Bon j'ai réglé le problème fetchmail,j'ai suivi ce tuto : http://forum.macbidouille.com/lofiversi … 18584.html et ça marche youpie par contre pour l'envoi des messages j'ai la même erreur.
J'ai tenté un dpkg-reconfigure postfix mais peut-tu m'éclairé sur les réglages.

Exige beaucoup de toi-même et attends peu des autres. Ainsi beaucoup d'ennuis te seront épargnés.
Confucius.

Hors ligne

Pied de page des forums