Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#51 02-12-2013 17:31:42

david96
Invité

Re : MPlayer s'est mal terminé.

/etc/X11/xorg.conf



Pour rechercher un nom de fichier rapidement tu as la commande locate :

locate xorg.conf

#52 05-12-2013 18:17:27

gio
Membre
Lieu : Strasbourg
Distrib. : stable (wheezy)
Noyau : Linux 3.2.0-4-686-pae
(G)UI : Gnome Version 3.4.2
Inscription : 18-09-2013
Site Web

Re : MPlayer s'est mal terminé.

J'ai trouvé ce fameux fichier ! (Déjà au départ je savais pas où on trouvait ce dossier "etc"...)

Et donc je dois copier

Section "Files"
ModulePath "/usr/lib64/xorg/modules/extensions/nvidia"
ModulePath "/usr/lib64/xorg/modules/drivers"
ModulePath "/usr/lib64/xorg/modules"
EndSection



...en bas du fichier xorg.conf ?
C'est à dire juste après :

Section "Extensions"
    Option         "Composite" "enable"
# Option      "RENDER"  "disable"
EndSection

Dernière modification par gio (05-12-2013 18:18:35)

Hors ligne

#53 06-12-2013 00:17:44

david96
Invité

Re : MPlayer s'est mal terminé.

Bon sang, excuse moi gio, mais je ne sais même plus de quoi on parlait… Tu peux me/nous faire un bref résumé de ton problème ?

#54 06-12-2013 01:23:31

gio
Membre
Lieu : Strasbourg
Distrib. : stable (wheezy)
Noyau : Linux 3.2.0-4-686-pae
(G)UI : Gnome Version 3.4.2
Inscription : 18-09-2013
Site Web

Re : MPlayer s'est mal terminé.

Bin le problème est toujours le même qu'au premier message de ce topic.
MPlayer ne veut rien ouvrir. :'(

Dernière modification par gio (06-12-2013 01:24:49)

Hors ligne

#55 06-12-2013 01:38:17

david96
Invité

Re : MPlayer s'est mal terminé.

Ha oui, bâ c'est étrange ; surtout qu'avec smplayer tout est possible en général… Pas glop tout ça ! hmm


Bon… Histoire que ma réponse ne soit pas totalement inutile, que te donne :

apt-cache policy smplayer

Dernière modification par Invité-2 (06-12-2013 01:40:34)

#56 06-12-2013 01:48:44

gio
Membre
Lieu : Strasbourg
Distrib. : stable (wheezy)
Noyau : Linux 3.2.0-4-686-pae
(G)UI : Gnome Version 3.4.2
Inscription : 18-09-2013
Site Web

Re : MPlayer s'est mal terminé.

gio@BOB:~$ apt-cache policy smplayer
smplayer:
  Installé : 0.8.0-1
  Candidat : 0.8.0-1
 Table de version :
 *** 0.8.0-1 0
        500 http://ftp.fr.debian.org/debian/ wheezy/main i386 Packages
        100 /var/lib/dpkg/status
 

Hors ligne

#57 06-12-2013 01:53:30

gio
Membre
Lieu : Strasbourg
Distrib. : stable (wheezy)
Noyau : Linux 3.2.0-4-686-pae
(G)UI : Gnome Version 3.4.2
Inscription : 18-09-2013
Site Web

Re : MPlayer s'est mal terminé.

Ah en fait je viens de remarquer que le message d'erreur quand j'essaie d'ouvrir un logiciel avec MPlayer n'est plus le même.
Maintenant c'est :

MPlayer ne s'est pas lancé. Veuillez vérifier votre chemin
MPlayer dans les préférences.



Et le journal indique :

xv, -noquiet -nofs -nomouseinput -sub-fuzziness 1 -identify -slave -vo x11 -ao pulse -zoom -nokeepaspect -framedrop -nodr -double -input nodefault-bindings:conf=/dev/null -stop-xscreensaver -wid 56623131 -monitorpixelaspect 1 -noass -fontconfig -font DejaVu Sans -subfont-autoscale 0 -subfont-text-scale 25 -subcp ISO-8859-1 -subpos 100 -volume 100 -nocache -osdlevel 0 -slices -channels 2 -af scaletempo,equalizer=0:0:0:0:0:0:0:0:0:0 -softvol -softvol-max 110 /home/gio/Bureau/Mon Nom Est Personne.avi
 

Dernière modification par gio (06-12-2013 01:54:13)

Hors ligne

#58 06-12-2013 01:58:31

david96
Invité

Re : MPlayer s'est mal terminé.

On a la même version de smplayer… Ton dernier message est intriguant…

Que te donne :

apt-cache policy mplayer


Voir :

apt-cache policy mplayer2

#59 06-12-2013 02:02:53

gio
Membre
Lieu : Strasbourg
Distrib. : stable (wheezy)
Noyau : Linux 3.2.0-4-686-pae
(G)UI : Gnome Version 3.4.2
Inscription : 18-09-2013
Site Web

Re : MPlayer s'est mal terminé.

Souviens toi le message #12 de ce topic, tu m'avais déjà demandé la même chose. Et il ne me semble pas y avoir une grande différence.

Le premier donne :

mplayer:
  Installé : 2:1.0~rc4.dfsg1+svn34540-1+b2
  Candidat : 2:1.0~rc4.dfsg1+svn34540-1+b2
 Table de version :
 *** 2:1.0~rc4.dfsg1+svn34540-1+b2 0
        500 http://ftp.fr.debian.org/debian/ wheezy/main i386 Packages
        100 /var/lib/dpkg/status
     2:1.0~rc3++svn20100804-0.2squeeze1 0
        500 http://mirror.home-dn.net/debian-multimedia/ stable/main i386 Packages
 



Et le deuxième :

mplayer2:
  Installé : (aucun)
  Candidat : 2.0-554-gf63dbad-1+b1
 Table de version :
     2.0-554-gf63dbad-1+b1 0
        500 http://ftp.fr.debian.org/debian/ wheezy/main i386 Packages
        100 /var/lib/dpkg/status
 

Dernière modification par gio (06-12-2013 02:05:42)

Hors ligne

#60 06-12-2013 02:13:50

david96
Invité

Re : MPlayer s'est mal terminé.

Oops, si je répète mes questions ce n'est pas bon signe, désolé… Je passe la main. hmm

#61 06-12-2013 02:14:51

gio
Membre
Lieu : Strasbourg
Distrib. : stable (wheezy)
Noyau : Linux 3.2.0-4-686-pae
(G)UI : Gnome Version 3.4.2
Inscription : 18-09-2013
Site Web

Re : MPlayer s'est mal terminé.

Il ne me reste plus qu'à retourner sous Windows...

Hors ligne

#62 06-12-2013 02:20:17

david96
Invité

Re : MPlayer s'est mal terminé.

Si tu penses que c'est mieux, ne te prive pas. wink

#63 06-12-2013 06:59:20

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : MPlayer s'est mal terminé.

C'est dommage de ne pas terminer ce que tu as entrepris sur df.

Si dans ta situation le privateur te paraît nécessaire, tu peux très bien le faire cohabiter avec du libre et poursuivre la continuité de tes efforts avec nous.
Comme le souligne david96, c'est à toi de choisir le libre, pas l'inverse.

Amitié, Joel smile

Dernière modification par smolski (06-12-2013 07:06:48)


"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

En ligne

#64 06-12-2013 07:39:30

kao
Modérateur
Distrib. : Testing
Noyau : Linux 4.quelquechose
(G)UI : Gnome 3
Inscription : 28-09-2012
Site Web

Re : MPlayer s'est mal terminé.

la première migration n'est jamais simple, parce que l'on ne sait pas toujours comment si prendre.
Mais je ne vois pas pourquoi tu t'entêtes avec Mplayer. Il existe plein d'autre lecteur dont VLC, Totem, ou encore Kaffeine. Tu dois même pouvoir déclencher les lectures directement depuis ffmpeg.
Personnellement, je n'ai jamais aimé Mplayer et cette histoire de libdvdpau me conforte dans cette idée.

Pour ton problème de son avec VLC, je pense que c'est lié à un problème de gestionnaire de son, et d'une application qui passe par alsa et d'une autre par pulseaudio. Un truc dans le style en tout cas.
Il est aussi possible que tu es fait une installation bancale de Debian, je ne sais pas comment tu as procédé, et que du coup le reste des logiciels en souffre.

Moi je pense que ça vaut le coup de persévérer, en refaisant une installation propre avec des bases saines.
On est tous passé par là big_smile , courage.

Hors ligne

#65 06-12-2013 10:04:26

golgot200
Membre
Lieu : AIN
Distrib. : Debian Jessie
Noyau : Linux debian 3.16.0-4-amd64
(G)UI : MATE
Inscription : 05-08-2007

Re : MPlayer s'est mal terminé.

kao a écrit :


je n'ai jamais aimé Mplayer et cette histoire de libdvdpau me conforte dans cette idée.



Ce serait plus du côté des pilotes pour cette prise en charge.

Pour Mplayer, aucun problème si on choisi la bonne version.

Dernière modification par golgot200 (06-12-2013 10:05:43)


L'ultime question ... l'intelligence a besoin de la bêtise pour s'affirmer, la beauté a besoin de la laideur pour resplendir, le courage nait dans la peur, les forts impressionnent au millieu des faibles, mais au final,... qui a donc besoin d'autant de connards ?

En ligne

#66 06-12-2013 10:09:24

kao
Modérateur
Distrib. : Testing
Noyau : Linux 4.quelquechose
(G)UI : Gnome 3
Inscription : 28-09-2012
Site Web

Re : MPlayer s'est mal terminé.

oui justement, un lecteur qui réclame une dépendance à une lib qui fonctionne que pour Nvidia, je trouve pas ça top.

Hors ligne

#67 06-12-2013 11:09:39

golgot200
Membre
Lieu : AIN
Distrib. : Debian Jessie
Noyau : Linux debian 3.16.0-4-amd64
(G)UI : MATE
Inscription : 05-08-2007

Re : MPlayer s'est mal terminé.

D'accord mais alors pourquoi vlc prend 35 à 45 % de charge CPU pour un 1080p et qu'mplayer me prend 2% CPU et ne fait travailler que ma carte graphique (GPU) ?

EDIT: VLC lira les vidéos boiteuses, ça c'est vrai mais qui ne sera pas le cas pour mplayer qui lui est plus exigeant.

Dernière modification par golgot200 (06-12-2013 11:15:34)


L'ultime question ... l'intelligence a besoin de la bêtise pour s'affirmer, la beauté a besoin de la laideur pour resplendir, le courage nait dans la peur, les forts impressionnent au millieu des faibles, mais au final,... qui a donc besoin d'autant de connards ?

En ligne

#68 06-12-2013 11:23:22

kao
Modérateur
Distrib. : Testing
Noyau : Linux 4.quelquechose
(G)UI : Gnome 3
Inscription : 28-09-2012
Site Web

Re : MPlayer s'est mal terminé.

@golgot Je suis d'accord avec toi, gio a un problème de pilote. Mais Mplayer demande l'accélération graphique par défaut et si tu ne l'as pas tant pis.

Par contre pour VLC il faut l'activer au cas par cas:
mini_131206102242231474.png
Tu devrais essayer pour voir si VLC le prends en compte et arrive à utiliser ta puce graphique. Ils appellent ça le décodage matériel, mais il n'est souvent disponible que pour certain codec.

Hors ligne

#69 06-12-2013 11:43:16

golgot200
Membre
Lieu : AIN
Distrib. : Debian Jessie
Noyau : Linux debian 3.16.0-4-amd64
(G)UI : MATE
Inscription : 05-08-2007

Re : MPlayer s'est mal terminé.

Oui oui, c'est déja tout bon de mon coté. VLC est moins performant au niveau ressource. C'était ma constatation.
Le pilote 304.88 dans les dépôts ne permet pas cette prise en charge. si je ne me trompe pas, c'est à partir de la version 310.
De plus, il existe différentes versions de Mplayer dans ça version 1. Mais certaines ne prennent pas VDPAU mais je ne sais plus laquelle. Je ne passe que par la version du dépot officiel. Elle tourne bien.

Pour information. Sur un autre PC et pourtant une série 8 la 8500 GT bas de gamme passe et pas une 8800 GTS pourtant plus costaud.
Mais il faut au minimum une série 8 pour le décodage. au dessous Nada smile

Dernière modification par golgot200 (06-12-2013 11:44:07)


L'ultime question ... l'intelligence a besoin de la bêtise pour s'affirmer, la beauté a besoin de la laideur pour resplendir, le courage nait dans la peur, les forts impressionnent au millieu des faibles, mais au final,... qui a donc besoin d'autant de connards ?

En ligne

#70 06-12-2013 12:17:01

kao
Modérateur
Distrib. : Testing
Noyau : Linux 4.quelquechose
(G)UI : Gnome 3
Inscription : 28-09-2012
Site Web

Re : MPlayer s'est mal terminé.

oui, au niveau des pilotes libres ou proprio c'est un peu la loterie, pour les fonctionnalités.

Hors ligne

#71 06-12-2013 12:42:10

gio
Membre
Lieu : Strasbourg
Distrib. : stable (wheezy)
Noyau : Linux 3.2.0-4-686-pae
(G)UI : Gnome Version 3.4.2
Inscription : 18-09-2013
Site Web

Re : MPlayer s'est mal terminé.

kao a écrit :

Mais je ne vois pas pourquoi tu t'entêtes avec Mplayer.


Plusieurs raisons :

  1. Comme tu le sais, j'utilise par défaut VLC, et il déconne aussi. J'ai le choix entre réparer le problème de VLC ou celui de SMplayer. Quitte à choisir, autant réparer le logiciel qui est mieux. Or on m'a dit que VLC était moins bien que SMplayer (ce que golgot200 semble confirmer). Je préfère garder VLC comme logiciel secondaire.

  2. C'est l'occasion pour moi d'apprendre à me servir de Linux, à voir comment ça marche et d'apprendre à résoudre des problèmes.

  3. Ça me ferait chier d'être passé à Linux en pensant que c'est plus stable, qu'il y a moins de problèmes...et de voir qu'au premier logiciel qui plante, on peut pas résoudre le problème. Que dès la première difficulté, c'est foutu. Car j'en ait encore d'autres des difficultés...(que je voudrais résoudre une fois que celle-ci sera réparée.)

  4. Question de principe. Quand j'ai un problème, je veux savoir que j'ai finalement finit par le résoudre.



kao a écrit :

Il est aussi possible que tu es fait une installation bancale de Debian, je ne sais pas comment tu as procédé, et que du coup le reste des logiciels en souffre.

Ce n'est pas moi qui ai fait l'installation, c'est un copain en qui j'ai une confiance totale en matière d'informatique (qui voulait vraiment que je passe à Linux), le connaissant, je doute qu'il ait fait une installation "impropre".
En ce qui me concerne, je serais bien incapable d'installer un système d'exploitation...

Sinon kao, peux-tu répondre au message #52 ? big_smile

Hors ligne

#72 06-12-2013 13:33:24

kao
Modérateur
Distrib. : Testing
Noyau : Linux 4.quelquechose
(G)UI : Gnome 3
Inscription : 28-09-2012
Site Web

Re : MPlayer s'est mal terminé.

@gio C'est une très bonne mentalité smile

En ce qui me concerne, je serais bien incapable d'installer un système d'exploitation...


C'est plus facile que ce que l'on croit, mais faut pas avoir peur de tout casser smile.
http://debian-facile.org/doc:install:in … n-standard

Sinon pour le #52 tu as raison de me tirer l'oreille big_smile voilà ma réponse:
Avant de toucher au xorg.conf, il faut commencer par sauvegarder ton xorg.conf

cp /etc/X11/xorg.conf /etc/X11/xorg.conf.old


Si le serveurX ne s'en sort pas tu pourras revenir en arrière en inversant la commande.

Une fois la sauvegarde faites,  tu dois déclarer ces trois chemins dans le fichier xorg.conf puisque tu as une machine 64bits.

Section "Files"
   ModulePath "/usr/lib64/xorg/modules/extensions/nvidia"
   ModulePath "/usr/lib64/xorg/modules/drivers"
   ModulePath "/usr/lib64/xorg/modules"
EndSection


Si aucune "Section Files" existe tu colles l'ensemble entre deux autres sections.
Sinon tu ajoutes les 3 lignes ModulePath dans la section Files existante.
Il faudra un redémarrage pour que ce soit pris en compte.

Si ça foire, tu reviens en arrière, et tu publies ici ton xorg.conf complet, on verra ce qui cloche.

Hors ligne

#73 06-12-2013 14:01:50

gio
Membre
Lieu : Strasbourg
Distrib. : stable (wheezy)
Noyau : Linux 3.2.0-4-686-pae
(G)UI : Gnome Version 3.4.2
Inscription : 18-09-2013
Site Web

Re : MPlayer s'est mal terminé.

Je n'arrive déjà pas à sauvegarder xorg.conf :

gio@BOB:~$ cp /etc/X11/xorg.conf /etc/X11/xorg.conf.old
cp: impossible de créer le fichier standard « /etc/X11/xorg.conf.old »: Permission non accordée

Hors ligne

#74 06-12-2013 14:06:41

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : MPlayer s'est mal terminé.

As-tu utilisé l'autocomplétion gio ?
L'autocompletion, c'est d'la crème !

"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

En ligne

#75 06-12-2013 14:12:55

kao
Modérateur
Distrib. : Testing
Noyau : Linux 4.quelquechose
(G)UI : Gnome 3
Inscription : 28-09-2012
Site Web

Re : MPlayer s'est mal terminé.

AhAh! cp est l'outil de copie, et le dossier dans lequel tu veux écrire le .old nécessite des droits d'admin (root).
Du coup il faut la lancer en root:

cp /etc/X11/xorg.conf /etc/X11/xorg.conf.old



Pareil pour l'édition du fichier, tu peux le lire en utilisateur normal, mais tu ne pourras enregistrer les modifications qu'en étant en root.
du coup:

gedit /etc/X11/xorg.conf


ou

nano /etc/X11/xorg.conf


remplace gedit ou nano par l'éditeur de ton choix.

Hors ligne

Pied de page des forums