Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 23-09-2013 12:21:46

df871
Membre
Lieu : Limousin
Distrib. : Debian Wheezy 7.1 32b
Noyau : Linux 3.2.0-4-486
(G)UI : Xfce 4.8
Inscription : 17-09-2013
Site Web

[Résolu] Lxde ne se désinstalle pas...

Bonjour à Toutes et Tous smile

Dans mes différents tests, j'ai testé Lxde, me déplaisant, entre autre pour cause d'impossibilité de paramétrer la résolution de l'écran, malgré que j'ai lu ceci :

paskal a écrit :

Et quant tu seras sous LXDE, ce sera lxrandr smile



ici :
http://debian-facile.org/viewtopic.php?id=7034

j'avais décidé de supprimer Lxde, or, il est toujours installé... roll

voici quelques retours de commande :

# apt-cache policy lxde
lxde:
  Installé : (aucun)
  Candidat : 4+nmu1
 Table de version :
     4+nmu1 0
        500 http://ftp.fr.debian.org/debian/ wheezy/main i386 Packages
#



# aptitude remove lxde
Aucun paquet ne va être installé, mis à jour ou enlevé.
0 paquets mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.
Il est nécessaire de télécharger 0 o d'archives. Après dépaquetage, 0 o seront utilisés.
                                             
#



# apt-get autoremove lxde
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Le paquet « lxde » n'est pas installé, et ne peut donc être supprimé
0 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.
#



mais il restait installé Openbox... !?

# apt-cache policy openbox
openbox:
  Installé : 3.5.0-7
  Candidat : 3.5.0-7
 Table de version :
 *** 3.5.0-7 0
        500 http://ftp.fr.debian.org/debian/ wheezy/main i386 Packages
        100 /var/lib/dpkg/status
#



donc :

# aptitude remove openbox
Les paquets suivants seront ENLEVÉS :        
  openbox
0 paquets mis à jour, 0 nouvellement installés, 1 à enlever et 0 non mis à jour.
Il est nécessaire de télécharger 0 o d'archives. Après dépaquetage, 1 348 ko seront libérés.
Les paquets suivants ont des dépendances non satisfaites :
 openbox-themes : Dépend: openbox (>= 3.0) mais il ne sera pas installé.
 lxde-core : Dépend: openbox mais il ne sera pas installé.
Les actions suivantes permettront de résoudre ces dépendances :

     Supprimer les paquets suivants :                  
1)     lxde-core                                        
2)     openbox-themes                                  

     Laisser les dépendances suivantes non satisfaites :
3)     lxde-common recommande lxde-core                
4)     obconf recommande openbox                        


Accepter cette solution ? [Y/n/q/?] y
Les paquets suivants seront ENLEVÉS :
  lxde-core{a} openbox openbox-themes{a}
0 paquets mis à jour, 0 nouvellement installés, 3 à enlever et 0 non mis à jour.
Il est nécessaire de télécharger 0 o d'archives. Après dépaquetage, 7 630 ko seront libérés.
Voulez-vous continuer ? [Y/n/?] y
(Lecture de la base de données... 187662 fichiers et répertoires déjà installés.)
Suppression de lxde-core ...
Suppression de openbox-themes ...
Suppression de openbox ...
update-alternatives: utilisation de « /usr/bin/metacity » pour fournir « /usr/bin/x-window-manager » (x-window-manager) en mode automatique
Traitement des actions différées (« triggers ») pour « doc-base »...
Traitement de 1 fichier de documentation supprimé…
Enregistrement des documents avec dwww…
Enregistrement des documents avec scrollkeeper…
Traitement des actions différées (« triggers ») pour « desktop-file-utils »...
Traitement des actions différées (« triggers ») pour « gnome-menus »...
Traitement des actions différées (« triggers ») pour « menu »...
Traitement des actions différées (« triggers ») pour « man-db »...
                                             
#



puis un p'tit nettoyage :

# aptitude clean
#



# aptitude autoclean
0 o d'espace disque ont été libérés          
#




Peut-être... j'écris bien peut-être... que Ben va m'écrire :
ta Debian n'est plus stable... ou  est devenue instable... !

peut-être... que tu aies raison... sauf que j'avais installé Lxde, puis désinstallé, avant d'installer Xcfe4.10 !

Je ne me suis aperçu de son installation "persistante" en changeant de session, son nom et Openbox étant toujours dans la liste de choix gestionnaire... !


Vous avez des suggestions, ou c'est moi qui suis "fatigué" tongue

Merci de vos retours smile

Dernière modification par df871 (23-09-2013 13:37:22)


Cordialement
Bernard
Crées, Consolides... puis, Continues à Créer smile
Asus P4P800, P4C 2,6Ghz, Seagate laptop SSHD 500Go, Nvidia GF 6200 512 Mo avec Debian 7.0, Xfce 4.08

Hors ligne

#2 23-09-2013 12:36:31

captnfab
Admin-Girafe
Lieu : /dev/random
Distrib. : Debian Stretch/Sid/Rc-Buggy
Noyau : Linux (≥ 4.3)
(G)UI : i3-wm (≥ 4.11)
Inscription : 07-07-2008
Site Web

Re : [Résolu] Lxde ne se désinstalle pas...

Salut,
Le paquet lxde a bien été désinstallé. Par contre, on voit que le paquet lxde-core n'a pas été désinstallé. Seuls les paquets installés automatiquement sont désinstallés automatiquement.
POur voir les traces de lxde :

aptitude search '~ilxde'


captnfab,
Association Debian-Facile, bépo.
TheDoctor: Your wish is my command… But be careful what you wish for.

Hors ligne

#3 23-09-2013 12:40:55

df871
Membre
Lieu : Limousin
Distrib. : Debian Wheezy 7.1 32b
Noyau : Linux 3.2.0-4-486
(G)UI : Xfce 4.8
Inscription : 17-09-2013
Site Web

Re : [Résolu] Lxde ne se désinstalle pas...

le retour :

~$ aptitude search '~ilxde'
i   lxde-common                     - LXDE configuration data                  
i   lxde-icon-theme                 - LXDE standard icon theme                  
~$


Cordialement
Bernard
Crées, Consolides... puis, Continues à Créer smile
Asus P4P800, P4C 2,6Ghz, Seagate laptop SSHD 500Go, Nvidia GF 6200 512 Mo avec Debian 7.0, Xfce 4.08

Hors ligne

#4 23-09-2013 13:22:12

captnfab
Admin-Girafe
Lieu : /dev/random
Distrib. : Debian Stretch/Sid/Rc-Buggy
Noyau : Linux (≥ 4.3)
(G)UI : i3-wm (≥ 4.11)
Inscription : 07-07-2008
Site Web

Re : [Résolu] Lxde ne se désinstalle pas...

« i » indique que les paquets ont été installés manuellement et non automatiquement (sinon, tu aurais « i A ». C'est donc normal qu'ils n'aient pas été désinstallées automatiquement. Quelle commande as-tu utilisé pour installer lxde ?

captnfab,
Association Debian-Facile, bépo.
TheDoctor: Your wish is my command… But be careful what you wish for.

Hors ligne

#5 23-09-2013 13:25:49

df871
Membre
Lieu : Limousin
Distrib. : Debian Wheezy 7.1 32b
Noyau : Linux 3.2.0-4-486
(G)UI : Xfce 4.8
Inscription : 17-09-2013
Site Web

Re : [Résolu] Lxde ne se désinstalle pas...


Cordialement
Bernard
Crées, Consolides... puis, Continues à Créer smile
Asus P4P800, P4C 2,6Ghz, Seagate laptop SSHD 500Go, Nvidia GF 6200 512 Mo avec Debian 7.0, Xfce 4.08

Hors ligne

#6 23-09-2013 13:34:52

df871
Membre
Lieu : Limousin
Distrib. : Debian Wheezy 7.1 32b
Noyau : Linux 3.2.0-4-486
(G)UI : Xfce 4.8
Inscription : 17-09-2013
Site Web

Re : [Résolu] Lxde ne se désinstalle pas...

après les avoir supprimés à la main, ils n'apparaissent plus lors du changement de session !

Merci Fab smile

Cordialement
Bernard
Crées, Consolides... puis, Continues à Créer smile
Asus P4P800, P4C 2,6Ghz, Seagate laptop SSHD 500Go, Nvidia GF 6200 512 Mo avec Debian 7.0, Xfce 4.08

Hors ligne

Pied de page des forums