Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 30-09-2013 21:59:32

Lunatic
Membre
Lieu : Lyon
Distrib. : Fedora 24
Noyau : Linux 4.6.5-300.fc24.x86_64
(G)UI : Gnome
Inscription : 03-08-2013
Site Web

Petit bug de gvim ?

Bonjour à tou·te·s,

J'utilise très fréquemment gvim, dont la fenêtre est maximisée verticalement (pas horizontalement). Lorsque je crée un nouvel onglet, ou bien lorsque je passe d'un onglet à l'autre, j'ai une espèce de bordure grise, relativement haute, qui apparaît au bas de la fenêtre. J'en ai fait une copie d'écran, visible ici.

J'ai essayé différentes options : avec ou sans décoration des fenêtres (habituellement je n'en utilise pas), avec des onglets utilisant le GUI ou sans (comme sur la copie d'écran)… le problème reste le même.

La seule façon rapide que j'ai trouvé de « résoudre » le problème consiste à afficher tint2 (qui se cache automatiquement), afin que la taille de la fenêtre soit recalculée et que son contenu soit redessiné.

D'avance merci et bonne soirée.

Je suis aussi sur Twitter et nouvellement sur Diaspora*
Mon blog de geekeries : HAL-9000

(J'applique la règle de proximité)

Hors ligne

#2 30-09-2013 22:25:18

david96
Invité

Re : Petit bug de gvim ?

Bonsoir,


Je ne connais pas l'interface graphique de vim, mais par curiosité je l'ai installé…
Je n'ai pas rencontré ton bogue. Tout fonctionne bien (cf capture)
Par contre, je remarque que ton interface ne ressemble pas du tout à celle qui est misE par défaut, à savoir la barre des menus, icônes etc…


As-tu tenté de revenir par défaut ? Possible que dans tes manipulations, tu ais grippé un petit rouage tongue


Capture :
1380572671.png
Zoom : 1680 x 1050 - 317.35 ko

Dernière modification par Invité-2 (30-09-2013 22:26:15)

#3 30-09-2013 22:50:35

Lunatic
Membre
Lieu : Lyon
Distrib. : Fedora 24
Noyau : Linux 4.6.5-300.fc24.x86_64
(G)UI : Gnome
Inscription : 03-08-2013
Site Web

Re : Petit bug de gvim ?

Merci pour ta réponse.

J'ai juste modifié l'interface pour qu'elle soit plus épurée (je n'utilise pas les menus…). Voir

:help 'guioptions'

pour davantage de détails à ce sujet smile

Malheureusement ça ne semble pas lié à mon problème.


Je suis aussi sur Twitter et nouvellement sur Diaspora*
Mon blog de geekeries : HAL-9000

(J'applique la règle de proximité)

Hors ligne

#4 30-09-2013 23:42:15

david96
Invité

Re : Petit bug de gvim ?

Il est donc possible que cela vienne d'une option de guioptions,

Je viens de faire qqs tests, genre :

:set guioptions=go-m
:set guioptions=go-g
:set guioptions=go-T



Et déjà, la fenêtre n'est plus conforme au cadrage verticale, notamment au niveau du bas.


Je suppose que gvim, doit avoir son fichier de config. Ça ne coûte rien de le copier histoire de remettre le tout par défaut wink

Dernière modification par Invité-2 (30-09-2013 23:42:50)

#5 01-10-2013 00:16:22

Lunatic
Membre
Lieu : Lyon
Distrib. : Fedora 24
Noyau : Linux 4.6.5-300.fc24.x86_64
(G)UI : Gnome
Inscription : 03-08-2013
Site Web

Re : Petit bug de gvim ?

La fenêtre dépouillée telle qu'elle apparaît sur la capture d'écran n'est pas celle que j'utilise en permanence : elle est mise en place automatiquement à l'édition d'un fichier portant l'extension .md (pour markdown), mais c'est tout. Autrement dit, il m'arrive de travailler dans un gvim avec l'ensemble des barres et autres menus, bref, avec un gvim à l'apparence « par défaut ». Et je confirme que le problème se pose également.

Mais je crois l'avoir mieux cerné : il survient lorsque j'utilise la maximisation verticale de la fenêtre que permet Openbox. J'ai l'impression que la maximisation « complète » (à la fois verticale et horizontale) ne pose pas le soucis évoqué.

Je suis aussi sur Twitter et nouvellement sur Diaspora*
Mon blog de geekeries : HAL-9000

(J'applique la règle de proximité)

Hors ligne

Pied de page des forums