Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 01-10-2013 20:31:42

golgot200
Membre
Lieu : AIN
Distrib. : Debian Jessie
Noyau : Linux debian 3.16.0-4-amd64
(G)UI : MATE
Inscription : 05-08-2007

Xfce et notification de mises à jour.

Bonsoir,


Je n'ai pas de gestionnaire de paquets sur mon installation minimale Xfce.
Est-il possible d'avoir un truc dans le genre qui averti des mises à jour en notification dans le tableau de bord ?
Si je dois installer un  gestionnaire de paquets avec interface graphique. J'ai vu qu'il y a Apper. Par rapport à Synaptic, les moins et les plus entre ces deux gestionnaireS.
Merci d'avance.

Dernière modification par golgot200 (01-10-2013 20:33:32)


L'ultime question ... l'intelligence a besoin de la bêtise pour s'affirmer, la beauté a besoin de la laideur pour resplendir, le courage nait dans la peur, les forts impressionnent au millieu des faibles, mais au final,... qui a donc besoin d'autant de connards ?

Hors ligne

#2 01-10-2013 21:21:52

pili36
Membre
Lieu : Lille
Distrib. : Debian Jessie / Raspbian Jessie
Noyau : 3.16_amd64 / 3.16_armhf
(G)UI : Mate / Lxde
Inscription : 03-11-2009

Re : Xfce et notification de mises à jour.

Bonsoir,

Pour avoir des notifications de mises à jour, il y a le paquet update-notifier. Par contre je ne peux pas te donner de comparatif entre Synaptic et Apper, ne connaissant pas Apper, mais je suis sur que quelqu'un d'autres le fera. Dans tous les cas, Apper est lié KDE, si tu installes Apper, tu auras une bonne partie de KDE qui sera installé avec, ce qui n'est pas forcément le but lorsqu'on utilise Xfce.
Concernant Synaptic, il me semble qu'il est installé par défaut durant l'installation de update-notifier. D'après le site de paquet de Debian, synaptic est taggé comme paquet recommandé, donc si tu n'en veux pas, l'option --no-install-recommends en ligne de commande avec apt-get devrait permettre de ne pas l'installer. Personnellement, je trouve synpatic très pratique même si j'ai tendance à utiliser plutôt la ligne de commande.

Dernière modification par pili36 (01-10-2013 21:29:27)


Debian Jessie Amd64, Mate, Lenovo G50, Amd Q4000 4*1,3Ghz, 4Go RAM, Amd Radeon R3
Debian Jessie Amd64, (pour Steam), Mate, Amd Athlon 860K 4*3.7Ghz, 8Go RAM, AMD Radeon R7 250 2Go
Raspbian Jessie Armhf, Lxde, Raspberry Pi model B

Hors ligne

#3 01-10-2013 21:35:06

golgot200
Membre
Lieu : AIN
Distrib. : Debian Jessie
Noyau : Linux debian 3.16.0-4-amd64
(G)UI : MATE
Inscription : 05-08-2007

Re : Xfce et notification de mises à jour.

Merci mon choix sera synaptic vu que je le connais bien.
Je viens de l'installer. Je veux une inteface graphique car en commande, j'ai du mal avec les noms de certains programmes que je ne connais pas par coeur.

Une chose me chagrine en fin d'installation de paquets, j'ai ce message :

W: A attendu dpkg --assert-multi-arch mais il n'était pas présent - dpkgGo (10: Aucun processus enfant)

Bon pas d'incidence mais ça cherche quelque chose mais quoi ?


EDIT : update-notifier n'est pas installé en même temps avec synaptic. Si je l'installe, il me met aussi " sudo, gksu gnome-keyring .... une dizaine de paquets. Je met ou je mais pas ?

Dernière modification par golgot200 (01-10-2013 21:38:31)


L'ultime question ... l'intelligence a besoin de la bêtise pour s'affirmer, la beauté a besoin de la laideur pour resplendir, le courage nait dans la peur, les forts impressionnent au millieu des faibles, mais au final,... qui a donc besoin d'autant de connards ?

Hors ligne

#4 01-10-2013 21:54:28

golgot200
Membre
Lieu : AIN
Distrib. : Debian Jessie
Noyau : Linux debian 3.16.0-4-amd64
(G)UI : MATE
Inscription : 05-08-2007

Re : Xfce et notification de mises à jour.

Pour ce qui est de l'erreur:

W: A attendu dpkg --assert-multi-arch mais il n'était pas présent - dpkgGo (10: Aucun processus enfant)

J'ai supprimé les paquets en cache et bingo, plus ce message big_smile

EDIT: Et ben non, ça marche plus, installation de Gimp et rebellote, même message mad
Arghhhhhhh, ça c'est fort. Si je coche "supprimer les paquets après installation". Plus ce message !!! KESAKO ????

Dernière modification par golgot200 (01-10-2013 22:20:18)


L'ultime question ... l'intelligence a besoin de la bêtise pour s'affirmer, la beauté a besoin de la laideur pour resplendir, le courage nait dans la peur, les forts impressionnent au millieu des faibles, mais au final,... qui a donc besoin d'autant de connards ?

Hors ligne

#5 01-10-2013 22:15:44

pili36
Membre
Lieu : Lille
Distrib. : Debian Jessie / Raspbian Jessie
Noyau : 3.16_amd64 / 3.16_armhf
(G)UI : Mate / Lxde
Inscription : 03-11-2009

Re : Xfce et notification de mises à jour.

J'ai 2 Debian, sur la version Gnome j'ai pas ce message, mais sur la version Xfce j'ai aussi ce message. Par contre, je n'ai aucune idée du pourquoi du comment et comme ça ne génère pas de problème au niveau stabilité, fonctionnalités, j'ai pas cherché plus loin. Peut être que quelqu'un nous donnera le pourquoi du comment smile

Debian Jessie Amd64, Mate, Lenovo G50, Amd Q4000 4*1,3Ghz, 4Go RAM, Amd Radeon R3
Debian Jessie Amd64, (pour Steam), Mate, Amd Athlon 860K 4*3.7Ghz, 8Go RAM, AMD Radeon R7 250 2Go
Raspbian Jessie Armhf, Lxde, Raspberry Pi model B

Hors ligne

#6 01-10-2013 22:18:01

golgot200
Membre
Lieu : AIN
Distrib. : Debian Jessie
Noyau : Linux debian 3.16.0-4-amd64
(G)UI : MATE
Inscription : 05-08-2007

Re : Xfce et notification de mises à jour.

Regarde mon edit juste en haut le dernier point wink

Dernière modification par golgot200 (01-10-2013 22:18:47)


L'ultime question ... l'intelligence a besoin de la bêtise pour s'affirmer, la beauté a besoin de la laideur pour resplendir, le courage nait dans la peur, les forts impressionnent au millieu des faibles, mais au final,... qui a donc besoin d'autant de connards ?

Hors ligne

#7 01-10-2013 22:25:58

pili36
Membre
Lieu : Lille
Distrib. : Debian Jessie / Raspbian Jessie
Noyau : 3.16_amd64 / 3.16_armhf
(G)UI : Mate / Lxde
Inscription : 03-11-2009

Re : Xfce et notification de mises à jour.

Ah oui, quand j'ai regardé, j'avais pas ou  je n'ai pas vu la ligne sous la ligne "EDIT", mais ça reste étrange de devoir supprimer les paquets téléchargés pour que le message disparaisse. Et puis comme j'utilise le paquet apt-p2p pour alléger les serveurs Debian, je n'ai pas d'intérêt à les supprimer. Si tu ne connais pas , que tu es curieux ou que cela t'intéresse, je te renvois vers la doc debian-facile.concernant ce paquet.

Debian Jessie Amd64, Mate, Lenovo G50, Amd Q4000 4*1,3Ghz, 4Go RAM, Amd Radeon R3
Debian Jessie Amd64, (pour Steam), Mate, Amd Athlon 860K 4*3.7Ghz, 8Go RAM, AMD Radeon R7 250 2Go
Raspbian Jessie Armhf, Lxde, Raspberry Pi model B

Hors ligne

#8 01-10-2013 22:34:00

golgot200
Membre
Lieu : AIN
Distrib. : Debian Jessie
Noyau : Linux debian 3.16.0-4-amd64
(G)UI : MATE
Inscription : 05-08-2007

Re : Xfce et notification de mises à jour.

OK merci.

Je continue de regarder le pourquoi du comment. Mais, c'est bizarre car maintenant les messages c'est à la désinstallation que je les ai maintenant. cool
Il manque un paquet ou deux, c'est sûr ....

L'ultime question ... l'intelligence a besoin de la bêtise pour s'affirmer, la beauté a besoin de la laideur pour resplendir, le courage nait dans la peur, les forts impressionnent au millieu des faibles, mais au final,... qui a donc besoin d'autant de connards ?

Hors ligne

#9 02-10-2013 11:17:27

golgot200
Membre
Lieu : AIN
Distrib. : Debian Jessie
Noyau : Linux debian 3.16.0-4-amd64
(G)UI : MATE
Inscription : 05-08-2007

Re : Xfce et notification de mises à jour.

Bonjour,

Bon ce message d'erreur n'apparait que si on utilise l'interface. En utilisant que le terminal, ce message n'apparait pas.
C'est le  --assert-multi-arch  qui me chagrine.

L'ultime question ... l'intelligence a besoin de la bêtise pour s'affirmer, la beauté a besoin de la laideur pour resplendir, le courage nait dans la peur, les forts impressionnent au millieu des faibles, mais au final,... qui a donc besoin d'autant de connards ?

Hors ligne

#10 02-10-2013 11:23:28

captnfab
Admin-Girafe
Lieu : /dev/random
Distrib. : Debian Stretch/Sid/Rc-Buggy
Noyau : Linux (≥ 4.3)
(G)UI : i3-wm (≥ 4.11)
Inscription : 07-07-2008
Site Web

Re : Xfce et notification de mises à jour.

Peut-être un bug de synaptic ? De toute façon, rien de tel que les commandes en console, au moins, on sait ce qu'elles font, et elles sont stables et éprouvées smile

captnfab,
Association Debian-Facile, bépo.
TheDoctor: Your wish is my command… But be careful what you wish for.

Hors ligne

#11 02-10-2013 12:57:47

golgot200
Membre
Lieu : AIN
Distrib. : Debian Jessie
Noyau : Linux debian 3.16.0-4-amd64
(G)UI : MATE
Inscription : 05-08-2007

Re : Xfce et notification de mises à jour.

Synaptic ou dpkg  peut-être.

Dernière modification par golgot200 (02-10-2013 12:58:29)


L'ultime question ... l'intelligence a besoin de la bêtise pour s'affirmer, la beauté a besoin de la laideur pour resplendir, le courage nait dans la peur, les forts impressionnent au millieu des faibles, mais au final,... qui a donc besoin d'autant de connards ?

Hors ligne

#12 02-10-2013 13:04:00

captnfab
Admin-Girafe
Lieu : /dev/random
Distrib. : Debian Stretch/Sid/Rc-Buggy
Noyau : Linux (≥ 4.3)
(G)UI : i3-wm (≥ 4.11)
Inscription : 07-07-2008
Site Web

Re : Xfce et notification de mises à jour.

Nah, dpkg est stable, s'il y a un bug et que c'est dpkg qui râle, c'est plus probablement qu'on lui a donné de mauvais arguments, ou que le paquet .deb est mal fichu.

captnfab,
Association Debian-Facile, bépo.
TheDoctor: Your wish is my command… But be careful what you wish for.

Hors ligne

#13 02-10-2013 13:23:14

golgot200
Membre
Lieu : AIN
Distrib. : Debian Jessie
Noyau : Linux debian 3.16.0-4-amd64
(G)UI : MATE
Inscription : 05-08-2007

Re : Xfce et notification de mises à jour.

Oui, c'est bien pour cela que je parle de dpkg mais je me suis mal exprimé. Ce ne sont pas tout les paquets qui me font ça à l'installation.

L'ultime question ... l'intelligence a besoin de la bêtise pour s'affirmer, la beauté a besoin de la laideur pour resplendir, le courage nait dans la peur, les forts impressionnent au millieu des faibles, mais au final,... qui a donc besoin d'autant de connards ?

Hors ligne

Pied de page des forums