Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 14-09-2008 15:23:33

mouloud7
Membre
Lieu : Guadeloupe
Distrib. : wheezy/testing
Noyau : 3.2.0.3
(G)UI : openbox
Inscription : 12-09-2008

pb installation driver ATI pour carte graphique ATI Radeon Xpress200M

Je suis sur un portable Compaq presario avec une carte ATI radeon Xpress 200M.
En voulant installer les pilotes propriétaires de la carte, je vais sur le site de ATI, je les récupère. Je commence l'install.
Tout va bien, le pilote semble s'installer sans souci, sauf que quand c'est terminé sans message d'erreur, apparaît dans l'onglet "applications" deux nouvelles icônes ATI catalyst control center & ATI catalyst control center (super user) qui, quand on clique dessus disent que le pilote ATI n'a pas été installé correctement ou que ce n'est pas le bon pilote ?
Que faire, je suis sous Debian Lenny, avec gnome
par avance merci

La liberté d'écrire et de parler dépend soit de l'extrême bonté du prince, soit du profond esclavage du peuple. On ne permet de dire qu'à celui qui ne peut rien. DIDEROT

Hors ligne

#2 15-09-2008 19:03:16

freddec
homo-informaticus du genre linuxo-debianicum
Lieu : Saint Jean d'Y (17)
Distrib. : Branche Stable (Jessie)
Noyau : Linux 3.16.0-4-amd64
(G)UI : XFCE_4.1 (+/- Mate) (+/- Cinnamon)
Inscription : 09-01-2008

Re : pb installation driver ATI pour carte graphique ATI Radeon Xpress200M

Salut

Tu as bien édité ton xorg.conf (après sauvegarde bien entendu) pour lui dire d'utiliser le pilote ATI et non le pilote générique de xorg pour ati ?

Desktop: Jessie (I5 - 16Go)
Laptop 1: Jessie (HP DV9000, 3Go)
Laptop 2: Jessie (PackardBell TS 44, Core I5, 4Go)
EeePC : Jessie (Atom N450, 2 Go)

Hors ligne

#3 15-09-2008 23:00:25

mouloud7
Membre
Lieu : Guadeloupe
Distrib. : wheezy/testing
Noyau : 3.2.0.3
(G)UI : openbox
Inscription : 12-09-2008

Re : pb installation driver ATI pour carte graphique ATI Radeon Xpress200M

Quelle manip faut-il faire en clair ?
par avance merci...

La liberté d'écrire et de parler dépend soit de l'extrême bonté du prince, soit du profond esclavage du peuple. On ne permet de dire qu'à celui qui ne peut rien. DIDEROT

Hors ligne

#4 16-09-2008 20:37:57

tux12
Membre
Lieu : ./
Distrib. : Squeeze
Noyau : Linux 2.6.32-5-686-bigmem
(G)UI : KDE
Inscription : 27-02-2008

Re : pb installation driver ATI pour carte graphique ATI Radeon Xpress200M

Bonjour,

Sous réserve que j'ai tout bien compris (le pilote ATI c'est fglrx?), ça devrait ressembler à ceci (section Editer le fichier xorg.conf).

@+

Hors ligne

#5 16-09-2008 20:52:22

mouloud7
Membre
Lieu : Guadeloupe
Distrib. : wheezy/testing
Noyau : 3.2.0.3
(G)UI : openbox
Inscription : 12-09-2008

Re : pb installation driver ATI pour carte graphique ATI Radeon Xpress200M

je viens d'aller voir : pas de section "module"... donc pas fait la suite. Voilà mon xorg.conf
# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "InputDevice"
    Identifier    "Generic Keyboard"
    Driver        "kbd"
    Option        "XkbRules"    "xorg"
    Option        "XkbModel"    "pc105"
    Option        "XkbLayout"    "fr"
    Option        "XkbVariant"    "latin9"
EndSection

Section "InputDevice"
    Identifier    "Configured Mouse"
    Driver        "mouse"
EndSection

Section "Device"
    Identifier    "Configured Video Device"
EndSection

Section "Monitor"
    Identifier    "Configured Monitor"
EndSection

Section "Screen"
    Identifier    "Default Screen"
    Monitor        "Configured Monitor"
EndSection

Que pasa anormal ????
par avance, merci beaucoup... Je ne suis vraiment pas doué...

La liberté d'écrire et de parler dépend soit de l'extrême bonté du prince, soit du profond esclavage du peuple. On ne permet de dire qu'à celui qui ne peut rien. DIDEROT

Hors ligne

#6 17-09-2008 12:44:27

freddec
homo-informaticus du genre linuxo-debianicum
Lieu : Saint Jean d'Y (17)
Distrib. : Branche Stable (Jessie)
Noyau : Linux 3.16.0-4-amd64
(G)UI : XFCE_4.1 (+/- Mate) (+/- Cinnamon)
Inscription : 09-01-2008

Re : pb installation driver ATI pour carte graphique ATI Radeon Xpress200M

Salut

Non ça n'a rien avoir avec toi, depuis xorg 7.1 la xorg.conf est trés allégé car il y a de plus en plus de reconnaissance automatique.
Mais cette reconnaissance auto utilise par défaut les pilote xorg libre.

Il faut donc que tu édites en root le fichier xorg.conf (apres sauvegarde) et que tu modifie la section "Input Device" pour qu'elle ressemble a ceci:

Section "Device"
    Identifier     "Configured Video Device"
    Driver         "fglrx"
EndSection

De cette manière ton xorg.conf prendra le pas sur le driver ati de "Configured Device"
Ce n'est peut être pas sufisant, mais c'est un début

Desktop: Jessie (I5 - 16Go)
Laptop 1: Jessie (HP DV9000, 3Go)
Laptop 2: Jessie (PackardBell TS 44, Core I5, 4Go)
EeePC : Jessie (Atom N450, 2 Go)

Hors ligne

#7 17-09-2008 21:03:23

mouloud7
Membre
Lieu : Guadeloupe
Distrib. : wheezy/testing
Noyau : 3.2.0.3
(G)UI : openbox
Inscription : 12-09-2008

Re : pb installation driver ATI pour carte graphique ATI Radeon Xpress200M

J'ai fait la manip.
J'ai redémarré mon système. Tout démarre normalement.
Il relance gdm... & là, écran noir !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
HELP !
Que dois-je faire pour pouvoir me mettre en ligne de commande & remettre la configuration précédente ????
merci

La liberté d'écrire et de parler dépend soit de l'extrême bonté du prince, soit du profond esclavage du peuple. On ne permet de dire qu'à celui qui ne peut rien. DIDEROT

Hors ligne

#8 17-09-2008 21:46:11

tux12
Membre
Lieu : ./
Distrib. : Squeeze
Noyau : Linux 2.6.32-5-686-bigmem
(G)UI : KDE
Inscription : 27-02-2008

Re : pb installation driver ATI pour carte graphique ATI Radeon Xpress200M

Bonjour,

Tu dois pouvoir démarrer en single en sélectionnant la ligne suivante dans le menu grub. En principe (si tu n'as pas modifié le menu.list) tu dois y retrouver le même noyau qu'à la précédente avec la mention "single user mode".

Sinon éditer la ligne de boot (taper e) de grub avant qu'il ne lance l'OS et ajouter "single" à la fin de la ligne.

@+

Dernière modification par tux12 (17-09-2008 21:46:25)

Hors ligne

#9 17-09-2008 22:45:46

mouloud7
Membre
Lieu : Guadeloupe
Distrib. : wheezy/testing
Noyau : 3.2.0.3
(G)UI : openbox
Inscription : 12-09-2008

Re : pb installation driver ATI pour carte graphique ATI Radeon Xpress200M

et ensuite ????

La liberté d'écrire et de parler dépend soit de l'extrême bonté du prince, soit du profond esclavage du peuple. On ne permet de dire qu'à celui qui ne peut rien. DIDEROT

Hors ligne

#10 17-09-2008 22:59:28

mouloud7
Membre
Lieu : Guadeloupe
Distrib. : wheezy/testing
Noyau : 3.2.0.3
(G)UI : openbox
Inscription : 12-09-2008

Re : pb installation driver ATI pour carte graphique ATI Radeon Xpress200M

Ok, problème d'écran  noir résolu, mais problème driver ATI pas du tout.
Question : quelqu'un peut-il m'expliquer que manière très simple & très claire où il faut déposer le fichier que l'on télécharge sur le site ATI pour le driver, puis comment on le décompresse proprement & ensuite comment l'installer.
Beaucoup de questions parce que je lis plein de trucs & rien ne fonctionne comme il est dit.
On me dit de décompresser dans /home puis de créer un lien symbolique ????? Quesako !
Je suis nul... I know ! Je débute !
En tout cas, merci pour ceux qui se dévouent...!

La liberté d'écrire et de parler dépend soit de l'extrême bonté du prince, soit du profond esclavage du peuple. On ne permet de dire qu'à celui qui ne peut rien. DIDEROT

Hors ligne

#11 17-09-2008 23:42:24

mouloud7
Membre
Lieu : Guadeloupe
Distrib. : wheezy/testing
Noyau : 3.2.0.3
(G)UI : openbox
Inscription : 12-09-2008

Re : pb installation driver ATI pour carte graphique ATI Radeon Xpress200M

à priori, c'est récolu, voici l'édit du xorg.conf. Qu'en pensez-vous ?
# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "ServerLayout"
    Identifier     "aticonfig Layout"
    Screen      0  "aticonfig-Screen[0]-0" 0 0
EndSection

Section "Files"
EndSection

Section "Module"
EndSection

Section "InputDevice"
    Identifier  "Generic Keyboard"
    Driver      "kbd"
    Option        "XkbRules" "xorg"
    Option        "XkbModel" "pc105"
    Option        "XkbLayout" "fr"
    Option        "XkbVariant" "latin9"
    Option        "XkbOptions" "lv3:ralt_switch"
EndSection

Section "InputDevice"
    Identifier  "Configured Mouse"
    Driver      "mouse"
EndSection

Section "Monitor"
    Identifier   "Configured Monitor"
EndSection

Section "Monitor"
    Identifier   "aticonfig-Monitor[0]-0"
    Option        "VendorName" "ATI Proprietary Driver"
    Option        "ModelName" "Generic Autodetecting Monitor"
    Option        "DPMS" "true"
EndSection

Section "Device"
    Identifier  "Configured Video Device"
    Option        "UseFBDev" "true"
EndSection

Section "Device"
    Identifier  "aticonfig-Device[0]-0"
    Driver      "fglrx"
    BusID       "PCI:1:5:0"
EndSection

Section "Screen"
    Identifier "Default Screen"
    Monitor    "Configured Monitor"
EndSection

Section "Screen"
    Identifier "aticonfig-Screen[0]-0"
    Device     "aticonfig-Device[0]-0"
    Monitor    "aticonfig-Monitor[0]-0"
    DefaultDepth     24
    SubSection "Display"
        Viewport   0 0
        Depth     24
    EndSubSection
EndSection

La liberté d'écrire et de parler dépend soit de l'extrême bonté du prince, soit du profond esclavage du peuple. On ne permet de dire qu'à celui qui ne peut rien. DIDEROT

Hors ligne

#12 18-09-2008 13:27:47

palmito
Administrateur
Lieu : Dans la boite de gâteau!
Distrib. : bah....
Noyau : heu...
(G)UI : gné?
Inscription : 28-05-2007

Re : pb installation driver ATI pour carte graphique ATI Radeon Xpress200M

Salut

Tu peux tester si l'accélération marche avec cette commande

glxgears


ou

fgl_glxgears


pour ati?

Désolé mais je prend toujours le soin de m'équiper de carte graphique nvidia smile

Hors ligne

#13 18-09-2008 22:45:26

tux12
Membre
Lieu : ./
Distrib. : Squeeze
Noyau : Linux 2.6.32-5-686-bigmem
(G)UI : KDE
Inscription : 27-02-2008

Re : pb installation driver ATI pour carte graphique ATI Radeon Xpress200M

Bonjour,

Ça fait plaisir de voir quelqu'un qui cherche à comprendre et à avancer.
_o_ \o/ _o_ \o/ Super, Mouloud7! Ok tu débutes, mais tu es sur la bonne voie pour progresser. Je ne peux que t"encourager dans ce sens. smile

Bon sinon, t'as essayé ton nouveau fichier? Ça donne quoi?

@+

Hors ligne

#14 19-09-2008 02:55:25

mouloud7
Membre
Lieu : Guadeloupe
Distrib. : wheezy/testing
Noyau : 3.2.0.3
(G)UI : openbox
Inscription : 12-09-2008

Re : pb installation driver ATI pour carte graphique ATI Radeon Xpress200M

le fglrxs donne 18.000 fichiers toutes les 5 secondes, c'est bon ??????
je ne sais pas à quoi ça correspond !
à+
Merci pour vos éclairages !

La liberté d'écrire et de parler dépend soit de l'extrême bonté du prince, soit du profond esclavage du peuple. On ne permet de dire qu'à celui qui ne peut rien. DIDEROT

Hors ligne

Pied de page des forums