Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 23-10-2013 14:35:04

Herbert west
Membre
Distrib. : stable 64 mise a jour regulièrement
Noyau : 3.x.x-x-amd64
(G)UI : gnome 3
Inscription : 17-05-2012

installer un paquet de sid alors que j'ai jessie :pinning

bonjour ,
je galere avec un codec et je souhaite installer le paquet :avifile-mjpeg-plugin qui n'existe pas sur ma testing jessie

j'ai donc changé mon sourceslist puis fait un pinning comme sur le wiki

voici mon nouvel sourceslist :

 ## ===============================================
 ## jessie
deb http://ftp.fr.debian.org/debian/ jessie main contrib non-free
deb-src http://ftp.fr.debian.org/debian/ jessie main contrib non-free
 ##pining pour sid
deb http://ftp.fr.debian.org/debian sid main contrib non-free
deb-src http://ftp.fr.debian.org/debian sid main contrib non-free
 ## jessie multimedia
##deb http://www.deb-multimedia.org jessie main non-free  (enlevée car deconseillée,a voir)
##deb-src http://www.deb-multimedia.org jessie main non-free
 
 ## jessie security
deb http://security.debian.org/ jessie/updates main contrib non-free
deb-src http://security.debian.org/ jessie/updates main contrib non-free



mon pinning situé dans le dossier preferences.de etc/apt appellé 40sid-et-testing:

Package: *
Pin: release n=sid
Pin-Priority: 100



je fais aptitude update
7 paquets a mettre a jour;je m'en fout je ne fait pas la mise a jour
je fais

aptitude show avifile-mjpeg-plugin
Pas de version courante ou candidate trouvée pour avifile-mjpeg-plugin
Paquet : avifile-mjpeg-plugin
État: n'est pas un paquet réel


ok marche po
j'essaye :

apt-get install -t sid --no-install-recommends avifile-mjpeg-plugin

  (en me demandant si le sid apres le -t est bien employé alors que je veux aller sur sid

marche pas non plus

du coup ennervé j'ai lancé la mise a jour ,les 7 paquets appartenaient a sid (du coup je me dis :j'ai cassé ma debian ) et je cherche toujours comment installer ce http://packages.debian.org/sid/avifile-mjpeg-plugin pour juste acquerir mon flux video .
ma seule satisfaction est d'avoir reviser quelques petits trucs .
plizzze help

Dernière modification par Herbert west (23-10-2013 14:48:39)


I72600k / radeonhd 6870 /asus p8p67 pro b3/syncmaster 3D Samsung 23p displayport
debian stable 64
Linux derniereversion 3.x.x-x-amd64
" Y a t il un sous-sol dans votre appartement ? "

Hors ligne

#2 24-10-2013 00:01:50

Herbert west
Membre
Distrib. : stable 64 mise a jour regulièrement
Noyau : 3.x.x-x-amd64
(G)UI : gnome 3
Inscription : 17-05-2012

Re : installer un paquet de sid alors que j'ai jessie :pinning

tout le monde est au cinéma ?

I72600k / radeonhd 6870 /asus p8p67 pro b3/syncmaster 3D Samsung 23p displayport
debian stable 64
Linux derniereversion 3.x.x-x-amd64
" Y a t il un sous-sol dans votre appartement ? "

Hors ligne

#3 24-10-2013 09:44:35

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : installer un paquet de sid alors que j'ai jessie :pinning

Herbert west a écrit :

tout le monde est au cinéma ?


Ben nan, yavait quoi ? smile

Désolé pour ton pb, je ne suis pas un accoutumé au pinning. Mais il y a bien qq qui va passer. big_smile


I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

#4 24-10-2013 11:30:05

captnfab
Admin-Girafe
Lieu : /dev/random
Distrib. : Debian Stretch/Sid/Rc-Buggy
Noyau : Linux (≥ 4.3)
(G)UI : i3-wm (≥ 4.11)
Inscription : 07-07-2008
Site Web

Re : installer un paquet de sid alors que j'ai jessie :pinning

Salut smile

Ton fichier de pinning semble bon, tu ne devrais pas avoir cassé ta Debian. smile

apt-cache policy avifile-mjpeg-plugin


avifile-mjpeg-plugin:
  Installé : (aucun)
  Candidat : 1:0.7.48~20090503.ds-2+b2
 Table de version :
     1:0.7.48~20090503.ds-2+b2 0
        500 http://ftp.fr.debian.org/debian/ oldstable/main amd64 Packages



Pas de avifile-mjpeg-plugin dans sid !


captnfab,
Association Debian-Facile, bépo.
TheDoctor: Your wish is my command… But be careful what you wish for.

Hors ligne

#5 24-10-2013 11:48:36

Herbert west
Membre
Distrib. : stable 64 mise a jour regulièrement
Noyau : 3.x.x-x-amd64
(G)UI : gnome 3
Inscription : 17-05-2012

Re : installer un paquet de sid alors que j'ai jessie :pinning

captnfab a écrit :

Salut smile

Ton fichier de pinning semble bon, tu ne devrais pas avoir cassé ta Debian. smile

apt-cache policy avifile-mjpeg-plugin


avifile-mjpeg-plugin:
  Installé : (aucun)
  Candidat : 1:0.7.48~20090503.ds-2+b2
 Table de version :
     1:0.7.48~20090503.ds-2+b2 0
        500 http://ftp.fr.debian.org/debian/ oldstable/main amd64 Packages



Pas de avifile-mjpeg-plugin dans sid !



merci les gars ,


si on peut plus se fier a http://packages.debian.org/sid/avifile-mjpeg-plugin
j'ai essayé avec le dpkg -i du fichier .deb ,mais pareil ; meme avec oldstable il veux pas me l'installer a cause des dependances. du coup j'ai supprimé mon pining en re modifiant mon listessource et effacer le fichier que j'avais cree dans preference.d
j'ai quand meme fait une mise a jour de 6 package de sid ;le boulet
donc le pining etait bon
merci bonne journée


I72600k / radeonhd 6870 /asus p8p67 pro b3/syncmaster 3D Samsung 23p displayport
debian stable 64
Linux derniereversion 3.x.x-x-amd64
" Y a t il un sous-sol dans votre appartement ? "

Hors ligne

#6 24-10-2013 11:53:36

captnfab
Admin-Girafe
Lieu : /dev/random
Distrib. : Debian Stretch/Sid/Rc-Buggy
Noyau : Linux (≥ 4.3)
(G)UI : i3-wm (≥ 4.11)
Inscription : 07-07-2008
Site Web

Re : installer un paquet de sid alors que j'ai jessie :pinning

Regarde la liste des architectures en bas de la page smile Le paquet n'est présent ni sur amd64 ni sur i386, seulement sur hppa.

captnfab,
Association Debian-Facile, bépo.
TheDoctor: Your wish is my command… But be careful what you wish for.

Hors ligne

#7 24-10-2013 12:02:58

Herbert west
Membre
Distrib. : stable 64 mise a jour regulièrement
Noyau : 3.x.x-x-amd64
(G)UI : gnome 3
Inscription : 17-05-2012

Re : installer un paquet de sid alors que j'ai jessie :pinning

captnfab a écrit :

Regarde la liste des architectures en bas de la page smile Le paquet n'est présent ni sur amd64 ni sur i386, seulement sur hppa.



je suis desolé captain ,mais je vois pas cette info sur la page .peux tu m'expliquer


I72600k / radeonhd 6870 /asus p8p67 pro b3/syncmaster 3D Samsung 23p displayport
debian stable 64
Linux derniereversion 3.x.x-x-amd64
" Y a t il un sous-sol dans votre appartement ? "

Hors ligne

#8 24-10-2013 12:22:23

captnfab
Admin-Girafe
Lieu : /dev/random
Distrib. : Debian Stretch/Sid/Rc-Buggy
Noyau : Linux (≥ 4.3)
(G)UI : i3-wm (≥ 4.11)
Inscription : 07-07-2008
Site Web

Re : installer un paquet de sid alors que j'ai jessie :pinning

2013-10-24-121734_2970x1680_scrot.png
à mettre en regard avec cette page par exemple : http://packages.debian.org/sid/libjpeg62 affichant :
2013-10-24-122246_2970x1680_scrot.png

captnfab,
Association Debian-Facile, bépo.
TheDoctor: Your wish is my command… But be careful what you wish for.

Hors ligne

#9 24-10-2013 12:49:02

Herbert west
Membre
Distrib. : stable 64 mise a jour regulièrement
Noyau : 3.x.x-x-amd64
(G)UI : gnome 3
Inscription : 17-05-2012

Re : installer un paquet de sid alors que j'ai jessie :pinning

dg4u.png

wow faut le deviner

Dernière modification par Herbert west (24-10-2013 13:00:25)


I72600k / radeonhd 6870 /asus p8p67 pro b3/syncmaster 3D Samsung 23p displayport
debian stable 64
Linux derniereversion 3.x.x-x-amd64
" Y a t il un sous-sol dans votre appartement ? "

Hors ligne

#10 24-10-2013 20:03:55

loreleil
Banni(e)
Lieu : Ch'timi
Distrib. : Aptosid
Noyau : 4.3.0-0.slh.3-aptosid-amd6/4 4.3-3 (2015-12-01)
(G)UI : Kde-Full
Inscription : 13-08-2010

Re : installer un paquet de sid alors que j'ai jessie :pinning

Salut,

Dans la mesure ou avifile-mjpeg-plugin n'est disponible qu'en Squeeze (oldstable).

Tu peux, d'une part déjà commencer par virer les dépôts Sid de ton sources et rectifier le fichier preferences avec ton pinning plus qu'approximatif

Dans la mesure :

* ou tu es sous Jessie. Même pas peur ... l'homme de l' West. lol

# aptitude update


# aptitude -s install avifile-mjpeg-plugin/squeeze



* ou l'épinglage n'est vraiment pas, ton truc ... roll

Je ne saurai trop de recommander tout simplement, de passer ce paquet en hold !!

* edit *

Il te faudras inclure le dépôts Squeeze (temporairement).

Dernière modification par loreleil (24-10-2013 20:08:20)


  La première loi du libre et de tout hacker, au sens noble, le partage de la connaissance 
.
Aptosid-Kde-Full (4.3.0-0.slh.2-aptosid-amd64/ aptosid 4.3-2 (2015-11-18))

Hors ligne

#11 24-10-2013 21:01:35

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : installer un paquet de sid alors que j'ai jessie :pinning

Pour installer le depot squeeeze comme proposé par lorelei, voir :
Les sources trop cool !

"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#12 24-10-2013 21:16:22

captnfab
Admin-Girafe
Lieu : /dev/random
Distrib. : Debian Stretch/Sid/Rc-Buggy
Noyau : Linux (≥ 4.3)
(G)UI : i3-wm (≥ 4.11)
Inscription : 07-07-2008
Site Web

Re : installer un paquet de sid alors que j'ai jessie :pinning

loreleil a écrit :

Tu peux, d'une part déjà commencer par virer les dépôts Sid de ton sources et rectifier le fichier preferences avec ton pinning plus qu'approximatif



Que reproches-tu à ce pinning ? Il permet de disposer des paquets de sid sans les installer par défaut, je ne pense pas que ce soit une mauvaise solution. Il n'est certes pas ciblé sur les paquets en question mais ce n'est pas forcément un mal non plus.


captnfab,
Association Debian-Facile, bépo.
TheDoctor: Your wish is my command… But be careful what you wish for.

Hors ligne

#13 24-10-2013 23:34:20

Herbert west
Membre
Distrib. : stable 64 mise a jour regulièrement
Noyau : 3.x.x-x-amd64
(G)UI : gnome 3
Inscription : 17-05-2012

Re : installer un paquet de sid alors que j'ai jessie :pinning

captnfab a écrit :

loreleil a écrit :

Tu peux, d'une part déjà commencer par virer les dépôts Sid de ton sources et rectifier le fichier preferences avec ton pinning plus qu'approximatif



Que reproches-tu à ce pinning ? Il permet de disposer des paquets de sid sans les installer par défaut, je ne pense pas que ce soit une mauvaise solution. Il n'est certes pas ciblé sur les paquets en question mais ce n'est pas forcément un mal non plus.



au passage il sort d'un wiki je n'ai rien inventé .

pour le pining comme dis plus haut j'ai tout laché avant de faire une grosse bourde .
j'ai donc zapper mon acquisition avec mencoder et j'ai pris un ordi avec windows pour le faire (ça marche nickel en 2clics)
donc la mencoder ,je l'ai legerement en travers du gosier , comme ni clou ni vis , ça colle nickel mais chez les autres .
par contre , pour le savoir , il est certainement possible de se faire un package mencodre avec toutes les bibliotheques inside qui ne seront utilisées que pour l'occaze?
en résumé on fait comment ?


I72600k / radeonhd 6870 /asus p8p67 pro b3/syncmaster 3D Samsung 23p displayport
debian stable 64
Linux derniereversion 3.x.x-x-amd64
" Y a t il un sous-sol dans votre appartement ? "

Hors ligne

#14 25-10-2013 10:39:36

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : installer un paquet de sid alors que j'ai jessie :pinning

Bonjour,

Herbert west a écrit :


Quelle est l'url d'où provient cette capture ?


I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

#15 25-10-2013 10:47:48

captnfab
Admin-Girafe
Lieu : /dev/random
Distrib. : Debian Stretch/Sid/Rc-Buggy
Noyau : Linux (≥ 4.3)
(G)UI : i3-wm (≥ 4.11)
Inscription : 07-07-2008
Site Web

Re : installer un paquet de sid alors que j'ai jessie :pinning

Très probablement http://packages.debian.org/oldstable/av … peg-plugin (ie. la liste des versions disponibles pour oldstable)

C'est plus clair lorsque l'on fait la recherche : http://packages.debian.org/search?searc … peg-plugin

Paquet avifile-mjpeg-plugin

  • squeeze (oldstable) (video): MJPEG video plugin for libavifile
        1:0.7.48~20090503.ds-2+b2: amd64 armel i386 ia64 kfreebsd-amd64 kfreebsd-i386 mips mipsel powerpc s390 sparc

  • sid (unstable) (video): MJPEG video plugin for libavifile
        1:0.7.48~20090503.ds-2+b1 [debports]: hppa


captnfab,
Association Debian-Facile, bépo.
TheDoctor: Your wish is my command… But be careful what you wish for.

Hors ligne

#16 25-10-2013 10:52:57

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : installer un paquet de sid alors que j'ai jessie :pinning

oups, dsl.
merci captnfab.  smile

I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

#17 25-10-2013 11:53:14

captnfab
Admin-Girafe
Lieu : /dev/random
Distrib. : Debian Stretch/Sid/Rc-Buggy
Noyau : Linux (≥ 4.3)
(G)UI : i3-wm (≥ 4.11)
Inscription : 07-07-2008
Site Web

Re : installer un paquet de sid alors que j'ai jessie :pinning

Y'a pas de mal hein smile

captnfab,
Association Debian-Facile, bépo.
TheDoctor: Your wish is my command… But be careful what you wish for.

Hors ligne

#18 25-10-2013 13:41:46

loreleil
Banni(e)
Lieu : Ch'timi
Distrib. : Aptosid
Noyau : 4.3.0-0.slh.3-aptosid-amd6/4 4.3-3 (2015-12-01)
(G)UI : Kde-Full
Inscription : 13-08-2010

Re : installer un paquet de sid alors que j'ai jessie :pinning

Salut,

captnfab a écrit :

loreleil a écrit :

Tu peux, d'une part déjà commencer par virer les dépôts Sid de ton sources et rectifier le fichier preferences avec ton pinning plus qu'approximatif



Que reproches-tu à ce pinning ? Il permet de disposer des paquets de sid sans les installer par défaut, je ne pense pas que ce soit une mauvaise solution. Il n'est certes pas ciblé sur les paquets en question mais ce n'est pas forcément un mal non plus.



L'absence de ce dernier et un sources très approximatif.

-------------

Il ne faudrait tout de même pas quitter des yeux le fait que Testing n'est pas prévue pour un usage à proprement dit "normal" mais purement et simplement à fins de débogage, bugs qui seront remontés aux développeurs, de part l'usage intensif qu'en feront les utilisateurs potentiels et avertis.

Testing est une branche de transition dans la conception de la prochaine version stable, à savoir Jessie, pour l'heure.

Et sachant que Sid fourni les paquets vers Testing, il faut tenir compte du fait que certains d'eux, essentiels et dépendances, peuvent disparaître, d'une heure à l'autre, définitivement ou à titre temporaire.

Dans cette perspective, le sources.list dont Herbert se contente m'apparaît des plus bancales.

À mon sens (et pas seulement), joindre les dépôts stable (Wheezy) et unstable (Sid) s'avère indispensable.

Permettre au system ou/et à root d'aller chercher ces paquets essentiels, là où ils sont présents et ceci via un fichier preferences des plus rigoureux.

J'entends déjà dire, oui mais "j'ai installé ma testing via les sources telles que cd/dvd/usb/netinstall/buisn..." qu'importe.

Testing et/ou Sid = Utilisateurs avertis et affranchis.

Je ne parlerai même pas de la présence obligatoire d'apt-listbugs, tout en sachant utiliser ce dernier à bonne escient.

De mon point de vue, l'utilisateur affranchi procède comme ci-dessous pour évoluer vers Testing ou Sid.

- Install minimal depuis une stable (autrement dit, pas de graphique)

- Modification du sources, création d'un preferences (stable => Testing)

- upgrade && full-upgrade, reboot

- Modification du sources et preferences (Testing => Sid)

- upgrade && full-upgrade, reboot, installation de l'environnement graphique.

Fiininini !

Geek qui peut ... cool


  La première loi du libre et de tout hacker, au sens noble, le partage de la connaissance 
.
Aptosid-Kde-Full (4.3.0-0.slh.2-aptosid-amd64/ aptosid 4.3-2 (2015-11-18))

Hors ligne

#19 25-10-2013 14:05:28

captnfab
Admin-Girafe
Lieu : /dev/random
Distrib. : Debian Stretch/Sid/Rc-Buggy
Noyau : Linux (≥ 4.3)
(G)UI : i3-wm (≥ 4.11)
Inscription : 07-07-2008
Site Web

Re : installer un paquet de sid alors que j'ai jessie :pinning

Merci pour ta réponse, la au moins on peut discuter.

loreleil a écrit :

L'absence de ce dernier et un sources très approximatif.


Tu ne peux pas dire ça smile

L'installation est une Jessie (donc testing), avec les sources habituelles de la testing plus les sources multimédia. Aucune mauvaise pratique ou approximation là-dedans.
Le fichier contient ensuite les sources pour sid, puisque c'est bien de là que l'on veut installer des paquets plus récents.

Pour qu'apt n'installe pas tous les paquets de sid lors de la prochaine mise à jour, il suffit de leur affecter une priorité basse, ce qui est exactement ce que fait le fichier de préférences donné.

loreleil a écrit :

Il ne faudrait tout de même pas quitter des yeux le fait que Testing n'est pas prévue pour un usage à proprement dit "normal" mais purement et simplement à fins de débogage, bugs qui seront remontés aux développeurs, de part l'usage intensif qu'en feront les utilisateurs potentiels et avertis.

Testing est une branche de transition dans la conception de la prochaine version stable, à savoir Jessie, pour l'heure.

Et sachant que Sid fourni les paquets vers Testing, il faut tenir compte du fait que certains d'eux, essentiels et dépendances, peuvent disparaître, d'une heure à l'autre, définitivement ou à titre temporaire.

Dans cette perspective, le sources.list dont Herbert se contente m'apparaît des plus bancales.


Au contraire, incluant les dépôts sid il prévient justement ce manque ! smile

loreleil a écrit :

À mon sens (et pas seulement), joindre les dépôts stable (Wheezy) et unstable (Sid) s'avère indispensable.


Tu voulais dire sid+testing ? C'est ce qui est fait. Sid + stable est au contraire bancal, bien sûr.

loreleil a écrit :

Permettre au system ou/et à root d'aller chercher ces paquets essentiels, là où ils sont présents et ceci via un fichier preferences des plus rigoureux.


Ici, sauf commande explicite lors de l'installation des paquets, tous sont choisis exclusivement dans testing, ce qui est bien ce que l'on veut.

loreleil a écrit :

Testing et/ou Sid = Utilisateurs avertis et affranchis.


Oui, il vaut mieux avoir un certain bagage pour l'utiliser, histoire de savoir quoi faire en cas de cassage, mais en réalité les risques sont faibles pour qui accepte de les assumer (ce qui est le choix de l'utilisateur.) Dans le pire des cas, il devra récupérer ses données depuis un live, c'est pas la mort non plus smile

Je suis par contre en désaccord sur ta procédure d'installation de testing depuis stable. Au contraire, jusqu'à la sortie de la testing en nouvelle stable, la mise à jour depuis l'ancienne stable n'est pas supportée, je préconise donc plutôt l'installation depuis la netinstall testing directement. Mais bon, nous sommes hors-sujet là.


captnfab,
Association Debian-Facile, bépo.
TheDoctor: Your wish is my command… But be careful what you wish for.

Hors ligne

#20 25-10-2013 14:15:33

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : installer un paquet de sid alors que j'ai jessie :pinning

Bien argumenté loreleil...
En même temps, il n'y a pas de stable nécessaire pour maintenir une testing, c'est même paraît-il (les sid ont la parole ici...) un bien mauvais choix par rapport à ajouter sid et experimental justement pour la rapidité de leurs mises à jour, contrairement à comme tu le signales la testing.

Pour le cas ici, c'est juste à ajouter une old et c'est donc pas méchant pour installer seulement un paquet en plus.

Enfin, à moins d'un an de la prochaine freeze de testing, il me semble que beaucoup de paquets sont et resteront opérationnels en testing, surtout avec l'usage de apt-listbugs (voir le tuto dans l'wiki).
Il serait dommage que de périlleux débutants ne se marrent pas un peu à se casser des testing pour se faire les crocs, les zouaves ! big_smile

Edit :
Grillé par le matelot ! smile
/me va passer au bepo pour taper plus vite que son ombre, comme lui ! tongue

Dernière modification par smolski (25-10-2013 14:18:07)


"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#21 29-10-2013 03:45:47

Herbert west
Membre
Distrib. : stable 64 mise a jour regulièrement
Noyau : 3.x.x-x-amd64
(G)UI : gnome 3
Inscription : 17-05-2012

Re : installer un paquet de sid alors que j'ai jessie :pinning

vous voulez un thé et des crêpes ?:lol:

1/mon poto m'a dit d'installer testing : du linux il en mange a toutes les sauces a son boulot ,donc je l'ecoute .

2/si en plus captain ,qui me sort toujours la tête de l'eau , va dans le même sens ....

3/j’étais en testing wheezy avant de passer en testing jessie

4/ j'ai vu des paquets disparaître au cours de mes pérégrinations , ça m'a fait galéré mais ça m'a fait revisé mon wiki

5/ je n'ai pas encore cassé ma testing

6/je suis pour le bon progrés , stable me sert pour mes ordinateurs moins puissants .

on peut pas relancer un debat sur les sourceslist ,a chaque fois il y a des avis partagés ;pourtant c'est logique ,on devrait pouvoir trouver des scenarii type

merci pour vos reactions ;alors y fais quoi herbert?

I72600k / radeonhd 6870 /asus p8p67 pro b3/syncmaster 3D Samsung 23p displayport
debian stable 64
Linux derniereversion 3.x.x-x-amd64
" Y a t il un sous-sol dans votre appartement ? "

Hors ligne

#22 29-10-2013 04:40:03

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : installer un paquet de sid alors que j'ai jessie :pinning

bebert a écrit :

on devrait pouvoir trouver des scenarii type


Ben c'est celui où tu parviens à trouver toi-même l'équilibre entre ton utilisation forcée et ta capacité à l'assumer...

Perso, j'suis en stable et en oldstable sur un banc de pc que j'utilise professionnellement et ça m'va comme une main légère dans un gant de velour parce que je ne veux pas me battre contre mon naturel assez puissamment cool. cool


"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#23 29-10-2013 09:37:09

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : installer un paquet de sid alors que j'ai jessie :pinning

Herbert west a écrit :

merci pour vos reactions ;alors y fais quoi herbert?


Je pense que tu peux, comme l'a suggéré lorelei,  inclure temporairement les dépôts squeeze, mettre à jour et voir ce que donne :

aptitude install -t oldstable --no-install-recommends avifile-mjpeg-plugin -s


I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

#24 29-10-2013 10:57:17

captnfab
Admin-Girafe
Lieu : /dev/random
Distrib. : Debian Stretch/Sid/Rc-Buggy
Noyau : Linux (≥ 4.3)
(G)UI : i3-wm (≥ 4.11)
Inscription : 07-07-2008
Site Web

Re : installer un paquet de sid alors que j'ai jessie :pinning

apt-cache show avifile-mjpeg-plugin a écrit :

This package provides a plugin for the avifile library to de/encode MJPEG video streams -  this implementation is rather slower and serves just as a sample plugin implementation. Usage of
ffmpeg or win32 codecs is a better choice.


captnfab show avifile-mjpeg-plugin a écrit :

Ce paquet fournit un plugin pour la bibliothèque avifile pour dé/encoder les flux vidéo MJPEG - cette implémentation est plutôt plus lente et ne sert juste d'exemple d'implémentation de plugin. L'utilisation de ffmpeg ou des win32codecs est une meilleure alternative.



Donc euh, tu utilises ffmpeg ou win32codecs ? smile


captnfab,
Association Debian-Facile, bépo.
TheDoctor: Your wish is my command… But be careful what you wish for.

Hors ligne

#25 30-10-2013 00:55:02

Herbert west
Membre
Distrib. : stable 64 mise a jour regulièrement
Noyau : 3.x.x-x-amd64
(G)UI : gnome 3
Inscription : 17-05-2012

Re : installer un paquet de sid alors que j'ai jessie :pinning

paskal a écrit :

Herbert west a écrit :

merci pour vos reactions ;alors y fais quoi herbert?


Je pense que tu peux, comme l'a suggéré lorelei,  inclure temporairement les dépôts squeeze, mettre à jour et voir ce que donne :

aptitude install -t oldstable --no-install-recommends avifile-mjpeg-plugin -s



oui merci ,mais je viens de voir que mencoder n'est plus dispo pour jessie

il faudrait que je fasse un pining axé sur les logiciels que j'utilise (wheezy et instable) ;cependant des bibliothèques telechargées sur ces derniers pourraient rendre instable ma testing ou creeraient des bugs .

j'aimerais donc savoir si dans le pining ou auyre , il est possible d'encapsuler ces biliotheques issues des dependances du package demandé pour ne fonctionner que l'orsque j'utilise ce package :
par exemple, package mencoder avec ses dependances  (avifile ...libavi...etc propres a stable et a instable) .

mes bibliotheques avi de testing reprendraient leur role apres etre sorti de mencoder .mes avi de stable ou instable  prendraient le flambeau lorsque j’ouvrirais mencoder)

si je m'exprime bien merci de me repondre


I72600k / radeonhd 6870 /asus p8p67 pro b3/syncmaster 3D Samsung 23p displayport
debian stable 64
Linux derniereversion 3.x.x-x-amd64
" Y a t il un sous-sol dans votre appartement ? "

Hors ligne

Pied de page des forums