Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 24-10-2013 22:02:16

golgot200
Membre
Lieu : AIN
Distrib. : Debian Jessie
Noyau : Linux debian 3.16.0-4-amd64
(G)UI : MATE
Inscription : 05-08-2007

Compiler Audacity 2.0.5

Bonjour,

Suite à un petit problème génant sur la coupure du son, j'ai désidé de compiler Audacity dans sa dernière version stable sur ma debian Wheezy stable. Bon, ça n'a pas réglé ce petit problème mais cette compilation c'est bien passée. Je met ma démarche ici avec une ou deux trucs que j'ai trouvé par ci par là.


J'ai tout d'abord viré Audacity 2.0.1 installé depuis les dépots:


apt-get remove --purge audacity audacity-data libflac++6 libportsmf0 libsbsms10 libvamp-hostsdk3
 


De toute façon libflac++6 libportsmf0 libsbsms10 libvamp-hostsdk3 seront réinstallés


Puis installé:


apt-get install build-essential
 




Et faire un:


apt-get build-dep audacity
 




Mais, j'ai préféré ne pas installer 2 paquets qui m'étaient proposés libjack-dev libjack0. J'ai pris libjack-jackd2-dev libjack-jackd2-0


Donc les paquets à installer:


apt-get install libasound2-dev libavcodec-dev libavutil-dev libavformat-dev libflac++-dev libflac++6 libflac-dev libid3tag0-dev libjack-jackd2-dev libjack-jackd2-0 libmad0-dev libmp3lame-dev libportaudiocpp0 libportsmf-dev libportsmf0 libsbsms-dev libsbsms10 libsndfile1-dev libsoundtouch-dev libtwolame-dev libvamp-hostsdk3 libvamp-sdk2 libwxbase2.8-dev wx2.8-headers libwxgtk2.8-dev wx-common portaudio19-dev vamp-plugin-sdk
 




A vérifier. Installés pour mener à bien la compilation.


apt-get install cdbs gettext libvorbis-dev zlib1g-dev twolame libgtk2.0-dev libsamplerate0 libsamplerate0-dev
 




Puis:


apt-get install cmake cmake-data emacsen-common libcurl3 libxmlrpc-core-c3
 




Aller sur le site http://audacity.sourceforge.net/
Charger les sources de la dernière version stable. (Version 2.0.5 à ce jour)


Se placer ou se trouve l'archive et faire un:
tar -Jxvf audacity-minsrc-2.0.5.tar.xz
se placer dans le dossier décompressé audacity-src-2.0.5


Faire:


./configure --with-libvorbis --with-libflac --with-libid3tag --with-soundtouch
 




Un make:


make
 




Et si vous voulez un:


make install
 




Moi, je ne l'ai pas fait. Je préféré lancer l'exécutable à partir du dossier. Mais l'installation complète fonctionne.
Donc si vous faite comme moi sans le # make install, le programme ne sera pas en français.
Ce placer dans le dossier audacity-src-2.0.5 et copier le dossier local dans /usr/local/share/



cp -R locale /usr/local/share/
 




Pour compiler une traduction. Récupérer le fichier ex: fr.po sur le site et faire simplement un:


msgfmt -o audacity.mo  fr.po
 




On se retrouve avec le fichier de traduction.
Voilà.

Dernière modification par golgot200 (24-10-2013 22:19:23)


L'ultime question ... l'intelligence a besoin de la bêtise pour s'affirmer, la beauté a besoin de la laideur pour resplendir, le courage nait dans la peur, les forts impressionnent au millieu des faibles, mais au final,... qui a donc besoin d'autant de connards ?

Hors ligne

Pied de page des forums