Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 30-10-2013 19:31:06

Shdouj
Membre
Distrib. : Debian Jessie / Sid
Noyau : 3.11-1-AMD64
(G)UI : Kde4
Inscription : 24-10-2013

[resolu en bug] Xorg Validation Error

bonjour ,

j'ai un probleme avec mon Xorg, j'ai installer le driver proprio Nvidia , j'ai fais un nvidia-xconfig afin qu'il me creer un xorg adequate , au reboot j'ai la console

j'ai regarder dans le xorg et demander en console avec une nouvelle fois un nvidia-xconfig j'ai ceci en retour :


Validation Error : path incomplete in file /etc/x11/xorg.conf
undefined Device "Device0" referenced by screen "screen0"
 



je pense qu'il doit s'agir du moniteur ??

voici le xorg creer par nvidia-xconfig


# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 319.60  (pbuilder@cake)  Mon Oct 21 09:49:27 UTC 2013

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0"
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
EndSection

Section "Files"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Unknown"
    HorizSync       28.0 - 33.0
    VertRefresh     43.0 - 72.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection


 



merci de votre aide

Dernière modification par Shdouj (08-11-2013 20:48:38)

Hors ligne

#2 30-10-2013 19:45:30

captnfab
Admin-Girafe
Lieu : /dev/random
Distrib. : Debian Stretch/Sid/Rc-Buggy
Noyau : Linux (≥ 4.3)
(G)UI : i3-wm (≥ 4.11)
Inscription : 07-07-2008
Site Web

Re : [resolu en bug] Xorg Validation Error

Salut,
Non, il râle après ta carte graphique, mais je ne comprends pas trop pourquoi. Je t'invite à regarder la page nvidia de notre wiki.

captnfab,
Association Debian-Facile, bépo.
TheDoctor: Your wish is my command… But be careful what you wish for.

Hors ligne

#3 30-10-2013 19:57:16

Shdouj
Membre
Distrib. : Debian Jessie / Sid
Noyau : 3.11-1-AMD64
(G)UI : Kde4
Inscription : 24-10-2013

Re : [resolu en bug] Xorg Validation Error

salut

comprend pas trop non plus, c'est bien la premiere fois , bon je vais fouiller votre wiki ..

edit: a votre avis cela pourrais venir d'un conflit avec le driver nouveau ??

j'ai ceci encore d'installé

xserver-xorg-video-nvidia



si je veux effacer le pilote "nouveau" il me dit :


Les paquets suivants seront ENLEVÉS :        
  xserver-xorg-video-nvidia
0 paquets mis à jour, 0 nouvellement installés, 1 à enlever et 1 non mis à jour.
Il est nécessaire de télécharger 0 o d'archives. Après dépaquetage, 17,1 Mo seront libérés.
Les paquets suivants ont des dépendances non satisfaites :
 nvidia-driver : Dépend: xserver-xorg-video-nvidia (= 319.60-2) mais il ne sera pas installé.
Les actions suivantes permettront de résoudre ces dépendances :

     Supprimer les paquets suivants :                        
1)     nvidia-driver                                          
2)     nvidia-glx                                            

     Laisser les dépendances suivantes non satisfaites :      
3)     nvidia-kernel-dkms recommande nvidia-driver (>= 319.60)


Accepter cette solution ? [Y/n/q/?]

 



votre avis ?

Dernière modification par Shdouj (30-10-2013 20:05:22)

Hors ligne

#4 31-10-2013 11:18:12

captnfab
Admin-Girafe
Lieu : /dev/random
Distrib. : Debian Stretch/Sid/Rc-Buggy
Noyau : Linux (≥ 4.3)
(G)UI : i3-wm (≥ 4.11)
Inscription : 07-07-2008
Site Web

Re : [resolu en bug] Xorg Validation Error

nouveau et nvidia sont deux pilotes bien différents, comme indiqué dans le wiki. Virer l'un ne vire pas l'autre smile

captnfab,
Association Debian-Facile, bépo.
TheDoctor: Your wish is my command… But be careful what you wish for.

Hors ligne

#5 02-11-2013 18:05:59

Shdouj
Membre
Distrib. : Debian Jessie / Sid
Noyau : 3.11-1-AMD64
(G)UI : Kde4
Inscription : 24-10-2013

Re : [resolu en bug] Xorg Validation Error

j'ai essayer votre wiki , toujours des erreur , j'ai donc pris un vieux xorg qui fonctionnais toujours....et qui ne fonctionne pas sur cette machine...

j'ai bien virer le driver nouveau je poste le fameux xorg mais je ne vois pas ou cela coince ....

etonnant car sous kali c'est le meme et il ne bronche pas ....

une derniere suggestion ?


# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "ServerFlags"

  Option  "IgnoreABI" "true"

EndSection

Section "InputDevice"
   Identifier   "Generic Keyboard"
   Driver      "kbd"
   Option      "XkbRules"   "xorg"
   Option      "XkbModel"   "pc105"
   Option      "XkbLayout"   "fr"
   Option      "XkbVariant"   "latin9"
   Option      "XkbOptions"   "lv3:ralt_switch"
EndSection

Section "InputDevice"
   Identifier   "Configured Mouse"
   Driver      "mouse"
EndSection

Section "Device"
    Identifier  "Nvidia Corporation C61 [GeForce 7025 / nForce 630a]
    Driver      "nvidia"

EndSection

Section "Device"
   Identifier   "Configured Video Device"
        Option          "EnablePageFlip"    "on"
        Option          "AccelMethod"        "XAA"
        Option          "MigrationHeuristic"   "greedy"
        Option          "AccelDFS"      "true"
        Option          "DynamicClocks"    "on"
        Option          "ColorTiling"       "on"
        Option          "FBTexPercent"       "95"
        Option          "XAANoOffscreenPixmaps" "true"
        Option          "AddARGBGLXVisuals"     "true"
        Option      "Tiling"   "false"
  Option  "AllowGLXWithComposite" "true"

EndSection

Section "Monitor"
   Identifier   "Configured Monitor"
   Option      "DPMS"
EndSection

Section "Screen"
   Identifier   "Default Screen"
   Monitor      "Configured Monitor"
   Option "AddARGBGLXVisuals" "true"

EndSection

Section "DRI"
        Mode 0666
EndSection
       
Section "Extensions"
        Option "Composite" "Enable"
EndSection

Section "Module"

  #Load "dri"
 
  #load "GLcore"

EndSection



 

Dernière modification par Shdouj (02-11-2013 18:07:00)

Hors ligne

#6 08-11-2013 20:50:16

Shdouj
Membre
Distrib. : Debian Jessie / Sid
Noyau : 3.11-1-AMD64
(G)UI : Kde4
Inscription : 24-10-2013

Re : [resolu en bug] Xorg Validation Error

je passe en resolu bug , impossible pour le moment d'utilisé le driver proprio Nvidia , ca fais deux semaines que la version est bugé et donc on se retrouve en TTY, pas a chercher plus loin

Hors ligne

#7 09-11-2013 13:39:41

captnfab
Admin-Girafe
Lieu : /dev/random
Distrib. : Debian Stretch/Sid/Rc-Buggy
Noyau : Linux (≥ 4.3)
(G)UI : i3-wm (≥ 4.11)
Inscription : 07-07-2008
Site Web

Re : [resolu en bug] Xorg Validation Error

Ton xorg.conf a une erreur (il manque un ")

Tu devrais le simplifier comme suit :

 Section "Device"
    Identifier  "NvidiaGeforce"
    Driver      "nvidia"
EndSection

(et virer tout le reste)

Tu peux aussi essayer avec "nouveau" à la place de "nvidia".


captnfab,
Association Debian-Facile, bépo.
TheDoctor: Your wish is my command… But be careful what you wish for.

Hors ligne

#8 30-11-2013 15:39:02

Shdouj
Membre
Distrib. : Debian Jessie / Sid
Noyau : 3.11-1-AMD64
(G)UI : Kde4
Inscription : 24-10-2013

Re : [resolu en bug] Xorg Validation Error

merci pour l'oublie des guillemets!

donc apres avoir virer tout du xorg.conf et fais comme tu me l'a suggerer en laissant juste les ID Nvidia , apres la startx j'ai droit a


ERROR:could not insert 'nvidia_current': no such device (EE)
Fatal Server Error  : (EE) no screen found (EE)
(EE)
Xinit:giving up
 



j'ai pas trouver grand choses sur google , sauf qu'il s'agirrais encore une fois d'un bug (kernel ? driver ? path?)

une autre idée ?

Hors ligne

Pied de page des forums