Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 31-10-2013 19:32:16

parpa
Membre
Distrib. : Debian Wheezy 7.2
Noyau : 3.2.0-4-686-pae
(G)UI : Xfce
Inscription : 31-10-2013

problème d'installation : impossible de télécharger paquets

bonjour,
je suis nouvelle ici.
Ça fait plusieurs années que je suis sur Ubuntu, puis là j'avais envie de changer, pour un peu plus de sécurité sur mon ordi et voir autre chose, alors j'ai gravé un Dvd avec debian et je l'ai installé.
Quand j'ai démarré j'étais super fière de moi (je suis hyper nulle en informatique) parce que j'avais réussi à crypter mon ordi .. bon, petit à petit je farfouille sur l'ordi, je vois qu' y a pas Firefox, pas Jabber, pas Open office, pas Gimp, aucun logiciel pour écouter de la musique, pas de logiciel pour télécharger via torrent, rien du tout quoi ... je me dis que y a qu'à télécharger les paquets. Ce que je fais. Et là impossible de les installer.

ça me dit ça : L'installation du fichier a échoué
                       GDBus.Error:org.gtk.GDBus.UnmappedGError.Quark._pk_5ftransaction_5ferror.Code4: SimulateInstallFiles not supported by backend

Peut-être que je fais pas comme il faut, je fais avec Ouvrir avec installation de logiciels.

Hors ligne

#2 31-10-2013 19:43:26

Haricophile
Adhérent(e)
Lieu : Pignans (Var)
Distrib. : SID
Noyau : 4.0.0-1-amd64
(G)UI : Mate / i3 selon...
Inscription : 14-09-2009

Re : problème d'installation : impossible de télécharger paquets

Ça me paraît très chelou. Tu as installé avec le disque netinstall ? Tu as vérifié que la gravure était bonne ? Tu n'as pas décoché "environnement de bureau" ?

Sinon passe en ligne de commande en ouvrant un terminal et log toi en root. (commande su ).

apt-get update

apt-get install gnome



ou l'environnement de bureau que tu veux, réfère toi à

https://wiki.debian.org/fr/DebianKDE
https://wiki.debian.org/fr/DebianGnome
https://wiki.debian.org/fr/Xfce
...


« La religion et l'art sont les luxes des lâches, qui permettent de fuir la réalité quand elle devient trop difficile à affronter. La différence c'est que la religion transforme tout mensonge en vérité alors que l'art transforme toute vérité en mensonge. »

Hors ligne

#3 31-10-2013 19:47:34

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : problème d'installation : impossible de télécharger paquets

Bonsoir et bienvenue sur ce forum  smile

Quel dvd as-tu effectivement gravé ?

I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

#4 31-10-2013 20:05:17

parpa
Membre
Distrib. : Debian Wheezy 7.2
Noyau : 3.2.0-4-686-pae
(G)UI : Xfce
Inscription : 31-10-2013

Re : problème d'installation : impossible de télécharger paquets

Alors j'ai gravé wheezy, et comme j'avais des problèmes je viens d'acheter une clé usb de la dernière version, mais elle ne marche pas ...

Lorsque je fais apt-get install gnome ça me donne ça :

parpalhou@debian-parpalhou:~$ su
Mot de passe :
root@debian-parpalhou:/home/parpalhou# apt-get update
Ign cdrom://[Debian GNU/Linux 7.0.0 _Wheezy_ - Official i386 CD Binary-1 20130504-15:20] wheezy Release.gpg
Ign cdrom://[Debian GNU/Linux 7.0.0 _Wheezy_ - Official i386 CD Binary-1 20130504-15:20] wheezy Release
Ign cdrom://[Debian GNU/Linux 7.0.0 _Wheezy_ - Official i386 CD Binary-1 20130504-15:20] wheezy/main i386 Packages/DiffIndex
Ign cdrom://[Debian GNU/Linux 7.0.0 _Wheezy_ - Official i386 CD Binary-1 20130504-15:20] wheezy/main Translation-fr_FR
Réception de : 1 http://security.debian.org wheezy/updates Release.gpg [836 B]
Réception de : 2 http://ftp.debian.org wheezy-updates Release.gpg [836 B]
Réception de : 3 http://security.debian.org wheezy/updates Release [102 kB]
Réception de : 4 http://ftp.debian.org wheezy-updates Release [124 kB] 
Réception de : 5 http://security.debian.org wheezy/updates/main Sources [69,5 kB]
Réception de : 6 http://ftp.debian.org wheezy-updates/main Sources [2 609 B]
Réception de : 7 http://ftp.debian.org wheezy-updates/main i386 Packages/DiffIndex [367 B]
Réception de : 8 http://ftp.debian.org wheezy-updates/main Translation-en/DiffIndex [367 B]
Réception de : 9 http://security.debian.org wheezy/updates/main i386 Packages [120 kB]
Réception de : 10 http://security.debian.org wheezy/updates/main Translation-en [69,0 kB]
490 ko réceptionnés en 26s (18,4 ko/s)                                         
Lecture des listes de paquets... Fait
root@debian-parpalhou:/home/parpalhou# apt-get install gnome
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Aucune version du paquet gnome n'est disponible, mais il existe dans la base
de données. Cela signifie en général que le paquet est manquant, qu'il est devenu obsolète
ou qu'il n'est disponible que sur une autre source

E: Le paquet « gnome » n'a pas de version susceptible d'être installée
root@debian-parpalhou:/home/parpalhou#

Hors ligne

#5 31-10-2013 20:07:30

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : problème d'installation : impossible de télécharger paquets

parpa a écrit :

Alors j'ai gravé wheezy,


Mais gnome était bien inclus ?


I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

#6 31-10-2013 20:12:14

Haricophile
Adhérent(e)
Lieu : Pignans (Var)
Distrib. : SID
Noyau : 4.0.0-1-amd64
(G)UI : Mate / i3 selon...
Inscription : 14-09-2009

Re : problème d'installation : impossible de télécharger paquets

Là je pense qu'il y a 2 choses à faire:

* Vérifier que le réseau fonctionne
* modifier /etc/apt/sources.list comme indiqué à
http://debian-facile.org/doc:systeme:ap … ble_wheezy

« La religion et l'art sont les luxes des lâches, qui permettent de fuir la réalité quand elle devient trop difficile à affronter. La différence c'est que la religion transforme tout mensonge en vérité alors que l'art transforme toute vérité en mensonge. »

Hors ligne

#7 31-10-2013 21:29:33

parpa
Membre
Distrib. : Debian Wheezy 7.2
Noyau : 3.2.0-4-686-pae
(G)UI : Xfce
Inscription : 31-10-2013

Re : problème d'installation : impossible de télécharger paquets

je sais pas si gnome était inclus, naïvement je pensais que ça l'était automatiquement ...

je vais essayer de modifier les sources.list

Hors ligne

#8 31-10-2013 21:33:00

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : problème d'installation : impossible de télécharger paquets

Hé bien c'est pour ça que je demande quel dvd EXPLICITEMENT as-tu utilisé pour l'installation.

I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

#9 31-10-2013 22:31:22

parpa
Membre
Distrib. : Debian Wheezy 7.2
Noyau : 3.2.0-4-686-pae
(G)UI : Xfce
Inscription : 31-10-2013

Re : problème d'installation : impossible de télécharger paquets

alors la seule info que j'arrive à trouver sur le dvd c'est Debian 7.0.0i38

Hors ligne

#10 31-10-2013 23:15:00

Haricophile
Adhérent(e)
Lieu : Pignans (Var)
Distrib. : SID
Noyau : 4.0.0-1-amd64
(G)UI : Mate / i3 selon...
Inscription : 14-09-2009

Re : problème d'installation : impossible de télécharger paquets

Les DVD c'est surtout quand on n'a pas le haut débit ou pas d'internet du tout. J'avoue ne jamais utiliser ça, que ce soit pour Debian ou Ubuntu (j'utilisais à l'époque le CD "alternate" qui ressemble fort au cd "netinstall" de Debian). L'installation en mode texte n'a rien de complexe sinon savoir comment on partitionne le disque, et l'avantage c'est que tu installe directement les paquets à jour. Il y a des gens qui vont te trouver des arguments contraires, mais bon...


Normalement, même s'il ne pose pas beaucoup de question, tu dois avoir à un moment de l'installation un formulaire avec des cases à cocher selon ce que tu veux installer. "environnement de bureau" t'installe gnome. C'est pas obligatoire, on peut partir sur une installation minimale et installer le bureau plus tard.


Il y a une petite chose à savoir, surtout quand on vient d'Ubuntu qui est beaucoup moins sourcilleux sur l'inclusion des choses non-libres : Debian a viré un maximum de choses pas libres du kernel et du système. Il faut donc les installer explicitement, ça concerne en particulier des pilotes de carte réseau, on peut les mettre en cours d'install en utilisant un support (clé usb), et ils ne s'appellent pas "driver-", mais "firmware-".


Dans le sources.list il n'y a par défaut que "main", on a généralement intérêt à ajouter "contrib" et "non-free". De même si on a une connexion internet décente, on peut commenter ou supprimer les lignes concernant les CD/DVD.
main = paquets libres maintenus par la team Debian
contrib = paquets libres non maintenu par la team
non-free = paquets contenant des logiciels avec une licence non libre.


Dernier petit point où on se fait avoir bêtement : Quand on installe par clé USB il faut, quand on a fini, supprimer les lignes concernant la clé dans /etc/fstab sinon on va avoir des problèmes de montages automatiques des clés. Comme il est possible de mettre une partie du système sur un périphérique USB (surtout sur des très petits systèmes), dans le doute Debian conserve les points de montage, c'est toujours discutable mais c'est ce qu'ils ont choisi.

Mais on trouve tout ça dans la doc et les wiki ^_^

« La religion et l'art sont les luxes des lâches, qui permettent de fuir la réalité quand elle devient trop difficile à affronter. La différence c'est que la religion transforme tout mensonge en vérité alors que l'art transforme toute vérité en mensonge. »

Hors ligne

#11 31-10-2013 23:33:08

captnfab
Admin-Girafe
Lieu : /dev/random
Distrib. : Debian Stretch/Sid/Rc-Buggy
Noyau : Linux (≥ 4.3)
(G)UI : i3-wm (≥ 4.11)
Inscription : 07-07-2008
Site Web

Re : problème d'installation : impossible de télécharger paquets

Salut et bienvenue,

Firefox s'appelle Iceweasel sous Debian, pour l'installer :

apt-get install iceweasel iceweasel-l10n-fr


Pour Gimp :

apt-get install gimp



Pour LibreOffice :

apt-get install libreoffice libreoffice-l10n-fr



Pour discuter via jabber, tu peux utiliser Pidgin, à installer via :

apt-get install pidgin



Pour sélectionner d'autres applications, tu peux utiliser la logithèque :

apt-get install software-center


pour l'installer, et la lancer avec :

software-center&!


captnfab,
Association Debian-Facile, bépo.
TheDoctor: Your wish is my command… But be careful what you wish for.

Hors ligne

#12 31-10-2013 23:57:36

parpa
Membre
Distrib. : Debian Wheezy 7.2
Noyau : 3.2.0-4-686-pae
(G)UI : Xfce
Inscription : 31-10-2013

Re : problème d'installation : impossible de télécharger paquets

ça me met ça :

root@debian-parpalhou:/home/parpalhou# apt-get install gimp
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Aucune version du paquet gimp n'est disponible, mais il existe dans la base
de données. Cela signifie en général que le paquet est manquant, qu'il est devenu obsolète
ou qu'il n'est disponible que sur une autre source

E: Le paquet « gimp » n'a pas de version susceptible d'être installée
root@debian-parpalhou:/home/parpalhou# apt-get install pidgin
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
E: Impossible de trouver le paquet pidgin
root@debian-parpalhou:/home/parpalhou#

en fait j'arrive pas à trouver comment changer à la version suivante, parce que dès que je veux installer un nouveau paquet ça me met que j'ai pas la bonne version .. j'ai essayé avec le terminal mais ça marche pas

Hors ligne

#13 01-11-2013 00:05:56

captnfab
Admin-Girafe
Lieu : /dev/random
Distrib. : Debian Stretch/Sid/Rc-Buggy
Noyau : Linux (≥ 4.3)
(G)UI : i3-wm (≥ 4.11)
Inscription : 07-07-2008
Site Web

Re : problème d'installation : impossible de télécharger paquets

Ah, en effet, ton sources.list ne semble pas être bon, l'installation a du être faite sans accès à internet.

Il te faut donc remplacer le fichier /etc/apt/sources.list par une version plus complète.

Regarde du côté du lien que t'as donné Haricophile : http://debian-facile.org/doc:systeme:ap … recommande

Tu prends le sources.list minimal si tu veux utiliser la version 17.0 de Firefox (qui a un support de sécurité à long terne) ou le sources.list avec backports et dépôts mozilla si tu veux la dernière version de Firefox.

N'hésite pas à poser des questions en cas de difficultés pour faire ça.

captnfab,
Association Debian-Facile, bépo.
TheDoctor: Your wish is my command… But be careful what you wish for.

Hors ligne

#14 01-11-2013 00:16:25

parpa
Membre
Distrib. : Debian Wheezy 7.2
Noyau : 3.2.0-4-686-pae
(G)UI : Xfce
Inscription : 31-10-2013

Re : problème d'installation : impossible de télécharger paquets

je pense que demain je vais télécharger la dernière version et tout réinstaller, parce que là quoi que je mette dans le terminal ça me dit que c'est pas possible, et  je peux rien faire sur mon ordi à part naviguer sur le net hmm
Le mieux et plus simple c'est que je grave l'image iso sur un dvd ou pas ?

Hors ligne

#15 01-11-2013 00:17:40

david96
Invité

Re : problème d'installation : impossible de télécharger paquets

Un CD-R suffit smile

Avec le lien c'est mieux : http://www.debian.org/CD/live/


Pour le gestionnaire Gnome sous wheezy sous architecture 32 bits :  debian-live-7.2-i386-gnome-desktop.iso   
http://cdimage.debian.org/debian-cd/cur … so-hybrid/



Pfiou je vois qu'il fait 1.2 GO !! Ça va donc être juste pour un CD-R hmm

Dernière modification par Invité-2 (01-11-2013 00:26:52)

#16 01-11-2013 01:11:34

captnfab
Admin-Girafe
Lieu : /dev/random
Distrib. : Debian Stretch/Sid/Rc-Buggy
Noyau : Linux (≥ 4.3)
(G)UI : i3-wm (≥ 4.11)
Inscription : 07-07-2008
Site Web

Re : problème d'installation : impossible de télécharger paquets

Salut,
Tu n'as pas besoin de réinstaller smile

Qu'y a-t-il dans ton /etc/apt/sources.list ?

Tu peux le savoir en tapant la commande suivante :

cat /etc/apt/sources.list


captnfab,
Association Debian-Facile, bépo.
TheDoctor: Your wish is my command… But be careful what you wish for.

Hors ligne

#17 01-11-2013 15:41:51

parpa
Membre
Distrib. : Debian Wheezy 7.2
Noyau : 3.2.0-4-686-pae
(G)UI : Xfce
Inscription : 31-10-2013

Re : problème d'installation : impossible de télécharger paquets

ça me met ça :

parpalhou@debian-parpalhou:~$ cat /etc/apt/sources.list


# deb cdrom:[Debian GNU/Linux 7.0.0 _Wheezy_ - Official i386 CD Binary-1 20130504-15:20]/ wheezy main

deb cdrom:[Debian GNU/Linux 7.0.0 _Wheezy_ - Official i386 CD Binary-1 20130504-15:20]/ wheezy main

# Line commented out by installer because it failed to verify:
deb http://security.debian.org/ wheezy/updates main
# Line commented out by installer because it failed to verify:
deb-src http://security.debian.org/ wheezy/updates main

# wheezy-updates, previously known as 'volatile'
# A network mirror was not selected during install.  The following entries
# are provided as examples, but you should amend them as appropriate
# for your mirror of choice.

deb http://ftp.debian.org/debian/ wheezy-updates main
deb-src http://ftp.debian.org/debian/ wheezy-updates main

mais j'ai réflêchi et je pense qu'au final je vais mettre KDE, parce que j'aime pas la configuration de Gnome ... j'imagine que je pourrai quand même installer les logiciels dont j'ai l'habitude genre Pidgin, Open office, Mozilla, Bitorrent, Gimp non ?

Dernière modification par parpa (01-11-2013 15:44:06)

Hors ligne

#18 01-11-2013 15:46:48

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : problème d'installation : impossible de télécharger paquets

Pas de problème pour les logiciels que tu souhaites sous KDE.

J'espère que tu ne vas pas te retrouver avec un sources.list aussi bizarre.

I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

#19 01-11-2013 15:47:45

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : problème d'installation : impossible de télécharger paquets

Pour l'architecture i386 tu es sûre ?
Quelle est ta machine ?

I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

#20 01-11-2013 15:53:18

captnfab
Admin-Girafe
Lieu : /dev/random
Distrib. : Debian Stretch/Sid/Rc-Buggy
Noyau : Linux (≥ 4.3)
(G)UI : i3-wm (≥ 4.11)
Inscription : 07-07-2008
Site Web

Re : problème d'installation : impossible de télécharger paquets

@parpa: Il faudrait que tu remplaces le fichier /etc/apt/sources.list par ça :

# wheezy
deb http://ftp.fr.debian.org/debian/ wheezy main contrib non-free
# wheezy updates  
deb http://ftp.fr.debian.org/debian/ wheezy-updates main contrib non-free
# wheezy security
deb http://security.debian.org/ wheezy/updates main contrib non-free
 



Tu peux faire ça avec gedit en lançant :

gksu gedit /etc/apt/sources.list



@paskal: osef, les distros i386 tournent sur un proco 64bits avec une perte de perf pas très importante.


captnfab,
Association Debian-Facile, bépo.
TheDoctor: Your wish is my command… But be careful what you wish for.

Hors ligne

#21 01-11-2013 15:54:17

parpa
Membre
Distrib. : Debian Wheezy 7.2
Noyau : 3.2.0-4-686-pae
(G)UI : Xfce
Inscription : 31-10-2013

Re : problème d'installation : impossible de télécharger paquets

j'ai un MSI VR601

Hors ligne

#22 01-11-2013 15:54:46

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : problème d'installation : impossible de télécharger paquets

Oui mais pour KDE, ne vaudrait-il pas mieux une amd64 si ça correspond à son ordi ?

I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

#23 01-11-2013 15:57:25

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : problème d'installation : impossible de télécharger paquets

parpa a écrit :

j'ai un MSI VR601


Il peut tourner en 64bits


I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

#24 01-11-2013 15:59:39

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : problème d'installation : impossible de télécharger paquets


I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

#25 01-11-2013 16:00:05

captnfab
Admin-Girafe
Lieu : /dev/random
Distrib. : Debian Stretch/Sid/Rc-Buggy
Noyau : Linux (≥ 4.3)
(G)UI : i3-wm (≥ 4.11)
Inscription : 07-07-2008
Site Web

Re : problème d'installation : impossible de télécharger paquets

Oui il peut, est-ce que ça vaut le coup de réinstaller pour ça, j'en doute fort. Est-ce que KDE tournera dessus, probablement, mais je n'en mettrai pas ma main à couper.

captnfab,
Association Debian-Facile, bépo.
TheDoctor: Your wish is my command… But be careful what you wish for.

Hors ligne

Pied de page des forums