Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 06-11-2013 15:02:41

AM
Membre
Lieu : NANTES
Distrib. : Debian GNU/Linux 7.4
Noyau : Linux 3.2.0.4-amd64
(G)UI : Gnome 3.4.2
Inscription : 14-08-2013

[Résolu] Clavier Qwerty ouverture de session

Bonjour tout le monde,

Désirant passer sous XFCE, j'ai refais une install toute fraiche via debian netinstall.

Cette installation a été faite via une install graphic en ayant sélectionné au tout début l'interface graphique xfce

L'installation terminée, je constate qu'à mon ouverture de session le clavier est en qwerty et non azerty,

J'ai contrôlé dans les paramètres systèmes sur l'agencement du clavier et j'ai décoché paramétrage par défaut en prenant bien soin d'avoir en clavier secondaire un clavier FR.

Je redémarre pour la bonne prise en compte et hélas toujours ce clavier en US,

Un petit tour sur la documentation :

http://debian-facile.org/doc:materiel:claviers:claviers

Mais rien n'y fait le clavier est toujours en qwerty à l'ouverture de session

J'ai aussi fais un tour dans /var/log et aucun message d'erreur

Bref j'espère que la lecture de mon périple sous xfce ne vous a pas trop assommé smile et que quelqu'un pourra m'aider afin que je passe définitivement sous xfce

Ps : Je tiens à préciser qu'après l'ouverture de session le clavier est bien en français

Dernière modification par AM (07-11-2013 10:42:22)


Un Jour Comme Aujourd'hui ...

Hors ligne

#2 06-11-2013 15:54:02

david96
Invité

Re : [Résolu] Clavier Qwerty ouverture de session

Bonjour,


Peux-tu nous retourner la commande suivante :

cat /etc/default/keyboard | grep -i variant

#3 06-11-2013 16:17:34

AM
Membre
Lieu : NANTES
Distrib. : Debian GNU/Linux 7.4
Noyau : Linux 3.2.0.4-amd64
(G)UI : Gnome 3.4.2
Inscription : 14-08-2013

Re : [Résolu] Clavier Qwerty ouverture de session

Je te fais ça ce soir quand je serais sur le poste smile

Un Jour Comme Aujourd'hui ...

Hors ligne

#4 06-11-2013 19:40:49

AM
Membre
Lieu : NANTES
Distrib. : Debian GNU/Linux 7.4
Noyau : Linux 3.2.0.4-amd64
(G)UI : Gnome 3.4.2
Inscription : 14-08-2013

Re : [Résolu] Clavier Qwerty ouverture de session

Voici le retour :

am@AM-PC:~$ cat /etc/default/keyboard | grep -i variant
XKBVARIANT="oss"
am@AM-PC:~$
 


Un Jour Comme Aujourd'hui ...

Hors ligne

#5 06-11-2013 22:02:31

Octopus Riot
Membre
Distrib. : Wheezy
Noyau : Linux 3.2.0-4-686-pae
(G)UI : XFCE 4.8
Inscription : 16-10-2012

Re : [Résolu] Clavier Qwerty ouverture de session

Salut AM,

Chez moi le clavier est bien Azerty dès le démarrage, et la commande

$ cat /etc/default/keyboard | grep -i variant



Donne comme résultat :

XKBVARIANT="latin9"



Pour info :

$ cat /etc/default/keyboard



a pour résultat :

# KEYBOARD CONFIGURATION FILE

# Consult the keyboard(5) manual page.

XKBMODEL="pc105"
XKBLAYOUT="fr"
XKBVARIANT="latin9"
XKBOPTIONS=""



Il semble que tu n'ai pas la même config.

Dernière modification par Octopus Riot (07-11-2013 16:40:39)

Hors ligne

#6 06-11-2013 22:16:30

AM
Membre
Lieu : NANTES
Distrib. : Debian GNU/Linux 7.4
Noyau : Linux 3.2.0.4-amd64
(G)UI : Gnome 3.4.2
Inscription : 14-08-2013

Re : [Résolu] Clavier Qwerty ouverture de session

Hello,

Merci pour ton retour, je vais apporter la modif' et voir ce que ça donne smile

Un Jour Comme Aujourd'hui ...

Hors ligne

#7 07-11-2013 00:22:37

david96
Invité

Re : [Résolu] Clavier Qwerty ouverture de session

Ça devrait le faire.

Merci Octopus Riot pour le retour smile


Édite : sinon, y'a le passage aussi par xorg.conf (il me semble que c'est toujours possible)

Dernière modification par Invité-2 (07-11-2013 00:24:03)

#8 07-11-2013 10:42:07

AM
Membre
Lieu : NANTES
Distrib. : Debian GNU/Linux 7.4
Noyau : Linux 3.2.0.4-amd64
(G)UI : Gnome 3.4.2
Inscription : 14-08-2013

Re : [Résolu] Clavier Qwerty ouverture de session

Je reviens pour vous dire que tout est ok maintenant smile

La méthode a été de modifier le fichier /etc/default/keyboard en ajoutant les paramètres suivants :

XKBMODEL="pc105"
XKBLAYOUT="fr"
XKBVARIANT="latin9"
XKBOPTIONS=""



et par sécurité j'ai modifier mon fichier xorg.cong en ajoutant :

Section "InputDevice"
    Identifier     "Generic Keyboard"
    Driver         "kbd"
    Option         "CoreKeyboard"
    Option         "XkbRules" "xorg"
    Option         "XkbModel" "pc105"
    Option         "XkbLayout" "fr"
    Option         "XkbVariant" "latin9"
EndSection



Merci à vous smile

Dernière modification par AM (07-11-2013 10:43:35)


Un Jour Comme Aujourd'hui ...

Hors ligne

#9 07-11-2013 11:13:51

david96
Invité

Re : [Résolu] Clavier Qwerty ouverture de session

Cool. cool

#10 07-11-2013 22:07:24

Y316
Membre
Distrib. : stretch/sid
Noyau : 4.3.0-1-amd64
Inscription : 15-11-2012

Re : [Résolu] Clavier Qwerty ouverture de session

mon fichier xorg.cong


big_smile T'es un king .


Debian 8.3 (jessie)  + la pire ICC que vous ayez probablement jamais rencontré.

Hors ligne

#11 07-11-2013 22:50:45

david96
Invité

Re : [Résolu] Clavier Qwerty ouverture de session

Lol, bien vu ! lol

#12 08-11-2013 07:33:28

AM
Membre
Lieu : NANTES
Distrib. : Debian GNU/Linux 7.4
Noyau : Linux 3.2.0.4-amd64
(G)UI : Gnome 3.4.2
Inscription : 14-08-2013

Re : [Résolu] Clavier Qwerty ouverture de session

Y316 a écrit :

mon fichier xorg.cong


big_smile T'es un king .


Effectivement ^^ bien vu smile


Un Jour Comme Aujourd'hui ...

Hors ligne

#13 04-03-2014 22:30:47

AM
Membre
Lieu : NANTES
Distrib. : Debian GNU/Linux 7.4
Noyau : Linux 3.2.0.4-amd64
(G)UI : Gnome 3.4.2
Inscription : 14-08-2013

Re : [Résolu] Clavier Qwerty ouverture de session

Bonsoir tout le monde,

Suite à uné réinstall je reviens vers vous pour vous partager une autre astuce pour avoir son clavier en azerty à l'ouverture de session :

à copier avant exit 0 du fichier gérant votre ouverture de session (exemple dans mon cas : /etc/gdm/Init/Default)

/usr/bin/setxkbmap fr

Je suis repassé sous gnome mais ça marche aussi pour mdm, slim et autre wink

Amicalement smile

Un Jour Comme Aujourd'hui ...

Hors ligne

Pied de page des forums