Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 13-11-2013 16:47:36

TyZef
Membre
Lieu : 0°31'48.9"N 72°59'44.7"E
Distrib. : Debian8.2 (jessie)
Noyau : Noyaux Linux 3.16.0-4-amd64
(G)UI : MATE 1.8.1
Inscription : 09-05-2013

[résolu] Pas de version cadidate trouvée pour virtualbox

Salut tout l'monde!

Donc un problème que je viens juste de rencontrer avec Vbox ici :

Pas de version cadidate trouvée pour virtualbox-4.1
1384353270.png

J'ai pu contourner ce problème en installant Vbox via Synaptic...

Alors est ce un problème venant de chez moi, du wiki ou autre?

Merci beaucoup !

Dernière modification par TyZef (16-11-2013 17:40:15)

Hors ligne

#2 13-11-2013 16:56:25

Ralph W. Llama
Membre
Lieu : /dev/null
Distrib. : Jessie 8.0
Noyau : Linux 3.16.0-4-amd64 / 686-pae
(G)UI : Xfce 4.10.1
Inscription : 09-08-2013
Site Web

Re : [résolu] Pas de version cadidate trouvée pour virtualbox

La 4.2 est sortie, ils ont peut-être viré la 4.1 des dépôts...

Vivre libre ou mourir !


Des détails sur mes PCs

Hors ligne

#3 13-11-2013 17:30:57

TyZef
Membre
Lieu : 0°31'48.9"N 72°59'44.7"E
Distrib. : Debian8.2 (jessie)
Noyau : Noyaux Linux 3.16.0-4-amd64
(G)UI : MATE 1.8.1
Inscription : 09-05-2013

Re : [résolu] Pas de version cadidate trouvée pour virtualbox

ben pourtant voici la version que Synaptic m'a installé !

1384356551.png

Hors ligne

#4 13-11-2013 18:43:40

Ralph W. Llama
Membre
Lieu : /dev/null
Distrib. : Jessie 8.0
Noyau : Linux 3.16.0-4-amd64 / 686-pae
(G)UI : Xfce 4.10.1
Inscription : 09-08-2013
Site Web

Re : [résolu] Pas de version cadidate trouvée pour virtualbox

Ouais, surtout que synaptic va chercher dans les dépots, donc je dis une connerie.

Pourtant, moi, quand je fais un apt-cache policy virtualbox-4.1, ça me donne un résultat...

antoine@PC:~$ apt-cache policy virtualbox-4.1
virtualbox-4.1:
  Installé : 4.1.28-89849~Debian~wheezy
  Candidat : 4.1.28-89849~Debian~wheezy
 Table de version :
 *** 4.1.28-89849~Debian~wheezy 0
        500 http://download.virtualbox.org/virtualbox/debian/ wheezy/contrib amd64 Packages
        100 /var/lib/dpkg/status



Et chez toi aussi ça devrait, puis que synaptic l'a trouvé. À moins que synaptic utilise sa propre liste de dépôts au lieu de /etc/apt/sources.list ? Faudrait que quelqu'un nous confirme ça.

Au passage, j'aurais du y penser : quand tu veux donner le résultat d'une commande, plutôt qu'un screenshot, utilise la balise [code], ça permet d'intégrer le code au forum, c'est plus sympa.

EDIT :

antoine@PC:~$ apt-cache policy virtualbox
virtualbox:
  Installé : (aucun)
  Candidat : 4.1.18-dfsg-2+deb7u1
 Table de version :
     4.2.16-dfsg-1~bpo70+1 0
        100 http://ftp.fr.debian.org/debian/ wheezy-backports/contrib amd64 Packages
     4.1.18-dfsg-2+deb7u1 0
        500 http://ftp.fr.debian.org/debian/ wheezy/main amd64 Packages



Il semblerait qu'il y aie une version de virtualbox présente dans les dépôts officiels. Essaie pour voir :

apt-get install virtualbox



ou

aptitude install virtualbox



pour voir... (désinstalle la version que t'as déjà avant, pour être sûr)

Dernière modification par Ralph W. Llama (13-11-2013 18:46:56)


Vivre libre ou mourir !


Des détails sur mes PCs

Hors ligne

#5 16-11-2013 05:58:22

TyZef
Membre
Lieu : 0°31'48.9"N 72°59'44.7"E
Distrib. : Debian8.2 (jessie)
Noyau : Noyaux Linux 3.16.0-4-amd64
(G)UI : MATE 1.8.1
Inscription : 09-05-2013

Re : [résolu] Pas de version cadidate trouvée pour virtualbox

Merci beaucoup Ralph pour ton aide !

Ralph W. Llama a écrit :

Au passage, j'aurais du y penser : quand tu veux donner le résultat d'une commande, plutôt qu'un screenshot, utilise la balise [code], ça permet d'intégrer le code au forum, c'est plus sympa.



Je n'aurais pas su le faire de cette manière je ne connais pas cette commande "apt-cache policy" j'essairai de m'en souvenir, merci !

Pour la désinstall de Vbox j'ai pas internet illimité et de plus il me coûte cher... mais bon, cette fois-ci je le fais histoire de contribuer au libre, pour le peux que j'y dépense !

Ah bah je ne comprend pas, on dirait que ça n'a rien télécharger ! Aussi j'ai eu un message d'erreur : "failed!"

tyzef@localhost:~$ su
Mot de passe :
root@localhost:/home/tyzef# apt-get install virtualbox
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Les paquets supplémentaires suivants seront installés :
  virtualbox-dkms virtualbox-qt
Paquets suggérés :
  virtualbox-guest-additions-iso vde2
Les NOUVEAUX paquets suivants seront installés :
  virtualbox virtualbox-dkms virtualbox-qt
0 mis à jour, 3 nouvellement installés, 0 à enlever et 0 non mis à jour.
Il est nécessaire de prendre 0 o/17,5 Mo dans les archives.
Après cette opération, 68,4 Mo d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer [O/n] ? o
Sélection du paquet virtualbox précédemment désélectionné.
(Lecture de la base de données... 115107 fichiers et répertoires déjà installés.)
Dépaquetage de virtualbox (à partir de .../virtualbox_4.1.18-dfsg-2+deb7u1_amd64.deb) ...
Sélection du paquet virtualbox-dkms précédemment désélectionné.
Dépaquetage de virtualbox-dkms (à partir de .../virtualbox-dkms_4.1.18-dfsg-2+deb7u1_all.deb) ...
Sélection du paquet virtualbox-qt précédemment désélectionné.
Dépaquetage de virtualbox-qt (à partir de .../virtualbox-qt_4.1.18-dfsg-2+deb7u1_amd64.deb) ...
Traitement des actions différées (« triggers ») pour « man-db »...
Traitement des actions différées (« triggers ») pour « menu »...
Traitement des actions différées (« triggers ») pour « hicolor-icon-theme »...
Traitement des actions différées (« triggers ») pour « shared-mime-info »...
Traitement des actions différées (« triggers ») pour « desktop-file-utils »...
Paramétrage de virtualbox (4.1.18-dfsg-2+deb7u1) ...
[ ok ] Stopping VirtualBox kernel modules.
[....] Starting VirtualBox kernel modules[....] No suitable module for running k[FAIL found ... failed!
 failed!
invoke-rc.d: initscript virtualbox, action "restart" failed.
Paramétrage de virtualbox-dkms (4.1.18-dfsg-2+deb7u1) ...
Loading new virtualbox-4.1.18 DKMS files...
First Installation: checking all kernels...
Building only for 3.2.0-4-amd64
Building initial module for 3.2.0-4-amd64
Done.

vboxdrv:
Running module version sanity check.
 - Original module
   - No original module exists within this kernel
 - Installation
   - Installing to /lib/modules/3.2.0-4-amd64/updates/dkms/

vboxnetadp.ko:
Running module version sanity check.
 - Original module
   - No original module exists within this kernel
 - Installation
   - Installing to /lib/modules/3.2.0-4-amd64/updates/dkms/

vboxnetflt.ko:
Running module version sanity check.
 - Original module
   - No original module exists within this kernel
 - Installation
   - Installing to /lib/modules/3.2.0-4-amd64/updates/dkms/

vboxpci.ko:
Running module version sanity check.
 - Original module
   - No original module exists within this kernel
 - Installation
   - Installing to /lib/modules/3.2.0-4-amd64/updates/dkms/

depmod....

DKMS: install completed.
[ ok ] Stopping VirtualBox kernel modules.
[ ok ] Starting VirtualBox kernel modules.
Paramétrage de virtualbox-qt (4.1.18-dfsg-2+deb7u1) ...
Traitement des actions différées (« triggers ») pour « menu »...
root@localhost:/home/tyzef#
 



Voilà !

Dernière modification par TyZef (16-11-2013 05:59:23)

Hors ligne

#6 16-11-2013 11:28:57

captnfab
Admin-Girafe
Lieu : /dev/random
Distrib. : Debian Stretch/Sid/Rc-Buggy
Noyau : Linux (≥ 4.3)
(G)UI : i3-wm (≥ 4.11)
Inscription : 07-07-2008
Site Web

Re : [résolu] Pas de version cadidate trouvée pour virtualbox

Tu n'as plus de message d'erreur « failed ».

La première fois il y était, puis il a compilé le module, et la seconde fois tout était ok.

captnfab,
Association Debian-Facile, bépo.
TheDoctor: Your wish is my command… But be careful what you wish for.

Hors ligne

#7 16-11-2013 15:35:54

Ralph W. Llama
Membre
Lieu : /dev/null
Distrib. : Jessie 8.0
Noyau : Linux 3.16.0-4-amd64 / 686-pae
(G)UI : Xfce 4.10.1
Inscription : 09-08-2013
Site Web

Re : [résolu] Pas de version cadidate trouvée pour virtualbox

Le message d'erreur "failed" est normal lors de la première installation. Je l'ai expliqué dans le tuto sur VB.

(c'est même grâce à ton topic que j'ai vu que VB était dans les dépôt officiels et que j'ai pu modifier ce tuto)

Vivre libre ou mourir !


Des détails sur mes PCs

Hors ligne

#8 16-11-2013 17:37:56

TyZef
Membre
Lieu : 0°31'48.9"N 72°59'44.7"E
Distrib. : Debian8.2 (jessie)
Noyau : Noyaux Linux 3.16.0-4-amd64
(G)UI : MATE 1.8.1
Inscription : 09-05-2013

Re : [résolu] Pas de version cadidate trouvée pour virtualbox

Ok cool !!!

Merci les gars !!!

Hors ligne

Pied de page des forums