Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 16-11-2013 19:07:46

golgot200
Membre
Lieu : AIN
Distrib. : Debian Jessie
Noyau : Linux debian 3.16.0-4-amd64
(G)UI : MATE
Inscription : 05-08-2007

[RÉSOLU]Samsung Syncmaster 2233rz 3D 120 HZ

Bonsoir,

Je viens de récupérer un écran cité dans le titre. Du démarrage jusque avant l'entrée dans ma session, j'ai dans mon info sur menu écran le 120 HZ d'activé et paf : arrivé dans mon bureau, je me retrouve en 60 HZ.

J'ai bien acheté un cable DVI Dual Link, ma carte, la 520 GT, c'est bon, donc je pense que c'est mes réglages ou mon xorg.conf ( une option) qui ne sont pas bons. Je n'ai pas d'autres écrans, je ne sais pas si ça a son importance. En root, j'ai bien écrasé mon xorg.conf avec l'option non auto pour la résolution 1680x2050 et la fréquence 120 HZ. ( J'ai aussi le 110HZ et 100HZ que je n'ai pas essayé)
Sur des forums, on parle de désactiver l'option  Full GPU Scaling dans le nvidia-settings. Moi, je n'ai pas cette option.


j'ai mis des option à la mano comme:

Modeline "1680x1050_120.00"  313.20  1680 1816 2000 2320  1050 1051 1054 1125  -HSync +Vsync
dans la Section "Monitor"

Et la fameuse ligne citée un peu partout mais qui ne marche pas chez moi :
Screen 0
Option "FlatPanelProperties" "Scaling = Native"
Dans la section "device"

Si quelqu'un pouvait m'en dire plus.
Merci par avance de votre aide.

Je peux le faire à chaque fois mais c'est pas top !!!


EDIT: mon xorg.conf


# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings:  version 331.20  (buildmeister@swio-display-x86-rhel47-05)  Wed Oct 30 18:20:32 PDT 2013


Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
    Option         "Xinerama" "0"
EndSection

Section "Files"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"

    # HorizSync source: edid, VertRefresh source: edid
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Samsung SyncMaster"
    HorizSync       30.0 - 190.0
    VertRefresh     56.0 - 125.0
    Modeline       "1680x1050_120.00"  313.20  1680 1816 2000 2320  1050 1051 1054 1125  -HSync +Vsync
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce GT 520"
    BoardName "NVIDIA GeForce 8 Series"
    Screen 0
    Option "FlatPanelProperties" "Scaling = Native"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "Stereo" "0"
    Option         "nvidiaXineramaInfoOrder" "DFP-0"
    Option         "metamodes" "1680x1050_120 +0+0"
    Option         "SLI" "Off"
    Option         "MultiGPU" "Off"
    Option         "BaseMosaic" "off"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection
 



Et j'ai viré le .nvidia-settings-rc de mon home au cas où.

Dernière modification par golgot200 (17-11-2013 13:25:02)


L'ultime question ... l'intelligence a besoin de la bêtise pour s'affirmer, la beauté a besoin de la laideur pour resplendir, le courage nait dans la peur, les forts impressionnent au millieu des faibles, mais au final,... qui a donc besoin d'autant de connards ?

Hors ligne

#2 16-11-2013 23:46:27

golgot200
Membre
Lieu : AIN
Distrib. : Debian Jessie
Noyau : Linux debian 3.16.0-4-amd64
(G)UI : MATE
Inscription : 05-08-2007

Re : [RÉSOLU]Samsung Syncmaster 2233rz 3D 120 HZ

J'ai presque trouvé.

Comment fait-on pour lancer ce script au démarrage de XFCE ???

#!/bin/bash

xrandr --addmode DVI-I-1 1680x1050 --rate 120
xrandr --output DVI-I-1 --mode 1680x1050 --rate 120


L'ultime question ... l'intelligence a besoin de la bêtise pour s'affirmer, la beauté a besoin de la laideur pour resplendir, le courage nait dans la peur, les forts impressionnent au millieu des faibles, mais au final,... qui a donc besoin d'autant de connards ?

Hors ligne

#3 17-11-2013 12:39:14

golgot200
Membre
Lieu : AIN
Distrib. : Debian Jessie
Noyau : Linux debian 3.16.0-4-amd64
(G)UI : MATE
Inscription : 05-08-2007

Re : [RÉSOLU]Samsung Syncmaster 2233rz 3D 120 HZ

Bon,

voilà une chose résolu et simplement. Et bien sur la toile, il y a à manger et à boire.

Je pars sur un pilote 304.88 du dépôt. Comme ça, j'évite un message d'erreur comme celui-ci dans mon .xsession-errors :


X Error of failed request: BadMatch (invalid parameter attributes) Major opcode of failed request: 153 (RANDR). Minor opcode of failed request: 18 (RRAddOutputMode). Serial number of failed request: 29. Current serial number in output stream: 30.




Donc le pilote 304.88 et un fichier xorg.conf mini :


Section     "Device"
Identifier  "Geforce 520 GT"
Driver      "nvidia"
Option      "NoLogo"         "1"
Option      "RenderAccel"    "1"

EndSection




Je veux récupérer les paramètres de la résolution que je souhaite, donc par xrandr



cvt 1680 1050 120
 



ce qui me donne:

# 1680x1050 119.89 Hz (CVT) hsync: 135.24 kHz; pclk: 313.75 MHz
Modeline "1680x1050_120.00"  313.75  1680 1816 2000 2320  1050 1053 1059 1128 -hsync +vsync
patrick@debian:~$



Je créer une nouvelle résolution et sa sortie :
Je me suis aidé de ça:
https://wiki.ubuntu.com/X/Config/Resolution
Mais pour connaître la sortie, il faut faire un xrandr | grep connected



xrandr | grep connected
 




DVI-I-0 disconnected (normal left inverted right x axis y axis)
VGA-0 disconnected (normal left inverted right x axis y axis)
DVI-I-1 connected 1680x1050+0+0 (normal left inverted right x axis y axis) 478mm x 296mm
HDMI-0 disconnected (normal left inverted right x axis y axis)



Donc chez moi : DVI-I-1


Donc je fais ça :


xrandr --addmode DVI-I-1 1680x1050 --rate 120
 



puis,


xrandr --output DVI-I-1 --mode 1680x1050 --rate 120
 




Et à ce moment, je vois mon écran passer de 60HZ à 120HZ

Là, j'ai bataillé: comment charger ces deux commandes au démarrage de la session.
J'ai pas trouvé que par un script: Resolution.sh que je met dans mon home.


#!/bin/bash

xrandr --addmode DVI-I-1 1680x1050 --rate 120
xrandr --output DVI-I-1 --mode 1680x1050 --rate 120



Dans Paramètres --- Gestionnaire de paramètres --- Session et démarrage --- Démarrage automatique -- Ajouter par exemple :

Nom :  Résolution Écran
Description:  Au démarrage
sh -c /home/VOTRE_USER/Resolution.sh


Voilà, si ça peux aider. smile


PS: Je ne lance pas de nvidia-settings -l au démarrage automatique pour l'instant.

Dernière modification par golgot200 (17-11-2013 13:24:01)


L'ultime question ... l'intelligence a besoin de la bêtise pour s'affirmer, la beauté a besoin de la laideur pour resplendir, le courage nait dans la peur, les forts impressionnent au millieu des faibles, mais au final,... qui a donc besoin d'autant de connards ?

Hors ligne

#4 17-11-2013 17:35:12

golgot200
Membre
Lieu : AIN
Distrib. : Debian Jessie
Noyau : Linux debian 3.16.0-4-amd64
(G)UI : MATE
Inscription : 05-08-2007

Re : [RÉSOLU]Samsung Syncmaster 2233rz 3D 120 HZ

La commande au démarrage qui va bien, pour laisser le temps au système de s'initialiser.

sh -c "sleep 10; ~/LE_SCRIPT.sh"


L'ultime question ... l'intelligence a besoin de la bêtise pour s'affirmer, la beauté a besoin de la laideur pour resplendir, le courage nait dans la peur, les forts impressionnent au millieu des faibles, mais au final,... qui a donc besoin d'autant de connards ?

Hors ligne

#5 17-11-2013 22:05:10

deuchdeb
Moderato ma non troppo
Lieu : Pays de Cocagne
Distrib. : Jessie 8 + backports
Noyau : linux-image-3.16
(G)UI : KDE4.14 - Mate
Inscription : 13-01-2010

Re : [RÉSOLU]Samsung Syncmaster 2233rz 3D 120 HZ

Merci pour ton retour. smile

Pas toujours simple les nouveaux matériels.

Hors ligne

#6 17-11-2013 22:24:15

golgot200
Membre
Lieu : AIN
Distrib. : Debian Jessie
Noyau : Linux debian 3.16.0-4-amd64
(G)UI : MATE
Inscription : 05-08-2007

Re : [RÉSOLU]Samsung Syncmaster 2233rz 3D 120 HZ

Oui, mais ce que c'est plaisant de s'arracher les cheveux. Surtout pour un dégarni comme moi !!! smile

L'ultime question ... l'intelligence a besoin de la bêtise pour s'affirmer, la beauté a besoin de la laideur pour resplendir, le courage nait dans la peur, les forts impressionnent au millieu des faibles, mais au final,... qui a donc besoin d'autant de connards ?

Hors ligne

Pied de page des forums