Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 23-09-2008 16:53:52

cmm
Adhérent(e)
Lieu : Meudon
Distrib. : wheezy / jessie
Noyau : 3.2.0-4-amd64 / 3.16.0-4-amd64
(G)UI : gnome classic / mate
Inscription : 23-09-2008
Site Web

[Résolu] configuration xorg.conf avec pilote nvidia

Bonjour,

Je viens d'installer Debian Lenny sur mon nouveau portable, un compaq presario V6533ef (Turion 64x2, nvidia geforce7150M /
nforce 630M). J'ai d'abord essayé d'installer la version stable etch (qui marche très bien sur mon vieux portable armada E500), à partir du cd netinstall, mais la connexion ethernet (pilotée par une puce nvidia) n'était pas reconnue, c'est pourquoi j'ai installé Lenny Beta 2 amd64 à partir du DVD1. Cette fois la connexion ethernet a fonctionné et j'ai pu achever l'installation. Lors de l'installation du serveur X, j'ai été surpris en constatant qu'aucune question ne m'était posée sur la nature de la "carte" graphique (ce n'est pas une vraie carte, mais un composant nvidia intégré à la carte mère), ni sur les résolutions que je voulais choisir. Les questions ne portaient pratiquement que sur le clavier. J'ai vu que le serveur X fonctionnait, pas avec le pilote nvidia mais avec, je crois, VESA, à une résolution de 1024x768. Or sous windows j'ai une résolution de 1280x800. J'ai vu que le fichier
/etc/X11/xorg.conf (créé automatiquement lors de l'installation) était très sommaire, ne chargeait pas le pilote nvidia et ne définissait aucune résolution.

Grâce au lien

http://www.commentcamarche.net/faq/suje … ers-nvidia

qui donne des explications très claires, j'ai pu télécharger et installer le pilote nvidia (en uilisant module-assistant) puis j'ai fabriqué un nouveau fichier xorg.conf grâce aux commandes, indiquées elles aussi sur la page web citée ci-dessus,

aptitude install nvidia-xconfig
dpkg-reconfigure xserver-xorg
nvidia-xconfig   

Je lance alors startx, je vois le logo de nvidia s'afficher avec une résolution correcte, puis l'écran devient tout granuleux et je me retrouve avec un écran à la résolution 320x240, inutilisable en pratique parce qu'une bonne partie des menus est en dehors des limites de l'écran. En prime, me voilà avec un clavier américain! J'édite en console le fichier xorg.conf, je vois qu'il ne définit aucune résolution et qu'il n'a retenu aucun des éléments du précédent fichier xorg.conf, et j'essaie de l"améliorer en piquant des informations dans man xorg.conf, et aussi à droite et à gauche sur le net. Après de nombreux essais, j'en suis toujours là (sauf que le clavier n'est plus américain et que le touchpad fonctionne, mais la résolution est toujours 320x240). Le fichier /var/log/Xorg.0.log n'indique pas d'erreur, seulement des avertissements, dont le plus inquiétant me semble être

(WW) NVIDIA: No matching Device section for instance (BusID PCI:0:1:3) found

Les autres avertissements concernent le touchpad synaptics, qui fonctionne.

Ce fichier montre que le pilote nvidia est bien chargé et qu'à un certain moment il choisit la résolution 1280x800, puisque ce fichier de log contient les lignes

(II) NVIDIA(0): Initialized GPU GART.
(II) NVIDIA(0): ACPI display change hotkey events enabled: the X server is new
(II) NVIDIA(0):     enough to receive ACPI display change hotkey events.
(II) NVIDIA(0): Setting mode "1280x800"
(II) Loading extension NV-GLX
(II) NVIDIA(0): NVIDIA 3D Acceleration Architecture Initialized
(II) NVIDIA(0): Using the NVIDIA 2D acceleration architecture
(==) NVIDIA(0): Backing store disabled
(==) NVIDIA(0): Silken mouse enabled

Mais patatras! la toute dernière ligne de ce fichier de log est

(II) NVIDIA(0): Setting mode "320x240"   

Les questions que je me pose:

1. Comment faire pour que dpkg-reconfigure xserver-xorg crée un nouveau fichier xorg.conf correct, comme c'était (je crois) le cas avec etch? ? Chaque fois que j'ai essayé, les questions posées danbs des boîtes de dialogue ne concernent que le clavier, pas la carte graphique ni l'écran.

2. Qu'est-ce qui ne va pas dans mon fichier xorg.conf, qui au dernier moment met la résolution à 320x240?

J'espère que les lecteurs me pardonneront de m'exprimer si longuement.

Merci d'avance à qui pourra apporter des éléments de réponse à mes questions!

Dernière modification par cmm1934@orange.fr (26-09-2008 23:46:26)

Hors ligne

#2 23-09-2008 19:32:20

jul
Membre
Distrib. : sid
Noyau : 2.6.32
(G)UI : gnome
Inscription : 01-06-2008

Re : [Résolu] configuration xorg.conf avec pilote nvidia

Salut

remets ton xorg.conf d'origine


et mets juste dans la section driver :
Driver         "nvidia"

Hors ligne

#3 23-09-2008 19:40:41

freddec
homo-informaticus du genre linuxo-debianicum
Lieu : Saint Jean d'Y (17)
Distrib. : Branche Stable (Jessie)
Noyau : Linux 3.16.0-4-amd64
(G)UI : XFCE_4.1 (+/- Mate) (+/- Cinnamon)
Inscription : 09-01-2008

Re : [Résolu] configuration xorg.conf avec pilote nvidia

Salut
Ce post pourra peut-être t'aider. forum.andesi.org
Il est vrai que depuis Xorg 7.3 les question posées par dpkg-reconfigure sont réduite au strict minimum et le xorg.conf à sa plus simple expression.

Il serait bon de trouver comment doit désormais être écrit le nouveau xorg.conf et de faire un tuto a ce sujet car je crois qu'on a pas fini de voir passer des messages.
Je vais voir ce que je trouve, mais je manque de temps pour raison professionnelles et ca va durer plusieurs mois !

Desktop: Jessie (I5 - 16Go)
Laptop 1: Jessie (HP DV9000, 3Go)
Laptop 2: Jessie (PackardBell TS 44, Core I5, 4Go)
EeePC : Jessie (Atom N450, 2 Go)

Hors ligne

#4 23-09-2008 22:32:06

n3os
Modérateur
Lieu : /Debian/Home/neos
Distrib. : Sid
Noyau : 2.6.35
(G)UI : e17
Inscription : 14-07-2007

Re : [Résolu] configuration xorg.conf avec pilote nvidia

Salut,

c'est clair que depuis son passage en version 7.3 il a de quoi se poser des questions,
j'ai enlevé quelques trucs dans mon xorg.conf, histoire de voir,

le minimum pour le clavier en fr, puis avec le driver nvidia.

Section "InputDevice"
      Identifier  "Generic Keyboard"
      Driver            "kbd"
      Option            "CoreKeyboard"
      Option            "XkbRules"  "xorg"
      Option            "XkbModel"  "pc105"
      Option            "XkbLayout" "fr"
      Option            "XkbVariant"      "latin9"
        Option            "XkbOptions"      "lv3:ralt_switch"
EndSection

Section "Device"
      Identifier  "nVidia Corporation NV40 [GeForce 6800 GT]"
      Driver            "nvidia"
EndSection


par contre il arrive qu'il faille rajouter l'id de la carte, lspci le donne
01:00.0 VGA compatible controller: nVidia Corporation NV40 [GeForce 6800 GT] (rev a1)
donc
BusID "PCI:01:00:0" (à rajouter dans la section "Device" si souci ou écran noir.

Pour la résolution d'écran, il faudra jouer avec xrandr un lien fr docs sidux xrandr

Hors ligne

#5 24-09-2008 09:44:59

cmm
Adhérent(e)
Lieu : Meudon
Distrib. : wheezy / jessie
Noyau : 3.2.0-4-amd64 / 3.16.0-4-amd64
(G)UI : gnome classic / mate
Inscription : 23-09-2008
Site Web

Re : [Résolu] configuration xorg.conf avec pilote nvidia

Bonjour,

Merci à tous pour vos réponses et vos suggestions très intéressantes. Je vais suivre vos conseils et j'indiquerai le résultat de mes essais. Je suis un peu occupé aujourd'hui, je pense faire cela pendant le prochain week-end. Ce n'est pas urgent parce qu'en remettant en fonction le xorg.conf d'origine, j'ai un serveur x correct, convenant bien au travail courant, même si ce n'est qu'avec la résolution 1024x780 au lieu de celle que je voudrais, 1280x800. 

Bien cordialement,

C.-M. M

Hors ligne

#6 25-09-2008 16:06:33

cmm
Adhérent(e)
Lieu : Meudon
Distrib. : wheezy / jessie
Noyau : 3.2.0-4-amd64 / 3.16.0-4-amd64
(G)UI : gnome classic / mate
Inscription : 23-09-2008
Site Web

Re : [Résolu] configuration xorg.conf avec pilote nvidia

Bonjour,

Désolé je crois bien avoir envoyé un message de manière intempestive alors que je l'avais à peine commencé. Je recommence.

J'ai fait quelques essais en utilisant vos conseils, je comprends un peu moins mal ce qui se passe, mais je n'ai pas encore résolu mon problème.

J'ai d'abord essayé d'ajouter, comme suggéré par jul, la ligne

Driver  "nvidia"

dans la section "Device" de mon xorg.conf d'origine. Résultat: un écran à la résolution 320x240, comme avec le xorg.conf fabriqué par la commande nvidia-xconfig.

J'ai ensuite essayé de lancer startx avec un fichier xorg.conf minimal comme recommandé par neos, mais avec Driver "nvidia"
dans la section "Device". Résultat: j'obtiens encore un écran à la résolution 320x240.

J'ai lu ce qui concerne xrandr grâce aux liens indiqués par neos, et aussi en faisant man xrandr. J'ai lancé startx avec un xorg.conf utilisant le pilote nvidia, j'ai ouvert un terminal en root sur le serveur graphique (difficile à utiliser, puisque la résolution n'est que 320x240, mais pas impossible), j'ai tapé xrandr et obtenu un résultat montrant que xrandr est présent et fonctionne, donnant la liste des résolutions possibles (parmi lesquelles celle que je voudrais, 1280x800) mais indiquant comme étant en service la résolution 320x240.

J'ai essayé de changer la résolution avec xrandr en mode graphique (toujours sur écran 320x240) en tapant, en root,

xrandr --output DFP-0 --mode 1280x800

(je ne savais pas trop quoi mettre après --output, j'ai trouvé DFP-0 dans le fichier de log /var/log/Xorg.0.log)
mais cela n'a rien changé, l'écran est resté en 320x240.

Au passage, je signale que lorsque je fais xrandr en console cela ne marche pas et lorsque je le fais après avoir lancé startx avec mon fichier xorg d'origine (qui n'utilise pas le pilote nvidia et me donne un écran 1024x768), xrandr indique que la plus haute résolution possible est 1024x768. Cela doit être, je crois, une limitation inhérente au pilote VESA.
 
J'ai visité les messages du forum andesi indiqués par freddec. J'ai vu, sur un de ces derniers messages, qu'on pouvait faire un fichier xorg.conf adapté à son matériel grâce à la commande (en console, le serveur x ne doit pas être en fonction, et en root)

Xorg -configure

Cela a en effet créé dans le home de root un fichier xorg.conf.new qui semble tenir compte de mon matériel, et qui utilise le pilote nvidia. Mais lorsque j'ai voulu le tester par la commande

X -config /root/xorg.conf.new

j'ai obtenu d'abord un bel écran avec le logo nvidia, puis l'écran est devenu gris (pas granuleux, je pense que la résolution est restée assez élevée), et çà s'est bloqué là avec un message disant que nvidia n'arrivait pas à faire marcher la carte graphique.

J'ai édité le fichier xorg.conf.new et j'ai vu qu'il prévoyait deux devices graphiques, deux moniteurs et deux écrans, alos que pour le moment je n'ai que l'écran standard du portable; peut-être que c'est pour prévoir des besoins futurs, ou parce qu'il y a une sortie VGA actuellement non utilisée.Ce fichierl indique, dans les sections Device correspondant aux cartes graphiques, des BusID  "PCI:

       BusID       "PCI:0:18:0"

pour Card0 et

        BusID       "PCI:0:1:3"

pour Card1. Or la commande lspci, dont voici un extrait

00:01.3 Co-processor: nVidia Corporation MCP67 Co-processor (rev a2)
00:02.0 USB Controller: nVidia Corporation MCP67 OHCI USB 1.1 Controller (rev a2)
.
.
.
00:08.0 PCI bridge: nVidia Corporation MCP67 PCI Bridge (rev a2)
00:09.0 IDE interface: nVidia Corporation MCP67 AHCI Controller (rev a2)
00:0a.0 Ethernet controller: nVidia Corporation MCP67 Ethernet (rev a2)
00:0c.0 PCI bridge: nVidia Corporation MCP67 PCI Express Bridge (rev a2)
00:0d.0 PCI bridge: nVidia Corporation MCP67 PCI Express Bridge (rev a2)
00:12.0 VGA compatible controller: nVidia Corporation GeForce 7150M (rev a2)
00:18.0 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] HyperTransport Technology Configuration
00:18.1 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Address Map
00:18.2 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM Controller
00:18.3 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Miscellaneous Control

semble montrer que les adresses de bus PCI 0:18:0 et 0:1:3 ne correspondent pas à la carte graphique, mais plutôt au processeur AMD et à un coprocesseur nvidia. J'ai donc essayé de remplacer

     BusID       "PCI:0:18:0"
     
par

   BusID       "PCI:0:12:0"
dans la section Device de Card0 (je n'ai rien changé à celle de Card1 pour ne pas faire deux modifications d'un coup).

Résultat: la command startx, après avoir correctement affiché le logo de nvidia, me donne un écran qui reste gris (pas granuleux, la résolution semble rester assez élevée).

Si vous avez encore la patience de me lire, tout conseil sera le bienvenu. La situation n'est pas critique ni urgente car j'ai remis un xorg.conf qui n'utilise pas le pilote nvidia et j'ai une résolution 1024x768 acceptable. et j'ai toujours mon vieil armadaE500 en dépannage.

Bien cordialement,

C.-M. M.

Hors ligne

#7 25-09-2008 17:08:22

tux12
Membre
Lieu : ./
Distrib. : Squeeze
Noyau : Linux 2.6.32-5-686-bigmem
(G)UI : KDE
Inscription : 27-02-2008

Re : [Résolu] configuration xorg.conf avec pilote nvidia

Bonjour CMM1934, et bienvenue. smile

Il est toujours possible de modifier un message déjà paru. Lorsque tu es connecté au forum, les messages que tu as écrits ont chacun en bas à droite de leur cadre un lien nommé Modifier sur lequel il suffit de cliquer pour pouvoir reprendre là ou tu en étais. Ça nous arrive à tous ce genre de gag. wink
De la même manière, tu peux supprimer un de tes messages avec le lien Supprimer.

Pour ton Xorg, désolé je n'ai pas trop d'idées. sad

@+

Hors ligne

#8 25-09-2008 20:02:28

cmm
Adhérent(e)
Lieu : Meudon
Distrib. : wheezy / jessie
Noyau : 3.2.0-4-amd64 / 3.16.0-4-amd64
(G)UI : gnome classic / mate
Inscription : 23-09-2008
Site Web

Re : [Résolu] configuration xorg.conf avec pilote nvidia

Merci tux12. J'ai effacé le message inutile.

Ce n'est pas grave si je n'arrive pas à faire marcher ce pilote nvidia, je peux me contenter de ce qui marche.

Bien cordialement,

C.-M. M.

Hors ligne

#9 25-09-2008 21:42:18

tux12
Membre
Lieu : ./
Distrib. : Squeeze
Noyau : Linux 2.6.32-5-686-bigmem
(G)UI : KDE
Inscription : 27-02-2008

Re : [Résolu] configuration xorg.conf avec pilote nvidia

Re,

Dans ton xorg.conf actuel (qui te donnes du 1024x768) vérifie ce que tu as dans la section "Screen", dans les SubSection(s) "Display"; en modes, tu as la mention des résolutions définies. Chez moi par exemple ça donne:

Section "Screen"
        Identifier      "Default Screen"
        Device          "ATI Technologies Inc RV350 AP [Radeon 9600]"
        Monitor         "Écran générique"
        DefaultDepth    24
        SubSection "Display"
                Depth           1
                Modes           "1280x1024" "1152x864" "1024x768" "800x600" "640x480"
        EndSubSection


Pareil pour les autres "SubSection"s.

Si ça peut t'aider...?
@+

Hors ligne

#10 26-09-2008 08:39:39

freddec
homo-informaticus du genre linuxo-debianicum
Lieu : Saint Jean d'Y (17)
Distrib. : Branche Stable (Jessie)
Noyau : Linux 3.16.0-4-amd64
(G)UI : XFCE_4.1 (+/- Mate) (+/- Cinnamon)
Inscription : 09-01-2008

Re : [Résolu] configuration xorg.conf avec pilote nvidia

Je te donne également mon xorg.conf (enfin les partie utiles) il est a base de chipset nvidia 6150LE et tourne avec un module nvidia fabriqué salement (nvidia.sh et non la methode deb)
A force de test tu finiras bien par trouver.


Section "ServerLayout"
    Identifier     "Default Layout"
    Screen         "Default Screen" 0 0
    InputDevice    "Generic Keyboard"
    InputDevice    "Configured Mouse"
EndSection

Section "Files"
EndSection

Section "Module"
    Load           "bitmap"
    Load           "dbe"
    Load           "ddc"
    Load           "extmod"
    Load           "freetype"
    Load           "glx"
    Load           "record"
    Load           "type1"
    Load           "v4l"
    Load           "vbe"
    Load     "dri"
    Load           "GLcore"
EndSection

Section "InputDevice"
blablabla
EndSection

Section "InputDevice"
blablabla
EndSection

Section "Monitor"
    Identifier     "NEC C LC17M"
    HorizSync       50.0 - 90.0
    VertRefresh     50.0 - 160.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "nVidia Corporation C51 [GeForce 6150 LE]"
    Driver         "nvidia"
    Option  "AddARGBGLXVisuals" "true"
    Option  "XAANoOffscreenPixmaps" "true" 
EndSection

Section "Screen"
    Identifier     "Default screen"
    Device         "nVidia Corporation C51 [GeForce 6150 LE]"
    Monitor        "NEC C LC17M"
    DefaultDepth    24
    SubSection     "Display"
        Depth       24
        Modes      "1280x1024" "1024x768" "800x600" "640x480"
    EndSubSection
EndSection

Section "Extensions"
    Option         "Composite" "enable"
EndSection


Desktop: Jessie (I5 - 16Go)
Laptop 1: Jessie (HP DV9000, 3Go)
Laptop 2: Jessie (PackardBell TS 44, Core I5, 4Go)
EeePC : Jessie (Atom N450, 2 Go)

Hors ligne

#11 26-09-2008 18:31:01

cmm
Adhérent(e)
Lieu : Meudon
Distrib. : wheezy / jessie
Noyau : 3.2.0-4-amd64 / 3.16.0-4-amd64
(G)UI : gnome classic / mate
Inscription : 23-09-2008
Site Web

Re : [Résolu] configuration xorg.conf avec pilote nvidia

Bonjour,

Merci à tous pour votre aide! Gâce à vous tous,  mon problème est presque résolu: j'ai enfin la résolution que je voulais, 1280x800. La différence, avec le mode 1024x768 que jusqu'à présent je pouvais avoir au mieux, est très visible! Sans parler, bien sûr, du mode 320x240 qui est pénible à utiliser.

Mon problème n'est pas complètement résolu, parce que, bien que j'aie ajouté dans la section "Screen" les sous-sections "Display" en m'inspirant des conseils donnés, dans les deux derniers messages,  par tux12 et freddec (que je remercie tout particulièrement), lorsque je fais startx, le serveur x me donne toujours un écran 320x240. Mais en ouvrant alors (en mode graphique et en root) un terminal, la commande:

xrandr --output default --mode 1280x800


me fait passer dans le mode désiré. Je n'ai toujours pas compris pourquoi, au démarrage du serveur x, c'est le mode de plus basse résolution qui est choisi. Mais l'essentiel, c'est que maintenant je peux avoir le mode que je veux. Il me reste à trouver comment automatiser, au démarrage du serveur x, le passage au mode 1280x800.

Encore une fois merci à tous, et bien cordialement,

C.-M. M.

Dernière modification par cmm1934@orange.fr (02-10-2008 17:32:43)

Hors ligne

#12 26-09-2008 20:14:03

cmm
Adhérent(e)
Lieu : Meudon
Distrib. : wheezy / jessie
Noyau : 3.2.0-4-amd64 / 3.16.0-4-amd64
(G)UI : gnome classic / mate
Inscription : 23-09-2008
Site Web

Re : [Résolu] configuration xorg.conf avec pilote nvidia

Bonjour,

Cette fois, mon problème est vraiment résolu! Merci à tous! En effet, le réglage de la résolution fait avec xrandr subsiste après redémarrage et subsiste aussi après réinstallation de gdm (pour un loging en mode graphique).

Finalement, je pense que la difficulté que j'ai rencontrée était due tout bêtement à quelque chose de suspect dans le dossier de pr fichier de préférences au démarrage de gmome, .gnome dans mon home. Quelque chose qui était incompatible avec le pilote nvidia, et qui a été rectifié lorsque j'ai modifié la résolution avec xrandr.

Bien cordialement,

C.-M. M

P.S. Comment faire pour marquer [Résolu] dans le titre de la discussion?

Dernière modification par cmm1934@orange.fr (26-09-2008 20:16:14)

Hors ligne

#13 26-09-2008 20:21:26

MaTTuX_
La Paillasse !!!
Lieu : Zoubidou-Land
Distrib. : 75 serveurs
Noyau : 3.2.0-4-amd64
(G)UI : tty et ... pas gnome en tout cas....
Inscription : 28-05-2007
Site Web

Re : [Résolu] configuration xorg.conf avec pilote nvidia

il faut édité ton premier post et marqué  [Résolu] dans le titre.


MaTTuX_

\o/ Le closedSource c'est tabou on a viendra tous à bout \o/

Hors ligne

#14 27-09-2008 09:36:50

cmm
Adhérent(e)
Lieu : Meudon
Distrib. : wheezy / jessie
Noyau : 3.2.0-4-amd64 / 3.16.0-4-amd64
(G)UI : gnome classic / mate
Inscription : 23-09-2008
Site Web

Re : [Résolu] configuration xorg.conf avec pilote nvidia

Merci MatTux, j'aurais dû ypenser. Voilà, c'est fait.

Bien cordialement,

C.-M. M.

Hors ligne

#15 27-09-2008 13:18:55

misaine
Membre
Lieu : sables d'olonne
Distrib. : Antergos (Archlinux)
Noyau : 4.3.3
(G)UI : gnome-shell 3.18.2
Inscription : 29-07-2007

Re : [Résolu] configuration xorg.conf avec pilote nvidia

ahhhhhh yikes mattux m'a tuer tongue

il faut éditer(prendre) ton premier post et marquer(inscrire)  [Résolu] dans le titre.


smile


amd phenom 7650 , 4 Go DDR2 ,GeForce N210

Hors ligne

#16 28-09-2008 04:43:47

MaTTuX_
La Paillasse !!!
Lieu : Zoubidou-Land
Distrib. : 75 serveurs
Noyau : 3.2.0-4-amd64
(G)UI : tty et ... pas gnome en tout cas....
Inscription : 28-05-2007
Site Web

Re : [Résolu] configuration xorg.conf avec pilote nvidia

disons que vous avez trainé tongue

\o/ Le closedSource c'est tabou on a viendra tous à bout \o/

Hors ligne

#17 29-09-2008 08:48:46

freddec
homo-informaticus du genre linuxo-debianicum
Lieu : Saint Jean d'Y (17)
Distrib. : Branche Stable (Jessie)
Noyau : Linux 3.16.0-4-amd64
(G)UI : XFCE_4.1 (+/- Mate) (+/- Cinnamon)
Inscription : 09-01-2008

Re : [Résolu] configuration xorg.conf avec pilote nvidia

Heureux que tout soit rentré dans l'ordre Cmm
2 Chose toute fois
1- Un mail comme identifiant c'est pas recommandé
2- Un dernier post avec un résumé du problème et la façon dont tu l'as résolu serait le bienvenue

Desktop: Jessie (I5 - 16Go)
Laptop 1: Jessie (HP DV9000, 3Go)
Laptop 2: Jessie (PackardBell TS 44, Core I5, 4Go)
EeePC : Jessie (Atom N450, 2 Go)

Hors ligne

#18 29-09-2008 13:48:59

cmm
Adhérent(e)
Lieu : Meudon
Distrib. : wheezy / jessie
Noyau : 3.2.0-4-amd64 / 3.16.0-4-amd64
(G)UI : gnome classic / mate
Inscription : 23-09-2008
Site Web

Re : [Résolu] configuration xorg.conf avec pilote nvidia

Merci freddec. Il est vrai que je suis plutôt confiant par nature. Je vais changer d'identifiant.

Voici le résumé du problème et la façon dont je l'ai résolu. Je précise que c'est grâce à l'aide trouvée auprès de vous tous que j'ai pu trouver cette solution. Avant de lire vos messages je ne savais pas ce que c'est que xrandr, ni comment créer un fichier xorg.conf prenant en compte le matériel.

Mon problème: je venais d'installer Debian Lenny sur mon nouveau portable (compaq presario V6533ef , avecTurion 64x2, nvidia geforce7150M /nforce 630M). Ce n'est pas par gôut du risque que j'ai choisi la version testing plutôt que la version stable. J'ai d'abord essayé d'installer la version stable, mais apparemment le noyau de celle-ci ne contient pas le pilote adéquat pour la connexion ethernet. Avec la version testing, l'installation s'est déroulée sans problème, automatiquement,y compris le serveur x qui d'autorité a choisi comme pilote vesa pour le device graphique. Il semble que celui-ci donne au mieux la résolution 1024x768, alors que sous windows j'ai la résolution 1280x800. La commande lspci indiquant

00:0a.0 Ethernet controller: nVidia Corporation MCP67 Ethernet (rev a2)
00:0c.0 PCI bridge: nVidia Corporation MCP67 PCI Express Bridge (rev a2)
00:0d.0 PCI bridge: nVidia Corporation MCP67 PCI Express Bridge (rev a2)
00:12.0 VGA compatible controller: nVidia Corporation GeForce 7150M (rev a2)


j'ai voulu installer le pilote graphique nvidia qui, en plus d'une résolution plus élevée, autorise l'accélération matérielle (j'en parle sans savoir exactement ce que c'est). Pour faire cette installation, j'ai trouvé la page

http://www.commentcamarche.net/faq/suje … ers-nvidia

qui indique très clairement plusieurs méthodes permettant d'installer ce pilote. J'ai choisi celle qui m'a semblé la plus simple, utilisant module-assistant. Attention: cette méthode ne marche que si on a correctement modifié le fichier /etc/apt/sources.list, car elle utilise certains fichiers qui ne se trouvent que dans la distribution instable. Voici le fichier /etc/apt/sources.list que j'ai utilisé:

deb http://ftp.fr.debian.org/debian/ lenny main contrib non-free
deb-src http://ftp.fr.debian.org/debian/ lenny main contrib non-free

deb http://security.debian.org/ lenny/updates main contrib non-free
deb-src http://security.debian.org/ lenny/updates main contrib non-free

deb http://www.debian-multimedia.org lenny main contrib non-free
deb-src http://www.debian-multimedia.org lenny main contrib non-free

## Dépôts Sid
# priorités spécifiées dans /etc/apt/preferences
deb http://ftp.fr.debian.org/debian/ sid main contrib non-free
deb-src http://ftp.fr.debian.org/debian/ sid main contrib non-free


Il faut aussi créer un fichier /etc/apt/preferences pour dire qu'on ne prend les paquets sid que si on ne trouve pas son bonheur dans les paquets lenny. Voici le fichier /etc/apt/preferences que j'ai créé:

Package: *
Pin: release o=Debian,a=testing
Pin-priority: 990

Package: *
Pin: release o=Debian,a=unstable
Pin-priority: 90


Ensuite on fait

aptitude update
aptitude safe-upgrade
aptitude install nvidia-kernel-common module-assistant


puis, pour installer le module

module-assistant auto-install nvidia


Comme j'avais déjà un fichier /etx/X11/xorg.conf qui avait été automatiquement créé lors de l'installation,
j'ai dû modifier ce fichier. J'ai d'abord essayé de le modifier le moins possible, en ajoutant simplement la ligne

Driver "nvidia"


dans la section "Device" (à l'origine, il n'y avait qaucune ligne Driver dans cette section, le pilote qui prenait en charge le graphisme était le pilote par défaut vesa).

Résultat, lorsque j'ai lancé le serveur graphique par startx, j'ai d'abord vu apparaître le logo nvidia, à une résolution correcte, puis le bureau gnome s'est affiché, mais à une résolution 320x240. Difficile à employer: une bonne partie des menus reste inaccessible, en dehors de limites de l'écran. On peut, cependant, ouvrir un terminal en mode graphique.

Je passe sur tous les essais infructueux que j'ai faits, et j'en arrive à ce qui a marché: dans un terminal en mode graphique (à la calamiteuse résolution 320x240), j'ai tapé

xrandr --output default --mode 1280x800


et la résolution s'est mise à 1280x800. Ce réglage a subsisté après redémarrage et après réinstallation de gdm (que j'avais enlevé pour que le démarreage n'ait pas lieu d'emblé en mode graphique. Il subsiste toujours, touchons du bois!

Un dernier mot sur les essais infructueux, qui m'ont cependant appris plusieurs choses:

-- ajouter des lignes de "Subsection Display" dans la section "Screen" de xorg.conf ou des lignes "Modes" ou Modeline dans la section "Monitort" n'a pas arrangé le problème: startx aboutissait toujours à une résolution 320x240. Je pense maintenant que la nouvelle version de xserver-xorg n'utilise en général pas ces lignes.

-- la commande

nvidia-xconfig


crée un nouveau fichier xorg.conf, mais contrairement à ce que j'ai lu quelque part, ce nouveau fichier ne retient aucun des éléments de l'ancien xorg.conf. Si on a peaufiné celui-ci pour avour un clavier français ou un touchpad comme on préfère, il faut recommencer avec le nouvel xorg.conf. En plus, avec ce nouvel xorg.conf, startx aboutissait encore à une résolution 320x240.

-- la commande (en root, dans le home de root)

Xorg -configure


crée dans le home de root un fichier xorg.conf.new qui tient compte du matériel qu'on a, et qu'on peut ernsuite tester avec la commande

X -config /root/xorg.conf.new


Dans mon cas, cela a conduit, après l'affichage du logo nvidia, à un écran gris, sans bureau, inutilisable.

Je pense (sans en être sûr) que tous ces échecs étaient causés par quelque chose de mauvais dans les fichiers de configuration de gnome, qui avaient été créés automatiquement pour le pilote vesa et qui ne fonctionnaient pas bien avec le pilote nvidia.

Si quelqu'un rencontre les mêmes difficultés que moi, je lui conseille,  après l'installation du pilote nvidia, de lance startx en tant que nouvel utilisateur n'ayant pas déjà utilisé un environnement de bureau avec le pilote vesa. Ou encore de supprimer et purger,  puis réinstaller, gnome ou kde ou xfce, avant de faire startx.

Dans l'espoir que ce compte-rendu rendra service,

Bien cordialement,

C.-M. M

Dernière modification par cmm1934@orange.fr (02-10-2008 17:38:02)

Hors ligne

#19 29-09-2008 16:41:21

freddec
homo-informaticus du genre linuxo-debianicum
Lieu : Saint Jean d'Y (17)
Distrib. : Branche Stable (Jessie)
Noyau : Linux 3.16.0-4-amd64
(G)UI : XFCE_4.1 (+/- Mate) (+/- Cinnamon)
Inscription : 09-01-2008

Re : [Résolu] configuration xorg.conf avec pilote nvidia

Voila qui est bien résumé
Merci wink

Desktop: Jessie (I5 - 16Go)
Laptop 1: Jessie (HP DV9000, 3Go)
Laptop 2: Jessie (PackardBell TS 44, Core I5, 4Go)
EeePC : Jessie (Atom N450, 2 Go)

Hors ligne

#20 29-09-2008 19:38:06

misaine
Membre
Lieu : sables d'olonne
Distrib. : Antergos (Archlinux)
Noyau : 4.3.3
(G)UI : gnome-shell 3.18.2
Inscription : 29-07-2007

Re : [Résolu] configuration xorg.conf avec pilote nvidia

et bien voilà un très bon tuto pour nvidia sur lenny! merci wink

amd phenom 7650 , 4 Go DDR2 ,GeForce N210

Hors ligne

#21 06-10-2008 23:16:01

Melodie
Modérateur
Lieu : Pyrénées
Inscription : 28-05-2007
Site Web

Re : [Résolu] configuration xorg.conf avec pilote nvidia

Bonjour,

Il te manque de régler avec nvidia-settings. Tu le lances avec gksu ou ktsuss, ou kdesu (pour gnome, ou pour autre, ou pour kde, respectivement, et c'est pas installé, donc installes-en un). Puis tu fais en user:

(par exemple)

gksu nvidia-settings

alors une petite fenêtre s'ouvre, pour root, et tu mets le mot de passe root. (C'est un protocole pour lancer les applis graphiques en root). Et là, plus qu'à configurer correctement, sauvegarder, et fermer.

le blog d'une newbie :: Linuxvillage :: Bentovillage


À propos de l'OS dominant ::> “Il est plus facile de berner les gens que de leur faire admettre qu'ils ont été bernés” (trad d'une citation approximative de Mark Twain)

Hors ligne

#22 07-10-2008 07:47:19

cmm
Adhérent(e)
Lieu : Meudon
Distrib. : wheezy / jessie
Noyau : 3.2.0-4-amd64 / 3.16.0-4-amd64
(G)UI : gnome classic / mate
Inscription : 23-09-2008
Site Web

Re : [Résolu] configuration xorg.conf avec pilote nvidia

Merci Mélodie! Je vais essayer. J'en apprends tous les jours. J'ai déjà constaté qu'avec mon nouvel ordinateur je pouvais utiliser Google Earth, qui fonctionne à une vitesse correcte alors que sur l'ancien Google Earth étairt d'une lenteur désespérante.

Bien cordialement,

C.-M. M.

Hors ligne

Pied de page des forums