Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 24-11-2013 12:20:11

Neorian
Membre
Distrib. : Debian x86_64 GNU/Linux (sid)
Noyau : Linux 3.13-1-amd64
(G)UI : Xfce, Openbox
Inscription : 29-07-2012

[Résolu] Problème avec nm-applet

Bonjour,
je suis sous debian sid avec openbox depuis un bon et je n'ai jamais eu de problème à part maintenant,
suite à une mise a jour, j'ai un problème avec nm-applet.


lorsque je ne peux pas créé de connexion wifi et lorsque j'essaie j'obtiens le message  :

Connection Failure
Failed to add/activate connection
(32) No session found for uid 1000 (No session found for uid 1000)



j'avais cherché sur le net et trouvé ces 2 liens :
http://forums.debian.net/viewtopic.php?t=85421
https://bbs.archlinux.org/viewtopic.php?id=146190
mais aucun ne marche.

lorsque je fais loginctl , j'ai ce résultat :

   SESSION        UID USER             SEAT
        c1        117 lightdm          seat0
         1       1000 adrian           seat0

2 sessions listed




Quand je lance nm-applet depuis un terminal

** (nm-applet:30294): WARNING **: Couldn't register with accessibility bus: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.

** (nm-applet:30294): WARNING **: Could not create object for /org/freedesktop/NetworkManager/Settings/3: No session found for uid 1000 (No session found for uid 1000)

** (nm-applet:30294): WARNING **: Could not create object for /org/freedesktop/NetworkManager/Settings/17: No session found for uid 1000 (No session found for uid 1000)

** (nm-applet:30294): WARNING **: Could not create object for /org/freedesktop/NetworkManager/Settings/2: No session found for uid 1000 (No session found for uid 1000)

** (nm-applet:30294): WARNING **: Could not create object for /org/freedesktop/NetworkManager/Settings/12: No session found for uid 1000 (No session found for uid 1000)

** (nm-applet:30294): WARNING **: handle_property_changed: failed to update property 'available-connections' of object type NMDeviceWifi.
** Message: applet now removed from the notification area
** Message: applet now embedded in the notification area

** (nm-applet:30294): WARNING **: Failed to register as an agent: (32) No session found for uid 1000



Que puis-je faire ?

merci d'avance

Dernière modification par Neorian (24-11-2013 21:19:44)

Hors ligne

#2 24-11-2013 12:55:44

Lunatic
Membre
Lieu : Lyon
Distrib. : Fedora 24
Noyau : Linux 4.6.5-300.fc24.x86_64
(G)UI : Gnome
Inscription : 03-08-2013
Site Web

Re : [Résolu] Problème avec nm-applet

Bonjour,

Ton utilisateur appartient bien au groupe netdev ?

Je suis aussi sur Twitter et nouvellement sur Diaspora*
Mon blog de geekeries : HAL-9000

(J'applique la règle de proximité)

Hors ligne

#3 24-11-2013 13:08:48

Neorian
Membre
Distrib. : Debian x86_64 GNU/Linux (sid)
Noyau : Linux 3.13-1-amd64
(G)UI : Xfce, Openbox
Inscription : 29-07-2012

Re : [Résolu] Problème avec nm-applet

oui je fais bien parti du groupe netdev

Hors ligne

#4 24-11-2013 13:15:05

captnfab
Admin-Girafe
Lieu : /dev/random
Distrib. : Debian Stretch/Sid/Rc-Buggy
Noyau : Linux (≥ 4.3)
(G)UI : i3-wm (≥ 4.11)
Inscription : 07-07-2008
Site Web

Re : [Résolu] Problème avec nm-applet

Salut,

Comment cela se fait-il que dbus ne soit pas lancé ? Tu l'as désinstallé ?

captnfab,
Association Debian-Facile, bépo.
TheDoctor: Your wish is my command… But be careful what you wish for.

Hors ligne

#5 24-11-2013 13:20:59

Neorian
Membre
Distrib. : Debian x86_64 GNU/Linux (sid)
Noyau : Linux 3.13-1-amd64
(G)UI : Xfce, Openbox
Inscription : 29-07-2012

Re : [Résolu] Problème avec nm-applet

Euhh non , j'ai pas à toucher à dbus. (en tout cas, si j'y ai touché c'était pas volontairement)

En plus il est lancé ,car quand je fais

 sudo /etc/init.d/dbus status
[ ok ] dbus is running

Hors ligne

#6 24-11-2013 14:24:18

captnfab
Admin-Girafe
Lieu : /dev/random
Distrib. : Debian Stretch/Sid/Rc-Buggy
Noyau : Linux (≥ 4.3)
(G)UI : i3-wm (≥ 4.11)
Inscription : 07-07-2008
Site Web

Re : [Résolu] Problème avec nm-applet

Normalement, une session dbus utilisateur est lancée automatiquement lors du démarrage de ta session graphique par le fichier /etc/X11/Xsession.d/75dbus_dbus-launch fournit par le paquet dbus-x11

Ce paquet est-il bien installé chez toi ?

captnfab,
Association Debian-Facile, bépo.
TheDoctor: Your wish is my command… But be careful what you wish for.

Hors ligne

#7 24-11-2013 15:03:00

Neorian
Membre
Distrib. : Debian x86_64 GNU/Linux (sid)
Noyau : Linux 3.13-1-amd64
(G)UI : Xfce, Openbox
Inscription : 29-07-2012

Re : [Résolu] Problème avec nm-applet

oui dbus-x11 est bien installé.

le contenu de /etc/X11/Xsession.d/75dbus_dbus-launch  est :

# $Id:$
# In order to activate the session bus at X session launch
# simply place use-session-dbus into your /etc/X11/Xsession.options file
#

STARTDBUS=
DBUSLAUNCH=/usr/bin/dbus-launch

if has_option use-session-dbus; then
  if [ -x "$DBUSLAUNCH" ]; then
    STARTDBUS=yes
  fi
fi

if [ -n "$STARTDBUS" ]; then
  STARTUP="$DBUSLAUNCH --exit-with-session $STARTUP"
fi
 

Hors ligne

#8 24-11-2013 17:02:11

captnfab
Admin-Girafe
Lieu : /dev/random
Distrib. : Debian Stretch/Sid/Rc-Buggy
Noyau : Linux (≥ 4.3)
(G)UI : i3-wm (≥ 4.11)
Inscription : 07-07-2008
Site Web

Re : [Résolu] Problème avec nm-applet

Ok, et comment lances-tu ton serveur X ? Et comment lances-tu openbox ?

captnfab,
Association Debian-Facile, bépo.
TheDoctor: Your wish is my command… But be careful what you wish for.

Hors ligne

#9 24-11-2013 18:26:12

Neorian
Membre
Distrib. : Debian x86_64 GNU/Linux (sid)
Noyau : Linux 3.13-1-amd64
(G)UI : Xfce, Openbox
Inscription : 29-07-2012

Re : [Résolu] Problème avec nm-applet

J'étais avec lightdm

J'ai testé avec slim et ça marche sans problème.
je pense que je vais rester avec slim.


Merci pour toutes vos réponses

Hors ligne

#10 24-11-2013 21:05:50

deuchdeb
Moderato ma non troppo
Lieu : Pays de Cocagne
Distrib. : Jessie 8 + backports
Noyau : linux-image-3.16
(G)UI : KDE4.14 - Mate
Inscription : 13-01-2010

Re : [Résolu] Problème avec nm-applet

Donc on peut mettre résolu alors?

Il faudrait l'indiquer dans le titre de ton 1er poste.


Merci smile

Hors ligne

Pied de page des forums