Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 05-12-2013 15:57:01

luxer
Membre
Distrib. : jessie/testing/sid--siduction
Noyau : 3.12-x-686-pae GCC4.8 (i686-linux-gnu)
(G)UI : xfce-4.10.0-5
Inscription : 12-02-2010

résolu bash ne fonctionnant pas

salut un ami a moi m'a donné ce scripte disant teste le tu verras c'est sympa alors voila je l'ai téléchargé mais là rien ne se passe mis a part ce petit message d'erreur de la console
(/bin/bash^M : mauvais interpréteur: Aucun fichier ou dossier de ce type)

voici donc ce fameux scripte http://paste.debian-facile.org//view/c497fbb0

si quelqu'un avait une solution ou une idée merci d'avance !

Dernière modification par luxer (07-12-2013 10:11:51)


Si Beethoven vivait encore il utiliserait lmms sur Debian

Hors ligne

#2 05-12-2013 18:09:37

Melodie
Modérateur
Lieu : Pyrénées
Inscription : 28-05-2007
Site Web

Re : résolu bash ne fonctionnant pas

Ton script est exécutable ? (chmod a+x). Si oui, essaie d'ajouter un espace entre '#! ' et '/bin/bash'

Vérifie l'encodage aussi.

le blog d'une newbie :: Linuxvillage :: Bentovillage


À propos de l'OS dominant ::> “Il est plus facile de berner les gens que de leur faire admettre qu'ils ont été bernés” (trad d'une citation approximative de Mark Twain)

Hors ligne

#3 06-12-2013 00:28:27

Dohri
Membre
Lieu : /home/dohri/canapé
Distrib. : Sid
Noyau : 3.10.1 amd64
Inscription : 19-12-2010
Site Web

Re : résolu bash ne fonctionnant pas

Chez moi le script marche....

le ^M est un caractère parasite  (qui correspond en fait à un retour à la ligne si mon cerveau n'est pas trop endormi ^^) , tu ouvres ton script et tu te mets à la fin de la première ligne pour le supprimer ça devrait aller.
s'il y en a d'autres tu dois pouvoir les enlever avec un truc du genre :% s/^M/\r/g dans vim

Dernière modification par Dohri (06-12-2013 00:34:03)


Asus Zenbook ux32vd > Sid   |   eeepc 1215 > Sid + gnome  |   eeepc 1015 > Squeeze + gnome   |   sony vaio > Squeeze CLI   |   serveur home made > debian squeeze CLI

Hors ligne

#4 07-12-2013 10:12:43

luxer
Membre
Distrib. : jessie/testing/sid--siduction
Noyau : 3.12-x-686-pae GCC4.8 (i686-linux-gnu)
(G)UI : xfce-4.10.0-5
Inscription : 12-02-2010

Re : résolu bash ne fonctionnant pas

si j'oublie d'installer les buid-essential c'est sur que mon script peut pas fonctionner  mea culpa


merci a tous !

Si Beethoven vivait encore il utiliserait lmms sur Debian

Hors ligne

Pied de page des forums