Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#76 21-12-2013 23:01:13

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : DVD6clone : lit, copie et ripe vos DVD. (Version en test)

Il faut agir pièce par pièce, c'est ce à quoi invite le matelot puisque vous proposez un soft pour tous.
Installer l'ensemble des paquets multimedia par simplicité, c'est une autre démarche.

"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

En ligne

#77 21-12-2013 23:05:17

golgot200
Membre
Lieu : AIN
Distrib. : Debian Jessie
Noyau : Linux debian 3.16.0-4-amd64
(G)UI : MATE
Inscription : 05-08-2007

Re : DVD6clone : lit, copie et ripe vos DVD. (Version en test)

Bien bien bien ....................... vite un clonezilla  et je reviens te dire si j'ai tout compris  roll

L'ultime question ... l'intelligence a besoin de la bêtise pour s'affirmer, la beauté a besoin de la laideur pour resplendir, le courage nait dans la peur, les forts impressionnent au millieu des faibles, mais au final,... qui a donc besoin d'autant de connards ?

Hors ligne

#78 21-12-2013 23:24:09

golgot200
Membre
Lieu : AIN
Distrib. : Debian Jessie
Noyau : Linux debian 3.16.0-4-amd64
(G)UI : MATE
Inscription : 05-08-2007

Re : DVD6clone : lit, copie et ripe vos DVD. (Version en test)

C'est trop compliqué pour mon petit cerveau:


patrick@debian:~$ su
Mot de passe :
root@debian:/home/patrick# nano /etc/apt/sources.list
root@debian:/home/patrick# apt-get update
Réception de : 1 http://www.deb-multimedia.org wheezy Release.gpg [198 B]
Réception de : 2 http://www.deb-multimedia.org wheezy Release [25,9 kB]        
Atteint http://ftp.fr.debian.org wheezy Release.gpg                            
Atteint http://security.debian.org wheezy/updates Release.gpg                  
Ign http://www.deb-multimedia.org wheezy Release              
Réception de : 3 http://ftp.fr.debian.org wheezy-updates Release.gpg [836 B]
Réception de : 4 http://www.deb-multimedia.org wheezy/main amd64 Packages [107 kB]
Atteint http://security.debian.org wheezy/updates Release                      
Atteint http://ftp.fr.debian.org wheezy Release                                
Atteint http://security.debian.org wheezy/updates/main Sources                
Réception de : 5 http://ftp.fr.debian.org wheezy-updates Release [124 kB]      
Atteint http://security.debian.org wheezy/updates/contrib Sources              
Atteint http://security.debian.org wheezy/updates/non-free Sources            
Réception de : 6 http://www.deb-multimedia.org wheezy/non-free amd64 Packages [2 657 B]
Atteint http://security.debian.org wheezy/updates/main amd64 Packages          
Atteint http://security.debian.org wheezy/updates/contrib amd64 Packages
Atteint http://security.debian.org wheezy/updates/non-free amd64 Packages
Atteint http://ftp.fr.debian.org wheezy/main Sources
Atteint http://ftp.fr.debian.org wheezy/contrib Sources
Atteint http://ftp.fr.debian.org wheezy/non-free Sources
Atteint http://ftp.fr.debian.org wheezy/main amd64 Packages
Atteint http://ftp.fr.debian.org wheezy/contrib amd64 Packages
Atteint http://ftp.fr.debian.org wheezy/non-free amd64 Packages
Réception de : 7 http://ftp.fr.debian.org wheezy-updates/main Sources [2 981 B]
Réception de : 8 http://ftp.fr.debian.org wheezy-updates/contrib Sources [14 B]
Réception de : 9 http://ftp.fr.debian.org wheezy-updates/non-free Sources [14 B]
Atteint http://ftp.fr.debian.org wheezy-updates/main amd64 Packages/DiffIndex
Réception de : 10 http://ftp.fr.debian.org wheezy-updates/contrib amd64 Packages [14 B]
Réception de : 11 http://ftp.fr.debian.org wheezy-updates/non-free amd64 Packages [14 B]
263 ko réceptionnés en 1s (147 ko/s)                
Lecture des listes de paquets... Fait
W: Erreur de GPG : http://www.deb-multimedia.org wheezy Release : Les signatures suivantes n'ont pas pu être vérifiées car la clé publique n'est pas disponible : NO_PUBKEY 07DC563D1F41B907
root@debian:/home/patrick#  apt-get install --no-install-recommends --allow-unauthenticated zenity gawk dvdbackup vamps gstreamer0.10-plugins-ugly tesseract-ocr transfig tesseract-ocr-equ ocrad tesseract-ocr-osd gpac gocr tesseract-ocr-deu tesseract-ocr-ita tesseract-ocr-nld tesseract-ocr-por tesseract-ocr-spa tesseract-ocr-vie oggz-tools vpx-tools
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'information suivante devrait vous aider à résoudre la situation :

Les paquets suivants contiennent des dépendances non satisfaites :
 gpac : Dépend: gpac-modules-base (= 1:0.5.0-dmo3) mais ne sera pas installé
E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».
root@debian:/home/patrick#  apt-get install --no-install-recommends --allow-unauthenticated zenity gawk dvdbackup vamps gstreamer0.10-plugins-ugly tesseract-ocr transfig tesseract-ocr-equ ocrad tesseract-ocr-osd gpac gocr tesseract-ocr-deu tesseract-ocr-ita tesseract-ocr-nld tesseract-ocr-por tesseract-ocr-spa tesseract-ocr-vie oggz-tools vpx-tools gpac-modules-base
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'information suivante devrait vous aider à résoudre la situation :

Les paquets suivants contiennent des dépendances non satisfaites :
 gpac-modules-base : Dépend: libavformat54 (>= 7:0.11.1) mais ne sera pas installé
E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».
root@debian:/home/patrick#  apt-get install --no-install-recommends --allow-unauthenticated zenity gawk dvdbackup vamps gstreamer0.10-plugins-ugly tesseract-ocr transfig tesseract-ocr-equ ocrad tesseract-ocr-osd gpac gocr tesseract-ocr-deu tesseract-ocr-ita tesseract-ocr-nld tesseract-ocr-por tesseract-ocr-spa tesseract-ocr-vie oggz-tools vpx-tools gpac-modules-base libavformat54
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  audacity-data libquicktime2 libtiff-tools libtiff5 transcode-doc
Veuillez utiliser « apt-get autoremove » pour les supprimer.
Les paquets supplémentaires suivants seront installés :
  gstreamer0.10-ffmpeg libaacplus2 libavcodec-dev libavcodec53 libavcodec54
  libavformat-dev libavutil-dev libavutil51 libbs2b0 libcrystalhd3
  libdc1394-22-dev libdirac-decoder0 libdirac-dev libfaac-dev libfaad-dev
  libfdk-aac0 libgpac2 libgsm1-dev liblept3 libmp3lame-dev libmp3lame0
  liboggz2 libopencore-amrnb-dev libopencore-amrwb-dev liborc-0.4-dev
  libraw1394-dev libschroedinger-dev libsidplay1 libsigsegv2 libswscale-dev
  libswscale2 libtesseract3 libwebp2 libx264-124 libx264-132 libx264-dev
  libxvidcore-dev libxvidcore4 mplayer2 zenity-common
Paquets suggérés :
  gawk-doc firmware-crystalhd liborc-0.4-doc libraw1394-doc sidplay-base
  xsidplay xfig
Paquets recommandés :
  libraw1394-tools
Les paquets suivants seront ENLEVÉS :
  audacity ffmpeg gimp gimp-gmic gimp-plugin-registry libav-tools
  libavdevice53 libavfilter2 libavformat53 libgegl-0.2-0 mencoder mplayer
  transcode
Les NOUVEAUX paquets suivants seront installés :
  dvdbackup gawk gocr gpac gpac-modules-base gstreamer0.10-plugins-ugly
  libaacplus2 libavcodec54 libavformat54 libbs2b0 libcrystalhd3
  libdc1394-22-dev libdirac-decoder0 libdirac-dev libfaac-dev libfaad-dev
  libfdk-aac0 libgpac2 libgsm1-dev liblept3 liboggz2 libopencore-amrnb-dev
  libopencore-amrwb-dev liborc-0.4-dev libraw1394-dev libschroedinger-dev
  libsidplay1 libsigsegv2 libtesseract3 libwebp2 libx264-124 libx264-132
  libx264-dev libxvidcore-dev mplayer2 ocrad oggz-tools tesseract-ocr
  tesseract-ocr-deu tesseract-ocr-equ tesseract-ocr-ita tesseract-ocr-nld
  tesseract-ocr-osd tesseract-ocr-por tesseract-ocr-spa tesseract-ocr-vie
  transfig vamps vpx-tools zenity zenity-common
Les paquets suivants seront mis à jour :
  gstreamer0.10-ffmpeg libavcodec-dev libavcodec53 libavformat-dev
  libavutil-dev libavutil51 libmp3lame-dev libmp3lame0 libswscale-dev
  libswscale2 libxvidcore4
11 mis à jour, 51 nouvellement installés, 13 à enlever et 14 non mis à jour.
Il est nécessaire de prendre 51,2 Mo/52,2 Mo dans les archives.
Après cette opération, 89,1 Mo d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer [O/n] ?

 



En ajoutant gpac-modules-base
Puis en ajoutant libavformat54
Mais ça me supprime d'autres paquets hmm


Les paquets suivants seront ENLEVÉS :
  audacity ffmpeg gimp gimp-gmic gimp-plugin-registry libav-tools
  libavdevice53 libavfilter2 libavformat53 libgegl-0.2-0 mencoder mplayer
  transcode
 

Dernière modification par golgot200 (21-12-2013 23:27:21)


L'ultime question ... l'intelligence a besoin de la bêtise pour s'affirmer, la beauté a besoin de la laideur pour resplendir, le courage nait dans la peur, les forts impressionnent au millieu des faibles, mais au final,... qui a donc besoin d'autant de connards ?

Hors ligne

#79 21-12-2013 23:34:41

golgot200
Membre
Lieu : AIN
Distrib. : Debian Jessie
Noyau : Linux debian 3.16.0-4-amd64
(G)UI : MATE
Inscription : 05-08-2007

Re : DVD6clone : lit, copie et ripe vos DVD. (Version en test)

De dioux, ça y est j'ai pigé !!!


captnfab a écrit :


retirer (commenter) les dépôts multimedia



J'ai lu retirer le # !!! big_smile

Dernière modification par golgot200 (22-12-2013 00:35:06)


L'ultime question ... l'intelligence a besoin de la bêtise pour s'affirmer, la beauté a besoin de la laideur pour resplendir, le courage nait dans la peur, les forts impressionnent au millieu des faibles, mais au final,... qui a donc besoin d'autant de connards ?

Hors ligne

#80 22-12-2013 02:02:39

golgot200
Membre
Lieu : AIN
Distrib. : Debian Jessie
Noyau : Linux debian 3.16.0-4-amd64
(G)UI : MATE
Inscription : 05-08-2007

Re : DVD6clone : lit, copie et ripe vos DVD. (Version en test)

@Slyfox

Post 69

C'est la méthode wink

Mais pour mon compte personnel je resterai comme j'ai mis au post 68. Je ne veux pas utiliser le deb-multimedia. Des mises à jour sur d'autres paquets qui n'ont rien à voir avec ce sujet ne me plaise pas. Style dans le terminal "un bug de gravité, voulez vous tout de même installer le paquet ..."
Donc pour toi, aucun problème comme dit de faire captnfab, c'est la méthode. wink
J'ai suivi son conseil pour les 9 paquets que j'avais mis à la mano du dépot deb-multimedia en passant directement par celui-ci pour les mises à jour futur.
Ce sujet m'a permis de connaitre et d'installer le paquet pour voir les bugs. Une parenthèse, on a eu une mise à jour de gimp, il n'y a pas si longtemps, je l'ai viré par besoin et réinstallé: bizarrement il a un bug de gravité smile

Voilà.
wink

Dernière modification par golgot200 (22-12-2013 02:04:29)


L'ultime question ... l'intelligence a besoin de la bêtise pour s'affirmer, la beauté a besoin de la laideur pour resplendir, le courage nait dans la peur, les forts impressionnent au millieu des faibles, mais au final,... qui a donc besoin d'autant de connards ?

Hors ligne

#81 27-12-2013 20:35:54

Slyfox
Membre
Lieu : Pays du chocolat
Distrib. : GNU/Linux Debian Sid
Noyau : Linux 4.7.0-1-amd64
(G)UI : MATE
Inscription : 15-12-2013

Re : DVD6clone : lit, copie et ripe vos DVD. (Version en test)

@ golgot

Maintenant j'ai compris pourquoi tu installes les paquets à la main... smile

Mais les dépendances nécessaire au soft doivent être installé automatiquement lors de l'installation du soft.
Je vois mal un ""noob"" commencer à installer les paquets manquants... sad

De plus tous les paquets nécessaire sont cités dans le fichier control du paquet DEB de DVD6clone.
Si on commence a devoir installer des paquets à côté je crains un problème en cas de d'installation de DVD6clone... ça risque de ne pas être très propre. hmm

A+ Sly

Hors ligne

#82 23-03-2014 16:17:24

Slyfox
Membre
Lieu : Pays du chocolat
Distrib. : GNU/Linux Debian Sid
Noyau : Linux 4.7.0-1-amd64
(G)UI : MATE
Inscription : 15-12-2013

Re : DVD6clone : lit, copie et ripe vos DVD. (Version en test)

Quelle nouvelles fraîches :

J'ai réécris le programme, corrigé certaine erreurs, ajouté des fonctions comme la conversion en X264, seul le problème de la conversion en STR pose encore problème mais sera corrigé prochainement.

Pour faire le test de ce programme y suffit d'installer le paquet dvd6clone-test.
Ce paquet permet de tester le programme avant la publication de la version "stable" (paquet dvd6clone)

apt-get install dvd6clone-test



smile Slyfox

Hors ligne

#83 06-04-2014 10:23:20

Slyfox
Membre
Lieu : Pays du chocolat
Distrib. : GNU/Linux Debian Sid
Noyau : Linux 4.7.0-1-amd64
(G)UI : MATE
Inscription : 15-12-2013

Re : DVD6clone : lit, copie et ripe vos DVD. (Version en test)

Petite new sur la correction des bugs.

Je viens de publier la version 20140406-1 avec la correction de la reconnaissance des sous-titres en STR.

Pour ceux qui ont déjà installé mon programme il suffit de faire une mise à jour. cool

smile Slyfox

Dernière modification par Slyfox (06-04-2014 10:30:08)

Hors ligne

#84 01-05-2014 23:31:43

Slyfox
Membre
Lieu : Pays du chocolat
Distrib. : GNU/Linux Debian Sid
Noyau : Linux 4.7.0-1-amd64
(G)UI : MATE
Inscription : 15-12-2013

Re : DVD6clone : lit, copie et ripe vos DVD. (Version en test)

Pour info un wiki a été créé ici : https://debian-facile.org/doc:media:dvd6clone

smile Slyfox

Dernière modification par Slyfox (01-09-2014 19:31:55)

Hors ligne

#85 01-09-2014 19:27:39

Slyfox
Membre
Lieu : Pays du chocolat
Distrib. : GNU/Linux Debian Sid
Noyau : Linux 4.7.0-1-amd64
(G)UI : MATE
Inscription : 15-12-2013

Re : DVD6clone : lit, copie et ripe vos DVD. (Version en test)

Bonjour les amis

Pour info pour lire les info des DVD j'utilise lsdvd.
Or il semble que sur certains DVD, lsdvd donne pas vraiment toutes les bonnes info en particulier les numéros de pistes audio et de sous-titrage.
Je suis en train de regarder pour corriger ce problème en le remplaçant par Mplayer, du coup je vais devoir réécris une grande partie du programme.
Mais au final il sera qu'amélioré.

J'ai aussi ajouté un avertissement dans le wiki pour éviter de mauvaise surprise.

Je vous tiens informé !

Amicalement Slyfox

Dernière modification par Slyfox (01-09-2014 19:34:07)

Hors ligne

#86 28-03-2015 15:08:36

Slyfox
Membre
Lieu : Pays du chocolat
Distrib. : GNU/Linux Debian Sid
Noyau : Linux 4.7.0-1-amd64
(G)UI : MATE
Inscription : 15-12-2013

Re : DVD6clone : lit, copie et ripe vos DVD. (Version en test)

Pour info, j'ai décidé d'arrêter momentanément le développement de DVD6clone

Merci de votre compréhension.

Dernière modification par Slyfox (11-04-2015 08:10:08)

Hors ligne

#87 11-04-2015 08:10:57

Slyfox
Membre
Lieu : Pays du chocolat
Distrib. : GNU/Linux Debian Sid
Noyau : Linux 4.7.0-1-amd64
(G)UI : MATE
Inscription : 15-12-2013

Re : DVD6clone : lit, copie et ripe vos DVD. (Version en test)

Bonjour,

Concernant le poste précédent.
Suite à quels problèmes que connaît DVD6clone, je l'ai retiré des dépôts Launchpad. Donc il ne peut plus être télécharger pour le moment.
Je recherche un autre moyen de l’héberger comme par exemple le mettre directement dans les dépôts de Debian ce qui apparemment devrai me facilité la vie (?)

Autre info, actuellement ce programme et écrit en Bash, je pense le réécrire prochainement en Python3, mais avant je dois apprendre ce langage.

Vous aurez compris qu'il encore du travail !

Merci de votre compréhension et de votre patience.

Dernière modification par Slyfox (11-04-2015 08:12:55)

Hors ligne

#88 11-04-2015 08:34:52

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : DVD6clone : lit, copie et ripe vos DVD. (Version en test)

smile

"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

En ligne

#89 28-01-2016 14:22:13

enicar
Membre
Lieu : Grenoble
Distrib. : debian/sid
Noyau : Linux 4.8.10
(G)UI : openbox
Inscription : 26-08-2010

Re : DVD6clone : lit, copie et ripe vos DVD. (Version en test)

On pourrait en faire un .deb et donc avec une gestion de dépendance.
Ce n'est pas difficile, c'est juste un peu long…

La machine, c'est dépassé ! On va tout remplacer par des humains big_smile

Hors ligne

#90 28-01-2016 18:23:48

greenmerlin
Membre
Lieu : 127.0.0.1
Distrib. : Archlinux/TinycoreLinux(CorePure 64-6.4.1)/Jessie
Noyau : 4.2.2-1 / 4.4
(G)UI : wmaker
Inscription : 23-01-2016

Re : DVD6clone : lit, copie et ripe vos DVD. (Version en test)

Super Boulot Slyfox !

bravo

" La plus importante et la plus négligée de toutes les conversations, c'est l'entretien avec soi-même. "
Chancelier Oxenstiern.

536920766f7573206172726976657220c3a0206c69726520c3a7612c20632765737420717565206e6f757320706172746167656f6e73206c6573206dc3aa6d65732063656e747265732064e28099696e74c3a972c3aa74732e

Hors ligne

Pied de page des forums