Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 22-12-2013 16:26:02

chrispi
Membre
Lieu : Genève (Suisse)
Distrib. : Stable (Wheezy)
(G)UI : Gnome
Inscription : 06-08-2010

[Résolu] Comment savoir si la carte dédiée fonctionne?

salut,

J'ai un portable Toshiba avec deux cartes graphiques:
$ lspci -nn:
...
00:02.0 VGA compatible controller [0300]: Intel Corporation 4th Gen Core Processor Integrated Graphics Controller [8086:0416] (rev 06)
01:00.0 3D controller [0302]: NVIDIA Corporation GK208M [GeForce GT 740M] [10de:1292] (rev ff)
...

Comme ce portable est très récent, j'ai installé la version testing (jessie), gnome 3.8.
J'ai installé bumblebee comme indiqué ici:
https://wiki.debian.org/Bumblebee
Je me suis ajouté comme user du groupe bumblebee
et j'ai précisé dans le fichier de configuration (/etc/bumblebee/bumblebee.conf)
Driver=nvidia
et
KernelDriver=nvidia-current

Ca a l'air de fonctionner:
optirun nvidia-settings -c :8
affiche le panel nvidia
et
optirun glxgears -info
affiche les engrenages

MAIS le débit est particulièrement lent: 60 FPS.
Exactement la même chose que la carte intégrée (Intel HD 4600)
D'ailleurs, sous paramètre système, seul la carte Intel est affichée.
L'affichage de certaines images vidéo est mauvais.

Comment savoir si la carte intégrée nvidia fonctionne?

Si vous avez une idée, je suis preneur.
Merci!
cp

PS: à la base, je voulais installer wheezy (càd la version stable). Mais après l'installation du noyeau 3.11 et de bumblebee, Gnome reste en mode restreint, et affiche, pour la carte graphique (sous paramètres système) Gallium 0.4 sur llvmpipe. Je suis donc preneur d'une solution que ce soit sous testing (jessie) ou stable (wheezy).

Dernière modification par chrispi (11-01-2014 11:33:02)

Hors ligne

#2 23-12-2013 09:45:51

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : [Résolu] Comment savoir si la carte dédiée fonctionne?

Peut-être un problème de version ? http://askubuntu.com/questions/366580/n … stallation

I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

#3 23-12-2013 23:18:02

chrispi
Membre
Lieu : Genève (Suisse)
Distrib. : Stable (Wheezy)
(G)UI : Gnome
Inscription : 06-08-2010

Re : [Résolu] Comment savoir si la carte dédiée fonctionne?

Hello, et merci.
Avant de poster ici mon problème j'ai essayé un peu toutes les configurations possibles, notamment celles indiquées dans le lien ci-dessus (à l'exception que je n'utilise que les dépôts officiels de debian, y compris backports)
Après une fresh install,et une installation de bumblebee comme indiquée dans mon premier post, les choses avaient l'air de fonctionner (puisqu'il n'y a pas de message d'erreur avec optirun glxgears -info, etc.) mais le FPS est aussi lent que la carte intégrée - et ça se voit sur certaine vidéo.
Donc y a-t-il une commande pour savoir si la carte dédiée est en fonction?
Le bios ne permet pas de désactiver la carte intégrée (malin!).
C'est bien la version 319 de nvidia que j'ai installée, compatible avec le GPU GT 740M. Le pilote nouveau ne supporte pas ce GPU, donc pas de choix.
Est-ce possible que bumblebee n'enclenche pas la carte nvidia (mais qu'elle fonctionne)?
cp

Dernière modification par chrispi (24-12-2013 16:40:23)

Hors ligne

#4 24-12-2013 09:08:01

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : [Résolu] Comment savoir si la carte dédiée fonctionne?

De ce que je comprends, tu devrais être en erreur : https://wiki.ubuntu.com/Bumblebee
Mais je peux me tromper (jamais utilisé).

Patiente le temps que quelques pointures avisées voient ton post.  smile
Bon courage

I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

#5 11-01-2014 11:28:17

chrispi
Membre
Lieu : Genève (Suisse)
Distrib. : Stable (Wheezy)
(G)UI : Gnome
Inscription : 06-08-2010

Re : [Résolu] Comment savoir si la carte dédiée fonctionne?

Hello,

J'ai pu résoudre une partie de mes questions grâce à ce ce tutoriel:
http://ubuntuguide.net/turn-off-discret … ard-ubuntu

En suivant ce tutoriel, on peut savoir si la carte dédiée fonctionne ou non lorsqu'un programme est lancé, activer ou désactiver la carte dédié, et finalement la désactiver durablement au boot (puisque certains bios ne fournissent pas cette option).

C'est déjà pas mal, et je peux considérer mon problème comme résolu.

Reste la question de savoir pourquoi ma carte nvidia GeForce GT 740M fait 60 FPS. Mais disons que c'est un autre problème.

Bon début d'année,

cp

Dernière modification par chrispi (11-01-2014 11:33:20)

Hors ligne

Pied de page des forums