Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 30-12-2013 13:01:03

powerflower5
Membre
Lieu : 29
Inscription : 16-11-2013

[Résolu] grub ne peut pas être installé pendant l'installation

Bonjour,
Je viens d'essayer d'installer debian. J'ai lancé l'installation de Debian en choisissant "installation dans un espace suffisant". ça m'a modifié mes partitions et après j'ai eu un message comme quoi grub ne peut pas être installé.
Du coup, j'ai arrêté l'installation. Je vous mets une copie de mes partitions actuelles : http://img97.xooimage.com/views/5/b/5/c … 02ebd.png/
Qu'est-ce qui ne va pas, svp?

Dernière modification par powerflower5 (31-12-2013 19:41:15)


PC portable HP G72 Notebook
Processeur : Intel Pentium P6000 1.87 GHz
GF : ATI Manhattan Mobility Radeon HD 5400 Series et carte graphique intégrée Intel
OS : Linux Mate 13 et Windows 7

Hors ligne

#2 30-12-2013 13:40:47

MicP
Invité

Re : [Résolu] grub ne peut pas être installé pendant l'installation

Je pense que tu as une machine utilisant l'EFI, et que la capture d'écran dont tu as posté le lien a été faite depuis le système "Mint" que tu avais installé précédemment.

Il faudrait que tu ouvre une fenêtre de terminal et que tu puisse obtenir (par "su" ou "sudo") les droits du compte super-utilisateur (root).
Poste nous un copié-collé du retour de la commande :

grub-mkconfig


Et aussi le retour de la commande suivante (en user ou root, ça n'a pas d'importance) :

cat /boot/grub/grub.cfg



==============
Dans la barre des menu de la fenêtre de "Gparted", il y a le menu "view".
En cliquant sur ce bouton, tu devrais avoir accès à un option qui en français est :"Information sur le périphérique" (la première de la liste).

Pourrais-tu nous poster un lien vers une capture d'écran de Gparted avec les informations sur le disque affichées.
Ou alors tout simplement le retour de la comande suivante:

parted -l



Merci.

Dernière modification par MicP (08-01-2014 19:27:11)

#3 30-12-2013 15:01:07

powerflower5
Membre
Lieu : 29
Inscription : 16-11-2013

Re : [Résolu] grub ne peut pas être installé pendant l'installation

1er retour de commande :

su


Password:


grub-mkconfig


Generating grub.cfg ...
#
# DO NOT EDIT THIS FILE
#
# It is automatically generated by grub-mkconfig using templates
# from /etc/grub.d and settings from /etc/default/grub
#

### BEGIN /etc/grub.d/00_header ###
if [ -s $prefix/grubenv ]; then
  set have_grubenv=true
  load_env
fi
set default="0"
if [ "${prev_saved_entry}" ]; then
  set saved_entry="${prev_saved_entry}"
  save_env saved_entry
  set prev_saved_entry=
  save_env prev_saved_entry
  set boot_once=true
fi

function savedefault {
  if [ -z "${boot_once}" ]; then
    saved_entry="${chosen}"
    save_env saved_entry
  fi
}

function recordfail {
  set recordfail=1
  if [ -n "${have_grubenv}" ]; then if [ -z "${boot_once}" ]; then save_env recordfail; fi; fi
}

function load_video {
  insmod vbe
  insmod vga
  insmod video_bochs
  insmod video_cirrus
}

insmod part_msdos
insmod ext2
set root='(hd0,msdos6)'
search --no-floppy --fs-uuid --set=root c8971e4f-90e8-47e3-8732-ce6170519290
if loadfont /usr/share/grub/unicode.pf2 ; then
  set gfxmode=auto
  load_video
  insmod gfxterm
  insmod part_msdos
  insmod ext2
  set root='(hd0,msdos6)'
  search --no-floppy --fs-uuid --set=root c8971e4f-90e8-47e3-8732-ce6170519290
  set locale_dir=($root)/boot/grub/locale
  set lang=fr_FR
  insmod gettext
fi
terminal_output gfxterm
if [ "${recordfail}" = 1 ] ; then
  set timeout=-1
else
  set timeout=10
fi
### END /etc/grub.d/00_header ###

### BEGIN /etc/grub.d/05_debian_theme ###
set menu_color_normal=white/black
set menu_color_highlight=black/light-gray
### END /etc/grub.d/05_debian_theme ###

### BEGIN /etc/grub.d/06_mint_theme ###
set menu_color_normal=white/black
set menu_color_highlight=white/light-gray
### END /etc/grub.d/06_mint_theme ###

### BEGIN /etc/grub.d/10_linux ###
function gfxmode {
  set gfxpayload="$1"
  if [ "$1" = "keep" ]; then
    set vt_handoff=vt.handoff=7
  else
    set vt_handoff=
  fi
}
if [ ${recordfail} != 1 ]; then
  if [ -e ${prefix}/gfxblacklist.txt ]; then
    if hwmatch ${prefix}/gfxblacklist.txt 3; then
      if [ ${match} = 0 ]; then
        set linux_gfx_mode=keep
      else
        set linux_gfx_mode=text
      fi
    else
      set linux_gfx_mode=text
    fi
  else
    set linux_gfx_mode=keep
  fi
else
  set linux_gfx_mode=text
fi
export linux_gfx_mode
if [ "$linux_gfx_mode" != "text" ]; then load_video; fi
Found linux image: /boot/vmlinuz-3.2.0-23-generic
Found initrd image: /boot/initrd.img-3.2.0-23-generic
menuentry 'Linux Mint 13 MATE 64-bit, 3.2.0-23-generic (/dev/sda6)' --class linuxmint --class gnu-linux --class gnu --class os {
  recordfail
  gfxmode $linux_gfx_mode
  insmod gzio
  insmod part_msdos
  insmod ext2
  set root='(hd0,msdos6)'
  search --no-floppy --fs-uuid --set=root c8971e4f-90e8-47e3-8732-ce6170519290
  linux /boot/vmlinuz-3.2.0-23-generic root=UUID=c8971e4f-90e8-47e3-8732-ce6170519290 ro   quiet splash $vt_handoff
  initrd  /boot/initrd.img-3.2.0-23-generic
}
menuentry 'Linux Mint 13 MATE 64-bit, 3.2.0-23-generic (/dev/sda6) -- recovery mode' --class linuxmint --class gnu-linux --class gnu --class os {
  recordfail
  insmod gzio
  insmod part_msdos
  insmod ext2
  set root='(hd0,msdos6)'
  search --no-floppy --fs-uuid --set=root c8971e4f-90e8-47e3-8732-ce6170519290
  echo  'Loading Linux 3.2.0-23-generic ...'
  linux /boot/vmlinuz-3.2.0-23-generic root=UUID=c8971e4f-90e8-47e3-8732-ce6170519290 ro recovery nomodeset
  echo  'Loading initial ramdisk ...'
  initrd  /boot/initrd.img-3.2.0-23-generic
}
### END /etc/grub.d/10_linux ###

### BEGIN /etc/grub.d/10_lupin ###
### END /etc/grub.d/10_lupin ###

### BEGIN /etc/grub.d/20_linux_xen ###
### END /etc/grub.d/20_linux_xen ###

### BEGIN /etc/grub.d/20_memtest86+ ###
Found memtest86+ image: /boot/memtest86+.bin
menuentry "Memory test (memtest86+)" {
  insmod part_msdos
  insmod ext2
  set root='(hd0,msdos6)'
  search --no-floppy --fs-uuid --set=root c8971e4f-90e8-47e3-8732-ce6170519290
  linux16 /boot/memtest86+.bin
}
menuentry "Memory test (memtest86+, serial console 115200)" {
  insmod part_msdos
  insmod ext2
  set root='(hd0,msdos6)'
  search --no-floppy --fs-uuid --set=root c8971e4f-90e8-47e3-8732-ce6170519290
  linux16 /boot/memtest86+.bin console=ttyS0,115200n8
}
### END /etc/grub.d/20_memtest86+ ###

### BEGIN /etc/grub.d/30_os-prober ###
Found Windows 7 (loader) on /dev/sda1
menuentry "Windows 7 (loader) (on /dev/sda1)" --class windows --class os {
  insmod part_msdos
  insmod ntfs
  set root='(hd0,msdos1)'
  search --no-floppy --fs-uuid --set=root F654AF3C54AEFF0D
  chainloader +1
}
Found Windows Recovery Environment (loader) on /dev/sda2
menuentry "Windows Recovery Environment (loader) (on /dev/sda2)" --class windows --class os {
  insmod part_msdos
  insmod ntfs
  set root='(hd0,msdos2)'
  search --no-floppy --fs-uuid --set=root 649A2D799A2D48BE
  drivemap -s (hd0) ${root}
  chainloader +1
}
Found Windows Recovery Environment (loader) on /dev/sda4
menuentry "Windows Recovery Environment (loader) (on /dev/sda4)" --class windows --class os {
  insmod part_msdos
  insmod ntfs
  set root='(hd0,msdos4)'
  search --no-floppy --fs-uuid --set=root 40D6676CD6676160
  drivemap -s (hd0) ${root}
  chainloader +1
}
set timeout_style=menu
if [ "${timeout}" = 0 ]; then
  set timeout=10
fi
### END /etc/grub.d/30_os-prober ###

### BEGIN /etc/grub.d/30_uefi-firmware ###
### END /etc/grub.d/30_uefi-firmware ###

### BEGIN /etc/grub.d/40_custom ###
# This file provides an easy way to add custom menu entries.  Simply type the
# menu entries you want to add after this comment.  Be careful not to change
# the 'exec tail' line above.
### END /etc/grub.d/40_custom ###

### BEGIN /etc/grub.d/41_custom ###
if [ -f  $prefix/custom.cfg ]; then
  source $prefix/custom.cfg;
fi
### END /etc/grub.d/41_custom ###
done
nath-HP-G72-Notebook-PC nath #
[/quote]
2ème retour de commande :
[quote]nath-HP-G72-Notebook-PC nath # cat /boot/grub/grub.cfg
#
# DO NOT EDIT THIS FILE
#
# It is automatically generated by grub-mkconfig using templates
# from /etc/grub.d and settings from /etc/default/grub
#

### BEGIN /etc/grub.d/00_header ###
if [ -s $prefix/grubenv ]; then
  set have_grubenv=true
  load_env
fi
set default="0"
if [ "${prev_saved_entry}" ]; then
  set saved_entry="${prev_saved_entry}"
  save_env saved_entry
  set prev_saved_entry=
  save_env prev_saved_entry
  set boot_once=true
fi

function savedefault {
  if [ -z "${boot_once}" ]; then
    saved_entry="${chosen}"
    save_env saved_entry
  fi
}

function recordfail {
  set recordfail=1
  if [ -n "${have_grubenv}" ]; then if [ -z "${boot_once}" ]; then save_env recordfail; fi; fi
}

function load_video {
  insmod vbe
  insmod vga
  insmod video_bochs
  insmod video_cirrus
}

insmod part_msdos
insmod ext2
set root='(hd0,msdos6)'
search --no-floppy --fs-uuid --set=root c8971e4f-90e8-47e3-8732-ce6170519290
if loadfont /usr/share/grub/unicode.pf2 ; then
  set gfxmode=auto
  load_video
  insmod gfxterm
  insmod part_msdos
  insmod ext2
  set root='(hd0,msdos6)'
  search --no-floppy --fs-uuid --set=root c8971e4f-90e8-47e3-8732-ce6170519290
  set locale_dir=($root)/boot/grub/locale
  set lang=fr_FR
  insmod gettext
fi
terminal_output gfxterm
if [ "${recordfail}" = 1 ] ; then
  set timeout=-1
else
  set timeout=10
fi
### END /etc/grub.d/00_header ###

### BEGIN /etc/grub.d/05_debian_theme ###
set menu_color_normal=white/black
set menu_color_highlight=black/light-gray
### END /etc/grub.d/05_debian_theme ###

### BEGIN /etc/grub.d/06_mint_theme ###
set menu_color_normal=white/black
set menu_color_highlight=white/light-gray
### END /etc/grub.d/06_mint_theme ###

### BEGIN /etc/grub.d/10_linux ###
function gfxmode {
  set gfxpayload="${1}"
  if [ "${1}" = "keep" ]; then
    set vt_handoff=vt.handoff=7
  else
    set vt_handoff=
  fi
}
if [ "${recordfail}" != 1 ]; then
  if [ -e ${prefix}/gfxblacklist.txt ]; then
    if hwmatch ${prefix}/gfxblacklist.txt 3; then
      if [ ${match} = 0 ]; then
        set linux_gfx_mode=keep
      else
        set linux_gfx_mode=text
      fi
    else
      set linux_gfx_mode=text
    fi
  else
    set linux_gfx_mode=keep
  fi
else
  set linux_gfx_mode=text
fi
export linux_gfx_mode
if [ "${linux_gfx_mode}" != "text" ]; then load_video; fi
menuentry 'LinuxMint, with Linux 3.2.0-23-generic' --class linuxmint --class gnu-linux --class gnu --class os {
  recordfail
  gfxmode $linux_gfx_mode
  insmod gzio
  insmod part_msdos
  insmod ext2
  set root='(hd0,msdos6)'
  search --no-floppy --fs-uuid --set=root c8971e4f-90e8-47e3-8732-ce6170519290
  linux /boot/vmlinuz-3.2.0-23-generic root=UUID=c8971e4f-90e8-47e3-8732-ce6170519290 ro   quiet splash $vt_handoff
  initrd  /boot/initrd.img-3.2.0-23-generic
}
menuentry 'LinuxMint, with Linux 3.2.0-23-generic (recovery mode)' --class linuxmint --class gnu-linux --class gnu --class os {
  recordfail
  insmod gzio
  insmod part_msdos
  insmod ext2
  set root='(hd0,msdos6)'
  search --no-floppy --fs-uuid --set=root c8971e4f-90e8-47e3-8732-ce6170519290
  echo  'Loading Linux 3.2.0-23-generic ...'
  linux /boot/vmlinuz-3.2.0-23-generic root=UUID=c8971e4f-90e8-47e3-8732-ce6170519290 ro recovery nomodeset
  echo  'Loading initial ramdisk ...'
  initrd  /boot/initrd.img-3.2.0-23-generic
}
### END /etc/grub.d/10_linux ###

### BEGIN /etc/grub.d/10_lupin ###
### END /etc/grub.d/10_lupin ###

### BEGIN /etc/grub.d/20_linux_xen ###
### END /etc/grub.d/20_linux_xen ###

### BEGIN /etc/grub.d/20_memtest86+ ###
menuentry "Memory test (memtest86+)" {
  insmod part_msdos
  insmod ext2
  set root='(hd0,msdos6)'
  search --no-floppy --fs-uuid --set=root c8971e4f-90e8-47e3-8732-ce6170519290
  linux16 /boot/memtest86+.bin
}
menuentry "Memory test (memtest86+, serial console 115200)" {
  insmod part_msdos
  insmod ext2
  set root='(hd0,msdos6)'
  search --no-floppy --fs-uuid --set=root c8971e4f-90e8-47e3-8732-ce6170519290
  linux16 /boot/memtest86+.bin console=ttyS0,115200n8
}
### END /etc/grub.d/20_memtest86+ ###

### BEGIN /etc/grub.d/30_os-prober ###
menuentry "Windows 7 (loader) (on /dev/sda1)" --class windows --class os {
  insmod part_msdos
  insmod ntfs
  set root='(hd0,msdos1)'
  search --no-floppy --fs-uuid --set=root F654AF3C54AEFF0D
  chainloader +1
}
menuentry "Windows Recovery Environment (loader) (on /dev/sda2)" --class windows --class os {
  insmod part_msdos
  insmod ntfs
  set root='(hd0,msdos2)'
  search --no-floppy --fs-uuid --set=root 649A2D799A2D48BE
  drivemap -s (hd0) ${root}
  chainloader +1
}
menuentry "Windows Recovery Environment (loader) (on /dev/sda4)" --class windows --class os {
  insmod part_msdos
  insmod ntfs
  set root='(hd0,msdos4)'
  search --no-floppy --fs-uuid --set=root 40D6676CD6676160
  drivemap -s (hd0) ${root}
  chainloader +1
}
set timeout_style=menu
if [ "${timeout}" = 0 ]; then
  set timeout=10
fi
### END /etc/grub.d/30_os-prober ###

### BEGIN /etc/grub.d/30_uefi-firmware ###
### END /etc/grub.d/30_uefi-firmware ###

### BEGIN /etc/grub.d/40_custom ###
# This file provides an easy way to add custom menu entries.  Simply type the
# menu entries you want to add after this comment.  Be careful not to change
# the 'exec tail' line above.
### END /etc/grub.d/40_custom ###

### BEGIN /etc/grub.d/41_custom ###
if [ -f  $prefix/custom.cfg ]; then
  source $prefix/custom.cfg;
fi
### END /etc/grub.d/41_custom ###
nath-HP-G72-Notebook-PC nath #
[/quote]

3ème retour de commande :
[quote]nath-HP-G72-Notebook-PC nath # parted -l
Model: ATA TOSHIBA MK5061GS (scsi)
Disk /dev/sda: 500GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos

Number  Start   End    Size    Type      File system     Flags
 1      1049kB  210MB  209MB   primary   ntfs            boot
 2      210MB   380GB  379GB   primary   ntfs
 3      380GB   485GB  105GB   extended                  lba
 5      380GB   383GB  3274MB  logical   ntfs
 6      383GB   403GB  20,0GB  logical   ext4
 7      403GB   406GB  3071MB  logical   linux-swap(v1)
 8      406GB   458GB  52,4GB  logical   ext4
 9      458GB   465GB  6725MB  logical   ext4
10      465GB   485GB  19,4GB  logical   ext4
 4      485GB   500GB  15,5GB  primary   ntfs
 


PC portable HP G72 Notebook
Processeur : Intel Pentium P6000 1.87 GHz
GF : ATI Manhattan Mobility Radeon HD 5400 Series et carte graphique intégrée Intel
OS : Linux Mate 13 et Windows 7

Hors ligne

#4 30-12-2013 15:33:56

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : [Résolu] grub ne peut pas être installé pendant l'installation

powerflower5,

Je t'ai mis tes quote en code afin de les rendre plus lisibles sur le forum.
Tu peux voir les balises en ouvrant par Modifier ton post précédent.

Pour le détail de ces balises sur le forum :
Le code, ça pique moins les yeux en couleur smile

"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#5 30-12-2013 16:33:35

MicP
Invité

Re : [Résolu] grub ne peut pas être installé pendant l'installation

Il semblerait qu'aucune partition swap n'ait été créée par le programme d'installation,
peut-être as-tu oublié de suivre les indications que je t'avais donné dans le post #18
Ce n'est pas très grave car on pourra résoudre ce problème plus tard.
Mais en attendant, n'utilise pas l'hibernation de Mint pour arrêter ta machine.

==============
- Il me faudrait avant tout savoir quel est le nom et l'adresse (lien web) de l'image iso qui a été utilisée pour créer le disque ou clé USB qui a servi à installer "debian".

- As-tu vérifié la somme MD5 ou SHA-1 du fichier ".iso" téléchargé, puis la somme MD5 ou SHA-1 du support (CD ou USB) gravé/copié ?

- Au cours de l'installation, as-tu créé un répertoire séparé  pour "/home" ?

- Au cours de l'installation, n'y-a-t-il pas eu de problèmes (à part celui de l'installation du chargeur de démarrage Grub) ?

- Poste aussi le retour de la commande (en root) suivante:

blkid




==============
Quand tu poste des retours de commandes sur le forum, c'est le bouton "Code" et pas "Quote" qu'il faut utiliser.
Par curiosité, tu peux visualiser comment j'ai fait dans ce post en cliquant sur le Mot Citer en bas à droite de ce post:


Model: ATA TOSHIBA MK5061GS (scsi)
Disk /dev/sda: 500GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
 




Number  Start   End    Size    Type      File system     Flags
 1      1049kB  210MB  209MB   primary   ntfs            boot
 2      210MB   380GB  379GB   primary   ntfs
 3      380GB   485GB  105GB   extended                  lba
 5      380GB   383GB  3274MB  logical   ntfs
 6      383GB   403GB  20,0GB  logical   ext4
 7      403GB   406GB  3071MB  logical   linux-swap(v1)
 8      406GB   458GB  52,4GB  logical   ext4
 9      458GB   465GB  6725MB  logical   ext4
10      465GB   485GB  19,4GB  logical   ext4
 4      485GB   500GB  15,5GB  primary   ntfs
 




/dev/sda1 SYSTEM               Windows 7 (loader)                    F654AF3C54AEFF0D
/dev/sda2                      Windows Recovery Environment (loader) 649A2D799A2D48BE
/dev/sda3 -----------partition étendue          --------------------------------------------------------
/dev/sda4 RECOVERY             Windows Recovery Environment (loader) 40D6676CD6676160
/dev/sda5 HP_TOOLS
/dev/sda6             /        Linux Mint 13 Mate 64 bits  3.2.0-23  c8971e4f-90e8-47e3-8732-ce6170519290
/dev/sda7             swap    Mint
/dev/sda8             /home   Mint
/dev/sda9  sans doute /       debian
/dev/sda10 sans doute /home   debian
 

Dernière modification par MicP (30-12-2013 20:18:11)

#6 30-12-2013 20:30:53

powerflower5
Membre
Lieu : 29
Inscription : 16-11-2013

Re : [Résolu] grub ne peut pas être installé pendant l'installation

voilà :

nath-HP-G72-Notebook-PC nath # blkid
/dev/sda1: LABEL="SYSTEM" UUID="F654AF3C54AEFF0D" TYPE="ntfs"
/dev/sda10: UUID="5dcfdc08-2bb1-4e6d-a915-6c226c8f87b4" TYPE="ext4"
/dev/sda2: UUID="649A2D799A2D48BE" TYPE="ntfs"
/dev/sda4: LABEL="RECOVERY" UUID="40D6676CD6676160" TYPE="ntfs"
/dev/sda5: LABEL="HP_TOOLS" UUID="EA54464854461829" TYPE="ntfs"
/dev/sda9: UUID="9d6953b5-d5fb-44ac-84db-869b097b6714" TYPE="ext4"
/dev/sda6: UUID="c8971e4f-90e8-47e3-8732-ce6170519290" TYPE="ext4"
/dev/sda7: UUID="274dc5fc-519b-4303-9c64-6e0abdcb3f9a" TYPE="swap"
/dev/sda8: UUID="adba1f71-d13d-47a4-82d8-68e0623ad9a2" TYPE="ext4"
nath-HP-G72-Notebook-PC nath #
 



Je n'ai pas vérifié la somme du MD5 ou SHA-1 du fichier ".iso" téléchargé et je ne trouve plus le lien que j'ai utilisé!
Au cour de l'installation, j'ai choisi d'installer debian dans un espace suffisant, je n'ai créé aucune partition , ça s'est fait tout seul (sda9 et sda10).
J'ai eu un autre problème avec la détection du wifi : ma box était bien détectée mais la clé était refusée.

Et voici le lien que j'ai utilisé pour me procurer l'iso : http://live.debian.net/cdimage/release/ … onfree.iso

Dernière modification par powerflower5 (30-12-2013 21:16:48)


PC portable HP G72 Notebook
Processeur : Intel Pentium P6000 1.87 GHz
GF : ATI Manhattan Mobility Radeon HD 5400 Series et carte graphique intégrée Intel
OS : Linux Mate 13 et Windows 7

Hors ligne

#7 30-12-2013 21:25:46

MicP
Invité

Re : [Résolu] grub ne peut pas être installé pendant l'installation

Parfait pour les balises de code de ton dernier post  smile

=======

Je ne comprends pas pourquoi tu as choisis une image ISO d'une ancienne version de "debian" et pourquoi une image "live" pour une installation.

=======
La somme SHA-1 de l'image iso "debian-live-7.2-amd64-gnome-desktop+nonfree.iso" est :

7b369256f95913fe06c50ad83d05d73e

Pourrais-tu vérifier si elle corresponds à celle du fichier que tu as téléchargé,
et faire ensuite la même vérification avec le support d'installation que tu as utilisé.

Bien sûr tu remplace le texte "à_remplacer_par_le_répertoire_et_nom_de_ton_image_iso" par ce qu'il faut dans la commande suivante :

md5sum à_remplacer_par_le_répertoire_et_nom_de_ton_image_iso



=======
Il me faudrait aussi le retour de la suite des commandes ci-dessous :


mkdir /mnt/sda9 && mount /dev/sda9 /mnt/sda9
mkdir /mnt/sda10 && mount /dev/sda10 /mnt/sda10
cat /mnt/sda9/boot/grub/grub.cfg; echo "=========="; cat /mnt/sda10/boot/grub/grub.cfg
umount /mnt/sda9 /mnt/sda10
 



Merci.

Dernière modification par MicP (08-01-2014 19:26:29)

#8 30-12-2013 22:20:13

powerflower5
Membre
Lieu : 29
Inscription : 16-11-2013

Re : [Résolu] grub ne peut pas être installé pendant l'installation

Bon, déjà ça ne correspond pas. L'iso que j'avais téléchargée était prévue pour que mon wifi soit reconnue... du moins c'est pour cette raison que j'avais pris celui-là.
Du coup, veux-tu bien me conseiller un iso en amd64 par contre en xfce pour que je retente une installation, svp?

PC portable HP G72 Notebook
Processeur : Intel Pentium P6000 1.87 GHz
GF : ATI Manhattan Mobility Radeon HD 5400 Series et carte graphique intégrée Intel
OS : Linux Mate 13 et Windows 7

Hors ligne

#9 30-12-2013 22:36:18

Lætitia
Modette
Lieu : Normandie du Nord
Distrib. : Stretch
Noyau : 4.6.0-1-amd64
(G)UI : Xfce4
Inscription : 14-04-2010
Site Web

Re : [Résolu] grub ne peut pas être installé pendant l'installation

salut,
c'est quoi ta carte. Certaines sont très faciles à installer. smile
Sinon, tu peux faire ton marché là : http://cdimage.debian.org/cdimage/unoff … -firmware/
Ici amd64 en netinstall, je crois que tu dois choisir d'installer en mode expert (ou un truc du genre) pour avoir le choix de bureau Xfce : http://cdimage.debian.org/cdimage/unoff … 64/iso-cd/

Pense à vérifier ton md5

<titia> pas assez cuit; µonde  -> explosion
<captnfab> ^^
<captnfab> s/µ/bl/ wink

Hors ligne

#10 30-12-2013 22:59:07

powerflower5
Membre
Lieu : 29
Inscription : 16-11-2013

Re : [Résolu] grub ne peut pas être installé pendant l'installation

Merci mais j'aimerais autant éviter un mode expert justement... un mode pas trop compliqué m'irait très bien wink. En netinstall, il n'y a pas d'interface graphique, c'est bien ça?

PC portable HP G72 Notebook
Processeur : Intel Pentium P6000 1.87 GHz
GF : ATI Manhattan Mobility Radeon HD 5400 Series et carte graphique intégrée Intel
OS : Linux Mate 13 et Windows 7

Hors ligne

#11 30-12-2013 23:05:36

MicP
Invité

Re : [Résolu] grub ne peut pas être installé pendant l'installation

Bon. Si tu projette de réinstaller depuis une netinstall (ce que j'aurais conseillé) et si ton problème concernait certains pilotes (ce qui ne m'étonne pas non plus pour une machine HP),
Voilà ce que je conseillerai :
Deux supports (CD ou USB : aucune importance)
Un support avec le paquetage "nonfree" qui restera connecté durant l'installation,
et un autre avec la netinstall.

debian-7.3.0-amd64-netinst.iso

Dernière modification par MicP (02-01-2014 16:13:44)

#12 30-12-2013 23:16:56

powerflower5
Membre
Lieu : 29
Inscription : 16-11-2013

Re : [Résolu] grub ne peut pas être installé pendant l'installation

Bon, j'ai mis l'iso que tu m'as indiquée à télécharger, ça sera bon avec ça?

PC portable HP G72 Notebook
Processeur : Intel Pentium P6000 1.87 GHz
GF : ATI Manhattan Mobility Radeon HD 5400 Series et carte graphique intégrée Intel
OS : Linux Mate 13 et Windows 7

Hors ligne

#13 30-12-2013 23:17:50

MicP
Invité

Re : [Résolu] grub ne peut pas être installé pendant l'installation

pour le firmware, il me faudrait avoir le retour de:

lspci



Il faudrait vérifier la somme SHA-1 du fichier de la netinstall téléchargé

Dernière modification par MicP (08-01-2014 19:25:48)

#14 30-12-2013 23:24:20

powerflower5
Membre
Lieu : 29
Inscription : 16-11-2013

Re : [Résolu] grub ne peut pas être installé pendant l'installation

voilà le retour de commande :

ath@nath-HP-G72-Notebook-PC ~ $ lspci
00:00.0 Host bridge: Intel Corporation Core Processor DRAM Controller (rev 02)
00:01.0 PCI bridge: Intel Corporation Core Processor PCI Express x16 Root Port (rev 02)
00:02.0 VGA compatible controller: Intel Corporation Core Processor Integrated Graphics Controller (rev 02)
00:16.0 Communication controller: Intel Corporation 5 Series/3400 Series Chipset HECI Controller (rev 06)
00:1a.0 USB controller: Intel Corporation 5 Series/3400 Series Chipset USB2 Enhanced Host Controller (rev 05)
00:1b.0 Audio device: Intel Corporation 5 Series/3400 Series Chipset High Definition Audio (rev 05)
00:1c.0 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 1 (rev 05)
00:1c.2 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 3 (rev 05)
00:1d.0 USB controller: Intel Corporation 5 Series/3400 Series Chipset USB2 Enhanced Host Controller (rev 05)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev a5)
00:1f.0 ISA bridge: Intel Corporation Mobile 5 Series Chipset LPC Interface Controller (rev 05)
00:1f.2 SATA controller: Intel Corporation 5 Series/3400 Series Chipset 4 port SATA AHCI Controller (rev 05)
00:1f.3 SMBus: Intel Corporation 5 Series/3400 Series Chipset SMBus Controller (rev 05)
00:1f.6 Signal processing controller: Intel Corporation 5 Series/3400 Series Chipset Thermal Subsystem (rev 05)
01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Park [Mobility Radeon HD 5430/5450/5470]
01:00.1 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] Cedar HDMI Audio [Radeon HD 5400/6300 Series]
02:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8101E/RTL8102E PCI Express Fast Ethernet controller (rev 02)
03:00.0 Network controller: Broadcom Corporation BCM4313 802.11bgn Wireless Network Adapter (rev 01)
7f:00.0 Host bridge: Intel Corporation Core Processor QuickPath Architecture Generic Non-core Registers (rev 02)
7f:00.1 Host bridge: Intel Corporation Core Processor QuickPath Architecture System Address Decoder (rev 02)
7f:02.0 Host bridge: Intel Corporation Core Processor QPI Link 0 (rev 02)
7f:02.1 Host bridge: Intel Corporation Core Processor QPI Physical 0 (rev 02)
7f:02.2 Host bridge: Intel Corporation Core Processor Reserved (rev 02)
7f:02.3 Host bridge: Intel Corporation Core Processor Reserved (rev 02)
nath@nath-HP-G72-Notebook-PC ~ $
 


En revanche, pour la vérif il faut attendre un peu (mon débit internet n'est pas un foudre de guerre!)


PC portable HP G72 Notebook
Processeur : Intel Pentium P6000 1.87 GHz
GF : ATI Manhattan Mobility Radeon HD 5400 Series et carte graphique intégrée Intel
OS : Linux Mate 13 et Windows 7

Hors ligne

#15 30-12-2013 23:25:58

MicP
Invité

Re : [Résolu] grub ne peut pas être installé pendant l'installation

Somme md5 de la "netinst" : j'avais mal recopié. désolé ...

72473e8a5e65b61acc7efde90d9f71d1



Pour le lspci, c'est bon :

Il y a le RJ45 => Realtek Semiconductor RTL8101E/RTL8102E
Le WiFi        => Broadcom Corporation BCM4313


Si le RJ45 fonctionne avec la "netinstall", et que tu peux te connecter par câble à ta box, alors on s'occupera du WiFi après.
Pour le savoir, il suffit de tenter l'installation avec la "netinstall".

Si ça veux se connecter, il suffira de continuer l'installation, et c'est tout bon.

Sinon, il suffira d'arrêter la machine direct, et recommencer dès qu'on aura le ".deb" de "Realtek".

Dernière modification par MicP (08-01-2014 19:25:28)

#16 30-12-2013 23:48:32

MicP
Invité

Re : [Résolu] grub ne peut pas être installé pendant l'installation

Realtek    => au cas où le réseau par câble (RJ45) ne fonctionne pas
Broadcom => pour le WiFi (mais il faudra peut-être autre chose en plus pour la BCM4313...)
Ce sont deux fichiers ".deb" à copier/coller coller dans une partition (FAT32 ou Ext2 ou Ext3 ou Ext4) sur une clef USB ou un CD qui restera connectée (ou sera connecté) quand le programme d'installation le demandera.

Pour l'installation, il est possible de supprimer depuis "Mint" les deux partitions "/dev/sda9" et "/dev/sda10" : l'installateur de la "netinstall" fera comme il veux en prenant la place disponible,
comme l'avait fait le programme d'installation précédente depuis la version "Live"

Dernière modification par MicP (30-12-2013 23:58:39)

#17 30-12-2013 23:58:18

powerflower5
Membre
Lieu : 29
Inscription : 16-11-2013

Re : [Résolu] grub ne peut pas être installé pendant l'installation

Pour la somme MD5, c'est bon.
Par contre, je ne ferai les manip que demain uniquement. Donc je te dis à demain (si tu es dispo bien sûr) et bonne nuit.

PC portable HP G72 Notebook
Processeur : Intel Pentium P6000 1.87 GHz
GF : ATI Manhattan Mobility Radeon HD 5400 Series et carte graphique intégrée Intel
OS : Linux Mate 13 et Windows 7

Hors ligne

#18 30-12-2013 23:59:21

MicP
Invité

Re : [Résolu] grub ne peut pas être installé pendant l'installation

Ok : à demain, il vaut mieux faire ça à tête reposée. smile

#19 31-12-2013 09:09:42

powerflower5
Membre
Lieu : 29
Inscription : 16-11-2013

Re : [Résolu] grub ne peut pas être installé pendant l'installation

Bonjour,
Faut -il que je supprime les partitions sda9 et sda 10 pour recréer l'espace libre suffisant pour l'installation ou je laisse les partitions telles qu'elles?
Ah, j'annule ma question car je viens de voir que tum'as déjà parlé de ça hier!

Dernière modification par powerflower5 (31-12-2013 09:11:38)


PC portable HP G72 Notebook
Processeur : Intel Pentium P6000 1.87 GHz
GF : ATI Manhattan Mobility Radeon HD 5400 Series et carte graphique intégrée Intel
OS : Linux Mate 13 et Windows 7

Hors ligne

#20 31-12-2013 11:57:39

powerflower5
Membre
Lieu : 29
Inscription : 16-11-2013

Re : [Résolu] grub ne peut pas être installé pendant l'installation

Encore une question : vu que j'ai le fichier deb du wifi, faut-il que je branche quand même mon portable directement à la box ou pas?

PC portable HP G72 Notebook
Processeur : Intel Pentium P6000 1.87 GHz
GF : ATI Manhattan Mobility Radeon HD 5400 Series et carte graphique intégrée Intel
OS : Linux Mate 13 et Windows 7

Hors ligne

#21 31-12-2013 13:34:56

MicP
Invité

Re : [Résolu] grub ne peut pas être installé pendant l'installation

Par câble, pas d'authentification, pas de parasitage possible, etc... Donc moins de problèmes possibles.
Ça marcherait aussi très bien en WiFi, mais pourquoi se priver du câble, au moins pour l'installation de debian.

Je recommande donc la connexion à la box par câble RJ45 pour une installation de debian.

Dernière modification par MicP (31-12-2013 14:53:43)

#22 31-12-2013 15:34:52

powerflower5
Membre
Lieu : 29
Inscription : 16-11-2013

Re : [Résolu] grub ne peut pas être installé pendant l'installation

D'accord, je vais faire ça d'ici une heure environ et je te dis ce qu'il en ai. Du coup, je vais graver l'iso et mettre les fichiers .deb que tu m'as indiqués sur une clé usb.
Par contre, mon souhait, au fina,l est de pouvoir utilisé mon portable sans qu'il soit branché en ethernet.

Dernière modification par powerflower5 (31-12-2013 15:41:06)


PC portable HP G72 Notebook
Processeur : Intel Pentium P6000 1.87 GHz
GF : ATI Manhattan Mobility Radeon HD 5400 Series et carte graphique intégrée Intel
OS : Linux Mate 13 et Windows 7

Hors ligne

#23 31-12-2013 16:56:22

MicP
Invité

Re : [Résolu] grub ne peut pas être installé pendant l'installation

Il n'y aura pas de problème pour l'utilisation du portable hors connexion internet.

==========
Juste une chose que j'avais oublié de te dire puisque tu avais demandé l'environnement de bureau "Xfce" :
Dès l'apparition du premier écran de l'installateur :
"Advanced options" -> "Alternative desktop environement" -> "Xfce" -> "Install"

Dernière modification par MicP (31-12-2013 17:01:42)

#24 31-12-2013 18:51:04

powerflower5
Membre
Lieu : 29
Inscription : 16-11-2013

Re : [Résolu] grub ne peut pas être installé pendant l'installation

Pour le bureau xfce, c'est trop tard mais c'est pas grave. L'installation est en cours : la barre rouge de choisir et installer des logiciels est à la moitié. L'ethernet a l'air de bien fonctionner. Par contre, tu pourras m'aider pour ma carte wifi car justement, j'ai besoin d'une connection wifi et pas filaire. Je te dirai quand l'installation sera terminée.

PC portable HP G72 Notebook
Processeur : Intel Pentium P6000 1.87 GHz
GF : ATI Manhattan Mobility Radeon HD 5400 Series et carte graphique intégrée Intel
OS : Linux Mate 13 et Windows 7

Hors ligne

#25 31-12-2013 19:01:06

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : [Résolu] grub ne peut pas être installé pendant l'installation


"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

Pied de page des forums