Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#26 10-10-2008 11:29:18

mouloud7
Membre
Lieu : Guadeloupe
Distrib. : wheezy/testing
Noyau : 3.2.0.3
(G)UI : openbox
Inscription : 12-09-2008

Re : [résolu] connexion wifi

Effectivement le"s" bloquait l'accès à la clé WEP
Problème maintenant, il me renvoie que mon mot de passe est trop long!!!
Pourtant j'ai bien vérifié, c'est celui qui est sous ma box & qui fonctionne avec l'ordi de ma femme qui est sous win...
Quel est le souci (pas pu te copier le terminal, gdm vient de planter...

La liberté d'écrire et de parler dépend soit de l'extrême bonté du prince, soit du profond esclavage du peuple. On ne permet de dire qu'à celui qui ne peut rien. DIDEROT

Hors ligne

#27 10-10-2008 16:28:06

tux12
Membre
Lieu : ./
Distrib. : Squeeze
Noyau : Linux 2.6.32-5-686-bigmem
(G)UI : KDE
Inscription : 27-02-2008

Re : [résolu] connexion wifi

Bonjour,

De quel mot de passe parles-tu?

Hors ligne

#28 10-10-2008 18:33:15

mouloud7
Membre
Lieu : Guadeloupe
Distrib. : wheezy/testing
Noyau : 3.2.0.3
(G)UI : openbox
Inscription : 12-09-2008

Re : [résolu] connexion wifi

la clé wep !

La liberté d'écrire et de parler dépend soit de l'extrême bonté du prince, soit du profond esclavage du peuple. On ne permet de dire qu'à celui qui ne peut rien. DIDEROT

Hors ligne

#29 10-10-2008 20:40:22

tux12
Membre
Lieu : ./
Distrib. : Squeeze
Noyau : Linux 2.6.32-5-686-bigmem
(G)UI : KDE
Inscription : 27-02-2008

Re : [résolu] connexion wifi

Ben tu dois avoir un problème avec la ligne ou est la clé.

Vérifie que tu as un espace avant la clé puis place toi à la fin de la ligne (touche Fin généralement). Celle-ci doit correspondre avec le dernier caractère de ta clé. Si ce n'est pas le cas, Backspace jusqu'à ce caractère, puis (dans tous les cas) Entrée pour aller à la ligne (comme ça on est sûr de la fin de ligne après le dernier caractère de la clé) puis supprimer la ligne nouvellement créée. Enregistrer et quitter. Les touches à utiliser peuvent varier d'un éditeur à l'autre. wink

Donnes nous de préférence les commandes que tu tapes et les messages d'erreur que tu obtiens; ça contient beaucoup plus d'information utile que tous les commentaires possibles.

@+

Hors ligne

#30 11-10-2008 03:37:23

mouloud7
Membre
Lieu : Guadeloupe
Distrib. : wheezy/testing
Noyau : 3.2.0.3
(G)UI : openbox
Inscription : 12-09-2008

Re : [résolu] connexion wifi

j'ai vérifié les espaces, essayé la clé wep en ascii en hexadécimal...
ça marche toujours pas
voilà les derniers trucs du terminal :

lepetit:/home/mouloud# /etc/init.d/networking restart
Reconfiguring network interfaces...There is already a pid file /var/run/dhclient.ath0.pid with pid 134518340
Internet Systems Consortium DHCP Client V3.1.1
Copyright 2004-2008 Internet Systems Consortium.
All rights reserved.
For info, please visit http://www.isc.org/sw/dhcp/

wifi0: unknown hardware address type 801
wifi0: unknown hardware address type 801
Listening on LPF/ath0/00:15:af:ca:17:1c
Sending on   LPF/ath0/00:15:af:ca:17:1c
Sending on   Socket/fallback
Error for wireless request "Set Encode" (8B2A) :
    invalid argument ":".
There is already a pid file /var/run/dhclient.ath0.pid with pid 134518340
Internet Systems Consortium DHCP Client V3.1.1
Copyright 2004-2008 Internet Systems Consortium.
All rights reserved.
For info, please visit http://www.isc.org/sw/dhcp/

wifi0: unknown hardware address type 801
wifi0: unknown hardware address type 801
Listening on LPF/ath0/00:15:af:ca:17:1c
Sending on   LPF/ath0/00:15:af:ca:17:1c
Sending on   Socket/fallback
DHCPDISCOVER on ath0 to 255.255.255.255 port 67 interval 7
DHCPDISCOVER on ath0 to 255.255.255.255 port 67 interval 20
DHCPDISCOVER on ath0 to 255.255.255.255 port 67 interval 19
DHCPDISCOVER on ath0 to 255.255.255.255 port 67 interval 10
DHCPDISCOVER on ath0 to 255.255.255.255 port 67 interval 5
No DHCPOFFERS received.
No working leases in persistent database - sleeping.
done.
lepetit:/home/mouloud# nano  /var/run/dhclient.ath0.pid with pid 134518340
lepetit:/home/mouloud# /etc/init.d/networking restart
Reconfiguring network interfaces...There is already a pid file /var/run/dhclient.ath0.pid with pid 134518340
Internet Systems Consortium DHCP Client V3.1.1
Copyright 2004-2008 Internet Systems Consortium.
All rights reserved.
For info, please visit http://www.isc.org/sw/dhcp/

wifi0: unknown hardware address type 801
wifi0: unknown hardware address type 801
Listening on LPF/ath0/00:15:af:ca:17:1c
Sending on   LPF/ath0/00:15:af:ca:17:1c
Sending on   Socket/fallback
Error for wireless request "Set Encode" (8B2A) :
    invalid argument ":".
There is already a pid file /var/run/dhclient.ath0.pid with pid 134518340
Internet Systems Consortium DHCP Client V3.1.1
Copyright 2004-2008 Internet Systems Consortium.
All rights reserved.
For info, please visit http://www.isc.org/sw/dhcp/

wifi0: unknown hardware address type 801
wifi0: unknown hardware address type 801
Listening on LPF/ath0/00:15:af:ca:17:1c
Sending on   LPF/ath0/00:15:af:ca:17:1c
Sending on   Socket/fallback
DHCPDISCOVER on ath0 to 255.255.255.255 port 67 interval 3
DHCPDISCOVER on ath0 to 255.255.255.255 port 67 interval 8
DHCPDISCOVER on ath0 to 255.255.255.255 port 67 interval 20

que faire ????????????????????????????????????

La liberté d'écrire et de parler dépend soit de l'extrême bonté du prince, soit du profond esclavage du peuple. On ne permet de dire qu'à celui qui ne peut rien. DIDEROT

Hors ligne

#31 11-10-2008 22:39:23

tux12
Membre
Lieu : ./
Distrib. : Squeeze
Noyau : Linux 2.6.32-5-686-bigmem
(G)UI : KDE
Inscription : 27-02-2008

Re : [résolu] connexion wifi

Bonjour,

 Error for wireless request "Set Encode" (8B2A) :
 invalid argument ":".


J'ai l'impression qu'on a toujours un ':' (deux points) qui traîne dans le fichier interfaces.
Vérifie son fichier, tu peux utiliser par exemple la fonction de recherche de ton éditeur pour trouver tous les caractères ':'.

J'ai lu quelque part (je ne trouve plus le lien) que le "s:" exprimait le fait que la clé était donnée sous forme de caractères (string). Donc il serait nécessaire qu'elle y soit dans le cas ou tu lui mets la clé dans ce format.

Donc essaie avec soit "s:la_clé_en_string" ou simplement la clé en hexa. (toujours dans interfaces)
Le but étant de ne plus avoir le message d'erreur ci-dessus. Ensuite il restera peut-être encore un problème avec le DHCP, mais peut-être pas. A voir selon le résultat du /etc/init.d/networking restart


Sinon j'ai trouvé ce tuto pour du WPA, et sur certains forums il est question qu'en WEP ça ne fonctionne pas sans un patch, mais c'est assez ancien (début 2008) et avec un noyau 2.6.24.

Personne n'a un eeepc parmis nous?

@+

Hors ligne

#32 12-10-2008 00:36:45

mouloud7
Membre
Lieu : Guadeloupe
Distrib. : wheezy/testing
Noyau : 3.2.0.3
(G)UI : openbox
Inscription : 12-09-2008

Re : [résolu] connexion wifi

j'ai tout enlevé : s & ":" mais à la fin du networking restart,il écrit :
"no DHCPOFFERS received
No working leases in persistent database - sleeping"

ça veut dire qu'il faut configurer le DHCP manuellement ?
comment on fait ?
Merci pour tout le mal que tu te donnes !

La liberté d'écrire et de parler dépend soit de l'extrême bonté du prince, soit du profond esclavage du peuple. On ne permet de dire qu'à celui qui ne peut rien. DIDEROT

Hors ligne

#33 12-10-2008 01:15:14

Melodie
Modérateur
Lieu : Pyrénées
Inscription : 28-05-2007
Site Web

Re : [résolu] connexion wifi

J'ai pas vu "route" dans ce fil.

Après avoir désactivé la carte ethernet, en root:

#ifconfig eth0 down


en root:

#route add default gateway 192.168.1.1


(ce chiffre est celui indiqué dans la barre du navigateur IE sur le tuto de chez mediaserv, à la page Comment paramétrer ma Box Mediaserv ?

Vérifier avec la commande "route":

#route

puis donnes-nous le résultat ici. (Et lances un ping sur cette passerelle pour voir si ça passe, puis sur une adresse ip quelconque sur le web, comme www.cequetuveux.truc)


le blog d'une newbie :: Linuxvillage :: Bentovillage


À propos de l'OS dominant ::> “Il est plus facile de berner les gens que de leur faire admettre qu'ils ont été bernés” (trad d'une citation approximative de Mark Twain)

Hors ligne

#34 12-10-2008 01:34:01

mouloud7
Membre
Lieu : Guadeloupe
Distrib. : wheezy/testing
Noyau : 3.2.0.3
(G)UI : openbox
Inscription : 12-09-2008

Re : [résolu] connexion wifi

voilà

lepetit:/home/mouloud# ifconfig eth0 down
lepetit:/home/mouloud# route add default gateway 192.18.1.1
SIOCADDRT: Aucun processus de ce type
lepetit:/home/mouloud# route
Table de routage IP du noyau
Destination     Passerelle      Genmask         Indic Metric Ref    Use Iface


Rien compris...

La liberté d'écrire et de parler dépend soit de l'extrême bonté du prince, soit du profond esclavage du peuple. On ne permet de dire qu'à celui qui ne peut rien. DIDEROT

Hors ligne

#35 12-10-2008 02:40:46

tux12
Membre
Lieu : ./
Distrib. : Squeeze
Noyau : Linux 2.6.32-5-686-bigmem
(G)UI : KDE
Inscription : 27-02-2008

Re : [résolu] connexion wifi

Bonjour Melodie, et merci de ton aide. smile

J'ai pensé que le routage n'était pas pertinent, car les requêtes DHCP se font en broadcast.

DHCPDISCOVER on ath0 to 255.255.255.255 port 67 interval 3


Mais je peux me tromper (et je le prouve régulièrement wink ).

Actuellement à mon avis il manque juste une IP à notre interface wifi pour fonctionner, si les erreurs que nous avions jusqu'ici ont disparu (wifi0: unknown hardware address type 801 et Error for wireless request "Set Encode" (8B2A) ).

Par contre je ne sais pas dire actuellement pourquoi on n'obtient pas d'IP.

Mouloud7, peux tu voir sur la box quel canal (channel) est utilisé pour le wifi (et de nous dire ce qu'il en est).

Toujours sur la box, dans la section consacrée au DHCP, (onglet réseau je pense - merci Melodie pour le lien), si tu trouves quelque chose qui ressemblerait à un nombre d'IPs à affecter par DHCP. Il me semble avoir vu sur Livebox que l'on pouvait avoir soit 1 soit plusieurs IPs dispos pour le DHCP, ceci peut nous bloquer dans le cas ou une seule IP est prévue.

Ensuite, côté client, peux-tu nous donner la sortie de la commande dhclient et la copie du fichier dhclient.conf qui doit se trouver dans /etc/ ou etc/dhcp/ ou /etc/dhcp3/ ou approchant.
pour le trouver: find /etc -name dhclient.conf renvoie l'emplacement du fichier s'il existe dans /etc ou un sous répertoire.

@+

Hors ligne

#36 12-10-2008 04:41:07

mouloud7
Membre
Lieu : Guadeloupe
Distrib. : wheezy/testing
Noyau : 3.2.0.3
(G)UI : openbox
Inscription : 12-09-2008

Re : [résolu] connexion wifi

lepetit:/home/mouloud# dhclient
Internet Systems Consortium DHCP Client V3.1.1
Copyright 2004-2008 Internet Systems Consortium.
All rights reserved.
For info, please visit http://www.isc.org/sw/dhcp/

wifi0: unknown hardware address type 801
wifi0: unknown hardware address type 801
Listening on LPF/wifi0/
Sending on   LPF/wifi0/
Listening on LPF/ath0/00:15:af:ca:17:1c
Sending on   LPF/ath0/00:15:af:ca:17:1c
Listening on LPF/eth0/00:22:15:88:41:6f
Sending on   LPF/eth0/00:22:15:88:41:6f
Sending on   Socket/fallback
DHCPDISCOVER on wifi0 to 255.255.255.255 port 67 interval 7
DHCPDISCOVER on ath0 to 255.255.255.255 port 67 interval 5
DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 6
DHCPOFFER from 192.168.1.1
DHCPREQUEST on eth0 to 255.255.255.255 port 67
DHCPACK from 192.168.1.1
bound to 192.168.1.4 -- renewal in 273170 seconds.




dhclient.conf
# Configuration file for /sbin/dhclient, which is included in Debian's
#    dhcp3-client package.
#
# This is a sample configuration file for dhclient. See dhclient.conf's
#    man page for more information about the syntax of this file
#    and a more comprehensive list of the parameters understood by
#    dhclient.
#
# Normally, if the DHCP server provides reasonable information and does
#    not leave anything out (like the domain name, for example), then
#    few changes must be made to this file, if any.
#

option rfc3442-classless-static-routes code 121 = array of unsigned integer 8;

#send host-name "andare.fugue.com";
#send dhcp-client-identifier 1:0:a0:24:ab:fb:9c;
#send dhcp-lease-time 3600;
#supersede domain-name "fugue.com home.vix.com";
#prepend domain-name-servers 127.0.0.1;
request subnet-mask, broadcast-address, time-offset, routers,
    domain-name, domain-name-servers, domain-search, host-name,
    netbios-name-servers, netbios-scope, interface-mtu,
    rfc3442-classless-static-routes;
#require subnet-mask, domain-name-servers;
#timeout 60;
#retry 60;
#reboot 10;
#select-timeout 5;
#initial-interval 2;
#script "/etc/dhcp3/dhclient-script";
#media "-link0 -link1 -link2", "link0 link1";
#reject 192.33.137.209;

#alias {
#  interface "eth0";
#  fixed-address 192.5.5.213;
#  option subnet-mask 255.255.255.255;
#}

#lease {
#  interface "eth0";
#  fixed-address 192.33.137.200;
#  medium "link0 link1";
#  option host-name "andare.swiftmedia.com";
#  option subnet-mask 255.255.255.0;
#  option broadcast-address 192.33.137.255;
#  option routers 192.33.137.250;
#  option domain-name-servers 127.0.0.1;
#  renew 2 2000/1/12 00:00:01;
#  rebind 2 2000/1/12 00:00:01;
#  expire 2 2000/1/12 00:00:01;
#}

je ne comprends rien mais tout est là...

La liberté d'écrire et de parler dépend soit de l'extrême bonté du prince, soit du profond esclavage du peuple. On ne permet de dire qu'à celui qui ne peut rien. DIDEROT

Hors ligne

#37 12-10-2008 07:14:59

tux12
Membre
Lieu : ./
Distrib. : Squeeze
Noyau : Linux 2.6.32-5-686-bigmem
(G)UI : KDE
Inscription : 27-02-2008

Re : [résolu] connexion wifi

Euh ... non, pas tout.

Mouloud7, peux tu voir sur la box quel canal (channel) est utilisé pour le wifi (et de nous dire ce qu'il en est).

Toujours sur la box, dans la section consacrée au DHCP, (onglet réseau je pense - merci Melodie pour le lien), si tu trouves quelque chose qui ressemblerait à un nombre d'IPs à affecter par DHCP. Il me semble avoir vu sur Livebox que l'on pouvait avoir soit 1 soit plusieurs IPs dispos pour le DHCP, ceci peut nous bloquer dans le cas ou une seule IP est prévue.

Hors ligne

#38 12-10-2008 15:18:11

Melodie
Modérateur
Lieu : Pyrénées
Inscription : 28-05-2007
Site Web

Re : [résolu] connexion wifi

tux12, donnez-vous rendez-vous avec mouloud7 sur le chan de debian-facile, et essaie plutôt de lui faire configurer une adresse statique. C'est un poil plus long, mais une fois que ça marche ça fait des connexion plus stables d'un reboot à l'autre.

mouloud7 : l'adresse de ta passerelle semble être 192.168.1.1 et non 192.18.1.1 comme tu as écris dans "route add default gateway 192.18.1.1".

Un peu de lecture peut aider:

Qu'est-ce qu'une adresse IP
http://www.commentcamarche.net/internet/ip.php3

le blog d'une newbie :: Linuxvillage :: Bentovillage


À propos de l'OS dominant ::> “Il est plus facile de berner les gens que de leur faire admettre qu'ils ont été bernés” (trad d'une citation approximative de Mark Twain)

Hors ligne

#39 12-10-2008 17:24:03

mouloud7
Membre
Lieu : Guadeloupe
Distrib. : wheezy/testing
Noyau : 3.2.0.3
(G)UI : openbox
Inscription : 12-09-2008

Re : [résolu] connexion wifi

J'ai trouvé IP locale  192.168.1.1
et pour IP Publique 93.121.236.46

est-ce que ça sert  à quelque chose ?

La liberté d'écrire et de parler dépend soit de l'extrême bonté du prince, soit du profond esclavage du peuple. On ne permet de dire qu'à celui qui ne peut rien. DIDEROT

Hors ligne

#40 12-10-2008 19:28:33

Melodie
Modérateur
Lieu : Pyrénées
Inscription : 28-05-2007
Site Web

Re : [résolu] connexion wifi

IP locale est l'IP de ton routeur "truc-box" (autrement dit la passerelle qui doit acheminer tes requêtes, uploads, download depuis et vers le réseau à l'extérieur de chez toi) et l'autre est très probablement une IP non fixe, donc il ne te servira pas à grand-chose de la connaître. La première est celle que tu donnes à la commande 'route' afin de la faire reconnaître comme passerelle.

As-tu tenté de lire la doc vers laquelle j'ai pointé ? Lis surtout le chapitre "Classe C".

le blog d'une newbie :: Linuxvillage :: Bentovillage


À propos de l'OS dominant ::> “Il est plus facile de berner les gens que de leur faire admettre qu'ils ont été bernés” (trad d'une citation approximative de Mark Twain)

Hors ligne

#41 12-10-2008 21:57:38

mouloud7
Membre
Lieu : Guadeloupe
Distrib. : wheezy/testing
Noyau : 3.2.0.3
(G)UI : openbox
Inscription : 12-09-2008

Re : [résolu] connexion wifi

oui , j'ai lu le truc, fort intéressant !
Mais cela ne me dit pas ce que je dois faire pour que le wifi fonctionne sur ma machine....

La liberté d'écrire et de parler dépend soit de l'extrême bonté du prince, soit du profond esclavage du peuple. On ne permet de dire qu'à celui qui ne peut rien. DIDEROT

Hors ligne

#42 13-10-2008 00:42:09

mouloud7
Membre
Lieu : Guadeloupe
Distrib. : wheezy/testing
Noyau : 3.2.0.3
(G)UI : openbox
Inscription : 12-09-2008

Re : [résolu] connexion wifi

j'ai assayé de mettre une IP fixe (192....), mais ça ne fonctionne toujours pas......... sad
quelqu'un a une idée ? Une solution ???

La liberté d'écrire et de parler dépend soit de l'extrême bonté du prince, soit du profond esclavage du peuple. On ne permet de dire qu'à celui qui ne peut rien. DIDEROT

Hors ligne

#43 13-10-2008 08:28:20

Melodie
Modérateur
Lieu : Pyrénées
Inscription : 28-05-2007
Site Web

Re : [résolu] connexion wifi

Oui, soit plus précis : 192 quoi ? Il faut que l'ip soit du type : 192.168.xx.xx

Par exemple, 192.168.0.5 ou 192.168.0.8 ou 192.168.1.35 etc... les deux premiers groupes doivent être ainsi. (Pour avoir l'ip fixe sur wlan0, en root, la commade est 'ifconfig wlan0 192.168.XX.XX' où XX sont des chiffres de ton choix)

Puis dans cet ordre:

#ifconfig eth0 down

#route add default gateway 192.168.1.1 (pour renseigner l'ip de la passerelle)

puis:

#ping -c4 192.168.1.1

(Quel est le contenu de ton fichier /etc/resolv.conf ? As-tu bien l'accès par Ethernet depuis cette machine ou ai-je loupé quelque chose ?)

Ensuite copies ici les résultat de:

#ifconfig

#ifconfig -a

#iwconfig

#route

Pour refaire un point.

le blog d'une newbie :: Linuxvillage :: Bentovillage


À propos de l'OS dominant ::> “Il est plus facile de berner les gens que de leur faire admettre qu'ils ont été bernés” (trad d'une citation approximative de Mark Twain)

Hors ligne

#44 13-10-2008 15:57:17

mouloud7
Membre
Lieu : Guadeloupe
Distrib. : wheezy/testing
Noyau : 3.2.0.3
(G)UI : openbox
Inscription : 12-09-2008

Re : [résolu] connexion wifi

il répond que wlan0 n'existe pas. Dois-je essayer avec ath0 ?

La liberté d'écrire et de parler dépend soit de l'extrême bonté du prince, soit du profond esclavage du peuple. On ne permet de dire qu'à celui qui ne peut rien. DIDEROT

Hors ligne

#45 13-10-2008 19:04:37

Melodie
Modérateur
Lieu : Pyrénées
Inscription : 28-05-2007
Site Web

Re : [résolu] connexion wifi

Je ne sais pas, c'est peut-être possible, mais on pourrait savoir quelles sont les interfaces disponibles avec les commandes précitées.

(en root, ifconfig, ifconfig -a et iwconfig)

le blog d'une newbie :: Linuxvillage :: Bentovillage


À propos de l'OS dominant ::> “Il est plus facile de berner les gens que de leur faire admettre qu'ils ont été bernés” (trad d'une citation approximative de Mark Twain)

Hors ligne

#46 15-10-2008 00:15:50

mouloud7
Membre
Lieu : Guadeloupe
Distrib. : wheezy/testing
Noyau : 3.2.0.3
(G)UI : openbox
Inscription : 12-09-2008

Re : [résolu] connexion wifi

lepetit:/home/mouloud# ifconfig
ath0      Link encap:Ethernet  HWaddr 00:15:af:ca:17:1c 
          inet adr:192.168.1.7  Bcast:192.168.1.255  Masque:255.255.255.0
          adr inet6: fe80::215:afff:feca:171c/64 Scope:Lien
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:0
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

lo        Link encap:Boucle locale 
          inet adr:127.0.0.1  Masque:255.0.0.0
          adr inet6: ::1/128 Scope:Hôte
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:65 errors:0 dropped:0 overruns:0 frame:0
          TX packets:65 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:0
          RX bytes:6120 (5.9 KiB)  TX bytes:6120 (5.9 KiB)

wifi0     Link encap:UNSPEC  HWaddr 00-15-AF-CA-17-1C-61-74-00-00-00-00-00-00-00-00 
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:1585 errors:0 dropped:0 overruns:0 frame:121
          TX packets:4720 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:280
          RX bytes:172440 (168.3 KiB)  TX bytes:243803 (238.0 KiB)
          Interruption:18

lepetit:/home/mouloud# iwconfig
lo        no wireless extensions.

eth0      no wireless extensions.

wifi0     no wireless extensions.

ath0      IEEE 802.11g  ESSID:"mediaserv5734"  Nickname:""
          Mode:Managed  Frequency:2.432 GHz  Access Point: Not-Associated   
          Bit Rate:1 Mb/s   Tx-Power:17 dBm   Sensitivity=1/1 
          Retry:off   RTS thr:off   Fragment thr:off
          Encryption key:7E1D-2FA9-1559-EF64-3633-E2F5-16   Security mode:restricted
          Power Management:off
          Link Quality=65/70  Signal level=-31 dBm  Noise level=-96 dBm
          Rx invalid nwid:1  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

qu'en penser si ce n'est que ça ne fonctionne toujours pas!

La liberté d'écrire et de parler dépend soit de l'extrême bonté du prince, soit du profond esclavage du peuple. On ne permet de dire qu'à celui qui ne peut rien. DIDEROT

Hors ligne

#47 15-10-2008 16:05:53

captnfab
Admin-Girafe
Lieu : /dev/random
Distrib. : Debian Stretch/Sid/Rc-Buggy
Noyau : Linux (≥ 4.3)
(G)UI : i3-wm (≥ 4.11)
Inscription : 07-07-2008
Site Web

Re : [résolu] connexion wifi

Tant que le "iwconfig" indique "Access Point: Not-Associated", ça n'est pas la peine de réfléchir aux problèmes d'IP, dns ou autre, c'est le WiFi qui n'est pas configuré.

Primo, est-ce que ta connexion est sécurisée avec WEP, WPA ou WPA2 ?

Si WEP :
en root :

iwconfig ath0 mode managed essid mediaserv5734 key tacléenhexa


et pour vérifier :

iwconfig


qui ne devrait plus afficher « Not-Associated »…

Dernière modification par Capitaine Fab (15-10-2008 20:07:23)


captnfab,
Association Debian-Facile, bépo.
TheDoctor: Your wish is my command… But be careful what you wish for.

Hors ligne

#48 15-10-2008 18:55:39

Melodie
Modérateur
Lieu : Pyrénées
Inscription : 28-05-2007
Site Web

Re : [résolu] connexion wifi

Salut Capitaine Fab, et merci de venir à la rescousse. Allez mouloud7 ! Tu vas y arriver !  tongue

le blog d'une newbie :: Linuxvillage :: Bentovillage


À propos de l'OS dominant ::> “Il est plus facile de berner les gens que de leur faire admettre qu'ils ont été bernés” (trad d'une citation approximative de Mark Twain)

Hors ligne

#49 15-10-2008 22:30:55

mouloud7
Membre
Lieu : Guadeloupe
Distrib. : wheezy/testing
Noyau : 3.2.0.3
(G)UI : openbox
Inscription : 12-09-2008

Re : [résolu] connexion wifi

je sais pas à quoi je vais arriver, mais j'ai tapé la ligne de commande précédente... & quand je fais iwconfig... il y a toujours access point not associated...
C'est une clé wep pour répondre à ta question...

Je commence à désespérer que ça fonctionne un jour...

La liberté d'écrire et de parler dépend soit de l'extrême bonté du prince, soit du profond esclavage du peuple. On ne permet de dire qu'à celui qui ne peut rien. DIDEROT

Hors ligne

#50 15-10-2008 23:18:27

captnfab
Admin-Girafe
Lieu : /dev/random
Distrib. : Debian Stretch/Sid/Rc-Buggy
Noyau : Linux (≥ 4.3)
(G)UI : i3-wm (≥ 4.11)
Inscription : 07-07-2008
Site Web

Re : [résolu] connexion wifi

Bon, on peut toujours regarder du côté des firmware.

Après un reboot frais, fais un

ifconfig ath0 up
iwconfig ath0 mode managed essid mediaserv5734 key tacléenhexa


(En remplaçant évidemment tacléenhexa par ta clé en hexa…)

Que te dis

dmesg | tail -n20


?


captnfab,
Association Debian-Facile, bépo.
TheDoctor: Your wish is my command… But be careful what you wish for.

Hors ligne

Pied de page des forums