Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 07-01-2014 15:59:08

vincentsimonnet
Membre
Inscription : 06-11-2013

sources.list lenny obsolète

Hello !

Je reprend la gestion d'un serveur sous debian lenny et j'ai quelques questions diverses sur la mise à jour des paquets (et pourquoi pas de la distribution).

Lorsque je lance apt-get update, j'obtiens :

Atteint http://archive.debian.org lenny Release.gpg
Atteint http://archive.debian.org lenny/main Translation-fr
Ign http://archive.debian.org lenny/contrib Translation-fr
Ign http://archive.debian.org lenny/non-free Translation-fr
Réception de : 1 http://archive.debian.org lenny/updates Release.gpg [836B]
Ign http://archive.debian.org lenny/updates/main Translation-fr
Atteint http://archive.debian.org lenny Release
Réception de : 2 http://archive.debian.org lenny/updates Release [92,4kB]
Ign http://archive.debian.org lenny/updates Release
Ign http://archive.debian.org lenny/main Sources/DiffIndex
Ign http://archive.debian.org lenny/non-free Sources/DiffIndex
Réception de : 3 http://archive.debian.org lenny/contrib Sources [44,6kB]
Ign http://archive.debian.org lenny/main Packages/DiffIndex
Réception de : 4 http://archive.debian.org lenny/contrib Packages [76,2kB]
Ign http://archive.debian.org lenny/non-free Packages/DiffIndex
Réception de : 5 http://archive.debian.org lenny/updates/main Packages [346kB]
Atteint http://archive.debian.org lenny/main Sources
Atteint http://archive.debian.org lenny/non-free Sources
Atteint http://archive.debian.org lenny/main Packages
Atteint http://archive.debian.org lenny/non-free Packages
560ko réceptionnés en 13s (41,8ko/s)
Lecture des listes de paquets... Fait
W: GPG error: http://archive.debian.org lenny/updates Release: Les signatures suivantes ne sont pas valables : KEYEXPIRED 1356982504
W: Vous pouvez lancer « apt-get update » pour corriger ces problèmes.



Voici le sources.list :

deb http://archive.debian.org/debian/ lenny main contrib non-free
deb-src http://archive.debian.org/debian/ lenny main non-free contrib
deb http://archive.debian.org/debian-security lenny/updates main



Je suis pas hyper familier du sources.list, mais je sais que les maj de sécurités ne sont plus assurées sur lenny depuis mars 2012. Donc si je comprend bien je peux virer de mon sources.list la ligne :

deb http://archive.debian.org/debian-security lenny/updates main


?

Et j'ai pas trouvé grand chose traitant du sujet, mais ça me semble imprudent de rester sur lenny du coup? Cela entraine t-il des failles de sécurités? Faut-il envisager urgemment une migration sur squeeze puis wheezy pour être tranquille?

Hors ligne

#2 07-01-2014 17:18:58

pili36
Membre
Lieu : Lille
Distrib. : Debian Jessie / Raspbian Jessie
Noyau : 3.16_amd64 / 3.16_armhf
(G)UI : Mate / Lxde
Inscription : 03-11-2009

Re : sources.list lenny obsolète

Bonjour,

En effet, la version Lenny n'est plus maintenue ce qui implique que l'équipe chargée de la sécurité ne s'occupe plus de cette version et les failles de sécurité ne sont donc plus corrigées ce qui peut présenter un risque. Il est donc conseillé de migrer (si nécessaire aide ici : http://debian-facile.org/doc:migrer?s=m … %A0&s=jour) vers Squeeze ou Wheezy. Si tu choisis Squeeze, c'est une migration vers une Oldstable qui ne sera donc bientôt plus maintenue non plus (cela devrait s'arrêter début mai 2014, soit un an après la publication de wheezy), et si vers Wheezy c'est une migration vers la branche stable.

Après, d'autres l'affirmeront ou le démentiront peut être, je pense qu'il peut s'avérer dangereux (du point vue risque d'échec) de passer de Lenny à Wheezy directement.

Dernière modification par pili36 (07-01-2014 17:20:08)


Debian Jessie Amd64, Mate, Lenovo G50, Amd Q4000 4*1,3Ghz, 4Go RAM, Amd Radeon R3
Debian Jessie Amd64, (pour Steam), Mate, Amd Athlon 860K 4*3.7Ghz, 8Go RAM, AMD Radeon R7 250 2Go
Raspbian Jessie Armhf, Lxde, Raspberry Pi model B

Hors ligne

#3 07-01-2014 19:36:39

nifseg
Adhérent(e)
Lieu : Dans une forêt
Distrib. : Debian Wheezy + Jessie
Noyau : 3.2.0-4-amd64 + 3.16.0-4-686-pae
(G)UI : Gnome/Mate/Cinnamon
Inscription : 15-12-2013

Re : sources.list lenny obsolète

Entièrement d'accord avec pili36!
Pour migrer d'une lenny à une wheezy, il est plus sage de passer par squeeze

L'important n'est pas la chute mais l'atterrissage...
Chapardeur de chocolat DF!!!
Admin un jour, admin toujours...

Hors ligne

Pied de page des forums