Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 12-10-2008 01:45:11

mouloud7
Membre
Lieu : Guadeloupe
Distrib. : wheezy/testing
Noyau : 3.2.0.3
(G)UI : openbox
Inscription : 12-09-2008

aptitude...

au départ, j'ai installé sur ma lenny gnome & e17... & puis, ne me servant pas de e17 (plantages...)
Je l'ai désinstallé, mais très mal... en laissant les dépendances.
Maintenant, à chaque fois que je lance sur une console aptitude, il me propose de supprimer 480 megas de fichiers... Est-ce que je peux dire oui sans risque de massacrer mon gnome qui marche bien :

voilà ce que ça donne en console :
Les paquets suivants seront ENLEVÉS :
  cupsddk{u} cupsddk-drivers{u} evolution{u} evolution-common{u}
  evolution-exchange{u} evolution-plugins{u} evolution-webcal{u}
  festival{u} festlex-cmu{u} festlex-poslex{u} foomatic-db-gutenprint{u}
  gcalctool{u} gconf-editor{u} gdebi{u} gdebi-core{u} gedit{u}
  gedit-common{u} ggzcore-bin{u} gnome-accessibility-themes{u}
  gnome-backgrounds{u} gnome-cards-data{u} gnome-mag{u} gnome-nettool{u}
  gnome-network-admin{u} gnome-power-manager{u} gnome-screensaver{u}
  gnome-spell{u} gnome-system-tools{u} gnome-themes{u}
  gnome-themes-extras{u} gnome-vfs-obexftp{u} gnome-volume-manager{u}
  gnumeric{u} gnumeric-common{u} gstreamer0.10-ffmpeg{u}
  gstreamer0.10-gnomevfs{u} gstreamer0.10-plugins-ugly{u}
  gstreamer0.10-tools{u} gtk2-engines{u} gtk2-engines-pixbuf{u}
  gtkhtml3.14{u} gucharmap{u} ijsgutenprint{u} latex-xft-fonts{u}
  libaiksaurus-1.2-0c2a{u} libaiksaurus-1.2-data{u} libao2{u}
  libatspi1.0-0{u} libavahi-ui0{u} libbluetooth2{u} libbrlapi0.5{u}
  libcolorblind0{u} libcurl3-gnutls{u} libecore-txt0{u} libembryo0{u}
  libempathy-common{u} libempathy-gtk-common{u} libempathy14{u}
  libepc-1.0-1{u} libepc-ui-1.0-1{u} libestools1.2{u}
  libexchange-storage1.2-3{u} libgalago3{u} libgd2-noxpm{u} libgda3-3{u}
  libgda3-common{u} libgdl-1-0{u} libgdl-1-common{u} libgdl-gnome-1-0{u}
  libgdome2-0{u} libgdome2-cpp-smart0c2a{u} libggz2{u} libggzcore9{u}
  libggzmod4{u} libgif4{u} libgksu1.2-0{u} libgksuui1.0-1{u} libgmyth0{u}
  libgnome-mag2{u} libgnome-pilot2{u} libgnomevfs2-bin{u} libgoffice-0-6{u}
  libgoffice-0-6-common{u} libgoffice-0-common{u} libgpgme11{u}
  libgsf-gnome-1-114{u} libgsl0ldbl{u} libgtk-vnc-1.0-0{u} libgtkglext1{u}
  libgtkhtml3.14-19{u} libgtksourceview2.0-0{u}
  libgtksourceview2.0-common{u} libgtkspell0{u} libijs-0.35{u}
  libisccc30{u} libisccfg30{u} libkleopatra1{u}
  libmissioncontrol-client0{u} libmissioncontrol-server1{u}
  libmusicbrainz4c2a{u} libnm-glib0{u} libopenobex1{u} libperl5.10{u}
  libpisock9{u} libpisync1{u} libpt-1.10.10{u}
  libpt-1.10.10-plugins-alsa{u} libpt-1.10.10-plugins-v4l{u} libpth20{u}
  libqt4-help{u} libqt4-webkit{u} libqt4-xmlpatterns{u} libsensors3{u}
  libsidplay1{u} libsnmp-base{u} libsnmp15{u} libspeexdsp1{u}
  libswfdec-0.6-90{u} libtelepathy-glib0{u} libtelepathy2{u}
  link-grammar-dictionaries-en{u} lsb-release{u} mousetweaks{u}
  openprinting-ppds{u} p7zip{u} pkg-config{u} python-4suite-xml{u}
  python-apt{u} python-brlapi{u} python-cups{u} python-cupsutils{u}
  python-eggtrayicon{u} python-foomatic{u} python-gdata{u} python-gdbm{u}
  python-gnome2-extras{u} python-gst0.10{u} python-gtkhtml2{u}
  python-gtksourceview2{u} python-imaging{u} python-ipy{u} python-qt3{u}
  python-qt4{u} python-qt4-common{u} python-reportlab{u} python-sexy{u}
  python-sip4{u} python-vte{u} seahorse{u} sound-juicer{u} swfdec-gnome{u}
  swfdec-mozilla{u} system-config-printer{u} telepathy-mission-control{u}
  totem-common{u} totem-gstreamer{u} totem-mozilla{u} totem-plugins{u}
  ttf-dustin{u} unzip{u} vinagre{u} vino{u} xdg-utils{u} zip{u}
0 paquets mis à jour, 0 nouvellement installés, 164 à enlever et 0 non mis à jour.
Il est nécessaire de télécharger 0o d'archives. Après dépaquetage, 482Mo seront libérés.


N'y en a-t-il pas qui sont utilisés par gnome & risquent de tout massacrer ????
Sans doute la question est-elle idiote ? Mais je m'interroge,tout fonctionne bien excepté le foutu wifi...
Par avance merci !

La liberté d'écrire et de parler dépend soit de l'extrême bonté du prince, soit du profond esclavage du peuple. On ne permet de dire qu'à celui qui ne peut rien. DIDEROT

Hors ligne

#2 12-10-2008 02:05:38

martinux_qc
Administrateur
Lieu : Montréal (Québec)
Distrib. : Sid
Noyau : Linux 4.7.0-1-amd64
(G)UI : XFCE 4.12
Inscription : 12-10-2008

Re : aptitude...

Salut

Pour installer Gnome et e17, tu as sûrement du installer des méta-paquet. Ceux-ci n'installent rien en eux-mêmes, mais installent tout un tas de dépendances qui sont considérées comme installées automatiquement. Maintenant, tu as enlevé le méta-paquet pour e17 et aptitude considère qu'ils ne sont plus utiles et veut les enlever. Bien sûr ce ne pas le cas si tu désires conserver Gnome. Pour corriger la situation, tu dois lancer la commande :

aptitude install la_liste_des_paquets


Ainsi, tu n'installe pas vraiment à nouveau les paquets mais tu les fais passer en "installés manuellement" et aptitude ne voudra pas tous enlever.

Bonne chance
Martin


"L'éducation vise à former des citoyens pas trop tatas et non pas à envoyer le plus de tatas possible à l'université."
Pierre Foglia (Journaliste à la retraite à La Presse)
Note : au Québec, le mot tata a un sens péjoratif qui sert à désigner une personne un peu idiote ou insignifiante. D'où les expressions familières : Espèce de grand, de gros tata! Être, avoir l'air tata.

Hors ligne

#3 12-10-2008 02:14:30

tux12
Membre
Lieu : ./
Distrib. : Squeeze
Noyau : Linux 2.6.32-5-686-bigmem
(G)UI : KDE
Inscription : 27-02-2008

Re : aptitude...

Bonjour martin_mtl

Bienvenue sur ce forum et merci pour le coup de main smile

@+

Hors ligne

#4 12-10-2008 02:22:45

martinux_qc
Administrateur
Lieu : Montréal (Québec)
Distrib. : Sid
Noyau : Linux 4.7.0-1-amd64
(G)UI : XFCE 4.12
Inscription : 12-10-2008

Re : aptitude...

Merci pour l'accueil.

Je viens de poster un message dans la section présentation pour me faire connaître un peu plus.

"L'éducation vise à former des citoyens pas trop tatas et non pas à envoyer le plus de tatas possible à l'université."
Pierre Foglia (Journaliste à la retraite à La Presse)
Note : au Québec, le mot tata a un sens péjoratif qui sert à désigner une personne un peu idiote ou insignifiante. D'où les expressions familières : Espèce de grand, de gros tata! Être, avoir l'air tata.

Hors ligne

#5 12-10-2008 04:43:21

mouloud7
Membre
Lieu : Guadeloupe
Distrib. : wheezy/testing
Noyau : 3.2.0.3
(G)UI : openbox
Inscription : 12-09-2008

Re : aptitude...

c'est à dire tous les paquets dont j'ai fait la liste plus haut ??????

La liberté d'écrire et de parler dépend soit de l'extrême bonté du prince, soit du profond esclavage du peuple. On ne permet de dire qu'à celui qui ne peut rien. DIDEROT

Hors ligne

#6 12-10-2008 05:12:15

martinux_qc
Administrateur
Lieu : Montréal (Québec)
Distrib. : Sid
Noyau : Linux 4.7.0-1-amd64
(G)UI : XFCE 4.12
Inscription : 12-10-2008

Re : aptitude...

Salut

Dans la liste de tous les paquets de la liste, je ne sais pas s'il y en a qui sont uniquement spécifiques à e17 et qui peuvent être enlevés sans problèmes, donc qui ne pas d'autres dépendances. Tous les paquets liés à GNOME ne peuvent être enlevés à priori, sauf s'ils sont liés uniquement à une application que tu ne désires pas. Une recherche dans synaptic sur e17 peut peut-être te permettra de trouver des paquets inutiles. Comme la liste est assez longue, il est difficile d'y faire le tri. Le mieux c'est peut-être de les faire tous passer en "installés manuellement". Certains d'entre eux, vraiment inutiles, pourront sauter plus tard.

"L'éducation vise à former des citoyens pas trop tatas et non pas à envoyer le plus de tatas possible à l'université."
Pierre Foglia (Journaliste à la retraite à La Presse)
Note : au Québec, le mot tata a un sens péjoratif qui sert à désigner une personne un peu idiote ou insignifiante. D'où les expressions familières : Espèce de grand, de gros tata! Être, avoir l'air tata.

Hors ligne

#7 12-10-2008 17:26:34

mouloud7
Membre
Lieu : Guadeloupe
Distrib. : wheezy/testing
Noyau : 3.2.0.3
(G)UI : openbox
Inscription : 12-09-2008

Re : aptitude...

OK, merci pour les infos !

La liberté d'écrire et de parler dépend soit de l'extrême bonté du prince, soit du profond esclavage du peuple. On ne permet de dire qu'à celui qui ne peut rien. DIDEROT

Hors ligne

#8 12-10-2008 21:23:36

MaTTuX_
La Paillasse !!!
Lieu : Zoubidou-Land
Distrib. : 75 serveurs
Noyau : 3.2.0-4-amd64
(G)UI : tty et ... pas gnome en tout cas....
Inscription : 28-05-2007
Site Web

Re : aptitude...

deplacer dans la zone APT

\o/ Le closedSource c'est tabou on a viendra tous à bout \o/

Hors ligne

#9 12-10-2008 22:56:21

kinroux
Membre
Lieu : Boulogne/mer
Distrib. : Squeeze
Noyau : 2.6.32-5-amd64
(G)UI : Gnome
Inscription : 27-06-2008

Re : aptitude...

J'ai déjà eu le même problème...

Essaies

aptitude install gnome-desktop-environment


puis fais une mise à jour.
Normalement, tu auras beaucoup moins de paquets à supprimer...

Hors ligne

#10 13-10-2008 02:05:22

martinux_qc
Administrateur
Lieu : Montréal (Québec)
Distrib. : Sid
Noyau : Linux 4.7.0-1-amd64
(G)UI : XFCE 4.12
Inscription : 12-10-2008

Re : aptitude...

Salut

Bien sûr si on installe un méta-paquet comme gnome-desktop-environment cela peut régler les choses. Par contre, si on désire enlever une application inutile et que cela entraîne la suppression d'un méta-paquet, on doit changer le statut de tous les paquets installés automatiquement. Un méta-paquet n'est pas toujours indispensable dans le cas d'une debian.

"L'éducation vise à former des citoyens pas trop tatas et non pas à envoyer le plus de tatas possible à l'université."
Pierre Foglia (Journaliste à la retraite à La Presse)
Note : au Québec, le mot tata a un sens péjoratif qui sert à désigner une personne un peu idiote ou insignifiante. D'où les expressions familières : Espèce de grand, de gros tata! Être, avoir l'air tata.

Hors ligne

Pied de page des forums