Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 13-01-2014 21:47:50

pmignon
Membre
Lieu : Lyon
Distrib. : Squeeze
Noyau : 2.6.35-2-686 et amd64
(G)UI : KDE: 4.3
Inscription : 14-06-2008

installation BlueGriffon

Bonjour,
j'essaye d'installer BlueGriffon, un editeur HTML WYSIWYG ...
j'ai téléchargé le logiciel décompressé, puis changé le LD_LIBRARY_PATH pour qu'il trouve ses propres librairies :

pierre@dynonegro:~/bin/bluegriffon$ export LD_LIBRARY_PATH="/home/pierre/bin/bluegriffon"              
 

                                                                                 
Mais il semble y avoir un pb de version de libc:

pierre@dynonegro:~/bin/bluegriffon$ ./bluegriffon-bin
./bluegriffon-bin: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.14' not found (required by /home/pierre/bin/bluegriffon/libxul.so)                                                
./bluegriffon-bin: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.15' not found (required by /home/pierre/bin/bluegriffon/libxul.so)                                                
./bluegriffon-bin: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.14' not found (required by /home/pierre/bin/bluegriffon/libnspr4.so)                                              
./bluegriffon-bin: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.15' not found (required by /home/pierre/bin/bluegriffon/libnspr4.so)
./bluegriffon-bin: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.14' not found (required by /home/pierre/bin/bluegriffon/libplc4.so)
./bluegriffon-bin: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.14' not found (required by /home/pierre/bin/bluegriffon/libplds4.so)
 


La version que j'ai (sur un wheezy fraichement installé:

root@dynonegro:/home/pierre/bin/bluegriffon# aptitude show libc6
Paquet : libc6                                
État: installé
Automatiquement installé: non
Multiarchitecture : même
Version : 2.13-38
Priorité : nécessaire
Section : libs
Responsable : GNU Libc Maintainers <debian-glibc@lists.debian.org>
Architecture : amd64
Taille décompressée : 9 745 k
Dépend: libc-bin (= 2.13-38), libgcc1
Suggère: glibc-doc, debconf | debconf-2.0, locales
Est en conflit: prelink (<= 0.0.20090311-1), prelink (<= 0.0.20090311-1), tzdata (< 2007k-1), tzdata (< 2007k-1),
                tzdata-etch, tzdata-etch
Casse: locales (< 2.13), locales (< 2.13), locales-all (< 2.13), locales-all (< 2.13), lsb-core (<= 3.2-27), lsb-core (<=
       3.2-27), nscd (< 2.13), nscd (< 2.13), libc6 (!= 2.13-38)
Remplace: libc6-amd64, libc6-amd64, libc6 (< 2.13-38)
Fournit: glibc-2.13-1
Description : bibliothèque C GNU embarquée : bibliothèques partagées
 Ce paquet contient les bibliothèques partagées utilisées par pratiquement tous les programmes du système. Il inclut entre
 autres les versions partagées de la bibliothèque C standard et de la bibliothèque mathématique standard.
Site : http://www.eglibc.org




Donc mon interrogation: Est-il possible d'installer la bonne bersion de libc6 ?
Merci
Pierre

Hors ligne

#2 13-01-2014 22:00:11

nifseg
Adhérent(e)
Lieu : Dans une forêt
Distrib. : Debian Wheezy + Jessie
Noyau : 3.2.0-4-amd64 + 3.16.0-4-686-pae
(G)UI : Gnome/Mate/Cinnamon
Inscription : 15-12-2013

Re : installation BlueGriffon

Il vaut mieux que tu fasse un rétroportage du paquet  BlueGriffon pour que celui-ci soit compatible avec la libc6 de Wheezy
Ou sinon installer une version antérieure de BlueGriffon compatible avec Wheezy

Dernière modification par nifseg (13-01-2014 22:02:54)


L'important n'est pas la chute mais l'atterrissage...
Chapardeur de chocolat DF!!!
Admin un jour, admin toujours...

Hors ligne

Pied de page des forums