Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 23-01-2014 23:34:56

bendia
Admin stagiaire
Distrib. : Jessie
Noyau : 3.16.0-4-amd64
(G)UI : Gnome + XFCE + Console
Inscription : 20-03-2012
Site Web

lighttpd et utilisateur particulier

Bonjour

J'ai un serveur lighttpd qui fonctionne sans problème avec l'utilisateur www-data. Pour des histoire de sécurité, je souhaitais changer cet utilisateur.
J'ai donc créer un nouvel utilisateur système avec des caractéristiques identiques aux uid et gid près et un /home en /var/htdocs au lieu de /var/www.
J'ai modifier le fichier de config de lighttpd afin qu'il prenne en compte ces modifications (modification de server.root, server.username, server.groupnameen prenant soins de modifier le propriétaire des fichiers de log.
Lorsque je lance le serveur avec

service lighttpd start



J'obtiens bien un [OK], un fichier /run/lighttpd.pid est créé, mais le serveur n'est pas actif et n'est pas visible dans les processus en cours listé par ps

Qu'est ce que j'ai oublié pour que ça fonctionna  hmm


Ben
___________________
La seule question bête, c'est celle qu'on ne pose pas.
file-Re06858991f6f328b4907296ac5cea283

Hors ligne

#2 23-01-2014 23:48:02

nifseg
Adhérent(e)
Lieu : Dans une forêt
Distrib. : Debian Wheezy + Jessie
Noyau : 3.2.0-4-amd64 + 3.16.0-4-686-pae
(G)UI : Gnome/Mate/Cinnamon
Inscription : 15-12-2013

Re : lighttpd et utilisateur particulier

bendia a écrit :

Qu'est ce que j'ai oublié pour que ça fonctionna


Peut-être q'un simple :

service lighttpd  force-reload


pourrait régler l'affaire mais j'en doute...


L'important n'est pas la chute mais l'atterrissage...
Chapardeur de chocolat DF!!!
Admin un jour, admin toujours...

Hors ligne

#3 23-01-2014 23:49:31

bendia
Admin stagiaire
Distrib. : Jessie
Noyau : 3.16.0-4-amd64
(G)UI : Gnome + XFCE + Console
Inscription : 20-03-2012
Site Web

Re : lighttpd et utilisateur particulier

Non effectivement, ça marche pas (j'avais essayé et gangé un joli Fail wink

Ben
___________________
La seule question bête, c'est celle qu'on ne pose pas.
file-Re06858991f6f328b4907296ac5cea283

Hors ligne

#4 23-01-2014 23:58:18

nifseg
Adhérent(e)
Lieu : Dans une forêt
Distrib. : Debian Wheezy + Jessie
Noyau : 3.2.0-4-amd64 + 3.16.0-4-686-pae
(G)UI : Gnome/Mate/Cinnamon
Inscription : 15-12-2013

Re : lighttpd et utilisateur particulier

Et sinon lighttpd sa fonctionne bien ? Et quel sont les différences avec apache em matière de fonctionnalité?
J'envisage de me tourner vers ce serveur pour mon RPI !
Tu vas certainement te dire : "Il est ouf d'utiliser un serveur aussi lourd qu' apache pour un ordi avec aussi peu de ressources!"

L'important n'est pas la chute mais l'atterrissage...
Chapardeur de chocolat DF!!!
Admin un jour, admin toujours...

Hors ligne

#5 24-01-2014 00:00:53

bendia
Admin stagiaire
Distrib. : Jessie
Noyau : 3.16.0-4-amd64
(G)UI : Gnome + XFCE + Console
Inscription : 20-03-2012
Site Web

Re : lighttpd et utilisateur particulier

Ben il tourne sur mon RPI ce lighttpd big_smile Et je bricole pour y installer owncloud big_smile Sinon, j'ai jamais vraiment utilisé Apache donc à mon petit niveau, je ne vois pas de différence.

Ben
___________________
La seule question bête, c'est celle qu'on ne pose pas.
file-Re06858991f6f328b4907296ac5cea283

Hors ligne

#6 24-01-2014 00:07:29

nifseg
Adhérent(e)
Lieu : Dans une forêt
Distrib. : Debian Wheezy + Jessie
Noyau : 3.2.0-4-amd64 + 3.16.0-4-686-pae
(G)UI : Gnome/Mate/Cinnamon
Inscription : 15-12-2013

Re : lighttpd et utilisateur particulier

bendia a écrit :

Et je bricole pour y installer owncloud


Tu pourrais faire des modifs sur le tuto OwnCloud.(si t'as le temps et l'envie)
Je encore jamais installé ownCloud sur une de mes machines de ce fait il y aurait certainement des choses à revoir au niveau du tuto. smile
En fait si j'avais fait une install de ownCloud mais vite fait(sans aprofondir)
Et sur les dépôts du RPI ownCloud est présent par défaut alors que sur Wheezy non.

Dernière modification par nifseg (24-01-2014 00:14:41)


L'important n'est pas la chute mais l'atterrissage...
Chapardeur de chocolat DF!!!
Admin un jour, admin toujours...

Hors ligne

#7 28-01-2014 13:57:59

bendia
Admin stagiaire
Distrib. : Jessie
Noyau : 3.16.0-4-amd64
(G)UI : Gnome + XFCE + Console
Inscription : 20-03-2012
Site Web

Re : lighttpd et utilisateur particulier

Bon, le problème est contourné en modifiant uid et gid de www-data. J'ai probablement oublié de modifier des droits quelque part, mais où ?

J'ai owncloud 4 dans les dépôts de mon rpi. Je viens de voir que la version 5 était dans wheezy-backports et dans Jessie, et 6 dans sid. Donc, ça devrait venir smile

Ben
___________________
La seule question bête, c'est celle qu'on ne pose pas.
file-Re06858991f6f328b4907296ac5cea283

Hors ligne

Pied de page des forums