Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 16-10-2008 19:23:00

mouloud7
Membre
Lieu : Guadeloupe
Distrib. : wheezy/testing
Noyau : 3.2.0.3
(G)UI : openbox
Inscription : 12-09-2008

[Résolu]VLC

Petit souci avec VLC, installé avec apt, sur mon eee & debian lenny : je n'arrive pas à lire les vidéos, ou plutôt à voir les images des fichiers .avi ou .mpeg... Question son, tout fonctionne parfaitement.
Quels plugins additionnels faut-il installer ?
Par avance merci.

Dernière modification par mouloud7 (22-10-2008 03:34:36)


La liberté d'écrire et de parler dépend soit de l'extrême bonté du prince, soit du profond esclavage du peuple. On ne permet de dire qu'à celui qui ne peut rien. DIDEROT

Hors ligne

#2 16-10-2008 22:39:25

mani
Road-Runnerus digestus
Lieu : Au bout du bout
Distrib. : Jessie
Noyau : Linux 3.16.0-4-amd64
(G)UI : Mate
Inscription : 20-06-2007

Re : [Résolu]VLC

Pas besoin de plugins additionnels pour lire les vidéos vu que c'est le but de VLC. smile

Par contre tu dois avoir un problème quelque part, lance-le dans un terminal et regarde si tu n'as pas un retour d'erreur quand tu ouvres un .avi ou un .mpg.

« Those who dream by day are cognizant of many things which escape those who dream only by night. »
- Edgar Allan Poe

Hors ligne

#3 16-10-2008 23:02:35

mouloud7
Membre
Lieu : Guadeloupe
Distrib. : wheezy/testing
Noyau : 3.2.0.3
(G)UI : openbox
Inscription : 12-09-2008

Re : [Résolu]VLC

ça je sais, en théorie...! Sauf que dans synaptic, il y a plein de plugins pour vlc !

La liberté d'écrire et de parler dépend soit de l'extrême bonté du prince, soit du profond esclavage du peuple. On ne permet de dire qu'à celui qui ne peut rien. DIDEROT

Hors ligne

#4 16-10-2008 23:13:25

Melodie
Modérateur
Lieu : Pyrénées
Inscription : 28-05-2007
Site Web

Re : [Résolu]VLC

mouloud7 a écrit :

ça je sais, en théorie...! Sauf que dans synaptic, il y a plein de plugins pour vlc !


Si tu lances "apt-cache search vlc" (en user) dans une console, tu auras la liste des paquets contenant la chaîne de caractères "vlc". Si tu installes wajig, (une surcouche de apt-get, mais en console) tu peux aisément avoir des infos sur les paquets. Il suffit de lancer wajig en console, puis tu as une invite de commande JIG qui ressemble à ça:
JIG>

help te donne une liste de commandes.

detail paquet (où paquet est le nom d'un paquet) te donne des informations. Et detail peut être suivi de plusieurs options (de bavard à très très bavard).

http://www.togaware.com/linux/survivor/ … rview.html

detail Provide a detailed description of package (describe -vv)


Par exemple,

detail -vvv lenomdupaquet


le blog d'une newbie :: Linuxvillage :: Bentovillage


À propos de l'OS dominant ::> “Il est plus facile de berner les gens que de leur faire admettre qu'ils ont été bernés” (trad d'une citation approximative de Mark Twain)

Hors ligne

#5 16-10-2008 23:57:25

tux12
Membre
Lieu : ./
Distrib. : Squeeze
Noyau : Linux 2.6.32-5-686-bigmem
(G)UI : KDE
Inscription : 27-02-2008

Re : [Résolu]VLC

Oui, sinon dans Synaptic il suffit de sélectionner un paquet pour avoir la description, et la liste des formats qui sont gérés par le plugin.

Hors ligne

#6 17-10-2008 00:12:38

mouloud7
Membre
Lieu : Guadeloupe
Distrib. : wheezy/testing
Noyau : 3.2.0.3
(G)UI : openbox
Inscription : 12-09-2008

Re : [Résolu]VLC

En fait ça ne répond pas à ma question sans aucun doute idiote : quelqu'un peut-il m'expliquer pourquoi vlc qui gère en temps normal tout seul comme un grand les supports audios & vidéos ne me sort-il pas d'images quand je lui balance un .mpeg ou un .avi ? Alors que le son fonctionne très bien.
Totem lui fonctionne bien, mais j'avoue ne pas l'aimer vraiment....

La liberté d'écrire et de parler dépend soit de l'extrême bonté du prince, soit du profond esclavage du peuple. On ne permet de dire qu'à celui qui ne peut rien. DIDEROT

Hors ligne

#7 17-10-2008 01:06:11

tux12
Membre
Lieu : ./
Distrib. : Squeeze
Noyau : Linux 2.6.32-5-686-bigmem
(G)UI : KDE
Inscription : 27-02-2008

Re : [Résolu]VLC

Bonsoir,

VLC est pareil au manche de tournevis sur lequel tu peux greffer des embouts. Le manche seul ne sert à rien, mais tu peux ainsi t'adapter à de nouveaux embouts qui n'existaient même pas forcément quand tu as acheté le manche.

plus d'info sur Wikipedia.

@+

Hors ligne

#8 17-10-2008 02:23:48

martinux_qc
Administrateur
Lieu : Montréal (Québec)
Distrib. : Sid
Noyau : Linux 4.7.0-1-amd64
(G)UI : XFCE 4.12
Inscription : 12-10-2008

Re : [Résolu]VLC

Salut

Tu dois sûrement utiliser les dépôts debian-multimedia : debian-multimedia. Si tu consultes la page d'accueil, tu peux y voir la mention d'un problème existant entre certains paquets des dépôts Debian officiel et ceux de debian multimédia. Ce problème ne semble donc pas être réglé.

En principe, pour que vlc fonctionne correctement il faudrait utiliser les depot Debian officiel pour ces paquets : vlc, ffmpeg libavcodec51 libavdevice52 libavformat52 libavutil49 libpostproc51 libswscale. Une fois cela fait, il faut faire un

rm ~/.vlc/cache/plugins-*.dat


Après cela, vlc devrait fonctionner correctement.

Je ne sais pas si tu utilises un fichier preferences en plus de ton fichier sources.list. Si c'est le cas, il faudrait y apporter des modifications pour piger en priorités dans les dépôts officiels. Enfin avant d'installer les paquets officiels, il serait bon de faire une simulation, par un apt-get -s, pour voir si cela n'implique pas top de modifications et si l'opération est faisable.

Dernière modification par martinux_qc (17-10-2008 02:24:14)


"L'éducation vise à former des citoyens pas trop tatas et non pas à envoyer le plus de tatas possible à l'université."
Pierre Foglia (Journaliste à la retraite à La Presse)
Note : au Québec, le mot tata a un sens péjoratif qui sert à désigner une personne un peu idiote ou insignifiante. D'où les expressions familières : Espèce de grand, de gros tata! Être, avoir l'air tata.

Hors ligne

#9 17-10-2008 08:40:38

mani
Road-Runnerus digestus
Lieu : Au bout du bout
Distrib. : Jessie
Noyau : Linux 3.16.0-4-amd64
(G)UI : Mate
Inscription : 20-06-2007

Re : [Résolu]VLC

C'est pas idiot le coup du VLC de Debian-multimedia, j'ai déjà entendu parler de problèmes à ce niveau là en effet. En tout cas ce n'est pas un problème de plugin, ça c'est certain, VLC n'en a jamais eu besoin pour lire de l'avi ou du mpeg.

Et si ça marche pas, retourne au post #2 pour qu'on ait des indications.

« Those who dream by day are cognizant of many things which escape those who dream only by night. »
- Edgar Allan Poe

Hors ligne

#10 17-10-2008 18:16:49

tux12
Membre
Lieu : ./
Distrib. : Squeeze
Noyau : Linux 2.6.32-5-686-bigmem
(G)UI : KDE
Inscription : 27-02-2008

Re : [Résolu]VLC

Bonjour,

Effectivement Mani, tu as raison, vlc me lit les .avi sans que je n'ai installé aucun des pluggins proposés.:|
Au temps pour moi donc.

@+

Hors ligne

#11 17-10-2008 20:53:43

n3os
Modérateur
Lieu : /Debian/Home/neos
Distrib. : Sid
Noyau : 2.6.35
(G)UI : e17
Inscription : 14-07-2007

Re : [Résolu]VLC

Hello,

effectivement le souci provient des versions de paquets libavcodec51 libavdevice52.....
pris dans le dépôt multimedia, il est donc préférable de mettre une priorité plus grande pour les dépôts officiels
exemple avec testing:

Package: *
Pin: release o=Debian,a=testing
Pin-priority: 970

Package: *
Pin: release o=Unofficial Multimedia Packages,a=testing
Pin-priority: 960


puis :
désinstalle le --> # apt-get remove --purge vlc
ensuite --> # apt-get remove --purge ffmpeg libavcodec51 libavdevice52 libavformat52 libavutil49 libpostproc51 libswscale
ensuite --> # apt-get autoremove
tu supprimes son cache --> $ rm ~/.vlc/cache/plugins-*.dat

puis réinstaller vlc.

Hors ligne

#12 17-10-2008 22:00:54

mouloud7
Membre
Lieu : Guadeloupe
Distrib. : wheezy/testing
Noyau : 3.2.0.3
(G)UI : openbox
Inscription : 12-09-2008

Re : [Résolu]VLC

Procédure appliquée à la lettre sauf que ça bugue dès la 2ème commande
# apt-get remove --purge ffmpeg libavcodec51 libavdevice52 libavformat52 libavutil49 libpostproc51 libswscale
Il ne se passe rien car ces codecs ne sont pas installés me renvoie la console...
En terminant l'installation, VLC fonctionne toujours de la même manière : son impec, pas d'image !

La liberté d'écrire et de parler dépend soit de l'extrême bonté du prince, soit du profond esclavage du peuple. On ne permet de dire qu'à celui qui ne peut rien. DIDEROT

Hors ligne

#13 19-10-2008 02:02:36

martinux_qc
Administrateur
Lieu : Montréal (Québec)
Distrib. : Sid
Noyau : Linux 4.7.0-1-amd64
(G)UI : XFCE 4.12
Inscription : 12-10-2008

Re : [Résolu]VLC

Salut

Si je comprends bien, tu ne peux pas enlever les paquets mentionnés parce qu'ils ne sont pas installés. As-tu essayé de les installer en prenant soin de choisir ceux qui sont présents dans le dépôt debian officiel (je parle de tous les paquets mentionnés dans mon message précédent).

"L'éducation vise à former des citoyens pas trop tatas et non pas à envoyer le plus de tatas possible à l'université."
Pierre Foglia (Journaliste à la retraite à La Presse)
Note : au Québec, le mot tata a un sens péjoratif qui sert à désigner une personne un peu idiote ou insignifiante. D'où les expressions familières : Espèce de grand, de gros tata! Être, avoir l'air tata.

Hors ligne

#14 20-10-2008 13:14:44

mouloud7
Membre
Lieu : Guadeloupe
Distrib. : wheezy/testing
Noyau : 3.2.0.3
(G)UI : openbox
Inscription : 12-09-2008

Re : [Résolu]VLC

Comment fait-on cette manip ?

La liberté d'écrire et de parler dépend soit de l'extrême bonté du prince, soit du profond esclavage du peuple. On ne permet de dire qu'à celui qui ne peut rien. DIDEROT

Hors ligne

#15 20-10-2008 20:14:32

Melodie
Modérateur
Lieu : Pyrénées
Inscription : 28-05-2007
Site Web

Re : [Résolu]VLC

Tu peux commenter les lignes des dépôts non officiels dans le fichier /etc/apt/sources.list, (ou configurer les dépôts dans Synaptic, ça revient au même) ou encore définir tes préférences avec apt-pinning (url déjà donnée précédemment et que tu n'auras pas manqué d'étudier ainsi que les explications donnée par neos ci-dessus.  wink  )

le blog d'une newbie :: Linuxvillage :: Bentovillage


À propos de l'OS dominant ::> “Il est plus facile de berner les gens que de leur faire admettre qu'ils ont été bernés” (trad d'une citation approximative de Mark Twain)

Hors ligne

#16 21-10-2008 21:27:58

mouloud7
Membre
Lieu : Guadeloupe
Distrib. : wheezy/testing
Noyau : 3.2.0.3
(G)UI : openbox
Inscription : 12-09-2008

Re : [Résolu]VLC

j'ai commenté les lignes dans les dépots, j'ai réinstallé VLC... & il ne se passe toujours strictement rien... !
J'ai le son, mais pas d'image... !
Une idée ????

La liberté d'écrire et de parler dépend soit de l'extrême bonté du prince, soit du profond esclavage du peuple. On ne permet de dire qu'à celui qui ne peut rien. DIDEROT

Hors ligne

#17 22-10-2008 00:15:14

Melodie
Modérateur
Lieu : Pyrénées
Inscription : 28-05-2007
Site Web

Re : [Résolu]VLC

Oui, essaie d'autres vidéos, et aussi d'autres lecteurs (totem, mplayer). avi est un conteneur, donc pour en lire le contenu, il faut savoir ce qui est à l'intérieur comme format.

(On peut accéder au contenu d'un .avi, depuis mc il me semble).

Quelques liens...

http://packages.debian.org/fr/etch/kde/codeine

http://www.libordux.org/doc/debian/sound-and-video.php

http://forum.hardware.fr/hfr/OSAlternat … 8842_1.htm

le blog d'une newbie :: Linuxvillage :: Bentovillage


À propos de l'OS dominant ::> “Il est plus facile de berner les gens que de leur faire admettre qu'ils ont été bernés” (trad d'une citation approximative de Mark Twain)

Hors ligne

#18 22-10-2008 01:07:24

mouloud7
Membre
Lieu : Guadeloupe
Distrib. : wheezy/testing
Noyau : 3.2.0.3
(G)UI : openbox
Inscription : 12-09-2008

Re : [Résolu]VLC

ça marche impec sous totem, là est le hic !

La liberté d'écrire et de parler dépend soit de l'extrême bonté du prince, soit du profond esclavage du peuple. On ne permet de dire qu'à celui qui ne peut rien. DIDEROT

Hors ligne

#19 22-10-2008 01:59:30

martinux_qc
Administrateur
Lieu : Montréal (Québec)
Distrib. : Sid
Noyau : Linux 4.7.0-1-amd64
(G)UI : XFCE 4.12
Inscription : 12-10-2008

Re : [Résolu]VLC

Salut

As-tu bien vérifié que vlc et tous les autres paquets mentionnés précédemment proviennent des dépôts officiels de debian et non de debian-multimedia ? De plus, si c'est le cas, as-tu bien supprimé le cache de vlc avant de le relancer ?

"L'éducation vise à former des citoyens pas trop tatas et non pas à envoyer le plus de tatas possible à l'université."
Pierre Foglia (Journaliste à la retraite à La Presse)
Note : au Québec, le mot tata a un sens péjoratif qui sert à désigner une personne un peu idiote ou insignifiante. D'où les expressions familières : Espèce de grand, de gros tata! Être, avoir l'air tata.

Hors ligne

#20 22-10-2008 03:33:29

mouloud7
Membre
Lieu : Guadeloupe
Distrib. : wheezy/testing
Noyau : 3.2.0.3
(G)UI : openbox
Inscription : 12-09-2008

Re : [Résolu]VLC

merci !
J'avais effectivement oublié cette dernière manip ! ça fonctionne impec !

La liberté d'écrire et de parler dépend soit de l'extrême bonté du prince, soit du profond esclavage du peuple. On ne permet de dire qu'à celui qui ne peut rien. DIDEROT

Hors ligne

#21 05-11-2008 20:07:40

blux
Membre
Distrib. : Wheezy
Noyau : Linux 3.1.0-1-686-pae
(G)UI : gnome3
Inscription : 05-11-2008

Re : [Résolu]VLC

neos a écrit :

Hello,

effectivement le souci provient des versions de paquets libavcodec51 libavdevice52.....
pris dans le dépôt multimedia, il est donc préférable de mettre une priorité plus grande pour les dépôts officiels
exemple avec testing:

Package: *
Pin: release o=Debian,a=testing
Pin-priority: 970

Package: *
Pin: release o=Unofficial Multimedia Packages,a=testing
Pin-priority: 960


Bonjour,

J'ai le meme probleme.
Je n'ai pas bien compris la manip a faire entre les balises code
Faut il rajouter cela dans le sources.list ?

Merci d'avance

Hors ligne

#22 05-11-2008 20:21:43

mani
Road-Runnerus digestus
Lieu : Au bout du bout
Distrib. : Jessie
Noyau : Linux 3.16.0-4-amd64
(G)UI : Mate
Inscription : 20-06-2007

Re : [Résolu]VLC

Bonjour, et bienvenue !

Ce qu'il y a entre les balises code est à copier dans le fichier /etc/apt/preferences . Tu auras plus d'infos par ici.

« Those who dream by day are cognizant of many things which escape those who dream only by night. »
- Edgar Allan Poe

Hors ligne

#23 05-11-2008 21:32:55

blux
Membre
Distrib. : Wheezy
Noyau : Linux 3.1.0-1-686-pae
(G)UI : gnome3
Inscription : 05-11-2008

Re : [Résolu]VLC

Merci : )

J'ai effectué les étapes suivantes :

- j'ai crée un fichier /etc/apt/preferences avec

Package: *
Pin: release o=Debian,a=testing
Pin-priority: 970

Package: *
Pin: release o=Unofficial Multimedia Packages,a=testing
Pin-priority: 960


- puis j'ai envoyé les commandes suivantes :

neos a écrit :

désinstalle le --> # apt-get remove --purge vlc
ensuite --> # apt-get remove --purge ffmpeg libavcodec51 libavdevice52 libavformat52 libavutil49 libpostproc51 libswscale
ensuite --> # apt-get autoremove
tu supprimes son cache --> $ rm ~/.vlc/cache/plugins-*.dat

puis réinstaller vlc.


Mais je n'ai toujours que le son, et pas d'image.  Aurais-je oublié quelque chose ?

Hors ligne

#24 15-03-2009 11:22:05

Melodie
Modérateur
Lieu : Pyrénées
Inscription : 28-05-2007
Site Web

Re : [Résolu]VLC

Mais je n'ai toujours que le son, et pas d'image.  Aurais-je oublié quelque chose ?


au hasard, as-tu installé libavcodec51 et libavdevice52 depuis les dépôts officiels ?

(sinon, relis tout le fil et refais toutes les étapes chez toi).


le blog d'une newbie :: Linuxvillage :: Bentovillage


À propos de l'OS dominant ::> “Il est plus facile de berner les gens que de leur faire admettre qu'ils ont été bernés” (trad d'une citation approximative de Mark Twain)

Hors ligne

#25 16-03-2009 02:25:29

martinux_qc
Administrateur
Lieu : Montréal (Québec)
Distrib. : Sid
Noyau : Linux 4.7.0-1-amd64
(G)UI : XFCE 4.12
Inscription : 12-10-2008

Re : [Résolu]VLC

Melodie a écrit :

Mais je n'ai toujours que le son, et pas d'image.  Aurais-je oublié quelque chose ?


au hasard, as-tu installé libavcodec51 et libavdevice52 depuis les dépôts officiels ?

(sinon, relis tout le fil et refais toutes les étapes chez toi).


Melodie, le message auquel tu fais référence date du 05-11-2008. J'espère que cette personne a trouvé la solution à son problème.;)

Martin


"L'éducation vise à former des citoyens pas trop tatas et non pas à envoyer le plus de tatas possible à l'université."
Pierre Foglia (Journaliste à la retraite à La Presse)
Note : au Québec, le mot tata a un sens péjoratif qui sert à désigner une personne un peu idiote ou insignifiante. D'où les expressions familières : Espèce de grand, de gros tata! Être, avoir l'air tata.

Hors ligne

Pied de page des forums