Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 06-02-2014 17:54:16

sogal
Black Metal Modo
Distrib. : Debian Testing
Noyau : 4.7
(G)UI : Gnome
Inscription : 09-05-2013
Site Web

[RÉSOLU mais NON] Lecteur CD audio: pas de son

Bonjour,

Debian est installée depuis longtemps mais c'est la première fois que j'essayais d'écouter un CD audio avec mon ordinateur.

Le problème est que la lecture se lance, mais que je n'ai pas de son (ce qui est quand même l'effet recherché smile )

Le CD est bien reconnu, je peux l'extraire avec abcde, cd paranoia. Le listing des tracks apparait bien sous VLC par exemple, la lecture se lance, mais non ça ne joue rien.
Pourtant j'ai du son sur mon système, aucune problème de base à ce niveau là.

Une idée car là je sèche un peu...

Merci à vous.

Dernière modification par sogal (06-02-2014 18:26:42)


Machine perso : Thinkpad x230 Debian Stretch | Machine pro : Thinpad T450 openSUSE Leap 42.2

Hors ligne

#2 06-02-2014 18:09:54

MicP
Invité

Re : [RÉSOLU mais NON] Lecteur CD audio: pas de son

Bonjour,

Est-ce que ton lecteur CD est bien connecté à la carte son (ou à la carte mère) par un cordon audio ?
Est-que tu utilise "alsamixer" pour activer/désactiver et régler les sorties son ?

Les commandes et sorties numériques ne passent pas par le même câble que la sortie CD Audio.

Dernière modification par MicP (06-02-2014 18:14:36)

#3 06-02-2014 18:17:15

sogal
Black Metal Modo
Distrib. : Debian Testing
Noyau : 4.7
(G)UI : Gnome
Inscription : 09-05-2013
Site Web

Re : [RÉSOLU mais NON] Lecteur CD audio: pas de son

Bon alors là, je n'y comprends plus rien... je galère depuis 2h: rien.
Je boote sur ma partition de test qui contient Mageia4 pour vérifier: ça fonctionne.
Retour sous Wheezy, je vérifie la présence de certaines librairies: tout OK elles étaient déjà installées, je réessaye avec VLC: et boom ça marche... mad

Comment passer pour un couillon avec un post qui sert à rien... lol

M'enfin, merci tout de même à toi pour avoir pris le temps de me répondre!

Machine perso : Thinkpad x230 Debian Stretch | Machine pro : Thinpad T450 openSUSE Leap 42.2

Hors ligne

#4 06-02-2014 18:27:44

MicP
Invité

Re : [RÉSOLU mais NON] Lecteur CD audio: pas de son

C'était avec un très grand plaisir de toutes façons, smile

Content que tu puisse de détendre en musique. cool

#5 06-02-2014 18:29:09

sogal
Black Metal Modo
Distrib. : Debian Testing
Noyau : 4.7
(G)UI : Gnome
Inscription : 09-05-2013
Site Web

Re : [RÉSOLU mais NON] Lecteur CD audio: pas de son

Bon...hem...en fait cela fonctionne bel et bien avec VLC, mais si j'utilise un lecteur en CLI, par exemple mcdp ou cdcd, toujours pas de son.
Pourtant la lecture démarre et le son est bien réglé:

sogal: ~ > cdcd getvol
         Left  Right
Front     255    255
Back        0      0
sogal: ~ > cdcd info
Album name:    
Total tracks:   14      Disc playing:   02:50 of 44:55
Playing:         02 01:04 of 03:47
 



(le "Back 0 0" c'est normal).

On dirait qu'il manque un "composant" logiciel pour faire le lien entre un lecteur en mode texte et la gestion du son...


Machine perso : Thinkpad x230 Debian Stretch | Machine pro : Thinpad T450 openSUSE Leap 42.2

Hors ligne

#6 06-02-2014 18:44:29

sogal
Black Metal Modo
Distrib. : Debian Testing
Noyau : 4.7
(G)UI : Gnome
Inscription : 09-05-2013
Site Web

Re : [RÉSOLU mais NON] Lecteur CD audio: pas de son

Bon, en fait on dirait bien que j'ai la réponse au problème:

https://lists.gnu.org/archive/html/libc … 00001.html

Si j'ai bien tout compris, les applications graphiques ont recours à un certain mode de lecture du lecteur CD qui fait transiter le flux et le son via le CPU et Alsa. Et les applications plus basiques ont recours uniquement aux capacités du lecteur CD qui gère lui-même le son.

Il faudrait comme tu l'avais suggéré,relier le lecteur à la carte mère mais sur un portable c'est une bidouille que je ne veux pas tenter, le hardware n'est pas mon fort. hmm

Machine perso : Thinkpad x230 Debian Stretch | Machine pro : Thinpad T450 openSUSE Leap 42.2

Hors ligne

Pied de page des forums