Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 09-02-2014 21:26:23

ecureuil
Membre
Inscription : 09-02-2014

installation debian wheezy avec carte mère asus H81 plus (UEFI)

bonjour,

J'ai récupéré le pc d'un ami qui n'arrivait pas à installer wheezy.

Carte mère 'asus H81 plus'  avec bios uefi :

dmidecode -t bios


# dmidecode 2.11
SMBIOS 2.7 present.

Handle 0x0000, DMI type 0, 24 bytes
BIOS Information
    Vendor: American Megatrends Inc.
    Version: 0704
    Release Date: 11/11/2013
    Address: 0xF0000
    Runtime Size: 64 kB
    ROM Size: 8192 kB
    Characteristics:
        PCI is supported
        APM is supported
        BIOS is upgradeable
        BIOS shadowing is allowed
        Boot from CD is supported
        Selectable boot is supported
        BIOS ROM is socketed
        EDD is supported
        5.25"/1.2 MB floppy services are supported (int 13h)
        3.5"/720 kB floppy services are supported (int 13h)
        3.5"/2.88 MB floppy services are supported (int 13h)
        Print screen service is supported (int 5h)
        8042 keyboard services are supported (int 9h)
        Serial services are supported (int 14h)
        Printer services are supported (int 17h)
        ACPI is supported
        USB legacy is supported
        BIOS boot specification is supported
        Targeted content distribution is supported
        UEFI is supported
    BIOS Revision: 4.6

Handle 0x004D, DMI type 13, 22 bytes
BIOS Language Information
    Language Description Format: Long
    Installable Languages: 8
        en|US|iso8859-1
        fr|FR|iso8859-1
        es|ES|iso8859-1
        de|DE|iso8859-1
        ru|RU|iso8859-5
        ko|KR|unicode
        ja|JP|unicode
        zh|CN|unicode
    Currently Installed Language: fr|FR|iso8859-1



Après une multitude d'installation et de réglage du bios, le pc de rleb fonctionne.

J'ai gravé une netinstall de debian 7.3
J'ai remis les réglages d'usine du bios de la carte mère.

secure-boot = uefi en premier et legacy en second.

J'ai mis le cd net-install... il a été reconnu tout de suite.
J'avais vu que dans /boot/grub du cd il y avait efi

ls -al /media/Debian\ 7.3.0\ amd64\ 1/boot/grub/


total 490
dr-xr-xr-x 1 anne anne   2048 déc.  15 05:55 .
dr-xr-xr-x 1 anne anne   2048 déc.  15 05:55 ..
-r--r--r-- 1 anne anne 458752 déc.  15 05:55 efi.img
-r--r--r-- 1 anne anne   4987 juil.  3  2013 font.pf2
-r--r--r-- 1 anne anne   8612 déc.  15 05:55 grub.cfg
dr-xr-xr-x 1 anne anne   2048 déc.  15 05:55 theme
dr-xr-xr-x 1 anne anne  22528 déc.  12 07:15 x86_64-efi



et j'ai lancé l'installation

Au niveau du partitionnement, il restait une partition de 1mo qui était en premier sans nom sans rien.
J'ai enlevé toutes les partitions et j'ai refait comme rleb voulait.
/boot de 1go, swap de 8 go, / de 30 go et le reste pour /home

/boot est dans une partition primaire, le reste en étendu.

J'ai dit de mettre grub sur /dev/sda

et au miracle au premier boot du pc, cela fonctionnait.

Dans /boot pas de efi mais une vmlinuz...

Je n'ai pas tout compris comment cela pouvait fonctionner...

S'il y a des pros qui ont testé.

Anne

Hors ligne

#2 09-02-2014 21:29:42

captnfab
Admin-Girafe
Lieu : /dev/random
Distrib. : Debian Stretch/Sid/Rc-Buggy
Noyau : Linux (≥ 4.3)
(G)UI : i3-wm (≥ 4.11)
Inscription : 07-07-2008
Site Web

Re : installation debian wheezy avec carte mère asus H81 plus (UEFI)

Merci de ton retour smile
Je pense que c'est le boot legacy qui est fonctionnel.

captnfab,
Association Debian-Facile, bépo.
TheDoctor: Your wish is my command… But be careful what you wish for.

Hors ligne

Pied de page des forums