Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 10-02-2014 22:23:12

billoute94
Membre
Distrib. : Wheezy 7.4
Noyau : Linux 3.9.0
(G)UI : Gnome3
Inscription : 10-02-2014

[Résolu] Problème de dépendances ?

Hello les amis !

J'utilise un pc portable sous Wheezy (arch : amd64)
Ce matin j'ai lancé un apt-get update suivi d'un apt-get dist-upgrade.

Depuis j'ai le problème suivant lorsque j'installe ou désinstalle un paquet (exemple avec le logiciel planner)

aptitude install planner


Les NOUVEAUX paquets suivants vont être installés :
  planner
Les paquets partiellement installés suivants seront configurés :
  apache2 apache2-mpm-prefork apache2.2-common cups libapache2-mod-php5 libnss-winbind libpam-winbind libvirt-bin mysql-server mysql-server-5.5 samba swat winbind
0 paquets mis à jour, 1 nouvellement installés, 0 à enlever et 0 non mis à jour.
Il est nécessaire de télécharger 490 ko d'archives. Après dépaquetage, 1 174 ko seront utilisés.
Prendre :  1 [url]http://ftp.fr.debian.org/debian/[/url] stable/main planner amd64 0.14.6-1 [490 kB]
 490 ko téléchargés en 0s (584 ko/s)
Sélection du paquet planner précédemment désélectionné.
(Lecture de la base de données... 237792 fichiers et répertoires déjà installés.)
Dépaquetage de planner (à partir de .../planner_0.14.6-1_amd64.deb) ...
Traitement des actions différées (« triggers ») pour « gconf2 »...
Traitement des actions différées (« triggers ») pour « menu »...
Traitement des actions différées (« triggers ») pour « man-db »...
Paramétrage de cups (1.5.3-5+deb7u1) ...
insserv: warning: script 'iptables.sh' missing LSB tags and overrides
insserv: There is a loop between service collectl and iptables.sh if stopped
insserv:  loop involving service iptables.sh at depth 2
insserv:  loop involving service collectl at depth 1
insserv: Stopping iptables.sh depends on collectl and therefore on system facility `$all' which can not be true!
insserv: exiting now without changing boot order!
update-rc.d: error: insserv rejected the script header
dpkg: erreur de traitement de cups (--configure) :
 le sous-processus script post-installation installé a retourné une erreur de sortie d'état 1
Paramétrage de winbind (2:3.6.6-6+deb7u2) ...
insserv: warning: script 'iptables.sh' missing LSB tags and overrides
insserv: There is a loop between service collectl and iptables.sh if stopped
insserv:  loop involving service iptables.sh at depth 2
insserv:  loop involving service collectl at depth 1
insserv: Stopping iptables.sh depends on collectl and therefore on system facility `$all' which can not be true!
insserv: exiting now without changing boot order!
update-rc.d: error: insserv rejected the script header
dpkg: erreur de traitement de winbind (--configure) :
 le sous-processus script post-installation installé a retourné une erreur de sortie d'état 1
dpkg: des problèmes de dépendances empêchent la configuration de libnss-winbind:amd64 :
 libnss-winbind:amd64 dépend de winbind (= 2:3.6.6-6+deb7u2) ; cependant :
 Le paquet winbind n'est pas encore configuré.

dpkg: erreur de traitement de libnss-winbind:amd64 (--configure) :
 problèmes de dépendances - laissé non configuré
dpkg: des problèmes de dépendances empêchent la configuration de libpam-winbind:amd64 :
 libpam-winbind:amd64 dépend de winbind (= 2:3.6.6-6+deb7u2) ; cependant :
 Le paquet winbind n'est pas encore configuré.

dpkg: erreur de traitement de libpam-winbind:amd64 (--configure) :
 problèmes de dépendances - laissé non configuré
Paramétrage de mysql-server-5.5 (5.5.35+dfsg-0+wheezy1) ...
[ ok ] Stopping MySQL database server: mysqld.
insserv: warning: script 'iptables.sh' missing LSB tags and overrides
insserv: There is a loop between service collectl and iptables.sh if stopped
insserv:  loop involving service iptables.sh at depth 2
insserv:  loop involving service collectl at depth 1
insserv: Stopping iptables.sh depends on collectl and therefore on system facility `$all' which can not be true!
insserv: exiting now without changing boot order!
update-rc.d: error: insserv rejected the script header
dpkg: erreur de traitement de mysql-server-5.5 (--configure) :
 le sous-processus script post-installation installé a retourné une erreur de sortie d'état 1
Paramétrage de samba (2:3.6.6-6+deb7u2) ...
insserv: warning: script 'iptables.sh' missing LSB tags and overrides
insserv: There is a loop between service collectl and iptables.sh if stopped
insserv:  loop involving service iptables.sh at depth 2
insserv:  loop involving service collectl at depth 1
insserv: Stopping iptables.sh depends on collectl and therefore on system facility `$all' which can not be true!
insserv: exiting now without changing boot order!
update-rc.d: error: insserv rejected the script header
dpkg: erreur de traitement de samba (--configure) :
 le sous-processus script post-installation installé a retourné une erreur de sortie d'état 1
dpkg: des problèmes de dépendances empêchent la configuration de swat :
 swat dépend de samba (= 2:3.6.6-6+deb7u2) ; cependant :
 Le paquet samba n'est pas encore configuré.

dpkg: erreur de traitement de swat (--configure) :
 problèmes de dépendances - laissé non configuré
Paramétrage de apache2.2-common (2.2.22-13+deb7u1) ...
insserv: warning: script 'iptables.sh' missing LSB tags and overrides
insserv: There is a loop between service collectl and iptables.sh if stopped
insserv:  loop involving service iptables.sh at depth 2
insserv:  loop involving service collectl at depth 1
insserv: Stopping iptables.sh depends on collectl and therefore on system facility `$all' which can not be true!
insserv: exiting now without changing boot order!
update-rc.d: error: insserv rejected the script header
dpkg: erreur de traitement de apache2.2-common (--configure) :
 le sous-processus script post-installation installé a retourné une erreur de sortie d'état 1
dpkg: des problèmes de dépendances empêchent la configuration de apache2-mpm-prefork :
 apache2-mpm-prefork dépend de apache2.2-common (= 2.2.22-13+deb7u1) ; cependant :
 Le paquet apache2.2-common n'est pas encore configuré.

dpkg: erreur de traitement de apache2-mpm-prefork (--configure) :
 problèmes de dépendances - laissé non configuré
dpkg: des problèmes de dépendances empêchent la configuration de apache2 :
 apache2 dépend de apache2-mpm-worker (= 2.2.22-13+deb7u1) | apache2-mpm-prefork (= 2.2.22-13+deb7u1) | apache2-mpm-event (= 2.2.22-13+deb7u1) | apache2-mpm-itk (= 2.2.22-13+deb7u1) ; cependant :
  Le paquet apache2-mpm-worker n'est pas installé.
 Le paquet apache2-mpm-prefork n'est pas encore configuré.
  Le paquet apache2-mpm-event n'est pas installé.
  Le paquet apache2-mpm-itk n'est pas installé.
 apache2 dépend de apache2.2-common (= 2.2.22-13+deb7u1) ; cependant :
 Le paquet apache2.2-common n'est pas encore configuré.

dpkg: erreur de traitement de apache2 (--configure) :
 problèmes de dépendances - laissé non configuré
dpkg: des problèmes de dépendances empêchent la configuration de libapache2-mod-php5 :
 libapache2-mod-php5 dépend de apache2-mpm-prefork (>> 2.0.52) | apache2-mpm-itk ; cependant :
 Le paquet apache2-mpm-prefork n'est pas encore configuré.
  Le paquet apache2-mpm-itk n'est pas installé.
 libapache2-mod-php5 dépend de apache2.2-common ; cependant :
 Le paquet apache2.2-common n'est pas encore configuré.

dpkg: erreur de traitement de libapache2-mod-php5 (--configure) :
 problèmes de dépendances - laissé non configuré
Paramétrage de libvirt-bin (0.9.12.3-1) ...
L'utilisateur « libvirt-qemu » appartient déjà au groupe « libvirt-qemu ».
[ ok ] Stopping libvirt management daemon: libvirtd not running.
insserv: warning: script 'iptables.sh' missing LSB tags and overrides
insserv: There is a loop between service collectl and iptables.sh if stopped
insserv:  loop involving service iptables.sh at depth 2
insserv:  loop involving service collectl at depth 1
insserv: Stopping iptables.sh depends on collectl and therefore on system facility `$all' which can not be true!
insserv: exiting now without changing boot order!
update-rc.d: error: insserv rejected the script header
dpkg: erreur de traitement de libvirt-bin (--configure) :
 le sous-processus script post-installation installé a retourné une erreur de sortie d'état 1
dpkg: des problèmes de dépendances empêchent la configuration de mysql-server :
 mysql-server dépend de mysql-server-5.5 ; cependant :
 Le paquet mysql-server-5.5 n'est pas encore configuré.

dpkg: erreur de traitement de mysql-server (--configure) :
 problèmes de dépendances - laissé non configuré
Paramétrage de planner (0.14.6-1) ...
Traitement des actions différées (« triggers ») pour « menu »...
Des erreurs ont été rencontrées pendant l'exécution :
 cups
 winbind
 libnss-winbind:amd64
 libpam-winbind:amd64
 mysql-server-5.5
 samba
 swat
 apache2.2-common
 apache2-mpm-prefork
 apache2
 libapache2-mod-php5
 libvirt-bin
 mysql-server
E: Sub-process /usr/bin/dpkg returned an error code (1)
Échec de l'installation d'un paquet. Tentative de réparation :
Paramétrage de samba (2:3.6.6-6+deb7u2) ...
insserv: warning: script 'iptables.sh' missing LSB tags and overrides
insserv: There is a loop between service collectl and iptables.sh if stopped
insserv:  loop involving service iptables.sh at depth 2
insserv:  loop involving service collectl at depth 1
insserv: Stopping iptables.sh depends on collectl and therefore on system facility `$all' which can not be true!
insserv: exiting now without changing boot order!
update-rc.d: error: insserv rejected the script header
dpkg: erreur de traitement de samba (--configure) :
 le sous-processus script post-installation installé a retourné une erreur de sortie d'état 1
Paramétrage de winbind (2:3.6.6-6+deb7u2) ...
insserv: warning: script 'iptables.sh' missing LSB tags and overrides
insserv: There is a loop between service collectl and iptables.sh if stopped
insserv:  loop involving service iptables.sh at depth 2
insserv:  loop involving service collectl at depth 1
insserv: Stopping iptables.sh depends on collectl and therefore on system facility `$all' which can not be true!
insserv: exiting now without changing boot order!
update-rc.d: error: insserv rejected the script header
dpkg: erreur de traitement de winbind (--configure) :
 le sous-processus script post-installation installé a retourné une erreur de sortie d'état 1
Paramétrage de libvirt-bin (0.9.12.3-1) ...
L'utilisateur « libvirt-qemu » appartient déjà au groupe « libvirt-qemu ».
[ ok ] Stopping libvirt management daemon: libvirtd not running.
insserv: warning: script 'iptables.sh' missing LSB tags and overrides
insserv: There is a loop between service collectl and iptables.sh if stopped
insserv:  loop involving service iptables.sh at depth 2
insserv:  loop involving service collectl at depth 1
insserv: Stopping iptables.sh depends on collectl and therefore on system facility `$all' which can not be true!
insserv: exiting now without changing boot order!
update-rc.d: error: insserv rejected the script header
dpkg: erreur de traitement de libvirt-bin (--configure) :
 le sous-processus script post-installation installé a retourné une erreur de sortie d'état 1
dpkg: des problèmes de dépendances empêchent la configuration de libnss-winbind:amd64 :
 libnss-winbind:amd64 dépend de winbind (= 2:3.6.6-6+deb7u2) ; cependant :
 Le paquet winbind n'est pas encore configuré.

dpkg: erreur de traitement de libnss-winbind:amd64 (--configure) :
 problèmes de dépendances - laissé non configuré
dpkg: des problèmes de dépendances empêchent la configuration de swat :
 swat dépend de samba (= 2:3.6.6-6+deb7u2) ; cependant :
 Le paquet samba n'est pas encore configuré.

dpkg: erreur de traitement de swat (--configure) :
 problèmes de dépendances - laissé non configuré
Paramétrage de mysql-server-5.5 (5.5.35+dfsg-0+wheezy1) ...
[ ok ] Stopping MySQL database server: mysqld.
insserv: warning: script 'iptables.sh' missing LSB tags and overrides
insserv: There is a loop between service collectl and iptables.sh if stopped
insserv:  loop involving service iptables.sh at depth 2
insserv:  loop involving service collectl at depth 1
insserv: Stopping iptables.sh depends on collectl and therefore on system facility `$all' which can not be true!
insserv: exiting now without changing boot order!
update-rc.d: error: insserv rejected the script header
dpkg: erreur de traitement de mysql-server-5.5 (--configure) :
 le sous-processus script post-installation installé a retourné une erreur de sortie d'état 1
Paramétrage de apache2.2-common (2.2.22-13+deb7u1) ...
insserv: warning: script 'iptables.sh' missing LSB tags and overrides
insserv: There is a loop between service collectl and iptables.sh if stopped
insserv:  loop involving service iptables.sh at depth 2
insserv:  loop involving service collectl at depth 1
insserv: Stopping iptables.sh depends on collectl and therefore on system facility `$all' which can not be true!
insserv: exiting now without changing boot order!
update-rc.d: error: insserv rejected the script header
dpkg: erreur de traitement de apache2.2-common (--configure) :
 le sous-processus script post-installation installé a retourné une erreur de sortie d'état 1
dpkg: des problèmes de dépendances empêchent la configuration de libapache2-mod-php5 :
 libapache2-mod-php5 dépend de apache2.2-common ; cependant :
 Le paquet apache2.2-common n'est pas encore configuré.

dpkg: erreur de traitement de libapache2-mod-php5 (--configure) :
 problèmes de dépendances - laissé non configuré
dpkg: des problèmes de dépendances empêchent la configuration de mysql-server :
 mysql-server dépend de mysql-server-5.5 ; cependant :
 Le paquet mysql-server-5.5 n'est pas encore configuré.

dpkg: erreur de traitement de mysql-server (--configure) :
 problèmes de dépendances - laissé non configuré
Paramétrage de cups (1.5.3-5+deb7u1) ...
insserv: warning: script 'iptables.sh' missing LSB tags and overrides
insserv: There is a loop between service collectl and iptables.sh if stopped
insserv:  loop involving service iptables.sh at depth 2
insserv:  loop involving service collectl at depth 1
insserv: Stopping iptables.sh depends on collectl and therefore on system facility `$all' which can not be true!
insserv: exiting now without changing boot order!
update-rc.d: error: insserv rejected the script header
dpkg: erreur de traitement de cups (--configure) :
 le sous-processus script post-installation installé a retourné une erreur de sortie d'état 1
dpkg: des problèmes de dépendances empêchent la configuration de libpam-winbind:amd64 :
 libpam-winbind:amd64 dépend de winbind (= 2:3.6.6-6+deb7u2) ; cependant :
 Le paquet winbind n'est pas encore configuré.

dpkg: erreur de traitement de libpam-winbind:amd64 (--configure) :
 problèmes de dépendances - laissé non configuré
dpkg: des problèmes de dépendances empêchent la configuration de apache2-mpm-prefork :
 apache2-mpm-prefork dépend de apache2.2-common (= 2.2.22-13+deb7u1) ; cependant :
 Le paquet apache2.2-common n'est pas encore configuré.

dpkg: erreur de traitement de apache2-mpm-prefork (--configure) :
 problèmes de dépendances - laissé non configuré
dpkg: des problèmes de dépendances empêchent la configuration de apache2 :
 apache2 dépend de apache2-mpm-worker (= 2.2.22-13+deb7u1) | apache2-mpm-prefork (= 2.2.22-13+deb7u1) | apache2-mpm-event (= 2.2.22-13+deb7u1) | apache2-mpm-itk (= 2.2.22-13+deb7u1) ; cependant :
  Le paquet apache2-mpm-worker n'est pas installé.
 Le paquet apache2-mpm-prefork n'est pas encore configuré.
  Le paquet apache2-mpm-event n'est pas installé.
  Le paquet apache2-mpm-itk n'est pas installé.
 apache2 dépend de apache2.2-common (= 2.2.22-13+deb7u1) ; cependant :
 Le paquet apache2.2-common n'est pas encore configuré.

dpkg: erreur de traitement de apache2 (--configure) :
 problèmes de dépendances - laissé non configuré
Des erreurs ont été rencontrées pendant l'exécution :
 samba
 winbind
 libvirt-bin
 libnss-winbind:amd64
 swat
 mysql-server-5.5
 apache2.2-common
 libapache2-mod-php5
 mysql-server
 cups
 libpam-winbind:amd64
 apache2-mpm-prefork
 apache2


                                             
J'ai bien essayé de faire un apt-get clean ; apt-get -f upgrade mais j'ai le même problème de dépendance ...

Pour info dans mon fichier sources.list j'ai :

deb http://ftp.fr.debian.org/debian stable main contrib non-free
deb http://ftp.debian.org/debian/ wheezy-updates main contrib non-free
deb http://security.debian.org/ wheezy/updates main contrib non-free
deb http://ftp.fr.debian.org/debian wheezy-backports main




Si quelqu'un a une idée ...
Par avance merci.

Dernière modification par billoute94 (13-02-2014 16:23:22)

Hors ligne

#2 11-02-2014 00:28:25

captnfab
Admin-Girafe
Lieu : /dev/random
Distrib. : Debian Stretch/Sid/Rc-Buggy
Noyau : Linux (≥ 4.3)
(G)UI : i3-wm (≥ 4.11)
Inscription : 07-07-2008
Site Web

Re : [Résolu] Problème de dépendances ?

Salut billoute,
J'ai édité ton post pour qu'il soit plus agréable à lire. Je t'invite à cliquer sur modifier pour voir par toi-même comment avoir ce rendu par la suite smile
Plus d'info ici : Voir le tuto : Le code, ça pique moins les yeux en couleur

Pour ce qui est de ton problème, tu as visiblement, lors de ton upgrade ou avant, rencontré un problème qui a cassé ton gestionnaire de paquets.

La priorité avant toute chose (et en particulier avant l'installation de paquet), est de le réparer.

Pour cela, peux-tu nous donner la sortie de la commande suivante :

apt-get install -f


captnfab,
Association Debian-Facile, bépo.
TheDoctor: Your wish is my command… But be careful what you wish for.

Hors ligne

#3 11-02-2014 00:32:31

david96
Invité

Re : [Résolu] Problème de dépendances ?

Effectivement, y'a des chances pour que ça arrange le tout smile

#4 11-02-2014 00:53:37

vv222
Membre
Lieu : Bretagne
Distrib. : GNU/Linux Debian « Sid »
Noyau : >= Linux 4.5.0 (amd64)
(G)UI : Openbox + ROX
Inscription : 18-11-2013
Site Web

Re : [Résolu] Problème de dépendances ?

Dans notre situation le apt-get install -f est prématuré et ne réglera pas le problème.
dpkg est bloqué ici par un script foireux, qui se trouve probablement sous /etc/init.d/iptables.sh

Déplacer temporairement ce script hors de cette arborescence, puis seulement lancer 'apt-get install -f' a de grandes chances de régler tout ça.

Il sera toujours temps par la suite de chercher à comprendre ce qui est bloquant dans ce script iptables.sh.

-----

Au passage, ce n'est pas la première fois que je vois la commande 'apt-get clean' utilisée en espérant qu'elle règle un problème d'APT cassé : c'est une erreur !
Cette commande se contente de vider complètement le cache de paquets d'APT, ce qui empêchera entre autres par la suite de réinstaller directement un éventuel paquet fautif via dpkg.

Jouer sous Debian ? Facile !

Hors ligne

#5 11-02-2014 01:22:14

captnfab
Admin-Girafe
Lieu : /dev/random
Distrib. : Debian Stretch/Sid/Rc-Buggy
Noyau : Linux (≥ 4.3)
(G)UI : i3-wm (≥ 4.11)
Inscription : 07-07-2008
Site Web

Re : [Résolu] Problème de dépendances ?

Mhh, en effet, maintenant que tu le soulignes. Toutes les configurations qui échoues sont des paquets liés à des daemon, dont la configuration échoue parce qu'insserv se plante à cause du script iptables.sh, dont les dépendances sont mal définies.

Donc je plussoie vv2222.

captnfab,
Association Debian-Facile, bépo.
TheDoctor: Your wish is my command… But be careful what you wish for.

Hors ligne

#6 11-02-2014 01:23:03

david96
Invité

Re : [Résolu] Problème de dépendances ?

Pfiouu, merci vv222 pour ta bienveillance, je dois avouer que j'avais lu en diagonale…_Oops sad

#7 11-02-2014 16:34:48

vv222
Membre
Lieu : Bretagne
Distrib. : GNU/Linux Debian « Sid »
Noyau : >= Linux 4.5.0 (amd64)
(G)UI : Openbox + ROX
Inscription : 18-11-2013
Site Web

Re : [Résolu] Problème de dépendances ?

@ david96 : Quand comme moi tu casseras APT une fois par semaine (minimum) à force de vouloir expérimenter, tu verras que ce sont des choses qu'on finit par repérer au premier coup d'œil wink
Je ne suis pas un spécialiste d'APT, mais j'ai déjà du rencontrer sur ma machine 98,6% des erreurs qu'il est capable de cracher…

Jouer sous Debian ? Facile !

Hors ligne

#8 11-02-2014 16:59:01

billoute94
Membre
Distrib. : Wheezy 7.4
Noyau : Linux 3.9.0
(G)UI : Gnome3
Inscription : 10-02-2014

Re : [Résolu] Problème de dépendances ?

Hello !

J'ai déplacer le script "foireux" iptables.sh et lancer un apt-get install -f
Tout fonctionne de nouveau !
Merci les amis pour votre aide.

captnfab : merci pour ton aide sur mon premier post big_smile j'ai pris notes des balises. wink

Hors ligne

#9 11-02-2014 20:18:06

vv222
Membre
Lieu : Bretagne
Distrib. : GNU/Linux Debian « Sid »
Noyau : >= Linux 4.5.0 (amd64)
(G)UI : Openbox + ROX
Inscription : 18-11-2013
Site Web

Re : [Résolu] Problème de dépendances ?

Tu peux poster le contenu de iptables.sh ici, si moi-même je n'ai pas les compétences pour t'aider à le debugger il passera sûrement quelqu'un de plus efficace à un moment ou un autre pour t'expliquer ce qui y coince.

Jouer sous Debian ? Facile !

Hors ligne

Pied de page des forums