Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 19-02-2014 08:44:13

Hypathie
Membre
Lieu : Chambéry _ Montréal
Distrib. : Jessie
Noyau : Linux debian 3.16.0-4-586
(G)UI : Cinnamon Mate Xfce
Inscription : 28-12-2013

[résolu]gnome : monter manuellement un disque usb

Bonjour,

J'ai un gros problème avec mon disque dur externe.

Une fois branché il est détecté, mais il m'est impossible d'y copier mes documents.

Le montage automatique donne un unique fichier que je n'ai pas le droit d'ouvrir.

1392789052.png

Je l'avais formater en faisant :

mkfs.ext3 /dev/sdb



Et l'avais partitionner en faisant en utilisant :

fdisk /dev/sdb




Enfin en faisant :

fdisk -l


J'ai le retour suivant :

Disque /dev/sda : 500.1 Go, 500107862016 octets
255 têtes, 63 secteurs/piste, 60801 cylindres, total 976773168 secteurs
Unités = secteurs de 1 * 512 = 512 octets
Taille de secteur (logique / physique) : 512 octets / 4096 octets
taille d'E/S (minimale / optimale) : 4096 octets / 4096 octets
Identifiant de disque : 0x0006d4af

Périphérique Amorce  Début        Fin      Blocs     Id  Système
/dev/sda1   *        2048   960403455   480200704   83  Linux
/dev/sda2       960405502   976771071     8182785    5  Étendue
La partition 2 ne commence pas sur une frontière de cylindre physique.
/dev/sda5       960405504   976771071     8182784   82  partition d'échange Linux / Solaris

Disque /dev/sdb : 2000.4 Go, 2000398931968 octets
255 têtes, 63 secteurs/piste, 243201 cylindres, total 3907029164 secteurs
Unités = secteurs de 1 * 512 = 512 octets
Taille de secteur (logique / physique) : 512 octets / 512 octets
taille d'E/S (minimale / optimale) : 512 octets / 512 octets
Identifiant de disque : 0x00000000

Le disque /dev/sdb ne contient pas une table de partitions valable
 



Quelqu'un pourrait-il m'aider à rendre ce périphérique utilisable ?

Merci big_smile

Dernière modification par Hypathie (20-02-2014 17:38:50)

Hors ligne

#2 19-02-2014 09:05:04

golgot200
Membre
Lieu : AIN
Distrib. : Debian Jessie
Noyau : Linux debian 3.16.0-4-amd64
(G)UI : MATE
Inscription : 05-08-2007

Re : [résolu]gnome : monter manuellement un disque usb

Bonjour,

Ton disque n'est pas inaccessible, puisque que tu entres dedans.
Tu n'a pas de problème coté disque dur. Ce fichier que tu vois n'est autre qu'une corbeille. Tu n'as simplement pas les bons droits en écriture .

Dernière modification par golgot200 (19-02-2014 09:12:34)


L'ultime question ... l'intelligence a besoin de la bêtise pour s'affirmer, la beauté a besoin de la laideur pour resplendir, le courage nait dans la peur, les forts impressionnent au millieu des faibles, mais au final,... qui a donc besoin d'autant de connards ?

Hors ligne

#3 19-02-2014 10:17:10

Hypathie
Membre
Lieu : Chambéry _ Montréal
Distrib. : Jessie
Noyau : Linux debian 3.16.0-4-586
(G)UI : Cinnamon Mate Xfce
Inscription : 28-12-2013

Re : [résolu]gnome : monter manuellement un disque usb

J'ai re-formaté mon disque dur externe avec gparted en ext2.

Mais impossible de changer les droits et le propriétaire en me plaçant au niveau du répertoire média :

 chown -R hypathie:hypathie a5eb8603-6407-4d03-bf4f-2bfe5d7e8a3f/



J'ai le retour :

chown: changement de propriétaire pour « a5eb8603-6407-4d03-bf4f-2bfe5d7e8a3f/ »: Système de fichiers accessible en lecture seulement



et en faisant

chmod -R u+rwx a5eb8603-6407-4d03-bf4f-2bfe5d7e8a3f


j'ai le retour :

chmod: modification des permissions de « a5eb8603-6407-4d03-bf4f-2bfe5d7e8a3f »: Système de fichiers accessible en lecture seulement



hmm

Hors ligne

#4 19-02-2014 10:26:23

Haricophile
Adhérent(e)
Lieu : Pignans (Var)
Distrib. : SID
Noyau : 4.0.0-1-amd64
(G)UI : Mate / i3 selon...
Inscription : 14-09-2009

Re : [résolu]gnome : monter manuellement un disque usb

- Il y a quoi dans fstab ?
- Un fsck ?

Dernière modification par Haricophile (19-02-2014 10:30:37)


« La religion et l'art sont les luxes des lâches, qui permettent de fuir la réalité quand elle devient trop difficile à affronter. La différence c'est que la religion transforme tout mensonge en vérité alors que l'art transforme toute vérité en mensonge. »

Hors ligne

#5 19-02-2014 10:40:49

captnfab
Admin-Girafe
Lieu : /dev/random
Distrib. : Debian Stretch/Sid/Rc-Buggy
Noyau : Linux (≥ 4.3)
(G)UI : i3-wm (≥ 4.11)
Inscription : 07-07-2008
Site Web

Re : [résolu]gnome : monter manuellement un disque usb

Salut Hypathie,

Différentes choses:

- ext2/3/4 sont des systèmes de fichiers embarquant des droits/permissions avec eux. Ces permissions sont liées à un système donné. Donc pour un disque dur externe, cela signifiera que sur une autre machine, les fichiers de ce disque dur qui appartiennent à l'utilisateur «hypathie» appartiendront à un autre utilisateur.
- ext2/3/4 ne sont pas reconnus par macosx/windows

Si ta debian a été installée via clé usb, il peut y avoir une ligne dans le fstab qui donne de mauvaises options de montage au disque. Tu peux nous en donner le contenu via :

cat /etc/fstab


captnfab,
Association Debian-Facile, bépo.
TheDoctor: Your wish is my command… But be careful what you wish for.

Hors ligne

#6 19-02-2014 13:02:38

Hypathie
Membre
Lieu : Chambéry _ Montréal
Distrib. : Jessie
Noyau : Linux debian 3.16.0-4-586
(G)UI : Cinnamon Mate Xfce
Inscription : 28-12-2013

Re : [résolu]gnome : monter manuellement un disque usb

Merci et désolée,

je me suis lancée dans une solution radicale et pendant que je la mettais en oeuvre je n'ai pas vu vos messages.

(En tout cas, il ne s'agissait de brancher ce disque sur un système autre que linux,  mais de le rendre inscriptible une fois qu'il avait été monter automatiquement.

1) J'ai désactivé le montage automatique des périphériques ;
(en faisant : Applications > Préférences des applications au démarrage > puis en décochant "Assistant de montage")
2) avec gparted, j'ai supprimer la partition de ce disque qui était défectueuse (prévenue par gparted)
et créé une partition ext2 ;
3) j'ai créé le répertoire de point de montage /mnt/sdb1 ;

mkdrir /mnt/sdb1


4) je l'ai monté sur /mnt/sdb1 ;

mount /dev/sdb1 /mnt/sdb1



Je peux alors copier ce que je veux sur mon disque dur mais en tant que root seulement.

Ce qui m'embête un peu c'est que je n'arrive pas à rendre le disque inscriptible en tant qu'utilisateur.
Même en faisant :

chown hypathie:hypathie /mnt/sdb1



La commande cp ne fonctionne pas dans un terminal utilisateur.

S'il y avait une solution pour faire en sorte  que mount n'exclut pas l'utilisateur, je serais bien prenante !

Merci smile

Hors ligne

#7 20-02-2014 05:50:10

nifseg
Adhérent(e)
Lieu : Dans une forêt
Distrib. : Debian Wheezy + Jessie
Noyau : 3.2.0-4-amd64 + 3.16.0-4-686-pae
(G)UI : Gnome/Mate/Cinnamon
Inscription : 15-12-2013

Re : [résolu]gnome : monter manuellement un disque usb

Coucou hypathie,
A ta place je ne formaterais pas ma partition avec le sytème de fichiers ext2 qui est plutot viello(à moins que tu as de bonne raison de choisir ce FS) mais plutot en ext4 voir ext3.
Autre chose, je metterais un nom différent entre ton fichier bloc "/dev/sdb1" (ta partition) et ton point de montage "/mnt/sdb1". Par exemple "/mnt/dd_ext".

D'autre part si tu veux que ta partition "/dev/sdb1" apparaisse en signet dans ton navigateur de fichier il faut la monter dans "media".

Et enfin il faut que tu crée ton dossier perso(par exemple "hypathie" sur ta partition dans le dossier qui se trouve etre ton point de montage.

C'est à dire, en root :

mkdir /mnt/dd_ext/hypathie ; mount /dev/sdb1 /mnt/dd_ext/hypathie



Et enfin tu applques les droits à ton dossier "hypathie"

chown -R hypathie:hypathie /mnt/dd_ext/hypathie



Et après ça sa devrait etre bon smile

Dernière modification par nifseg (20-02-2014 05:54:20)


L'important n'est pas la chute mais l'atterrissage...
Chapardeur de chocolat DF!!!
Admin un jour, admin toujours...

Hors ligne

#8 20-02-2014 06:50:46

MicP
Invité

Re : [résolu]gnome : monter manuellement un disque usb

Applications -> Accessoires -> Utilitaire de disque
Sélectionner (à gauche) le disque à formater,

Cliquer sur Démonter le volume,

Puis Formater le volume,
Donner un nom de "label" (nommer) le disque (par exemple 1TioBleu),
Cocher Devenir propriétaire du système de fichiers,

Cliquer sur Formater,
Attendre que la roue ait fini de tourner (en bas à droite de la partition),

Cliquer sur Monter le volume.

EDIT: Je cherche...
Mais apparemment, tout se passe au niveau de "Nautilus" pour la récupération et l'affichage du nom de Label de la partition.
Il doit sans doute y avoir du "fuse" et de l'"espace utilisateur" là dessous, d'où la manip depuis l'interface graphique.
Faut dire aussi que je connais mal Gnome, je viens juste de l'installer hier soir.

Dernière modification par MicP (20-02-2014 07:57:27)

#9 20-02-2014 07:02:08

Hypathie
Membre
Lieu : Chambéry _ Montréal
Distrib. : Jessie
Noyau : Linux debian 3.16.0-4-586
(G)UI : Cinnamon Mate Xfce
Inscription : 28-12-2013

Re : [résolu]gnome : monter manuellement un disque usb

Merci les amis wink

J'vais mettre en application

smile

Hors ligne

#10 20-02-2014 07:56:36

Hypathie
Membre
Lieu : Chambéry _ Montréal
Distrib. : Jessie
Noyau : Linux debian 3.16.0-4-586
(G)UI : Cinnamon Mate Xfce
Inscription : 28-12-2013

Re : [résolu]gnome : monter manuellement un disque usb

En fait je m'aperçois que sous gnome, décocher "Assistant de montage" dans : Applications > Préférences des applications au démarrage, ne suffit pas.

J'ai testé, une fois décochée, et après avoir relancé la session, une clé branchée, est montée automatiquement dans  "périphériques" ; je ne sais pas par quel programme, mais j'aimerais bien le savoir.
Je peux même ouvrir des fichiers sur cette clé alors que je ne réponds rien à la fenêtre qui apparaît au moment du branchement d'une clé  "système de fichiers" : ouvrir avec Fichiers" ou "Éjecter".

J'hésite un peu à créer un point de montage dans média, en suivant la méthode de nifseg, alors que la clé est déjà montée automatiquement.

Comment faire sous gnome, pour que la clé soit reconnue comme branchée, mais que sa partition ne soit pas montée automatiquement ?

Je voudrais qu'il n'y ait plus du tout de montage automatique  et qu'il n'y ait plus de proposition de l'ouvrir avec "Fichier" ; est-ce possible ? 

roll

Dernière modification par Hypathie (20-02-2014 08:01:21)

Hors ligne

#11 20-02-2014 08:01:52

MicP
Invité

Re : [résolu]gnome : monter manuellement un disque usb

Applications -> Dconf Editor

org -> gnome -> desktop -> media-handling

Décocher :
automount 
automount-open

Cocher :
autorun-never

Dernière modification par MicP (20-02-2014 09:21:28)

#12 20-02-2014 08:42:31

Hypathie
Membre
Lieu : Chambéry _ Montréal
Distrib. : Jessie
Noyau : Linux debian 3.16.0-4-586
(G)UI : Cinnamon Mate Xfce
Inscription : 28-12-2013

Re : [résolu]gnome : monter manuellement un disque usb

Merci beaucoup MicP

cool

Hors ligne

#13 20-02-2014 09:18:02

Hypathie
Membre
Lieu : Chambéry _ Montréal
Distrib. : Jessie
Noyau : Linux debian 3.16.0-4-586
(G)UI : Cinnamon Mate Xfce
Inscription : 28-12-2013

Re : [résolu]gnome : monter manuellement un disque usb

En fait, j'ai testé ta méthode MicP,

elle permet de ne plus avoir la fenêtre "ouvrir avec fichier ou éjecté" au moment du branchement ; à remarquer la clé apparaît dans "Périphériques" et si on pointe la souris sur "système de fichier" (celui qui correspond à sa clé) il apparaît à côté du curseur de la souris : "monter et ouvrir Système de fichier (avec son espace disponible). La partition sera monté que si on cliquera sur le système de fichier de sa clé.

smile

Par ailleurs, d'une façon générale j'ai d'autres questions.
Avec ce qu'on a fait là pour "iniber le montage automatique",  est-ce que je peux dire qu'on a juste "différé ce montage automatique" ? Il me semble que quand je vais cliquer sur périphérique, il va s'agir d'un montage automatique, non ?

En comprenant les choses dans ce sens, j'ai un doute sur l'idée de créer un point de montage dans "média", puisque si j'ai bien compris "média" est réservé au montage automatique des périphériques amovibles. Du coup, j'ai peur de créer un "conflit" entre le montage automatique et mon montage manuel, non ?


Quel pourrait-être l'avantage de créer un point de montage dans le fichier de type répertoire "mnt" par rapport au montage automatique "différé" qu'on vient de trouver ?

Merci d'avance ces questions sont importantes, car là j'ai l'impression que l'interface graphique m'empêche de comprendre ce qui se passe par en dessous, et ça m'énerve !

big_smile

Dernière modification par Hypathie (20-02-2014 10:18:00)

Hors ligne

#14 20-02-2014 11:16:42

Hypathie
Membre
Lieu : Chambéry _ Montréal
Distrib. : Jessie
Noyau : Linux debian 3.16.0-4-586
(G)UI : Cinnamon Mate Xfce
Inscription : 28-12-2013

Re : [résolu]gnome : monter manuellement un disque usb

mkdir /mnt/dd_ext/hypathie



donne la réponse :

mkdir: impossible de créer le répertoire "/mnt/dd_ext/hypathie

  ?

Ça fait un sous-fichier en même temps que le fichier ?  smile

Hors ligne

#15 20-02-2014 12:19:28

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : [résolu]gnome : monter manuellement un disque usb

Hypathie, Oui.
Utilise l'option -p alors :
mkdir - l'option p come parent. Voir ici !

"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#16 20-02-2014 12:28:19

MicP
Invité

Re : [résolu]gnome : monter manuellement un disque usb

hypathie a écrit :

...elle permet de ne plus avoir la fenêtre "ouvrir avec fichier ou éjecté" au moment du branchement ...

Voici le descriptif (très parlant) concernant les paramètres qui ont été désactivés (post #11) avec "Dconf Editor":
automount : If set to true, then Nautilus will automatically mount media such as user-visible hard disks and removable media on start-up and media insertion.
automount-open : If set to true, then Nautilus will automatically open a folder when media is automounted. This only applies to media where no known x-content/* type was detected; for media where a known x-content type is detected, the user configurable action will be taken instead.

==============

hypathie a écrit :

...il va s'agir d'un montage automatique, non ? ......

Plus vraiment puisqu'il nécessite l'intervention de l'utilisatrice ("...quand je vais cliquer sur périphérique...")

==============

hypathie a écrit :

...Du coup, j'ai peur de créer un "conflit" entre le montage automatique et mon montage manuel, non ?...

Bien vu, ce répertoire doit être laissé entièrement à la disposition du système de mountage automatique des systèmes de fichiers des périphériques amovibles pour qu'il puisse y créer les points de mountages nommés comme il le décidera.

==============

hypathie a écrit :

...Quel pourrait-être l'avantage de créer un point de montage dans le fichier de type répertoire "mnt"......

pouvoir manipuler (réparer une partition, etc...) sans voir le système d'auto-mountage intervenir intempestivement, pouvoir en modifier les droits etc...

Dernière modification par MicP (20-02-2014 12:48:56)

#17 20-02-2014 21:47:19

Hypathie
Membre
Lieu : Chambéry _ Montréal
Distrib. : Jessie
Noyau : Linux debian 3.16.0-4-586
(G)UI : Cinnamon Mate Xfce
Inscription : 28-12-2013

Re : [résolu]gnome : monter manuellement un disque usb

MicP a écrit :

Plus vraiment puisqu'il nécessite l'intervention de l'utilisatrice ("...quand je vais cliquer sur périphérique...")



C'est quand même une intervention de l'user sacrément assistée ; sinon..... "semi-automatique", pour blaguer un peu  wink

Merci, MicP pour toutes ces précisions,

Hors ligne

#18 23-02-2014 21:22:36

MicP
Invité

Re : [résolu]gnome : monter manuellement un disque usb

Pied de page des forums