Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 27-10-2008 12:10:16

stopher
Membre
Lieu : lille
Distrib. : squeeze
Noyau : 2.6.32
(G)UI : Gnome
Inscription : 03-10-2008
Site Web

[ Résolu ]Serveur de temps

Bonjour à tous ,

Je cherche à mettre en place , un server de temps NTP , afin que mes autres serveurs se synchronises dessus ... afin qu'un seul serveur se connecte aux serveurs NTP publics ..

J'ai donc procédé comme ceci :

sudo apt-get install ntpdate ntp-simple ntp-doc

Puis j'ai configéré le fichier /etc/ntp.conf comme ceci :

# /etc/ntp.conf, configuration for ntpd

driftfile /var/lib/ntp/ntp.drift
statsdir /var/log/ntpstats/

statistics loopstats peerstats clockstats
filegen loopstats file loopstats type day enable
filegen peerstats file peerstats type day enable
filegen clockstats file clockstats type day enable


# You do need to talk to an NTP server or two (or three).
#server ntp.your-provider.example

# pool.ntp.org maps to more than 300 low-stratum NTP servers.
# Your server will pick a different set every time it starts up.
#  *** Please consider joining the pool! ***
#  *** <http://www.pool.ntp.org/join.html> ***

server ntp.univ-lyon1.fr prefer
server ntp.imag.fr
server ntp.uvsq.fr
server ntp.laas.fr
server ntp.unilim.fr

#server 0.debian.pool.ntp.org iburst
#server 1.debian.pool.ntp.org iburst
#server 2.debian.pool.ntp.org iburst
#server 3.debian.pool.ntp.org iburst

# By default, exchange time with everybody, but don't allow configuration.
# See /usr/share/doc/ntp-doc/html/accopt.html for details.
restrict -4 default kod notrap nomodify nopeer noquery
restrict -6 default kod notrap nomodify nopeer noquery

# Local users may interrogate the ntp server more closely.
restrict 127.0.0.1
restrict ::1

# Clients from this (example!) subnet have unlimited access,
# but only if cryptographically authenticated
#restrict 192.168.123.0  mask  255.255.255.0 notrust
restrict 10.0.0.0 mask 255.255.255.0 notrust

# If you want to provide time to your local subnet, change the next line.
# (Again, the address is an example only.)
broadcast 10.0.0.255

# If you want to listen to time broadcasts on your local subnet,
# de-comment the next lines. Please do this only if you trust everybody
# on the network!
#disable auth
#broadcastclient


mon réseau étant 10.0.0.0/255.255.255.0

A premiére vue , mon serveur se synchronise bien avec l'exterieur :

mailhost:/home/mailadmin# ntpq -p
     remote           refid      st t when poll reach   delay   offset  jitter
==============================================================================
 dns.univ-lyon1. .INIT.          16 u   55   64    0    0.000    0.000   0.000
 imag.imag.fr    .INIT.          16 u   57   64    0    0.000    0.000   0.000
 soleil.uvsq.fr  .INIT.          16 u   59   64    0    0.000    0.000   0.000
 ntp1.laas.fr    .INIT.          16 u   56   64    0    0.000    0.000   0.000
 ntp.unilim.fr   .INIT.          16 u   54   64    0    0.000    0.000   0.000


Mais pas moyen de synchroniser d'autres machines de mon réseau sur mon serveur de temps

ntpdate 10.0.0.8
27 Oct 11:09:02 ntpdate[22166]: no server suitable for synchronization found


Please Help ... :-)

Dernière modification par stopher (27-10-2008 13:29:39)

Hors ligne

#2 27-10-2008 12:54:23

tux12
Membre
Lieu : ./
Distrib. : Squeeze
Noyau : Linux 2.6.32-5-686-bigmem
(G)UI : KDE
Inscription : 27-02-2008

Re : [ Résolu ]Serveur de temps

Salut stopher,

Au vu des zéros que tu obtiens dans les colonnes "reach" et suivantes, et si j'en crois ce que je vois par exemple ici (2e post), je ne pense pas que ton serveur se soit synchronisé avec l'extérieur.
Le port 123 est ouvert sur le parefeu?

@+

Hors ligne

#3 27-10-2008 12:58:00

stopher
Membre
Lieu : lille
Distrib. : squeeze
Noyau : 2.6.32
(G)UI : Gnome
Inscription : 03-10-2008
Site Web

Re : [ Résolu ]Serveur de temps

Oui , le parfeu est bien configuré pour laisser passer les datas sur le port 123 ...

Le serveur n'était pas à l'heure , je l'ai mis à l'heure en tapant ntpdate ntp.univ-lyon1.fr mais c'etait avant d'installer ntp-simple et ntp-doc ...

Mais il y a tellement de paquets diffèrent que je ne sais lequel prendre réellement ...

Hors ligne

#4 27-10-2008 13:01:49

stopher
Membre
Lieu : lille
Distrib. : squeeze
Noyau : 2.6.32
(G)UI : Gnome
Inscription : 03-10-2008
Site Web

Re : [ Résolu ]Serveur de temps

Apres quelques modif dans la config :

mailhost:/home/mailadmin# ntpq -p
     remote           refid      st t when poll reach   delay   offset  jitter
==============================================================================
 dns.univ-lyon1. 195.220.94.163   2 u    8   64    1   62.282   24.999   0.001
 imag.imag.fr    192.93.2.20      2 u    7   64    1   65.826   24.263   0.001
 soleil.uvsq.fr  195.83.222.27    2 u    6   64    1   56.883   23.244   0.001
 ntp1.laas.fr    138.96.64.10     3 u    5   64    1   86.354   21.182   0.001
 ntp.unilim.fr   195.220.94.163   2 u    4   64    1   65.269   21.632   0.001
 LOCAL(0)        .LOCL.           5 l    3   64    1    0.000    0.000   0.001


Voici mon ntp.conf

# /etc/ntp.conf, configuration for ntpd
logfile /var/log/ntpd
driftfile /var/lib/ntp/ntp.drift
statsdir /var/log/ntpstats/

statistics loopstats peerstats clockstats
filegen loopstats file loopstats type day enable
filegen peerstats file peerstats type day enable
filegen clockstats file clockstats type day enable


# You do need to talk to an NTP server or two (or three).
#server ntp.your-provider.example

# pool.ntp.org maps to more than 300 low-stratum NTP servers.
# Your server will pick a different set every time it starts up.
#  *** Please consider joining the pool! ***
#  *** <http://www.pool.ntp.org/join.html> ***

server ntp.univ-lyon1.fr
server ntp.imag.fr
server ntp.uvsq.fr
server ntp.laas.fr
server ntp.unilim.fr
server 127.127.1.0
fudge 127.127.0.0 stratum 10

# By default, exchange time with everybody, but don't allow configuration.
# See /usr/share/doc/ntp-doc/html/accopt.html for details.
restrict default kod notrap nomodify nopeer noquery
restrict 127.0.0.1 nomodify
restrict 10.0.0.0 mask 255.255.255.0 nomodify notrap


Malheureusement , à partir d'un autre poste :

root@AR21B:~# ntpdate 10.0.0.8
27 Oct 13:01:31 ntpdate[10456]: no server suitable for synchronization found

Hors ligne

#5 27-10-2008 13:29:24

stopher
Membre
Lieu : lille
Distrib. : squeeze
Noyau : 2.6.32
(G)UI : Gnome
Inscription : 03-10-2008
Site Web

Re : [ Résolu ]Serveur de temps

Bon à premiére vue , ca y est ca fonctionne avec cette configue ,
pour les clients , il faut juste installer ntp-simple

Puis modifier la seule ligne qui nous interesse dans /etc/ntp.conf :

server <adresse du serveur NTP>


Un petit redémarrage du service ,

/etc/init.d/ntp restart


Puis pour voir quand la maj va se faire :

ntp-wait -v


Et au finale , voilà le résultat  :

ftpadmin@legolas:~$ ntp-wait -v
Waiting for ntpd to synchronize... OK!


Victoire .. big_smile

Hors ligne

Pied de page des forums