Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 03-03-2014 11:20:07

nIQnutn
Modérateur
Lieu : Lyon
Distrib. : Jessie
Noyau : Linux 3.16-amd64
(G)UI : XFCE
Inscription : 16-03-2012
Site Web

Fstab et option noauto

Bonjour,

Je cherche à pouvoir monter une partition facilement sans avoir à taper de mot de passe

UUID=bff3e381-e0b3-4f5a-8ce1-68bc003d68a4 /media/MaPartition       ext4    defaults,noauto,user        0 0


Le pb arrive quand je veux monter la partition: le  dossier n'existe pas dans /media
Si je crée ce dossier, la partition de monte normallement. Dans ce cas je me retrouve avec des entrées MaPartition dupliqué dans Nautilus et c'est le bazar. En déplacant le point de montage vers un autre répertoire, la partition n'est plus visible dans Nautilus

Je voudrais savoir s'il existe un moyen de faire créer automatiquement ce répertoire ou de nettoyer les entrées dans Nautilus.

Hors ligne

#2 03-03-2014 11:25:39

nifseg
Adhérent(e)
Lieu : Dans une forêt
Distrib. : Debian Wheezy + Jessie
Noyau : 3.2.0-4-amd64 + 3.16.0-4-686-pae
(G)UI : Gnome/Mate/Cinnamon
Inscription : 15-12-2013

Re : Fstab et option noauto

Si tu veux avoir ton dd d'afficher dans nautilus(en signet) il faut que ta partition soit montée dans /media et non dans /mnt
Pour ma part quand je mets en options defaults,user dans mon fstab, je n'ai pas à taper de mot de passe
Il me semble que c'est l'option user qui permet celà

Dernière modification par nifseg (03-03-2014 11:27:13)


L'important n'est pas la chute mais l'atterrissage...
Chapardeur de chocolat DF!!!
Admin un jour, admin toujours...

Hors ligne

#3 03-03-2014 11:57:45

nIQnutn
Modérateur
Lieu : Lyon
Distrib. : Jessie
Noyau : Linux 3.16-amd64
(G)UI : XFCE
Inscription : 16-03-2012
Site Web

Re : Fstab et option noauto

j'ai effectivement constaté que seul les partitions montées dans /media apparaissent dans Nautilus.
Avec ce que j'ai mis dans le fstab, je n'ai pas besoin de taper de mot de passe, par contre il me dit que le dossier /media/MaPartition n'existe pas. Normalement, pour monter une partition il faut taper le mot de passe admin et je suppose qu'il crée le dossier en question. Dans mon cas c'est à partir d'un utilisateur qui n'a pas ces droits et je pense que le pb vient de là.

Quand je crée le dossier /media/MaPartition il me crée cette entrée dans Nautilus en plus de la partition nommée MaPartition. Du coup je me retrouve avec des doublons dans Nautilus

Hors ligne

#4 03-03-2014 12:25:56

nifseg
Adhérent(e)
Lieu : Dans une forêt
Distrib. : Debian Wheezy + Jessie
Noyau : 3.2.0-4-amd64 + 3.16.0-4-686-pae
(G)UI : Gnome/Mate/Cinnamon
Inscription : 15-12-2013

Re : Fstab et option noauto

Creer un dossier dans /media avec un autre nom par exemple dd_int et précise /media/dd_int dans ton fstab et donne moi le retour si tu veux bien

Dernière modification par nifseg (03-03-2014 12:26:17)


L'important n'est pas la chute mais l'atterrissage...
Chapardeur de chocolat DF!!!
Admin un jour, admin toujours...

Hors ligne

#5 03-03-2014 12:29:29

nifseg
Adhérent(e)
Lieu : Dans une forêt
Distrib. : Debian Wheezy + Jessie
Noyau : 3.2.0-4-amd64 + 3.16.0-4-686-pae
(G)UI : Gnome/Mate/Cinnamon
Inscription : 15-12-2013

Re : Fstab et option noauto

En fait je pense savoir d'où vient t'on pb. Sa doit venir de l'option noauto.
Enlève cette option et dit moi ce que sa donne au niveau de nautilus(doublons)

Dernière modification par nifseg (03-03-2014 12:29:57)


L'important n'est pas la chute mais l'atterrissage...
Chapardeur de chocolat DF!!!
Admin un jour, admin toujours...

Hors ligne

#6 03-03-2014 15:21:37

nIQnutn
Modérateur
Lieu : Lyon
Distrib. : Jessie
Noyau : Linux 3.16-amd64
(G)UI : XFCE
Inscription : 16-03-2012
Site Web

Re : Fstab et option noauto

Non, le pb ne vient pas de l'option noauto.
J'ai redémarré pour être sûr et je vois d'une part la partition indiqué par son label  et le dossier que je viens de créer dans /media/.

Dans nautilus, je vois la partition et le dossier donc je retrouve mes doublons. Par contre je me retrouve avec une erreur quand je clique sur le dossier :

Impossible de monter MaPartition
mount: /dev/sdd2 already mounted or /media/MaPartition busy
mount: according to mtab, /dev/sdd2 is already mounted on /media/MaPartition
 






dans mon fstab j'ai une ligne pour le lecteur cd.

/dev/sr0        /media/cdrom0   udf,iso9660 user,noauto     0       0


dans le dossier /media , j'ai un dossier cdrom0

Peut être que l'option defaults n'est pas nécessaire dans ce cas.
Je vais créer un dossier dans le répertoire /media et mettre uniquement les options user,noauto pour cette partition.
Je vais voir ce que ça donne.

Hors ligne

#7 03-03-2014 15:30:23

nifseg
Adhérent(e)
Lieu : Dans une forêt
Distrib. : Debian Wheezy + Jessie
Noyau : 3.2.0-4-amd64 + 3.16.0-4-686-pae
(G)UI : Gnome/Mate/Cinnamon
Inscription : 15-12-2013

Re : Fstab et option noauto

Non n'enlève pas l'option défaut sa ne changera rien à ton pb et de plus si tu fais ca tu vas avoir des soucis.
Pour info l'option defaults active rw,suid,dev,exec,auto,nouser et async.

Dernière modification par nifseg (03-03-2014 15:30:56)


L'important n'est pas la chute mais l'atterrissage...
Chapardeur de chocolat DF!!!
Admin un jour, admin toujours...

Hors ligne

#8 03-03-2014 15:34:19

nIQnutn
Modérateur
Lieu : Lyon
Distrib. : Jessie
Noyau : Linux 3.16-amd64
(G)UI : XFCE
Inscription : 16-03-2012
Site Web

Re : Fstab et option noauto

Je vais essayer de regarder du coté de Nautilus pour essayer de faire le ménage.
J'en profiterai aussi pour faire le nettoyage puisque j'ai des partitions chiffrées que je ne devrais pas voir puisqu'elle ne sont pas montées dans /media.


Dans tous les cas je pense que pour monter la partition avoir les droits d'un utilisateur normal il faut créer le dossier au préalable.
Il s'agit certainement d'un pb dans Nautilus. Je ne sais pas si ce comportement est identique pour les autres environnement comme KDE, LXDE ...

Hors ligne

#9 03-03-2014 15:38:12

nifseg
Adhérent(e)
Lieu : Dans une forêt
Distrib. : Debian Wheezy + Jessie
Noyau : 3.2.0-4-amd64 + 3.16.0-4-686-pae
(G)UI : Gnome/Mate/Cinnamon
Inscription : 15-12-2013

Re : Fstab et option noauto

Ben moi perso je n'ai pas ce soucis.
T'as essayé de faire ce que je t'ai proposé au post 4. Peut-être un blem de syntaxe avec ton dossier

L'important n'est pas la chute mais l'atterrissage...
Chapardeur de chocolat DF!!!
Admin un jour, admin toujours...

Hors ligne

#10 03-03-2014 15:43:39

nifseg
Adhérent(e)
Lieu : Dans une forêt
Distrib. : Debian Wheezy + Jessie
Noyau : 3.2.0-4-amd64 + 3.16.0-4-686-pae
(G)UI : Gnome/Mate/Cinnamon
Inscription : 15-12-2013

Re : Fstab et option noauto

Essai en précisant le nom de ta partition /dev/sdd2 plutot qu'avec le UUID dans fstab

/dev/sdd2 /media/MaPartition       ext4    defaults,noauto,user        0 0

Dernière modification par nifseg (03-03-2014 15:45:05)


L'important n'est pas la chute mais l'atterrissage...
Chapardeur de chocolat DF!!!
Admin un jour, admin toujours...

Hors ligne

#11 03-03-2014 16:04:23

nIQnutn
Modérateur
Lieu : Lyon
Distrib. : Jessie
Noyau : Linux 3.16-amd64
(G)UI : XFCE
Inscription : 16-03-2012
Site Web

Re : Fstab et option noauto

Non, je pense avoir suivi ce que tu m'as dit au post 4.
j'ai bien créé un dossier avec un nom différent dans /media


Je pense que le fait d'avoir l'option noauto pet expliquer le pb ou peut être un vieux fichier de config qui traine depuis le temps.


Je fais réessayer pour voir

Hors ligne

#12 03-03-2014 16:08:01

nifseg
Adhérent(e)
Lieu : Dans une forêt
Distrib. : Debian Wheezy + Jessie
Noyau : 3.2.0-4-amd64 + 3.16.0-4-686-pae
(G)UI : Gnome/Mate/Cinnamon
Inscription : 15-12-2013

Re : Fstab et option noauto

Pour ce que je le changement de nom je me doutais que sa n'allait rein changer par contre tester ce que je t'ai dit au post 10.
Il se peut que le uuid de ta partoche soit erroné

Dernière modification par nifseg (03-03-2014 16:08:28)


L'important n'est pas la chute mais l'atterrissage...
Chapardeur de chocolat DF!!!
Admin un jour, admin toujours...

Hors ligne

#13 03-03-2014 16:26:27

nIQnutn
Modérateur
Lieu : Lyon
Distrib. : Jessie
Noyau : Linux 3.16-amd64
(G)UI : XFCE
Inscription : 16-03-2012
Site Web

Re : Fstab et option noauto

J'avance doucement mais je viens de voir que dans Nautilus il m'affiche la partition avec son label et le nom du point de montage.
Il ne m'affiche pas les dossiers qui sont dans /media.

Je vais voir ce qu'il me fait au prochain redémarrage.


Voilà ce que j'ai dans Nautilus
file-Ra0e545af3ecf7624e22666c1baa47e88

Software / Jeux : label de ma partition
Software : point de montage dans fstab.

Hors ligne

#14 03-03-2014 16:29:22

nifseg
Adhérent(e)
Lieu : Dans une forêt
Distrib. : Debian Wheezy + Jessie
Noyau : 3.2.0-4-amd64 + 3.16.0-4-686-pae
(G)UI : Gnome/Mate/Cinnamon
Inscription : 15-12-2013

Re : Fstab et option noauto

dsl mais je n'arrive pas avoir les détails dans nautilus
Tu peux pas mettre une photo qu'on peut agrandir stp?

Dernière modification par nifseg (03-03-2014 16:30:03)


L'important n'est pas la chute mais l'atterrissage...
Chapardeur de chocolat DF!!!
Admin un jour, admin toujours...

Hors ligne

#15 03-03-2014 16:30:46

nIQnutn
Modérateur
Lieu : Lyon
Distrib. : Jessie
Noyau : Linux 3.16-amd64
(G)UI : XFCE
Inscription : 16-03-2012
Site Web

Re : Fstab et option noauto

nifseg a écrit :

Il se peut que le uuid de ta partoche soit erroné


j'ai bien accès au données de ma partition en indiquant l'UUID.

Je regarderai ce que ça donne enmettant /dev/sdd2

Hors ligne

#16 03-03-2014 16:33:45

nIQnutn
Modérateur
Lieu : Lyon
Distrib. : Jessie
Noyau : Linux 3.16-amd64
(G)UI : XFCE
Inscription : 16-03-2012
Site Web

Re : Fstab et option noauto

l'URL de la capture d'écran

http://images.debian-facile.org/file-Ra0e545af3ecf7624e22666c1baa47e88

Hors ligne

Pied de page des forums