Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 05-03-2014 15:33:12

Laërte
Membre
Distrib. : Debian Testing
Noyau : Linux 3.16.0-4-amd64
(G)UI : Kwin
Inscription : 01-09-2013

Problème de reconnaissance du lecteur SD

Bonjour !
Le titre me paraît suffisamment explicite : Les cartes SD ne sont pas lues par mon lecteur SD.
Pour les informations, j'ai utilisé les commandes lspci et lsusb.
Voici leurs renvois :

lspci :

00:00.0 Host bridge: Intel Corporation 3rd Gen Core processor DRAM Controller (rev 09)
00:02.0 VGA compatible controller: Intel Corporation 3rd Gen Core processor Graphics Controller (rev 09)
00:14.0 USB controller: Intel Corporation 7 Series/C210 Series Chipset Family USB xHCI Host Controller (rev 04)
00:16.0 Communication controller: Intel Corporation 7 Series/C210 Series Chipset Family MEI Controller #1 (rev 04)
00:1a.0 USB controller: Intel Corporation 7 Series/C210 Series Chipset Family USB Enhanced Host Controller #2 (rev 04)
00:1b.0 Audio device: Intel Corporation 7 Series/C210 Series Chipset Family High Definition Audio Controller (rev 04)
00:1c.0 PCI bridge: Intel Corporation 7 Series/C210 Series Chipset Family PCI Express Root Port 1 (rev c4)
00:1c.2 PCI bridge: Intel Corporation 7 Series/C210 Series Chipset Family PCI Express Root Port 3 (rev c4)
00:1c.3 PCI bridge: Intel Corporation 7 Series/C210 Series Chipset Family PCI Express Root Port 4 (rev c4)
00:1d.0 USB controller: Intel Corporation 7 Series/C210 Series Chipset Family USB Enhanced Host Controller #1 (rev 04)
00:1f.0 ISA bridge: Intel Corporation HM76 Express Chipset LPC Controller (rev 04)
00:1f.2 SATA controller: Intel Corporation 7 Series Chipset Family 6-port SATA Controller [AHCI mode] (rev 04)
00:1f.3 SMBus: Intel Corporation 7 Series/C210 Series Chipset Family SMBus Controller (rev 04)
02:00.0 Network controller: Intel Corporation Centrino Wireless-N 2230 (rev c4)
03:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. Device 5289 (rev 01)
03:00.2 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 0a)



lsusb -t :

/:  Bus 04.Port 1: Dev 1, Class=root_hub, Driver=ehci_hcd/2p, 480M
    |__ Port 1: Dev 2, If 0, Class=hub, Driver=hub/6p, 480M
/:  Bus 03.Port 1: Dev 1, Class=root_hub, Driver=ehci_hcd/2p, 480M
    |__ Port 1: Dev 2, If 0, Class=hub, Driver=hub/6p, 480M
/:  Bus 02.Port 1: Dev 1, Class=root_hub, Driver=xhci_hcd/4p, 5000M
/:  Bus 01.Port 1: Dev 1, Class=root_hub, Driver=xhci_hcd/4p, 480M
    |__ Port 4: Dev 2, If 0, Class='bInterfaceClass 0x0e not yet handled', Driver=uvcvideo, 480M
    |__ Port 4: Dev 2, If 1, Class='bInterfaceClass 0x0e not yet handled', Driver=uvcvideo, 480M



Voilà, c'est à peu près tout ce que j'ai...
En espérant que quelqu'un puisse m'aider.

Merci ! smile

P.S : Je pense que le lecteur de carte SD est 00:1f.3 SMBus: Intel Corporation 7 Series/C210 Series Chipset Family SMBus Controller (rev 04), mais je suis pas sûr...

Hors ligne

#2 05-03-2014 16:11:21

pili36
Membre
Lieu : Lille
Distrib. : Debian Jessie / Raspbian Jessie
Noyau : 3.16_amd64 / 3.16_armhf
(G)UI : Mate / Lxde
Inscription : 03-11-2009

Re : Problème de reconnaissance du lecteur SD

Bonjour,

D'après le résultat de ton lspci, il s'agit du lecteur de cartes SD Realtek RTL8411 (Device 5289). Ayant la même carte, je peux te donner 3 solutions. Soit tu suis le lien du wiki debian (EN) et les instructions qu'ils fournissent, soit tu télécharges le .deb disponible, via un lien, dans la documentation Ubuntu (vers le bas de la page), soit tu installes un noyau plus récent en te servant des backports Wheezy.

Si tu as de soucis pour l'une ou l'autre des solutions, n'hésites pas à demander.

Dernière modification par pili36 (05-03-2014 16:25:41)


Debian Jessie Amd64, Mate, Lenovo G50, Amd Q4000 4*1,3Ghz, 4Go RAM, Amd Radeon R3
Debian Jessie Amd64, (pour Steam), Mate, Amd Athlon 860K 4*3.7Ghz, 8Go RAM, AMD Radeon R7 250 2Go
Raspbian Jessie Armhf, Lxde, Raspberry Pi model B

Hors ligne

#3 05-03-2014 21:06:52

Laërte
Membre
Distrib. : Debian Testing
Noyau : Linux 3.16.0-4-amd64
(G)UI : Kwin
Inscription : 01-09-2013

Re : Problème de reconnaissance du lecteur SD

OK, j'ai suivi le wiki debian et tout marche à la perfection ! Les cartes sont reconnues et montées sans problèmes.
Par contre, lors de mes recherches, j'ai chargé beaucoup de modules qui n'ont servis à rien, comment peut-on savoir quels sont les modules chargés inutiles pour les décharger (c'est de l'ordre du détail mais je suis méticuleux tongue )

Merci beaucoup pour ton aide !

Hors ligne

Pied de page des forums