Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#51 26-10-2017 14:58:26

Franck-AWO
Membre
Lieu : Chelles
Distrib. : Debian Stretch (9.1)
Noyau : Linux 4.9.0-4-amd64
(G)UI : Gnome Version 3.22.2
Inscription : 26-10-2017

Re : HandBrake : Mon premier tuto :)

@nIQnutn: a priori je n'avais pas (plus) la GUI après apt-get install handbrake
C'est pour cela que j'ai lancé apt-get install handbrake-gtk
Au passage c'est vrai que je n'ai pas exclusivement suivi le tuto puisque j'ai aussi appliqué les indications trouvées sur www.deb-multimedia.org pour stretch :
add in your /etc/apt/sources.list

deb http://www.deb-multimedia.org stretch main non-free
deb ftp://ftp.deb-multimedia.org stretch main non-free


apt-get update -oAcquire::AllowInsecureRepositories=true


apt-get install deb-multimedia-keyring -oAcquire::AllowInsecureRepositories=true


apt-get update


apt-get dist-upgrade


puis

apt-get install handbrake


apt-get install handbrake-gtk


Mais là ça se complique pour écrire tout ça tout bien avec des explications...
Je trouvais que c'était tout simple d'ajouter la commande apt-get install handbrake-gtk.
En tout cas je n'ai plus le torticolis à regarder mes vidéos prises avec mon téléphone intelligent smile
a+

Edit à toto :

Mis les sources sous les balises Code option : apt_sources et les commandes root sous les balises Commande root du forum, ça fait moins mal aux yeux ainsi... wink

Hors ligne

#52 26-10-2017 15:11:18

nIQnutn
Modérateur
Lieu : Lyon
Distrib. : Stretch
Noyau : Linux 4.9.0-3-amd64
(G)UI : Gnome
Inscription : 16-03-2012
Site Web

Re : HandBrake : Mon premier tuto :)

concernant la partie activation des dépôts, je l'ai mis volontairement dans le tuto qui correspond.
ça évite les doublons et facilite les contributions et mises à jour.

pour handbrake, j'ai rajouté handbrake-gtk dans le wiki.

En ligne

#53 29-10-2017 09:51:14

chalu
Modératrice
Lieu : Anjou
Distrib. : Debian Stretch
Noyau : Linux 4.9.0-3-amd64
(G)UI : Mate 1.16
Inscription : 11-03-2016

Re : HandBrake : Mon premier tuto :)

Juste une question la commande

 apt-get dist-upgrade

ne risque-t-elle pas de mettre à jour des paquets comme vlc ou d’autres sur le dépôt deb-multimédia sans qu’on le veuille ?
Et si on suit le conseil judicieux de faire un fichier de pinning alors dans ce cas, il faut mettre l’option

apt-get -t stable install handbrake

pour installer la version de ce dépot ? sans l’option c’est la version du dépôt officiel qui est installé c’est bien ça ?

Hors ligne

#54 29-10-2017 10:23:28

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 3.16.0-4-amd64 - 3.16.39-1
(G)UI : gnome 1:3.14+3
Inscription : 21-10-2008

Re : HandBrake : Mon premier tuto :)

chalu a écrit :

apt-get -t stable install handbrake


Non rien...
Voir le tuto des dépôts tiers :
https://debian-facile.org/doc:systeme:a … multimedia

cool


"Théo et Adama te rappellent pourquoi Zyed et Bouna couraient…"
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

En ligne

#55 29-10-2017 10:24:51

nIQnutn
Modérateur
Lieu : Lyon
Distrib. : Stretch
Noyau : Linux 4.9.0-3-amd64
(G)UI : Gnome
Inscription : 16-03-2012
Site Web

Re : HandBrake : Mon premier tuto :)

apt-get dist-upgrade est à mon avis à déconseillé sur stable sauf cas très rare.
perso, je dois l'utiliser 2x par an max, apt-get upgrade suffit.
le comportement est variable selon les priorités mais je ne pense pas que cela fasse de différence entre upgrade et dist-upgrade dans ce cas.

oui, théoriquement il faudrait ajouter la cible du dépôt (encore une fois le comportement dépendra des priorités).
faut juste que ça reste raccord entre https://debian-facile.org/doc:systeme:a … pots-tiers et https://debian-facile.org/doc:media:handbrake

En ligne

#56 29-10-2017 10:28:28

enicar
Membre
Lieu : Grenoble
Distrib. : debian/sid
Noyau : Linux 4.11.12
(G)UI : openbox
Inscription : 26-08-2010

Re : HandBrake : Mon premier tuto :)

nIQnutn a écrit :

apt-get dist-upgrade est à mon avis à déconseillé sur stable sauf cas très rare.
perso, je dois l'utiliser 2x par an max, apt-get update suffit.



Je suppose que tu veux dire « apt-get upgrade »… wink


La machine, c'est dépassé ! On va tout remplacer par des humains big_smile

Hors ligne

#57 29-10-2017 10:35:10

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 3.16.0-4-amd64 - 3.16.39-1
(G)UI : gnome 1:3.14+3
Inscription : 21-10-2008

Re : HandBrake : Mon premier tuto :)

enicar a écrit :

apt-get dist-upgrade est à mon avis à déconseillé sur stable sauf cas très rare.


Si cela ne fait pas d' bien, cela ne fait pas d' mal non plus pour les débutants, en attendant qu'ils s'aguerissent ? big_smile


"Théo et Adama te rappellent pourquoi Zyed et Bouna couraient…"
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

En ligne

#58 29-10-2017 10:45:58

enicar
Membre
Lieu : Grenoble
Distrib. : debian/sid
Noyau : Linux 4.11.12
(G)UI : openbox
Inscription : 26-08-2010

Re : HandBrake : Mon premier tuto :)

smolski a écrit :

enicar a écrit :

apt-get dist-upgrade est à mon avis à déconseillé sur stable sauf cas très rare.


Si cela ne fait pas d' bien, cela ne fait pas d' mal non plus pour les débutants, en attendant qu'ils s'aguerissent ? big_smile



Ce n'est pas de moi cette phrase… merci de l'attribuer à son propriétaire big_smile


La machine, c'est dépassé ! On va tout remplacer par des humains big_smile

Hors ligne

#59 29-10-2017 11:02:37

nIQnutn
Modérateur
Lieu : Lyon
Distrib. : Stretch
Noyau : Linux 4.9.0-3-amd64
(G)UI : Gnome
Inscription : 16-03-2012
Site Web

Re : HandBrake : Mon premier tuto :)

oui, je parlais de upgrade et non pas update.

smolski a écrit :

apt-get dist-upgrade est à mon avis à déconseillé sur stable sauf cas très rare.


Si cela ne fait pas d' bien, cela ne fait pas d' mal non plus pour les débutants, en attendant qu'ils s'aguerissent ? big_smile


on a vu tellement de choses surprenantes sur le forum et ailleurs. si les deux commandes sont différentes c'est pas un hasard.
en gros, c'est comme si tu rentrais chez toi en cassant systématiquement la porte alors que tu peux utiliser la clé. c'est certains que si tu casses la porte tu peux renter chez toi. je préfère utiliser la clé pour rentrer et ça marche à 99,9% des cas. si vraiment ça s'ouvre pas, on peut envisager l'autre solution.

En ligne

#60 29-10-2017 11:20:19

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 3.16.0-4-amd64 - 3.16.39-1
(G)UI : gnome 1:3.14+3
Inscription : 21-10-2008

Re : HandBrake : Mon premier tuto :)

/me a perdu les clés des portes de toutes ses habitations depuis longtemps ! big_smile

Sinon, ta remarque est forte, en quoi le nettoyage systématique de ses installations est néfaste au système ?

"Théo et Adama te rappellent pourquoi Zyed et Bouna couraient…"
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

En ligne

#61 29-10-2017 11:37:37

nIQnutn
Modérateur
Lieu : Lyon
Distrib. : Stretch
Noyau : Linux 4.9.0-3-amd64
(G)UI : Gnome
Inscription : 16-03-2012
Site Web

Re : HandBrake : Mon premier tuto :)

upgrade, c'est la méthode soft. avec dist-upgrade c'est beaucoup plus violent, tu laisses la possibilité à apt d'installer ou supprimer des paquets (il gère les conflits).
si upgrade fait le travail pas la peine de lancer dist-upgrade.

après, dist-upgrade est probablement plus utilisé pour unstable et testing qui s'adresse plutôt à des utilisateurs avertis.

En ligne

#62 29-10-2017 11:41:10

chalu
Modératrice
Lieu : Anjou
Distrib. : Debian Stretch
Noyau : Linux 4.9.0-3-amd64
(G)UI : Mate 1.16
Inscription : 11-03-2016

Re : HandBrake : Mon premier tuto :)

Mon interrogation sur dist-upgrade aurait été la même pour upgrade car le problème porte surtout sur le fait qu'il faut qu'il y ait un fichier de préférences sur le dépôt deb-multimedia pour ne pas avoir des paquets, comme vlc installé avec la majorité des bureaux, qui se mettent à jour sur ce dépôt.
Il me semble important que partout dans le wiki dès qu'il est question du dépôt deb-multimedia on ajoute un "rappel" sur la création de ce fichier de préférences, y a-t-il accord sur ce point ?
Il y a eu un fil récent avec des soucis à cause de l'absence de ce fichier de pinning.

smolski a écrit :

Non rien...
Voir le tuto des dépôts tiers :
https://debian-facile.org/doc:systeme:a … multimedia

cool


Fort justement big_smile dans le tuto il y a deux cas/exemples pour les commandes, l'exemple d'avidemux qui n'est pas présent dans les dépôts officiels et s'installe sans l'option -t et l'exemple de ffdiaporama qui est présent dans les dépôts officiels et s'installe alors avec l'option -t si on veut la version du dépôt deb-multimedia.
Pour Handbrake, il est présent dans les dépôts officiels depuis whezzy-backports

J'ai peut-être eu tort d'intervenir car je n'utilise pas ce dépôt et je n'ai pas fait de tests en VM mais il me semble qu'il y aurait des modifications à faire si j'ai compris correctement ... ce qui n'est pas gagné ! lol

Edit : un membre dans un fil récent lui aussi a conseillé l'utilisation d'application portable appImage pour avidemux au lieu d'utiliser le dépôt deb-multimedia, dans le lien ci-dessous il semble que cette possibilité existe aussi pour handbrake :
http://www.omgubuntu.co.uk/2010/07/port … -usb-drive

Hors ligne

#63 29-10-2017 11:51:28

enicar
Membre
Lieu : Grenoble
Distrib. : debian/sid
Noyau : Linux 4.11.12
(G)UI : openbox
Inscription : 26-08-2010

Re : HandBrake : Mon premier tuto :)

nIQnutn a écrit :

après, dist-upgrade est probablement plus utilisé pour unstable et testing qui s'adresse plutôt à des utilisateurs avertis.


Hummm…  Je n'utilise que debian/sid et je ne fais que des « aptitude safe-upgrade », c'est bien plus sûr. Je dirais même
que dist-upgrade (ou full-upgrade) posera moins de soucis en stable qu'en testing/unstable car il y a beaucoup moins
de mises à jour. Avec sid (unstable) il faut avoir de la patience. Certains paquets peuvent voir leur mises à jour bloquer
plusieurs semaines. L'expérience m'a montré que le forçage dans l'upgrade produisait des résultats fort peu désirables.
Donc, il vaut mieux être circonspect… Ce que l'on peut faire, c'est regarder dans aptitude en mode curses, si on peut trouver
une solution manuellement, mais je ne fais jamais de full-upgrade (dist-upgrade) qui devrait être réservé pour les changements
de version majeure de la distribution.

J'ai entendu dire que certains utilisent tout le temps dist-upgrade en testing/sid et qu'ils n'ont pas eu de problèmes… mais
je doute que ce soit une bonne pratique, notamment en sid où certains paquets peuvent être suffisamment buggés pour ne plus
fonctionner du tout, ou pire ne pas s'installer correctement, prudence donc …


La machine, c'est dépassé ! On va tout remplacer par des humains big_smile

Hors ligne

#64 29-10-2017 12:16:07

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 3.16.0-4-amd64 - 3.16.39-1
(G)UI : gnome 1:3.14+3
Inscription : 21-10-2008

Re : HandBrake : Mon premier tuto :)

nIQnutn a écrit :

tu laisses la possibilité à apt d'installer ou supprimer des paquets (il gère les conflits)


Oui, mais il t'averti dans ce cas.
Ce qui revient à utiliser un aptitude restreint, c'est à dire sans les solutions toujours délicates à lire pour un débutant (même un peu plus...) wink

Dès lors, on peut refuser la mise à jour et passer un petit up sur le forum df dans la difficulté.

Dernière modification par smolski (29-10-2017 12:18:42)


"Théo et Adama te rappellent pourquoi Zyed et Bouna couraient…"
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

En ligne

#65 29-10-2017 12:51:02

nIQnutn
Modérateur
Lieu : Lyon
Distrib. : Stretch
Noyau : Linux 4.9.0-3-amd64
(G)UI : Gnome
Inscription : 16-03-2012
Site Web

Re : HandBrake : Mon premier tuto :)

@enicar: théoriquement, avec une debian stable pure, tu peux utiliser dist-upgrade et ça ne posera pas de problème. aucun nouveau paquet n'est censé s'ajouter après sa sortie. 
dans la réalité, les configurations sont parfois complexes et dans certains cas bancales.
de toute façon, si upgrade n'est pas suffisant, tout a toujours possibilité de lancer dist-upgrade par la suite. revenir en arrière après dist-upgrade pour ne faire qu'un upgrade, c'est plus compliqué.

@smolski: cela suppose dans ton cas que l'utilisateur soit vigilant. je ne le suis pas toujours donc j'évite ce genre de solution. certains n'ont pas nécessairement conscience des répercussions.

il faudrait regarder ce qui est préconisé dans les différentes documentations.

dans tous les cas, s'il n'y a pas de conflit, apt-get upgrade suffit. ça c'est certain.
s'il y a un conflit, il me semble nécessaire de lancer dist-upgrade avec prudence et ne pas hésiter à refuser les modifications. en plus,  aptitude full-upgrade pourrait donner des résultats plus pertinents. donc, cette commande ne devrait pas être lancé par habitude mais par nécessité.

en tout cas avec aptitude, on a  aptitude safe-upgrade et  aptitude full-upgrade . c'est plutôt explicite comme nom.
après, c'est sûrement des habitudes liées à Ubuntu qui n'ont pas lieu d'être ici.

@chalu: par défaut, on attribue une certaine priorité aux dépôts tiers (je veux dire sans avoir besoin d'éditer de fichier préférence).
je sais que pour backports c'est 100. pour les autres je ne sais pas.
du coup, c'est pas toujours indispensable mais simplement recommandé.
"Il me semble important que partout dans le wiki dès qu'il est question du dépôt deb-multimedia on ajoute un "rappel" sur la création de ce fichier de préférences," on devrait surtout supprimé ces redondances et ajouter un lien vers https://debian-facile.org/doc:systeme:a … multimedia . éventuellement on pourrait rajouter le fichier "preferences"

quand tu ajoutes "-t", ça augmente la priorité. du coup le paquet de deb-multimedia s'installera en priorité sur celui de Debian.
si on ne mets pas "-t" c'est uniquement parce qu'il n'a pas besoin de se poser la question. mais si tu fais 'apt-get -t stable install avidemux' ça le fait aussi.
personnellement, je trouve la commande dans le wiki "apt-get install avidemux"  superflue et inutile.

En ligne

#66 29-10-2017 14:06:07

chalu
Modératrice
Lieu : Anjou
Distrib. : Debian Stretch
Noyau : Linux 4.9.0-3-amd64
(G)UI : Mate 1.16
Inscription : 11-03-2016

Re : HandBrake : Mon premier tuto :)

@nIQnutn : stretch-backports est par défaut à 100 sans action de l’administrateur du PC car il est pris en charge par Debian.
Les autres dépôts, comme deb-multimedia, sont à 500 comme les dépôts stables si on ne fait pas de fichiers de pinning.

Hors ligne

#67 29-10-2017 14:32:22

nIQnutn
Modérateur
Lieu : Lyon
Distrib. : Stretch
Noyau : Linux 4.9.0-3-amd64
(G)UI : Gnome
Inscription : 16-03-2012
Site Web

Re : HandBrake : Mon premier tuto :)

dans ce cas, il est important de créer le fichier "preferences".
on peut essayer de compléter la partie sur deb-multimédia.

En ligne

#68 29-10-2017 16:09:56

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 3.16.0-4-amd64 - 3.16.39-1
(G)UI : gnome 1:3.14+3
Inscription : 21-10-2008

Re : HandBrake : Mon premier tuto :)

nIQnutn a écrit :

on peut essayer de compléter la partie sur deb-multimédia.


Il y a un lien vers les dépôts tiers de créé. smile


"Théo et Adama te rappellent pourquoi Zyed et Bouna couraient…"
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

En ligne

#69 29-10-2017 18:14:03

deuchdeb
Moderato ma non troppo
Lieu : Pays de Cocagne
Distrib. : Strtch 9 + backports
Noyau : Noyau stable
(G)UI : KDE 5.8 - Gnome 3.22
Inscription : 13-01-2010

Re : HandBrake : Mon premier tuto :)

On a tout ça ici : https://debian-facile.org/doc:systeme:a … multimedia

nIQnutn a écrit :

je trouve la commande dans le wiki "apt-get install avidemux"  superflue et inutile.


Je me suis fait la même réflexion.

En ligne

#70 29-10-2017 19:00:12

nIQnutn
Modérateur
Lieu : Lyon
Distrib. : Stretch
Noyau : Linux 4.9.0-3-amd64
(G)UI : Gnome
Inscription : 16-03-2012
Site Web

Re : HandBrake : Mon premier tuto :)

le ménage est fait.

En ligne

Pied de page des forums