Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 22-03-2014 11:47:48

cybertaf
Membre
Distrib. : Debian GNU/Linux jessie/sid
Noyau : 3.10.37-031037-generic
Inscription : 12-02-2014

Wake On LAN sur Jessie

Bonjour,

Alors voilà, je galère depuis un petit moment pour faire du WOL sur une Debian Jessie.
Ma carte mère est une Asrock FM2A78M-ITX+ et j'utilise le chipset réseau de la carte, un Qualcomm Atheros AR8171, qui supporte le WOL.
Le BIOS est correctement paramétré, pour faire des tests j'ai installé une Win7. Le WOL fonctionne très bien dans ce cas-là et la diode reste allumée.
Par contre, sur Debian elle est constamment éteinte.

Quand je fais un ethtool eth0, j'obtiens:

Settings for eth0:
        Supported ports: [ TP ]
        Supported link modes:   10baseT/Half 10baseT/Full
                                100baseT/Half 100baseT/Full
                                1000baseT/Full
        Supported pause frame use: Symmetric Receive-only
        Supports auto-negotiation: Yes
        Advertised link modes:  10baseT/Half 10baseT/Full
                                100baseT/Half 100baseT/Full
                                1000baseT/Full
        Advertised pause frame use: Symmetric
        Advertised auto-negotiation: Yes
        Speed: 1000Mb/s
        Duplex: Full
        Port: Twisted Pair
        PHYAD: 0
        Transceiver: internal
        Auto-negotiation: on
        MDI-X: Unknown
        Current message level: 0x000060e4 (24804)
                               link ifup rx_err tx_err hw wol
        Link detected: yes



Apparemment, il manque les lignes

Supports Wake-on: pumbg
Wake-on: g



Quand je fais un ethtool -s eth0 wol g, la réponse est:

Cannot get current wake-on-lan settings: Operation not supported
  not setting wol



J'ai testé plusieurs tutos trouvés sur le net en rajoutant dans /etc/network/interfaces

up ethtool -s $IFACE wol g
ethernet-wol g
post-up ethtool -s eth0 wol g
post-down ethtool -s eth0 wol g



et aussi

NETDOWN=no


dans /etc/default/halt et dans /etc/init.d/halt mais rien n'y fait...

Est-ce que quelqu'un peut m'aider car là je sèche un peu sad

Hors ligne

#2 22-03-2014 17:11:28

captnfab
Admin-Girafe
Lieu : /dev/random
Distrib. : Debian Stretch/Sid/Rc-Buggy
Noyau : Linux (≥ 4.3)
(G)UI : i3-wm (≥ 4.11)
Inscription : 07-07-2008
Site Web

Re : Wake On LAN sur Jessie

Salut,
Je ne comprends pas trop ce que tu cherches à faire. Je pensais que le WOL était un truc purement lié au bios et sans configuration à faire sur le système.

captnfab,
Association Debian-Facile, bépo.
TheDoctor: Your wish is my command… But be careful what you wish for.

Hors ligne

#3 22-03-2014 17:43:37

cybertaf
Membre
Distrib. : Debian GNU/Linux jessie/sid
Noyau : 3.10.37-031037-generic
Inscription : 12-02-2014

Re : Wake On LAN sur Jessie

Ben non.
Apparemment sous Linux, l'OS (ou le pilote) désactive l'alimentation du chipset à la fermeture.
C'est plus compliqué que sous Windows où il y a juste quelques case à cocher dans l'alimentation du périphérique.

Hors ligne

#4 23-03-2014 10:54:57

cybertaf
Membre
Distrib. : Debian GNU/Linux jessie/sid
Noyau : 3.10.37-031037-generic
Inscription : 12-02-2014

Re : Wake On LAN sur Jessie

Un p'tit UP...

Hors ligne

#5 23-03-2014 11:25:06

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : Wake On LAN sur Jessie

Bonjour et bienvenue  smile

Une petite piqûre de rappel concernant un texte que tu as sans doute lu : http://debian-facile.org/doku.php?id=re … -generales

Les personnes ayant souscrit sont bénévoles : ce n'est pas parce qu'une question est posée, qu'une réponse DOIT être donnée ; donc, si votre question ne reçoit pas de réponse immédiate, attendez un peu (24 à 48H semble un délai raisonnable) avant de reposter… Il se peut aussi que votre question ne soit pas bien formulée (auquel cas ceux qui pourraient vous aider n'ont certainement rien compris à votre problème) ou que - cela arrive - personne n'ait de réponse à vous apporter !

Aussi, pour le confort de tous, ne pratique-t-on pas le "up" ici.  wink
Merci de ta compréhension.

Patience et bon courage.
  smile


I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

#6 23-03-2014 11:38:58

cybertaf
Membre
Distrib. : Debian GNU/Linux jessie/sid
Noyau : 3.10.37-031037-generic
Inscription : 12-02-2014

Re : Wake On LAN sur Jessie

Bonjour Paskal.
Mea Cupa...
Je patiente alors smile

Hors ligne

#7 23-03-2014 12:18:41

bendia
Admin stagiaire
Distrib. : Jessie
Noyau : 3.16.0-4-amd64
(G)UI : Gnome + XFCE + Console
Inscription : 20-03-2012
Site Web

Re : Wake On LAN sur Jessie

Salut

Je ne sais pas si tu as vu ça : https://www.linuxquestions.org/question … 175491464/

En espérant que ça puisse aider smile

Ben
___________________
La seule question bête, c'est celle qu'on ne pose pas.
file-Re06858991f6f328b4907296ac5cea283

Hors ligne

#8 23-03-2014 12:23:08

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : Wake On LAN sur Jessie

Once verified the power button got briefly pressed, so the system went into S5-mode.

Je me demande si c'est lié à cette carte, ou ce serait nécessaire pour toute config ?


I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

#9 23-03-2014 12:31:25

cybertaf
Membre
Distrib. : Debian GNU/Linux jessie/sid
Noyau : 3.10.37-031037-generic
Inscription : 12-02-2014

Re : Wake On LAN sur Jessie

bendia a écrit :

Salut

Je ne sais pas si tu as vu ça : https://www.linuxquestions.org/question … 175491464/

En espérant que ça puisse aider smile



Salut !
Oui je l'avais vu.
Si mes notions d'anglais sont bonnes, il dit qu'il a appuyé sur le bouton "Power" pour éteindre le PC.
J'avais testé mais ça n'a pas résolu mon soucis sad

Apparemment il dit aussi qu'il a peaufiné les réglages du driver alx pour que ça marche:

just the alx-kernel driver need to be polished as shown above so it will support "wol-g¨ in /etc/network/interfaces ( debian/wheezy )



Mais personnellement, j'ai toujours l'erreur

Cannot get current wake-on-lan settings: Operation not supported
  not setting wol



mad

Hors ligne

#10 23-03-2014 12:38:54

bendia
Admin stagiaire
Distrib. : Jessie
Noyau : 3.16.0-4-amd64
(G)UI : Gnome + XFCE + Console
Inscription : 20-03-2012
Site Web

Re : Wake On LAN sur Jessie

Ce que je comprend, c'est que le matériel sait le faire (chez moi, une brève pression sur le bouton marche met le PC en veille et la carte réseau reste donc allumée), mais que le pilote n'est pas capable de maintenir cet état avec le PC complètement éteint (la commande wol g n'est pas encore supportée par le pilote). Donc, pour l'instant, ça semble compliqué hmm

Ben
___________________
La seule question bête, c'est celle qu'on ne pose pas.
file-Re06858991f6f328b4907296ac5cea283

Hors ligne

#11 23-03-2014 13:14:26

cybertaf
Membre
Distrib. : Debian GNU/Linux jessie/sid
Noyau : 3.10.37-031037-generic
Inscription : 12-02-2014

Re : Wake On LAN sur Jessie

Effectivement on peut le comprendre comme ça aussi...

Le matériel sait le faire oui. Je viens de restester avec Win7, ça fonctionne parfaitement. Ça vient donc bien de Debian, je ne sais pas si c'est le pilote ou la gestion de l'alimentation qui pose ce soucis.

J'ai tout de même testé de supprimer le fichier /usr/lib/pm-utils/sleep.d/50unload_alx qui est apparemment le script qui désactive le pilote à la fermeture. Sans succès...

Je continue de chercher hmm Merci de vous être penchés sur mon problème en tout cas.

Hors ligne

#12 23-03-2014 19:43:30

fran.b
Membre
Inscription : 02-01-2012

Re : Wake On LAN sur Jessie

Le wake on lan marche-t-il si la machine est complètement éteinte (halt) et non en hibernation? Cela dit le problème semble être visiblement que la carte ne reconnait pas le WOL. Peux tu indiquer le résultat de lspci -n pour ta carte (en clair lspci -v suivi de lspci -n) pour qu'on voit le module utilisé. Indique également ton noyau.

Hors ligne

#13 23-03-2014 20:02:41

cybertaf
Membre
Distrib. : Debian GNU/Linux jessie/sid
Noyau : 3.10.37-031037-generic
Inscription : 12-02-2014

Re : Wake On LAN sur Jessie

Salut,

Non le WOL ne fonctionne pas, ni avec "halt", ni avec "shutdown".

Le noyau est 3.13-1-amd64.

lspci -v


00:00.0 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 15h (Models 10h-1fh) Processor Root Complex
  Subsystem: ASRock Incorporation Device 1410
  Flags: bus master, 66MHz, medium devsel, latency 0

00:01.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Richland [Radeon HD 8470D] (prog-if 00 [VGA controller])
  Subsystem: ASRock Incorporation Device 9996
  Flags: bus master, fast devsel, latency 0, IRQ 11
  Memory at d0000000 (32-bit, prefetchable) [size=256M]
  I/O ports at f000 [size=256]
  Memory at ff700000 (32-bit, non-prefetchable) [size=256K]
  Expansion ROM at <unassigned> [disabled]
  Capabilities: [50] Power Management version 3
  Capabilities: [58] Express Root Complex Integrated Endpoint, MSI 00
  Capabilities: [a0] MSI: Enable- Count=1/1 Maskable- 64bit+
  Capabilities: [100] Vendor Specific Information: ID=0001 Rev=1 Len=010 <?>

00:01.1 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] Trinity HDMI Audio Controller
  Subsystem: ASRock Incorporation Device 9902
  Flags: bus master, fast devsel, latency 0, IRQ 48
  Memory at ff744000 (32-bit, non-prefetchable) [size=16K]
  Capabilities: [50] Power Management version 3
  Capabilities: [58] Express Root Complex Integrated Endpoint, MSI 00
  Capabilities: [a0] MSI: Enable+ Count=1/1 Maskable- 64bit+
  Capabilities: [100] Vendor Specific Information: ID=0001 Rev=1 Len=010 <?>
  Kernel driver in use: snd_hda_intel

00:10.0 USB controller: Advanced Micro Devices, Inc. [AMD] FCH USB XHCI Controller (rev 09) (prog-if 30 [XHCI])
  Subsystem: ASRock Incorporation Device 7814
  Flags: bus master, fast devsel, latency 0, IRQ 18
  Memory at ff74a000 (64-bit, non-prefetchable) [size=8K]
  Capabilities: [50] Power Management version 3
  Capabilities: [70] MSI: Enable- Count=1/8 Maskable- 64bit+
  Capabilities: [90] MSI-X: Enable+ Count=8 Masked-
  Capabilities: [a0] Express Root Complex Integrated Endpoint, MSI 00
  Capabilities: [100] Latency Tolerance Reporting
  Kernel driver in use: xhci_hcd

00:10.1 USB controller: Advanced Micro Devices, Inc. [AMD] FCH USB XHCI Controller (rev 09) (prog-if 30 [XHCI])
  Subsystem: ASRock Incorporation Device 7814
  Flags: bus master, fast devsel, latency 0, IRQ 17
  Memory at ff748000 (64-bit, non-prefetchable) [size=8K]
  Capabilities: [50] Power Management version 3
  Capabilities: [70] MSI: Enable- Count=1/8 Maskable- 64bit+
  Capabilities: [90] MSI-X: Enable+ Count=8 Masked-
  Capabilities: [a0] Express Root Complex Integrated Endpoint, MSI 00
  Kernel driver in use: xhci_hcd

00:11.0 SATA controller: Advanced Micro Devices, Inc. [AMD] FCH SATA Controller [AHCI mode] (rev 40) (prog-if 01 [AHCI 1.0])
  Subsystem: ASRock Incorporation Device 7801
  Flags: bus master, 66MHz, medium devsel, latency 32, IRQ 47
  I/O ports at f140 [size=8]
  I/O ports at f130 [size=4]
  I/O ports at f120 [size=8]
  I/O ports at f110 [size=4]
  I/O ports at f100 [size=16]
  Memory at ff751000 (32-bit, non-prefetchable) [size=2K]
  Capabilities: [50] MSI: Enable+ Count=1/8 Maskable- 64bit+
  Capabilities: [70] SATA HBA v1.0
  Kernel driver in use: ahci

00:12.0 USB controller: Advanced Micro Devices, Inc. [AMD] FCH USB OHCI Controller (rev 11) (prog-if 10 [OHCI])
  Subsystem: ASRock Incorporation Device 7807
  Flags: bus master, 66MHz, medium devsel, latency 32, IRQ 18
  Memory at ff750000 (32-bit, non-prefetchable) [size=4K]
  Kernel driver in use: ohci-pci

00:12.2 USB controller: Advanced Micro Devices, Inc. [AMD] FCH USB EHCI Controller (rev 11) (prog-if 20 [EHCI])
  Subsystem: ASRock Incorporation Device 7808
  Flags: bus master, 66MHz, medium devsel, latency 32, IRQ 17
  Memory at ff74f000 (32-bit, non-prefetchable) [size=256]
  Capabilities: [c0] Power Management version 2
  Capabilities: [e4] Debug port: BAR=1 offset=00e0
  Kernel driver in use: ehci-pci

00:13.0 USB controller: Advanced Micro Devices, Inc. [AMD] FCH USB OHCI Controller (rev 11) (prog-if 10 [OHCI])
  Subsystem: ASRock Incorporation Device 7807
  Flags: bus master, 66MHz, medium devsel, latency 32, IRQ 18
  Memory at ff74e000 (32-bit, non-prefetchable) [size=4K]
  Kernel driver in use: ohci-pci

00:13.2 USB controller: Advanced Micro Devices, Inc. [AMD] FCH USB EHCI Controller (rev 11) (prog-if 20 [EHCI])
  Subsystem: ASRock Incorporation Device 7808
  Flags: bus master, 66MHz, medium devsel, latency 32, IRQ 17
  Memory at ff74d000 (32-bit, non-prefetchable) [size=256]
  Capabilities: [c0] Power Management version 2
  Capabilities: [e4] Debug port: BAR=1 offset=00e0
  Kernel driver in use: ehci-pci

00:14.0 SMBus: Advanced Micro Devices, Inc. [AMD] FCH SMBus Controller (rev 16)
  Subsystem: ASRock Incorporation Device 780b
  Flags: 66MHz, medium devsel
  Kernel driver in use: piix4_smbus

00:14.2 Audio device: Advanced Micro Devices, Inc. [AMD] FCH Azalia Controller (rev 01)
  Subsystem: ASRock Incorporation Device 1150
  Flags: bus master, slow devsel, latency 32, IRQ 16
  Memory at ff740000 (64-bit, non-prefetchable) [size=16K]
  Capabilities: [50] Power Management version 2
  Kernel driver in use: snd_hda_intel

00:14.3 ISA bridge: Advanced Micro Devices, Inc. [AMD] FCH LPC Bridge (rev 11)
  Subsystem: ASRock Incorporation Device 780e
  Flags: bus master, 66MHz, medium devsel, latency 0

00:14.4 PCI bridge: Advanced Micro Devices, Inc. [AMD] FCH PCI Bridge (rev 40) (prog-if 01 [Subtractive decode])
  Flags: bus master, 66MHz, medium devsel, latency 64
  Bus: primary=00, secondary=01, subordinate=01, sec-latency=64

00:14.5 USB controller: Advanced Micro Devices, Inc. [AMD] FCH USB OHCI Controller (rev 11) (prog-if 10 [OHCI])
  Subsystem: ASRock Incorporation Device 7809
  Flags: bus master, 66MHz, medium devsel, latency 32, IRQ 18
  Memory at ff74c000 (32-bit, non-prefetchable) [size=4K]
  Kernel driver in use: ohci-pci

00:15.0 PCI bridge: Advanced Micro Devices, Inc. [AMD] Hudson PCI to PCI bridge (PCIE port 0) (prog-if 00 [Normal decode])
  Flags: bus master, fast devsel, latency 0
  Bus: primary=00, secondary=02, subordinate=02, sec-latency=0
  I/O behind bridge: 0000e000-0000efff
  Memory behind bridge: ff600000-ff6fffff
  Capabilities: [50] Power Management version 3
  Capabilities: [58] Express Root Port (Slot+), MSI 00
  Capabilities: [a0] MSI: Enable+ Count=1/1 Maskable- 64bit+
  Capabilities: [b0] Subsystem: Advanced Micro Devices, Inc. [AMD] Device 0000
  Capabilities: [b8] HyperTransport: MSI Mapping Enable+ Fixed+
  Capabilities: [100] Vendor Specific Information: ID=0001 Rev=1 Len=010 <?>
  Kernel driver in use: pcieport

00:18.0 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 15h (Models 10h-1fh) Processor Function 0
  Flags: fast devsel

00:18.1 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 15h (Models 10h-1fh) Processor Function 1
  Flags: fast devsel

00:18.2 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 15h (Models 10h-1fh) Processor Function 2
  Flags: fast devsel

00:18.3 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 15h (Models 10h-1fh) Processor Function 3
  Flags: fast devsel
  Capabilities: [f0] Secure device <?>
  Kernel driver in use: k10temp

00:18.4 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 15h (Models 10h-1fh) Processor Function 4
  Flags: fast devsel

00:18.5 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 15h (Models 10h-1fh) Processor Function 5
  Flags: fast devsel

02:00.0 Ethernet controller: Qualcomm Atheros QCA8171 Gigabit Ethernet (rev 10)
  Subsystem: ASRock Incorporation Device 10a1
  Flags: bus master, fast devsel, latency 0, IRQ 49
  Memory at ff600000 (64-bit, non-prefetchable) [size=256K]
  I/O ports at e000 [size=128]
  Capabilities: [40] Power Management version 3
  Capabilities: [58] Express Endpoint, MSI 00
  Capabilities: [c0] MSI: Enable+ Count=1/16 Maskable+ 64bit+
  Capabilities: [d8] MSI-X: Enable- Count=16 Masked-
  Capabilities: [100] Advanced Error Reporting
  Capabilities: [180] Device Serial Number ff-fb-09-90-bc-5f-f4-ff
  Kernel driver in use: alx
 



lspci -n


00:00.0 0600: 1022:1410
00:01.0 0300: 1002:9996
00:01.1 0403: 1002:9902
00:10.0 0c03: 1022:7814 (rev 09)
00:10.1 0c03: 1022:7814 (rev 09)
00:11.0 0106: 1022:7801 (rev 40)
00:12.0 0c03: 1022:7807 (rev 11)
00:12.2 0c03: 1022:7808 (rev 11)
00:13.0 0c03: 1022:7807 (rev 11)
00:13.2 0c03: 1022:7808 (rev 11)
00:14.0 0c05: 1022:780b (rev 16)
00:14.2 0403: 1022:780d (rev 01)
00:14.3 0601: 1022:780e (rev 11)
00:14.4 0604: 1022:780f (rev 40)
00:14.5 0c03: 1022:7809 (rev 11)
00:15.0 0604: 1022:43a0
00:18.0 0600: 1022:1400
00:18.1 0600: 1022:1401
00:18.2 0600: 1022:1402
00:18.3 0600: 1022:1403
00:18.4 0600: 1022:1404
00:18.5 0600: 1022:1405
02:00.0 0200: 1969:10a1 (rev 10)
 



Voilà...

Hors ligne

#14 23-03-2014 21:22:24

fran.b
Membre
Inscription : 02-01-2012

Re : Wake On LAN sur Jessie

Bon, j'ai regardé dans les sources, a priori le WOL est bien supporté (3.10).

1) Vérifie que le WOL est activé via la commande

acpitool -w



Si ça n'est pas le cas (ligne LANC) fais

acpitool -W x



où x est le numéro de LANC.

2) Vérifie que le module alx n'est pas viré à l'hibernation. (

grep alx /usr/lib/pm-utils/sleep.d/*

)

Est ce que le WOL marche sur un arrêt simple (halt) et non une hibernation

[edit: principe des balises compris]

Dernière modification par fran.b (23-03-2014 21:46:26)

Hors ligne

#15 23-03-2014 21:28:40

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : Wake On LAN sur Jessie

Je n'ai pas ces outils disponibles pour tester de mon côté fran.b.
Ce sont des executions user et root telles que je te les ai modifiées dans ton post#14 ?

PS : Edites ton post#14 par Modifier pour voir comment je les ai mises en valeur sur le forum. wink

"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

En ligne

#16 23-03-2014 21:41:25

cybertaf
Membre
Distrib. : Debian GNU/Linux jessie/sid
Noyau : 3.10.37-031037-generic
Inscription : 12-02-2014

Re : Wake On LAN sur Jessie

Merci de t'occuper de mon soucis smile
J'ai déjà testé acpitool.

acpitool -w

renvoie:

   Device       S-state   Status   Sysfs node
  ---------------------------------------
  1. PB2          S4    *disabled
  2. PB3          S4    *disabled
  3. PB4          S4    *disabled
  4. PB5          S4    *disabled
  5. PB6          S4    *disabled
  6. PB7          S4    *disabled
  7. SBAZ         S4    *disabled  pci:0000:00:14.2
  8. PS2K         S4    *disabled
  9. P0PC         S4    *disabled  pci:0000:00:14.4
  10. OHC1        S4    *enabled   pci:0000:00:12.0
  11. EHC1        S4    *enabled   pci:0000:00:12.2
  12. OHC2        S4    *enabled   pci:0000:00:13.0
  13. EHC2        S4    *enabled   pci:0000:00:13.2
  14. OHC3        S4    *disabled
  15. EHC3        S4    *disabled
  16. OHC4        S4    *enabled   pci:0000:00:14.5
  17. XHC0        S4    *enabled   pci:0000:00:10.0
  18. XHC1        S4    *enabled   pci:0000:00:10.1
  19. PE20        S4    *disabled  pci:0000:00:15.0
  20. PE21        S4    *disabled
  21. PE22        S4    *disabled
  22. PE23        S4    *disabled
 


Pas de LANC.
La ligne que je pense correspondre à mon chipset réseau est la 19.
J'ai donc fait un

acpitool -W 19


et ça me passe bien la ligne en "enabled". Le problème c'est qu'au reboot ou au halt, ça revient en "disabled". Ça ne garde pas la modif' en mémoire.

La commande 

grep alx /usr/lib/pm-utils/sleep.d/*

renvoie:

/usr/lib/pm-utils/sleep.d/50unload_alx:# 50unload_alx: unload the alx module during suspend (LP #1173952)
/usr/lib/pm-utils/sleep.d/50unload_alx:[ -d /sys/module/alx ] || exit 0
/usr/lib/pm-utils/sleep.d/50unload_alx:         echo "Unloading alx kernel module ..."
/usr/lib/pm-utils/sleep.d/50unload_alx:         modunload alx && echo Done. || echo Failed.
/usr/lib/pm-utils/sleep.d/50unload_alx:         echo "Reloading alx kernel module ..."
 


Je fais quoi avec ça ?
Pour info j'avais tenté de supprimer 50unload_alx, mais ça n'a eu aucun effet...

Dernière modification par cybertaf (23-03-2014 21:44:09)

Hors ligne

#17 23-03-2014 22:02:34

fran.b
Membre
Inscription : 02-01-2012

Re : Wake On LAN sur Jessie

19. PE20        S4    *disabled  pci:0000:00:15.0


correspond à

00:15.0 PCI bridge: Advanced Micro Devices, Inc. [AMD] Hudson PCI to PCI bridge (PCIE port 0) (prog-if 00 [Normal decode])


donc non. Ta carte est

02:00.0 Ethernet controller: Qualcomm Atheros QCA8171 Gigabit Ethernet (rev 10)


et devrait apparaître comme

1. LANC      S4    *enabled  pci:0000:02:00.0


Elle n'est donc pas vu par l'acpi ce qui explique le pbm. C'est sans doute pour cela qu'elle a droit à un traitement spécial dans l'hibernation. Ceci est spécifique à testing/sid, car ce fichier ne figure pas dans la stable.

En fait ça vient du bug #1173952 (cf https://bugs.launchpad.net/ubuntu/+sour … ug/1173952 )

Visiblement il y a un souci avec le module alx et l'hibernation. As tu des messages spécifiques dans le syslog quand tu actives l'hibernation.

Pour rendre  permanent le «enabled», ça n'est pas un souci mais il faut voir si cela marche.

Tu n'as pas dit si le WOL marchait lors de l'arrêt normal?

Dernière modification par fran.b (23-03-2014 22:16:08)

Hors ligne

#18 23-03-2014 22:21:30

cybertaf
Membre
Distrib. : Debian GNU/Linux jessie/sid
Noyau : 3.10.37-031037-generic
Inscription : 12-02-2014

Re : Wake On LAN sur Jessie

Expliqué comme ça ça me fait sortir de ma newbitude, c'est cool smile

Non le WOL n'a jamais fonctionné sous Debian. Nickel sous Win7, rien du tout sous Debian...

Quand tu dis

Ceci est spécifique à testing/sid

tu veux parler de ma version de Debian (Jessie) ?

J'ai pris cette version justement à cause d'un problème avec mon chipset réseau lors de l'intall. Il n'était pas reconnu.
Si ce n'est que ça, je peux installer une Wheezy stable et installer les pilotes Ethernet après... Si ça peut régler mon problème.

Dernière modification par cybertaf (23-03-2014 22:22:04)

Hors ligne

#19 23-03-2014 22:45:49

fran.b
Membre
Inscription : 02-01-2012

Re : Wake On LAN sur Jessie

Jessie est effectivement testing. C'est plutôt un problème noyau plutôt que de distribution. Quelle version as tu (uname -r)?

Hors ligne

#20 23-03-2014 22:49:35

cybertaf
Membre
Distrib. : Debian GNU/Linux jessie/sid
Noyau : 3.10.37-031037-generic
Inscription : 12-02-2014

Re : Wake On LAN sur Jessie

3.13-1-amd64

Hors ligne

#21 23-03-2014 23:16:28

fran.b
Membre
Inscription : 02-01-2012

Re : Wake On LAN sur Jessie

Groumf, difficile de faire plus récent...

Bon pendant ce temps j'ai regardé et j'ai une mauvaise nouvelle:
http://www.spinics.net/lists/netdev/msg242477.html
En clair le WOL a été supprimé sur le module alx car il ne fonctionnait plus. Je te suggère d'essayer lebon vieux 3.2.0 de la wheezy, peut être que le WOL fonctionnait, j'ai vérifié que alx existait bien sur ce noyau. Installe le noyau sur ta jessie sans rien modifier d'autre, ça ne devrait pas poser de souci

Hors ligne

#22 23-03-2014 23:33:19

cybertaf
Membre
Distrib. : Debian GNU/Linux jessie/sid
Noyau : 3.10.37-031037-generic
Inscription : 12-02-2014

Re : Wake On LAN sur Jessie

Installe le noyau sur ta jessie sans rien modifier d'autre, ça ne devrait pas poser de souci



Je vais peut-être paraître un peu c**, mais comment on fait ?:|
J'imagine que c'est long à expliquer, alors si tu as un lien vers un bon tuto...

Hors ligne

#23 23-03-2014 23:41:25

fran.b
Membre
Inscription : 02-01-2012

Re : Wake On LAN sur Jessie

Pas très dur:

apt-get install linux-headers-3.2.0-4-amd64 linux-image-3.2.0-4-amd64



devrait faire le travail.

Auparavant, si tu n'as pas mis wheezy dans ton sources.list, fais

echo deb http://ftp.fr.debian.org/debian/ wheezy main >> /etc/apt/sources.list
apt-get update

Dernière modification par fran.b (23-03-2014 23:43:08)

Hors ligne

#24 24-03-2014 00:03:54

Invité-5
Banni(e)

Re : Wake On LAN sur Jessie

Salut, j'espère apprendre beaucoup avec vous.

#25 24-03-2014 00:14:17

cybertaf
Membre
Distrib. : Debian GNU/Linux jessie/sid
Noyau : 3.10.37-031037-generic
Inscription : 12-02-2014

Re : Wake On LAN sur Jessie

Ça va c'est assez simple alors smile

Bon je pense que c'est fait. J'ai rebooté.

Si je lance une seconde fois la commande

apt-get install linux-headers-3.2.0-4-amd64 linux-image-3.2.0-4-amd64


J'obtiens:

linux-headers-3.2.0-4-amd64 is already the newest version.
linux-image-3.2.0-4-amd64 is already the newest version.


Par contre si je fais un

uname -r

j'ai toujours

3.13-1-amd64



Dans le dossier /boot, j'ai:

-rw-r--r--  1 root root   150718 mars   5 14:46 config-3.13-1-amd64
-rw-r--r--  1 root root   129094 févr.  2 02:16 config-3.2.0-4-amd64
drwxr-xr-x  5 root root     4096 mars  23 22:54 grub
-rw-r--r--  1 root root 14524948 mars  23 21:09 initrd.img-3.13-1-amd64
-rw-r--r--  1 root root 11688434 mars  23 22:26 initrd.img-3.2.0-4-amd64
-rw-r--r--  1 root root  2353612 mars   5 14:46 System.map-3.13-1-amd64
-rw-r--r--  1 root root  2109657 févr.  2 02:16 System.map-3.2.0-4-amd64
-rw-r--r--  1 root root  2887760 mars   5 14:40 vmlinuz-3.13-1-amd64
-rw-r--r--  1 root root  2837536 févr.  2 01:51 vmlinuz-3.2.0-4-amd64



Il faut reconfigurer quelque chose au démarrage ?

Hors ligne

Pied de page des forums