Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#26 24-03-2014 00:14:54

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : Wake On LAN sur Jessie

cybertaf a écrit :

J'imagine que c'est long à expliquer, alors si tu as un lien vers un bon tuto...


Un tuto sur les sources :
Tuto sur les sources en détail
Un peu longuet mais il semble complet à ce jour. smile


"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#27 24-03-2014 00:17:41

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : Wake On LAN sur Jessie

cybertaf a écrit :

j'ai toujours

3.13-1-amd64


Faire une mise à jour update et full-upgrade certainement. smile


"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#28 24-03-2014 00:20:04

fran.b
Membre
Inscription : 02-01-2012

Re : Wake On LAN sur Jessie

Oui, quand tu boutes, tu dois avoir une banière (au besoin appuies sur une touche (Shift,Espace, ...) et selectionne le noyau dans le menu grub

Hors ligne

#29 24-03-2014 00:41:28

cybertaf
Membre
Distrib. : Debian GNU/Linux jessie/sid
Noyau : 3.10.37-031037-generic
Inscription : 12-02-2014

Re : Wake On LAN sur Jessie

Ah ben ouais ! Vu que je suis en SSH je risquais pas de le voir big_smile

Bon j'ai bien booté sur le kernel 3.2
Maintenant il ne me reconnais plus la carte réseau hmm

Cannot find device "eth0"
Blind socket to interface: No such device
Failed to bring up eth0.



Je n'ai même pas de fichier 70-persistent-net.rules dans /etc/udev/rules.d/

Bon pas grave, je verrai ça plus tard car demain boulot ^^.

Merci à vous tous de m'avoir donné un coup de main en tout cas smile je reviens vers vous dès que je m'y recolle.

Hors ligne

#30 24-03-2014 00:50:48

fran.b
Membre
Inscription : 02-01-2012

Re : Wake On LAN sur Jessie

Merdouille, lemodule alx du 3.2.0 ne connait pas ta carte


filename:       /lib/modules/3.2.0-4-amd64/kernel/drivers/net/ethernet/atheros/alx/alx.ko
staging:        Y
license:        Dual BSD/GPL
description:    Qualcomm Atheros Gigabit Ethernet Driver
author:         Qualcomm Corporation, <nic-devel@qualcomm.com>
alias:          pci:v00001969d00001090sv*sd*bc*sc*i*
alias:          pci:v00001969d00001091sv*sd*bc*sc*i*
depends:        
intree:         Y
vermagic:       3.2.0-4-amd64 SMP mod_unload modversions
 

pas de ligne

alias:          pci:v00001969d000010a1sv

tu peux essayer un

modprobe alx

mais je n'y crois guère, on peut trafiquoter  le module pour le forcer à gérer la carte mais ça commence à être aventureux. Il va falloir prendre un noyau intermédiaire et faire des essais mais ça risque d'être long pour un résultat incertain.

/sbin/modinfo alx

Hors ligne

#31 26-03-2014 00:57:24

cybertaf
Membre
Distrib. : Debian GNU/Linux jessie/sid
Noyau : 3.10.37-031037-generic
Inscription : 12-02-2014

Re : Wake On LAN sur Jessie

Bonsoir,

Bon j'ai essayé plein de trucs mais là je lâche l'affaire, c'est trop gonflant.
Dommage, la prochaine fois je me renseignerai avant d'acheter du matos sad

Merci à tous quand même smile

Hors ligne

#32 26-03-2014 01:02:01

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : Wake On LAN sur Jessie

/o\

I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

#33 26-03-2014 04:41:26

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : Wake On LAN sur Jessie

Merci de tes retours, cela a permis de proposer des solutions avancées sur le forum.

A bientôt, amitié Joel smile

"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#34 26-03-2014 12:08:48

fran.b
Membre
Inscription : 02-01-2012

Re : Wake On LAN sur Jessie

Surveille sur le site kernel.org les changelog qui concernent le module alx

Dernière modification par fran.b (26-03-2014 12:09:23)

Hors ligne

#35 20-04-2014 12:43:55

cybertaf
Membre
Distrib. : Debian GNU/Linux jessie/sid
Noyau : 3.10.37-031037-generic
Inscription : 12-02-2014

Re : Wake On LAN sur Jessie

Bonjour à tous.

Avec ce petit week-end de 3 jours, je me sens la moelle de m'y recoller ^^ (ouais ça m'énerve quand je n'arrive pas à résoudre un problème !)

Si j'en crois ce qui est dit ici, le WOL a été supprimé des pilotes alx depuis le 3/07/2013. Alors bêtement je me suis dit que je n'avais qu'à désinstaller ces pilotes et installer à la place une version antérieure à cette date. J'ai bon ? neutral

Hors ligne

#36 20-04-2014 15:08:01

cybertaf
Membre
Distrib. : Debian GNU/Linux jessie/sid
Noyau : 3.10.37-031037-generic
Inscription : 12-02-2014

Re : Wake On LAN sur Jessie

Yeeeaahhh !!!! Je crois bien que j'ai réussi !! big_smile

J'ai testé plusieurs kernels trouvés ici: http://kernel.ubuntu.com/~kernel-ppa/mainline/

Au fur et à mesure je me notais ceux qui fonctionnais et ceux qui merdaient.
Donc ma conclusion est que le kernel le plus récent qui fonctionne est le 3.10.37-031037-generic (celui-là).

ethtool eth0

renvoie:

Settings for eth0:
        Supported ports: [ TP ]
        Supported link modes:   10baseT/Half 10baseT/Full
                                100baseT/Half 100baseT/Full
                                1000baseT/Full
        Supported pause frame use: Symmetric
        Supports auto-negotiation: Yes
        Advertised link modes:  10baseT/Half 10baseT/Full
                                100baseT/Half 100baseT/Full
                                1000baseT/Full
        Advertised pause frame use: Symmetric
        Advertised auto-negotiation: Yes
        Speed: 1000Mb/s
        Duplex: Full
        Port: Twisted Pair
        PHYAD: 0
        Transceiver: internal
        Auto-negotiation: on
        MDI-X: Unknown
        Supports Wake-on: pg
        Wake-on: pg
        Current message level: 0x000060e4 (24804)
                               link ifup rx_err tx_err hw wol
        Link detected: yes



Et mon WOL fonctionne smile

Ça commence à merder à partir de la 3.11.0 alors je n'ai pas cherché plus loin.

Pour ceux que ça intéresse, voici la manip' à faire:

64bits


wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.10.37-saucy/linux-headers-3.10.37-031037-generic_3.10.37-031037.201404141035_amd64.deb
wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.10.37-saucy/linux-headers-3.10.37-031037_3.10.37-031037.201404141035_all.deb
wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.10.37-saucy/linux-image-3.10.37-031037-generic_3.10.37-031037.201404141035_amd64.deb
dpkg -i *.deb
update-grub
reboot
 



32bits


wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.10.37-saucy/linux-headers-3.10.37-031037-generic_3.10.37-031037.201404141035_i386.deb
wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.10.37-saucy/linux-headers-3.10.37-031037_3.10.37-031037.201404141035_all.deb
wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.10.37-saucy/linux-image-3.10.37-031037-generic_3.10.37-031037.201404141035_i386.deb
dpkg -i *.deb
update-grub
reboot
 



Pour moi je n'ai pas eu à reparamétrer le WOL avec ethtool -s, le Supports Wake-on et le Wake-on sont sur pg par défaut.

Bon question maintenant: est-ce que je peux virer mon kernel 3.13-1-amd64 en toute sécurité ?

Hors ligne

#37 21-04-2014 08:15:03

fran.b
Membre
Inscription : 02-01-2012

Re : Wake On LAN sur Jessie

Oui

Hors ligne

Pied de page des forums