Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 05-11-2008 21:17:33

blux
Membre
Distrib. : Wheezy
Noyau : Linux 3.1.0-1-686-pae
(G)UI : gnome3
Inscription : 05-11-2008

mount partitons ntfs

Salut,

J'ai une Lenny fraichement installée sur mon pc, qui est muni de plusieurs disques durs formatés en ntfs.

Lorsque je clique sur ces disques dans "computer:///"  un message d'erreur apparait : Cannot mount volume. Invalid mount option when attempting to mount the volume.

Premier probleme :

Apres quelques recherches, j'ai pu monter deux des trois disques par la commande :

 debian:/home/blux# mount -t ntfs-3g /dev/sde1 /home/blux/Desktop/500go


Par contre apres un reboot, les disques ne sont plus montés et je dois retaper la ligne, c'est un peu contraignant et je souhaiterait pouvoir y acceder simplement en cliquant dessus. Y a-t-il une solution ?

Deuxiemme probleme
Lorsque j'execute la ligne

 debian:/home/blux# mount -t ntfs-3g /dev/sdb1 /home/blux/Desktop/donnees


pour l'un des trois disques, cela ne fonctionne pas, j'ai droit au message suivant :
"ntfs-3g: Failed to access volume '/dev/sdb1': No such file or directory
Please type '/sbin/mount.ntfs-3g --help' for more information."

J'ai essayé avec :

debian:/home/blux# mount -t ntfs-3g /dev/sdb1 /home/blux/Desktop/donnees -o force


mais ca donne le meme message d'erreur.

Merci d'avance

Hors ligne

#2 05-11-2008 21:30:30

mani
Road-Runnerus digestus
Lieu : Au bout du bout
Distrib. : Jessie
Noyau : Linux 3.16.0-4-amd64
(G)UI : Mate
Inscription : 20-06-2007

Re : mount partitons ntfs

Pour ton premier problème, il va falloir que tu édites le fichier /etc/fstab et que tu rajoutes à la fin cette ligne (rajoutes-en une par partition à monter) :

/dev/sde1 /home/blux/Desktop/500go ntfs-3g defaults,locale=fr_FR.utf8 0 0


Pour ton deuxième problème, es-tu sûr que /dev/sdb1 existe ?

Edit : et pense à faire toujours une copie avant de modifier un fichier :

cp fichier fichier_backup


smile

Dernière modification par mani (05-11-2008 21:31:18)


« Those who dream by day are cognizant of many things which escape those who dream only by night. »
- Edgar Allan Poe

Hors ligne

#3 05-11-2008 21:34:51

tux12
Membre
Lieu : ./
Distrib. : Squeeze
Noyau : Linux 2.6.32-5-686-bigmem
(G)UI : KDE
Inscription : 27-02-2008

Re : mount partitons ntfs

Bonjour,

Pour rendre permanent le montage de tes disques, il faut les inscrire dans le fichier /etc/fstab qui recense les volumes montés statiquement par le système au démarrage.
Regarde le contenu de ce fichier et le man (en français) de fstab, c'est pas compliqué.

Pour ton disque non montable, dis nous ce que te renvoie la commande

ls -l /dev/hd[abcd]*


@+

oups, grillé par mani smile

Hors ligne

#4 05-11-2008 21:46:33

blux
Membre
Distrib. : Wheezy
Noyau : Linux 3.1.0-1-686-pae
(G)UI : gnome3
Inscription : 05-11-2008

Re : mount partitons ntfs

mani a écrit :

Pour ton premier problème, il va falloir que tu édites le fichier /etc/fstab et que tu rajoutes à la fin cette ligne (rajoutes-en une par partition à monter) :

/dev/sde1 /home/blux/Desktop/500go ntfs-3g defaults,locale=fr_FR.utf8 0 0


J'ai installé la distro en anglais, et j'ai un clavier belge,  Je me souviens vaguement qu'a l'install j'ai accepté un truc comme utf8 mais US et pas FR, du coup, j'ai peur d'effectuer ta commande. Y a-t-il un risque ?

mani a écrit :

Pour ton deuxième problème, es-tu sûr que /dev/sdb1 existe ?


Oui il existe, mais apparament il a un probleme.
Peut etre ca vient du fait que, lors de l'installation, pour ne pas prendre de risque de me tromper de disque, j'ai débranché tout mes disques sauf celui réservé a Debian.  Une fois l'install terminée, j'ai eteind l'ordinateur et j'ai rebranché mes autres disques. Au redemarage il y a eu des problemes, je pense que les disques ont du se "mélanger", j'ai alors changé les cables sata de place sur la carte mere et j'ai pu booter.

voici le résultat de fdisk -l :

debian:/home/blux# fdisk -l

Disk /dev/sda: 250.0 GB, 250059350016 bytes
255 heads, 63 sectors/track, 30401 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x0001efb4

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1               1        6091    48925926   83  Linux
/dev/sda2           28942       30401    11727450    5  Extended
/dev/sda3            6092       28941   183542625   83  Linux
/dev/sda5           28943       30401    11719417+  82  Linux swap / Solaris

Partition table entries are not in disk order

Disk /dev/sdb: 250.0 GB, 250059350016 bytes
255 heads, 63 sectors/track, 30401 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x2052474d

This doesn't look like a partition table
Probably you selected the wrong device.

   Device Boot      Start         End      Blocks   Id  System
/dev/sdb1   ?         410      119791   958924038+   7  HPFS/NTFS
Partition 1 does not end on cylinder boundary.
/dev/sdb2   ?      121585      234786   909287957+  43  Unknown
Partition 2 does not end on cylinder boundary.
/dev/sdb3   ?       14052       14052           5   72  Unknown
Partition 3 does not end on cylinder boundary.
/dev/sdb4          164483      164486       25945    0  Empty
Partition 4 does not end on cylinder boundary.

Partition table entries are not in disk order

Disk /dev/sdc: 250.0 GB, 250059350016 bytes
255 heads, 63 sectors/track, 30401 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x0001b74f

   Device Boot      Start         End      Blocks   Id  System

Disk /dev/sdd: 250.0 GB, 250059350016 bytes
255 heads, 63 sectors/track, 30401 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x66214322

   Device Boot      Start         End      Blocks   Id  System
/dev/sdd1   *           1        3824    30716248+   7  HPFS/NTFS

Disk /dev/sde: 500.1 GB, 500107862016 bytes
255 heads, 63 sectors/track, 60801 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0xc19f3b46

   Device Boot      Start         End      Blocks   Id  System
/dev/sde1               1       60801   488384001    7  HPFS/NTFS

Disk /dev/sdf: 300.0 GB, 300090728448 bytes
184 heads, 52 sectors/track, 61257 cylinders
Units = cylinders of 9568 * 512 = 4898816 bytes
Disk identifier: 0x0000ce8b

   Device Boot      Start         End      Blocks   Id  System
/dev/sdf1   *           1       61258   293054464    7  HPFS/NTFS
debian:/home/blux#

Hors ligne

#5 05-11-2008 21:51:14

blux
Membre
Distrib. : Wheezy
Noyau : Linux 3.1.0-1-686-pae
(G)UI : gnome3
Inscription : 05-11-2008

Re : mount partitons ntfs

tux12 a écrit :

Pour ton disque non montable, dis nous ce que te renvoie la commande

ls -l /dev/hd[abcd]*


@+

oups, grillé par mani smile


Ah ben moi aussi je suis grillé. Du coup voila le resultat :

debian:/home/blux# ls -l /dev/hd[abcd]*
ls: cannot access /dev/hd[abcd]*: No such file or directory
debian:/home/blux# ls -l /dev/hdb
ls: cannot access /dev/hdb: No such file or directory
debian:/home/blux# ls -l /dev/hda
ls: cannot access /dev/hda: No such file or directory
debian:/home/blux# ls -l /dev/hdc
ls: cannot access /dev/hdc: No such file or directory
debian:/home/blux# ls -l /dev/hdd
ls: cannot access /dev/hdd: No such file or directory


mouarf la premiere ligne, j'avais pas réalisé tout de suite smile

Hors ligne

#6 05-11-2008 22:09:13

mani
Road-Runnerus digestus
Lieu : Au bout du bout
Distrib. : Jessie
Noyau : Linux 3.16.0-4-amd64
(G)UI : Mate
Inscription : 20-06-2007

Re : mount partitons ntfs

blux a écrit :

J'ai installé la distro en anglais, et j'ai un clavier belge,  Je me souviens vaguement qu'a l'install j'ai accepté un truc comme utf8 mais US et pas FR, du coup, j'ai peur d'effectuer ta commande. Y a-t-il un risque ?


Je ne pense pas que tu risques quoique ce soit, ça définit juste un système d'encodage de caractères à utiliser pour la partition. Tu peux juste mettre defaults si tu veux, mais tu auras peut-être des caractères bizarres (à cause des différences d'encodage entre Windows et GNU/Linux, surtout les accents). D'ailleurs fais attention aux caractères que tu utilises, Linux supporte des caractères que Windows ne supporte pas !

Et pour ton deuxième problème on dirait que tu as un beau bordel dans tes partitions ! Et je ne peux pas te dire si c'est rattrapable ou pas... neutral


« Those who dream by day are cognizant of many things which escape those who dream only by night. »
- Edgar Allan Poe

Hors ligne

#7 05-11-2008 22:42:18

tux12
Membre
Lieu : ./
Distrib. : Squeeze
Noyau : Linux 2.6.32-5-686-bigmem
(G)UI : KDE
Inscription : 27-02-2008

Re : mount partitons ntfs

Bon, je me suis raté, j'aurais du te demander ls -l /dev/[hs]d[abcd]* pour inclure les disques SATA.

Comme mani, je pense que tu as un soucis avec la reconnaissance du partitionnement de ton /dev/hdb. Si tu en as la possibilité, je suggère de tenter de le faire reconnaître correctement sur une machine sous Windows dans un premier temps.

Hors ligne

#8 05-11-2008 22:49:05

blux
Membre
Distrib. : Wheezy
Noyau : Linux 3.1.0-1-686-pae
(G)UI : gnome3
Inscription : 05-11-2008

Re : mount partitons ntfs

tux12 a écrit :

Si tu en as la possibilité, je suggère de tenter de le faire reconnaître correctement sur une machine sous Windows dans un premier temps.


J'avais tenté le coup, j'ai installé vite fait un windows xp sur une des partitions et la le disque est bien reconnu.

debian:/home/blux# ls -l /dev/[hs]d[abcd]*
brw-rw---- 1 root disk 8,  0 2008-11-05 18:38 /dev/sda
brw-rw---- 1 root disk 8,  1 2008-11-05 18:38 /dev/sda1
brw-rw---- 1 root disk 8,  2 2008-11-05 19:13 /dev/sda2
brw-rw---- 1 root disk 8,  3 2008-11-05 18:38 /dev/sda3
brw-rw---- 1 root disk 8,  5 2008-11-05 18:38 /dev/sda5
brw-rw---- 1 root disk 8, 16 2008-11-05 18:38 /dev/sdb
brw-rw---- 1 root disk 8, 32 2008-11-05 18:38 /dev/sdc
brw-rw---- 1 root disk 8, 48 2008-11-05 18:38 /dev/sdd
brw-rw---- 1 root disk 8, 49 2008-11-05 18:38 /dev/sdd1

Hors ligne

#9 05-11-2008 23:07:12

tux12
Membre
Lieu : ./
Distrib. : Squeeze
Noyau : Linux 2.6.32-5-686-bigmem
(G)UI : KDE
Inscription : 27-02-2008

Re : mount partitons ntfs

D'après les infos du fdisk tu as 6 disques sur cette machine: 4 de 250Go chacun (sda à sdd - dont sdc non partitionné) plus un 500Go (sde) et un 300Go (sdf). C'est bien cela?

Le test sous windows dont tu parles, a été fait sur la même machine et configuration (nombre et emplacement des disques)?

Hors ligne

#10 06-11-2008 02:43:12

blux
Membre
Distrib. : Wheezy
Noyau : Linux 3.1.0-1-686-pae
(G)UI : gnome3
Inscription : 05-11-2008

Re : mount partitons ntfs

Oui, c'est correct.
J'ai installé xp sur le sdd et sur la meme machine et la meme configuration.

Hors ligne

#11 06-11-2008 17:02:02

tux12
Membre
Lieu : ./
Distrib. : Squeeze
Noyau : Linux 2.6.32-5-686-bigmem
(G)UI : KDE
Inscription : 27-02-2008

Re : mount partitons ntfs

Bonjour,

Ben je sais pas... hmm
Quelques pistes:
- Vérifier dans le Bios que les paramètres des disques sont corrects (heads, sectors, cyl, et mode) et ce que l'on obtient par autodétection des disques.

- N'y a-t'il pas un RAID activé qui puisse être à l'origine du problème (?)

- Vérifier les cavaliers de config des disques (Master/Slave/CS) et éventuellement les passer en master ou slave selon leur emplacement sur la nappe.

- Je suppose que pour avoir 6 disques tu as ajouté une carte d'interface IDE? J'essaierai de ne garder que le minimum de disques (les partitions nécessaires au système plus le disque mal détecté) et de démonter cette carte pour voir si ça change quelque chose.
Pour ne monter que le minima, tu peux ne garder dans le /etc/fstab que les lignes qui concernent les partitions du système et mettre les autres sd* en commentaire en insérant une # en début de ligne. Ces modifications prendront effet au redémarrage. Ensuite tu pourras toujours tenter de monter les partitions à la main pour tester.

Si tu as des questions n'hésites pas, et tiens nous au courant.

Hors ligne

#12 06-11-2008 20:47:35

blux
Membre
Distrib. : Wheezy
Noyau : Linux 3.1.0-1-686-pae
(G)UI : gnome3
Inscription : 05-11-2008

Re : mount partitons ntfs

Ubuntu hardy etait monté sur un raid 0  et les autres disques etaient en mode raid car ma carte mere venait de sortir en juin et ubuntu ne reconaissais pas les disques en mode sata ide.  Donc ton intuition est peut etre bonne.

Je n'ai pas d'interface ide, la carte a 6 ports sata + 2 pour le raid.

J'ai fini par abandonner, je viens d'installer ubuntu intrepid et tout fonctionne facilement, c'est un peu dommage, mais j'ai besoin d'un systeme fonctionnel et je n'ai malheureusement pas assez de temps pour le moment.  Je reviendrai certainement a Debian plus tard.

En tout cas, merci beaucoup pour vos interventions, j'ai appris pas mal sur les systemes de partitionnement dans cette aventure.

A bientot.

Blux

Hors ligne

Pied de page des forums