Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 31-03-2014 10:31:55

Alarc'h
Membre
Distrib. : Debian 7.0 Wheezy
Noyau : Linux 3.2.0-4-686-pae
(G)UI : TDE / KDE4
Inscription : 31-03-2014

scanner canon MP280 ne fonctionne pas sous wheezy

Bonjour,

j'ai eu à guider par téléphone la reconfiguration d'une machine. Cette machine tournait sur une vieille Ubuntu et le propriétaire ne voulait pas passer à Unity, leur nouveau bureau par défaut. Comme je ne connais pas bien et n'ai pas d'expérience d'Ubuntu, je lui ai fait réinstaller en Debian Wheezy avec Gnome. Tout fonctionne sauf... le scanner !

Il s'agit d'une machine combinée scanner et imprimante, de marque Canon (hélas) un modèle PIXMA MP280.

Auparavant sous Ubuntu tout fonctionnait après que j'ai simplement installé les paquets téléchargés chez Canon :
http://www.canon.fr/Support/Consumer_Pr … oad&page=1

Ubuntu étant censée être juste une Debian bricolée je me suis dit que ça passerait sous Wheezy. Pour la partie impression une fois les programmes canon installés tout marche impeccable. Ce n'est pas le cas du scanner.

J'ai fait décompresser (tout est par téléphone) l'archive et lancer le script d'install avec sudo (j'ai fait faire l'installation Debian avec sudo pour ne pas trop bouleverser les habitudes de l'utilisateur).

L'utilisateur courant est rajouté dans le groupe scanner.

le périphérique usb est bien connecté (on peut d'ailleurs imprimer). La commande lsusb retourne :


g@lily:~/Téléchargements/ lsusb
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 008 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 006: ID 04a9:1746 Canon, Inc. <---VOILÀ LA BÊTE
Bus 003 Device 002: ID 046d:c050 Logitech, Inc. RX 250 Optical Mouse
Bus 004 Device 002: ID 046d:c312 Logitech, Inc. DeLuxe 250 Keyboard
 




la commande sane-find-scanner le voit :


g@lily:~/Téléchargements/ sane-find-scanner
  [...]

found USB scanner (vendor=0x04a9, product=0x1746) at libusb:001:005

  [...]
 



Mais par contre quand on passe aux choses sérieuses avec scanimage avec ou sans sudo :


 g@lily:~/Téléchargements/ sudo scanimage -L

No scanners were identified. If you were expecting something different,
check that the scanner is plugged in, turned on and detected by the
sane-find-scanner tool (if appropriate). Please read the documentation
which came with this software (README, FAQ, manpages).
 



Le scanner est "plugged in", il est "turned on" et il est "detected by the sane-find-scanner tool". Par contre je ne sais pas si il est "appropriate" ou pas cet outil.

Quelqu'un aurait-il une idée de ce qui coince ? Je n'ai jamais rencontré de problème d'installation de scanner, ce qui est bien pratique, mais du coup m'a laissé assez ignare sur ces appareils et leur configuration.

Hors ligne

#2 31-03-2014 10:37:34

Invité-5
Banni(e)

Re : scanner canon MP280 ne fonctionne pas sous wheezy

Bonjour et bienvenue,

En attendant les spécialistes, jette un coup d’œil ici => https://debian-facile.org/doc:materiel: … rs:accueil

#3 31-03-2014 10:44:20

Alarc'h
Membre
Distrib. : Debian 7.0 Wheezy
Noyau : Linux 3.2.0-4-686-pae
(G)UI : TDE / KDE4
Inscription : 31-03-2014

Re : scanner canon MP280 ne fonctionne pas sous wheezy

Merci,

J'ai jeté un oeil, j'avais déjà croisé cette page, mais il n'y a pas grand chose pour Canon et rien qui me sauve wink

Hors ligne

#4 31-03-2014 12:09:22

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : scanner canon MP280 ne fonctionne pas sous wheezy

Salut Alarc'h et bienvenue sur df !

Alarc'h a écrit :

Ubuntu étant censée être juste une Debian bricolée je me suis dit que ça passerait sous Wheezy.


Et ben non, c'est pas juste bricolé, maintenant tu sais. big_smile

J'utilise des imprimantes canon mais j'ai choisi de conserver sur 2 pc un dual-boot avec vista parce que les pilotes canon pour linux ne sont pas à la hauteur de ceux de canon pour le privateur.
Après, c'est chacun qui voit, mais je sais pas faire pour ton cas. wink

Amitié, Joel smile


"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

En ligne

#5 31-03-2014 15:19:39

Alarc'h
Membre
Distrib. : Debian 7.0 Wheezy
Noyau : Linux 3.2.0-4-686-pae
(G)UI : TDE / KDE4
Inscription : 31-03-2014

Re : scanner canon MP280 ne fonctionne pas sous wheezy

Ben crotte alors !

Ça fait pas du tout mon affaire ça. Je pensais que c'était encore une histoire de droits unix, mais quand je vois que root n'y arrive pas ça me coupe un peu les ailes.

Je continue à chercher, car si ça marche sous Ubuntu ça doit bien pouvoir marcher sur Debian quand même. Ça me ferait un peu mal au bas du dos de devoir réinstaller Ubuntu !

Existerait-il un wrapper qui permettrait d'utiliser les pilotes Micromachin sous Linux ?

Hors ligne

#6 31-03-2014 17:04:43

captnfab
Admin-Girafe
Lieu : /dev/random
Distrib. : Debian Stretch/Sid/Rc-Buggy
Noyau : Linux (≥ 4.3)
(G)UI : i3-wm (≥ 4.11)
Inscription : 07-07-2008
Site Web

Re : scanner canon MP280 ne fonctionne pas sous wheezy

Salut,

Tu as téléchargé ces pilotes ? http://files.canon-europe.com/files/sof … driver.tar
Et tu en as fait quoi ?
(D'après le site, il n'y a pas de raison que ça ne fonctionne pas sous Debian, surtout s'il s'agit simplement des pilotes pour le scanner.)

captnfab,
Association Debian-Facile, bépo.
TheDoctor: Your wish is my command… But be careful what you wish for.

Hors ligne

#7 31-03-2014 22:46:31

Alarc'h
Membre
Distrib. : Debian 7.0 Wheezy
Noyau : Linux 3.2.0-4-686-pae
(G)UI : TDE / KDE4
Inscription : 31-03-2014

Re : scanner canon MP280 ne fonctionne pas sous wheezy

(D'après le site, il n'y a pas de raison que ça ne fonctionne pas sous Debian, surtout s'il s'agit simplement des pilotes pour le scanner.)



C'est ce que j'ai pensé aussi. Dans cette archive il y a les pilotes pour l'imprimante et ceux pour le scanner. Je les ai fait installer. Pour l'imprimante ça marche impeccable mais pas pour le scanner.

Il y a un dossier scangearmp-mp280series-1.60-1-deb qui contient des archives .deb par architecture, des fichiers de localisation et un script shell d'installation qui copie les fichiers de localisation vérifie certains truc et effectue un

dpkg -iG

(l'option G empêchant simplement le downgrad d'après ce que me dit man dpkg).

Son exécution en tant que root a fonctionné et il a envoyé un message de succès. Donc les pilotes devraient être installés.

Ce qui m'épate c'est que sane-find-scanner voit le scanner mais scanimage -L lui ne le trouve pas.

Hors ligne

#8 01-04-2014 08:50:13

df871
Membre
Lieu : Limousin
Distrib. : Debian Wheezy 7.1 32b
Noyau : Linux 3.2.0-4-486
(G)UI : Xfce 4.8
Inscription : 17-09-2013
Site Web

Re : scanner canon MP280 ne fonctionne pas sous wheezy

smile

Lorsque tu l'as installé sous ubuntu, y avait-il une procédure à suivre ?

L'as-tu répétée sous debian ?

Juste cet aparté, parce que pour mon epson SX125, j'ai eu le même souci, tant sur ubuntu, que sous debian, et en reproduisant la procédure ubuntu, j'ai mon scanner fonctionnel !

A bientôt smile

Cordialement
Bernard
Crées, Consolides... puis, Continues à Créer smile
Asus P4P800, P4C 2,6Ghz, Seagate laptop SSHD 500Go, Nvidia GF 6200 512 Mo avec Debian 7.0, Xfce 4.08

Hors ligne

#9 01-04-2014 10:03:40

Invité-5
Banni(e)

Re : scanner canon MP280 ne fonctionne pas sous wheezy

Que-ce que vous en pensez ?

adduser user scanner && adduser user lp

#10 01-04-2014 11:21:01

captnfab
Admin-Girafe
Lieu : /dev/random
Distrib. : Debian Stretch/Sid/Rc-Buggy
Noyau : Linux (≥ 4.3)
(G)UI : i3-wm (≥ 4.11)
Inscription : 07-07-2008
Site Web

Re : scanner canon MP280 ne fonctionne pas sous wheezy

@darien: faudrait essayer en root alors.

@Alarc'h: Est-ce que « scanimage -L » en root te liste ton scanner ?

captnfab,
Association Debian-Facile, bépo.
TheDoctor: Your wish is my command… But be careful what you wish for.

Hors ligne

#11 01-04-2014 11:21:55

Alarc'h
Membre
Distrib. : Debian 7.0 Wheezy
Noyau : Linux 3.2.0-4-686-pae
(G)UI : TDE / KDE4
Inscription : 31-03-2014

Re : scanner canon MP280 ne fonctionne pas sous wheezy

L'installation sous Ubuntu date de quelque temps et, comme tout c'était passé tout seul sans soucis, j'avoue que je n'ai plus le détail en tête, mais je ne me souviens pas avoir fait autre chose qu'installer les mêmes pilotes Canon. Et pour répondre à l'autre message, oui l'utilisateur est bien dans les groupes lp et scanner. En fait les paquets fournis par Canon sont annoncés pour Ubuntu car c'est la distribution la plus connue d'un large public pas très linuxien, mais n'ayant pas d'Ubuntu sous la main je ne peux pas me rendre compte de la différence qu'il peut y avoir dans l'installation d'un simple pilote sur Debian et Ubuntu.

Si cela peut aider, voici la structure des deux paquets (scangearmp-common_1.60-1_amd64.deb et scangearmp-mp280series_1.60-1_amd64.deb) où je ne vois que des chemins tout à fait standards il me semble :


~/$ dpkg-deb --contents scangearmp-common_1.60-1_amd64.deb
drwxr-xr-x root/root         0 2010-08-19 02:51 ./
drwxr-xr-x root/root         0 2010-08-19 02:51 ./usr/
drwxr-xr-x root/root         0 2010-08-19 02:51 ./usr/share/
drwxr-xr-x root/root         0 2010-08-19 02:51 ./usr/share/locale/
drwxr-xr-x root/root         0 2010-08-19 02:51 ./usr/share/locale/cs/
drwxr-xr-x root/root         0 2010-08-19 02:51 ./usr/share/locale/cs/LC_MESSAGES/
-rw-r--r-- root/root     16180 2010-08-19 02:51 ./usr/share/locale/cs/LC_MESSAGES/scangearmp.mo
drwxr-xr-x root/root         0 2010-08-19 02:51 ./usr/share/locale/da/
drwxr-xr-x root/root         0 2010-08-19 02:51 ./usr/share/locale/da/LC_MESSAGES/
-rw-r--r-- root/root     15407 2010-08-19 02:51 ./usr/share/locale/da/LC_MESSAGES/scangearmp.mo
drwxr-xr-x root/root         0 2010-08-19 02:51 ./usr/share/locale/de/
drwxr-xr-x root/root         0 2010-08-19 02:51 ./usr/share/locale/de/LC_MESSAGES/
-rw-r--r-- root/root     16455 2010-08-19 02:51 ./usr/share/locale/de/LC_MESSAGES/scangearmp.mo
drwxr-xr-x root/root         0 2010-08-19 02:51 ./usr/share/locale/el/
drwxr-xr-x root/root         0 2010-08-19 02:51 ./usr/share/locale/el/LC_MESSAGES/
-rw-r--r-- root/root     22108 2010-08-19 02:51 ./usr/share/locale/el/LC_MESSAGES/scangearmp.mo
drwxr-xr-x root/root         0 2010-08-19 02:51 ./usr/share/locale/es/
drwxr-xr-x root/root         0 2010-08-19 02:51 ./usr/share/locale/es/LC_MESSAGES/
-rw-r--r-- root/root     16584 2010-08-19 02:51 ./usr/share/locale/es/LC_MESSAGES/scangearmp.mo
drwxr-xr-x root/root         0 2010-08-19 02:51 ./usr/share/locale/fi/
drwxr-xr-x root/root         0 2010-08-19 02:51 ./usr/share/locale/fi/LC_MESSAGES/
-rw-r--r-- root/root     15840 2010-08-19 02:51 ./usr/share/locale/fi/LC_MESSAGES/scangearmp.mo
drwxr-xr-x root/root         0 2010-08-19 02:51 ./usr/share/locale/fr/
drwxr-xr-x root/root         0 2010-08-19 02:51 ./usr/share/locale/fr/LC_MESSAGES/
-rw-r--r-- root/root     16472 2010-08-19 02:51 ./usr/share/locale/fr/LC_MESSAGES/scangearmp.mo
drwxr-xr-x root/root         0 2010-08-19 02:51 ./usr/share/locale/hu/
drwxr-xr-x root/root         0 2010-08-19 02:51 ./usr/share/locale/hu/LC_MESSAGES/
-rw-r--r-- root/root     16401 2010-08-19 02:51 ./usr/share/locale/hu/LC_MESSAGES/scangearmp.mo
drwxr-xr-x root/root         0 2010-08-19 02:51 ./usr/share/locale/id/
drwxr-xr-x root/root         0 2010-08-19 02:51 ./usr/share/locale/id/LC_MESSAGES/
-rw-r--r-- root/root     15654 2010-08-19 02:51 ./usr/share/locale/id/LC_MESSAGES/scangearmp.mo
drwxr-xr-x root/root         0 2010-08-19 02:51 ./usr/share/locale/it/
drwxr-xr-x root/root         0 2010-08-19 02:51 ./usr/share/locale/it/LC_MESSAGES/
-rw-r--r-- root/root     16437 2010-08-19 02:51 ./usr/share/locale/it/LC_MESSAGES/scangearmp.mo
drwxr-xr-x root/root         0 2010-08-19 02:51 ./usr/share/locale/ja/
drwxr-xr-x root/root         0 2010-08-19 02:51 ./usr/share/locale/ja/LC_MESSAGES/
-rw-r--r-- root/root     17552 2010-08-19 02:51 ./usr/share/locale/ja/LC_MESSAGES/scangearmp.mo
drwxr-xr-x root/root         0 2010-08-19 02:51 ./usr/share/locale/ko/
drwxr-xr-x root/root         0 2010-08-19 02:51 ./usr/share/locale/ko/LC_MESSAGES/
-rw-r--r-- root/root     16513 2010-08-19 02:51 ./usr/share/locale/ko/LC_MESSAGES/scangearmp.mo
drwxr-xr-x root/root         0 2010-08-19 02:51 ./usr/share/locale/nl/
drwxr-xr-x root/root         0 2010-08-19 02:51 ./usr/share/locale/nl/LC_MESSAGES/
-rw-r--r-- root/root     16134 2010-08-19 02:51 ./usr/share/locale/nl/LC_MESSAGES/scangearmp.mo
drwxr-xr-x root/root         0 2010-08-19 02:51 ./usr/share/locale/nb/
drwxr-xr-x root/root         0 2010-08-19 02:51 ./usr/share/locale/nb/LC_MESSAGES/
-rw-r--r-- root/root     15567 2010-08-19 02:51 ./usr/share/locale/nb/LC_MESSAGES/scangearmp.mo
drwxr-xr-x root/root         0 2010-08-19 02:51 ./usr/share/locale/pl/
drwxr-xr-x root/root         0 2010-08-19 02:51 ./usr/share/locale/pl/LC_MESSAGES/
-rw-r--r-- root/root     16426 2010-08-19 02:51 ./usr/share/locale/pl/LC_MESSAGES/scangearmp.mo
drwxr-xr-x root/root         0 2010-08-19 02:51 ./usr/share/locale/pt/
drwxr-xr-x root/root         0 2010-08-19 02:51 ./usr/share/locale/pt/LC_MESSAGES/
-rw-r--r-- root/root     16158 2010-08-19 02:51 ./usr/share/locale/pt/LC_MESSAGES/scangearmp.mo
drwxr-xr-x root/root         0 2010-08-19 02:51 ./usr/share/locale/ru/
drwxr-xr-x root/root         0 2010-08-19 02:51 ./usr/share/locale/ru/LC_MESSAGES/
-rw-r--r-- root/root     20682 2010-08-19 02:51 ./usr/share/locale/ru/LC_MESSAGES/scangearmp.mo
drwxr-xr-x root/root         0 2010-08-19 02:51 ./usr/share/locale/sv/
drwxr-xr-x root/root         0 2010-08-19 02:51 ./usr/share/locale/sv/LC_MESSAGES/
-rw-r--r-- root/root     15840 2010-08-19 02:51 ./usr/share/locale/sv/LC_MESSAGES/scangearmp.mo
drwxr-xr-x root/root         0 2010-08-19 02:51 ./usr/share/locale/th/
drwxr-xr-x root/root         0 2010-08-19 02:51 ./usr/share/locale/th/LC_MESSAGES/
-rw-r--r-- root/root     24097 2010-08-19 02:51 ./usr/share/locale/th/LC_MESSAGES/scangearmp.mo
drwxr-xr-x root/root         0 2010-08-19 02:51 ./usr/share/locale/tr/
drwxr-xr-x root/root         0 2010-08-19 02:51 ./usr/share/locale/tr/LC_MESSAGES/
-rw-r--r-- root/root     15776 2010-08-19 02:51 ./usr/share/locale/tr/LC_MESSAGES/scangearmp.mo
drwxr-xr-x root/root         0 2010-08-19 02:51 ./usr/share/locale/zh/
drwxr-xr-x root/root         0 2010-08-19 02:51 ./usr/share/locale/zh/LC_MESSAGES/
-rw-r--r-- root/root     14909 2010-08-19 02:51 ./usr/share/locale/zh/LC_MESSAGES/scangearmp.mo
drwxr-xr-x root/root         0 2010-08-19 02:51 ./usr/share/locale/zh_TW/
drwxr-xr-x root/root         0 2010-08-19 02:51 ./usr/share/locale/zh_TW/LC_MESSAGES/
-rw-r--r-- root/root     14897 2010-08-19 02:51 ./usr/share/locale/zh_TW/LC_MESSAGES/scangearmp.mo
drwxr-xr-x root/root         0 2010-08-19 02:51 ./usr/share/scangearmp/
drwxr-xr-x root/root         0 2010-08-19 02:51 ./usr/share/scangearmp/pixmaps/
-rw-r--r-- root/root     11010 2010-08-19 02:51 ./usr/share/scangearmp/pixmaps/image_curve_h_grad_226.xpm
-rw-r--r-- root/root     11854 2010-08-19 02:51 ./usr/share/scangearmp/pixmaps/image_curve_v_grad_226.xpm
drwxr-xr-x root/root         0 2010-08-19 02:51 ./usr/share/doc/
drwxr-xr-x root/root         0 2010-08-19 02:51 ./usr/share/doc/scangearmp-common/
-rw-r--r-- root/root     10231 2010-02-17 03:22 ./usr/share/doc/scangearmp-common/LICENSE-scangearmp-1.60JP.txt.gz
-rw-r--r-- root/root     10130 2010-02-17 03:22 ./usr/share/doc/scangearmp-common/LICENSE-scangearmp-1.60FR.txt.gz
-rw-r--r-- root/root      9440 2010-02-17 03:22 ./usr/share/doc/scangearmp-common/LICENSE-scangearmp-1.60SC.txt.gz
-rw-r--r-- root/root       221 2010-02-17 03:22 ./usr/share/doc/scangearmp-common/copyright
-rw-r--r-- root/root       166 2010-08-19 02:41 ./usr/share/doc/scangearmp-common/changelog.Debian.gz
-rw-r--r-- root/root      9074 2010-02-17 03:22 ./usr/share/doc/scangearmp-common/LICENSE-scangearmp-1.60EN.txt.gz
drwxr-xr-x root/root         0 2010-08-19 02:51 ./usr/lib/
-rw-r--r-- root/root     36824 2010-08-19 02:51 ./usr/lib/libsane-canon_mfp.so.1.0.6
-rw-r--r-- root/root     47576 2010-08-19 02:51 ./usr/lib/libcncpcmcm.so.8.0.1
-rw-r--r-- root/root     15512 2010-08-19 02:51 ./usr/lib/libcncpmsui.so.1.6.0
drwxr-xr-x root/root         0 2010-08-19 02:51 ./usr/lib/bjlib/
-rw-r--r-- root/root      1243 2010-08-19 02:51 ./usr/lib/bjlib/canon_mfp.conf
-rw-rw-rw- root/root        53 2010-08-19 02:51 ./usr/lib/bjlib/canon_mfp_net.ini
-rw-r--r-- root/root    122472 2010-08-19 02:51 ./usr/lib/libcncpmsimg.so.1.0.2
-rw-r--r-- root/root    148768 2010-08-19 02:51 ./usr/lib/libcncpmslld.so.1.0.1
-rw-r--r-- root/root     38576 2010-08-19 02:51 ./usr/lib/libcncpnet.so.1.2.0
drwxr-xr-x root/root         0 2010-08-19 02:51 ./usr/bin/
-rwxr-xr-x root/root    236784 2010-08-19 02:51 ./usr/bin/scangearmp
drwxr-xr-x root/root         0 2010-08-19 02:51 ./etc/
drwxr-xr-x root/root         0 2010-08-19 02:51 ./etc/udev/
drwxr-xr-x root/root         0 2010-08-19 02:51 ./etc/udev/rules.d/
-rw-r--r-- root/root      2486 2010-08-19 02:51 ./etc/udev/rules.d/80-canon_mfp.rules
lrwxrwxrwx root/root         0 2010-08-19 02:51 ./usr/lib/libsane-canon_mfp.so.1 -> libsane-canon_mfp.so.1.0.6
lrwxrwxrwx root/root         0 2010-08-19 02:51 ./usr/lib/libsane-canon_mfp.so -> libsane-canon_mfp.so.1.0.6
 



et l'autre :


~/$ dpkg-deb --contents scangearmp-mp280series_1.60-1_amd64.deb
drwxr-xr-x root/root         0 2010-08-19 02:51 ./
drwxr-xr-x root/root         0 2010-08-19 02:51 ./usr/
drwxr-xr-x root/root         0 2010-08-19 02:51 ./usr/lib/
-rw-r--r-- root/root    156792 2010-08-19 02:51 ./usr/lib/libcncpmsimg370.so.1.6.0
-rw-r--r-- root/root    212088 2010-08-19 02:51 ./usr/lib/libcncpmslld370.so.1.6.0
-rw-r--r-- root/root     27288 2010-08-19 02:51 ./usr/lib/libcncpmslld370c.so.1.04.1
drwxr-xr-x root/root         0 2010-08-19 02:51 ./usr/lib/bjlib/
-rwxr-xr-x root/root     12800 2010-08-19 02:51 ./usr/lib/bjlib/cnc1746d.tbl
-rwxr-xr-x root/root     83200 2010-08-19 02:51 ./usr/lib/bjlib/cnc_3700.tbl
-rwxr-xr-x root/root     30720 2010-08-19 02:51 ./usr/lib/bjlib/CNC280.DAT
-rwxr-xr-x root/root    177648 2010-08-19 02:51 ./usr/lib/bjlib/CNC280P.DAT
drwxr-xr-x root/root         0 2010-08-19 02:51 ./usr/share/
drwxr-xr-x root/root         0 2010-08-19 02:51 ./usr/share/doc/
drwxr-xr-x root/root         0 2010-08-19 02:51 ./usr/share/doc/scangearmp-mp280series/
-rw-r--r-- root/root     10231 2010-02-17 03:22 ./usr/share/doc/scangearmp-mp280series/LICENSE-scangearmp-1.60JP.txt.gz
-rw-r--r-- root/root     10130 2010-02-17 03:22 ./usr/share/doc/scangearmp-mp280series/LICENSE-scangearmp-1.60FR.txt.gz
-rw-r--r-- root/root      9440 2010-02-17 03:22 ./usr/share/doc/scangearmp-mp280series/LICENSE-scangearmp-1.60SC.txt.gz
-rw-r--r-- root/root       221 2010-02-17 03:22 ./usr/share/doc/scangearmp-mp280series/copyright
-rw-r--r-- root/root       166 2010-08-19 02:41 ./usr/share/doc/scangearmp-mp280series/changelog.Debian.gz
-rw-r--r-- root/root      9074 2010-02-17 03:22 ./usr/share/doc/scangearmp-mp280series/LICENSE-scangearmp-1.60EN.txt.gz
 

Hors ligne

#12 01-04-2014 11:27:12

Alarc'h
Membre
Distrib. : Debian 7.0 Wheezy
Noyau : Linux 3.2.0-4-686-pae
(G)UI : TDE / KDE4
Inscription : 31-03-2014

Re : scanner canon MP280 ne fonctionne pas sous wheezy

captnfab a écrit :

@darien: faudrait essayer en root alors.

@Alarc'h: Est-ce que « scanimage -L » en root te liste ton scanner ?


Ah nos messages se sont croisés, non il me semble l'avoir dit, ce qui me semble le plus bizarre c'est qu'avec ou sans sudo (puisque cette installation a été faite à la mode Ubuntu avec sudo, pour maintenir une continuité d'exploitation pour l'utilisateur) scanimage ne le voit pas plus alors que, je le répète, sane-find-scanner le voit.

Hors ligne

#13 01-04-2014 13:39:10

Invité-5
Banni(e)

Re : scanner canon MP280 ne fonctionne pas sous wheezy

Ou en root si vous voulez ! Poste #9

As tu le noyau amd64 (voir distro)

dpkg-deb --contents scangearmp-mp280series_1.60-1_amd64.deb


Essaye 3.40 => http://www.canon.fr/Support/Consumer_Pr … oad&page=1

Dernière modification par Invité-5 (01-04-2014 14:21:57)

#14 01-04-2014 14:40:36

df871
Membre
Lieu : Limousin
Distrib. : Debian Wheezy 7.1 32b
Noyau : Linux 3.2.0-4-486
(G)UI : Xfce 4.8
Inscription : 17-09-2013
Site Web

Re : scanner canon MP280 ne fonctionne pas sous wheezy

smile

Ce qu'il y a d'étonnant, dans "scangearmp-mp280series" c'est que tu as la version 1.60 alors que là, sur cette discussion d'ubuntu en 2012...
http://forum.ubuntu-fr.org/viewtopic.php?pid=7393941)

elle est en version 1.80

et sur la page de renvoi, elle est à 2.10...
https://code.launchpad.net/~michael-gru … /+packages



et une autre en "résolu" :
https://forum.ubuntu-fr.org/viewtopic.p … 358341&p=1



Une suggestion, que je pratique : je me fais un tuto par matériel, avec toutes les commandes et adresses de fichiers à charger, et je garde tout cela au chaud... et çà me sert lorsque je réinstalle... wink

Dernière modification par df871 (01-04-2014 14:45:47)


Cordialement
Bernard
Crées, Consolides... puis, Continues à Créer smile
Asus P4P800, P4C 2,6Ghz, Seagate laptop SSHD 500Go, Nvidia GF 6200 512 Mo avec Debian 7.0, Xfce 4.08

Hors ligne

#15 01-04-2014 16:56:38

Alarc'h
Membre
Distrib. : Debian 7.0 Wheezy
Noyau : Linux 3.2.0-4-686-pae
(G)UI : TDE / KDE4
Inscription : 31-03-2014

Re : scanner canon MP280 ne fonctionne pas sous wheezy

Je n'avais pas vu le 3.4... Merci pour vos liens je vais potasser ça un peu et essayer  une de ces solutions ce soir.

Hors ligne

#16 04-04-2014 09:30:34

Alarc'h
Membre
Distrib. : Debian 7.0 Wheezy
Noyau : Linux 3.2.0-4-686-pae
(G)UI : TDE / KDE4
Inscription : 31-03-2014

Re : scanner canon MP280 ne fonctionne pas sous wheezy

Bonjour,

Je n'ai pas pu me repencher tout de suite sur le problème. Alors pour ce qui est du numéro de version en 1.80 c'est pour un paquet tiers destiné à Ubuntu. Ça ne m'avance pas.

Du coup j'ai faire réinstaller les paquets Canon que j'avais fait désinstaller. Et en refaisant des tests voici ce qui apparaît :

    - Sane ne sait pas utiliser cette machine (PIXMA MP280 Canon), visiblement rien à faire pour l'instant (ce que j'ai compris de discussions sur des forums anglophones).

    - La seule façon de l'utiliser est d'utiliser scangearmp  qui est l'interface proprio développée par Canon.

    - Contrairement à la première fois (et je ne comprends pas d'où vient la différence) scangearmp trouve le scanner, mais seulement lorsqu'il est lancé en root (en pratique ici avec sudo).

Donc je me retrouve avec une situation plus classique de droit d'utilisateur. Pourtant :

    - l'utilisateur figure dans le groupe scanner

    - l'exécutable scangearmp qui se trouve dans /usr/lib/ et a des droits 755 (rwxr-xr-x) et donc peut être exécuté par tout le monde.

Quelqu'un a-t-il une idée des autres fichiers dont il faudrait véfirier les droits  ou d'une étape que j'aurais oublié ?

Hors ligne

#17 04-04-2014 12:02:14

Invité-5
Banni(e)

Re : scanner canon MP280 ne fonctionne pas sous wheezy

Alarc'h a écrit :

c'est pour un paquet tiers destiné à Ubuntu


ubuntu en question utilise ?

uname -r


Sinon t'as dans wheezy-backports kernel 3.12 et 3.13   http://debian-facile.org/viewtopic.php?id=8748

Dernière modification par Invité-5 (04-04-2014 15:57:43)

#18 05-04-2014 01:01:25

Alarc'h
Membre
Distrib. : Debian 7.0 Wheezy
Noyau : Linux 3.2.0-4-686-pae
(G)UI : TDE / KDE4
Inscription : 31-03-2014

Re : scanner canon MP280 ne fonctionne pas sous wheezy

darien a écrit :


A priori ce n'est pas un problème de kernel, le paquet Canon fonctionne avec son interface graphique maison, il semble que ce soit un problème de droit d'utilisation. Le lien ci-dessus concerne l'aspect imprimante qui elle fonctionne sans problème.

Hors ligne

#19 05-04-2014 01:34:26

Haricophile
Adhérent(e)
Lieu : Pignans (Var)
Distrib. : SID
Noyau : 4.0.0-1-amd64
(G)UI : Mate / i3 selon...
Inscription : 14-09-2009

Re : scanner canon MP280 ne fonctionne pas sous wheezy

Si c'est pour ubuntu, ils comptent peut-être sur apparmor ... mais j'ai un doute.

J'ai un vieil epson V200 photo et il fonctionne sans config supplémentaire une fois installé
iscan iscan-data iscan-plugin-gt-f670 et je crois une bibiothèque QT, tant sur Wheezy que Jessie ou Sid

Le V200 a donc la même mécanique que le gt-f670, c'est toujours difficile de connaître la mécanique utilisée par le scanner, les constructeurs ne sont guère bavards.

« La religion et l'art sont les luxes des lâches, qui permettent de fuir la réalité quand elle devient trop difficile à affronter. La différence c'est que la religion transforme tout mensonge en vérité alors que l'art transforme toute vérité en mensonge. »

Hors ligne

Pied de page des forums