Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 12-04-2014 01:38:31

Henze
Membre
Inscription : 12-04-2014

Probleme d'installation vulture sous Debian7

Bonsoir tt le monde,

je veux installer installer Vulture sur Debian 7  en suivant le lien http://www.vultureproject.org/documenta … tallation/,
Quand je tappe la commande hmm# dpkg -i vulture_*.deb
voila le msg "dpkg: erreur de traitement de vulture_*.deb (--install) :
ne peut pas accéder à l'archive: Aucun fichier ou dossier de ce type
Des erreurs ont été rencontrées pendant l'exécution :
vulture_*.deb
"
Merçi de m'aider à résoudre le problème

Hors ligne

#2 12-04-2014 02:18:07

david96
Invité

Re : Probleme d'installation vulture sous Debian7

Il ne trouve pas les fichiers. Assure toi de taper la commande là où sont les fichiers wink

Dernière modification par Invité-2 (12-04-2014 02:19:12)

#3 12-04-2014 02:57:04

Henze
Membre
Inscription : 12-04-2014

Re : Probleme d'installation vulture sous Debian7

oui tu as raison car j'ai mal écrit le bath

mais j'ai rencontré un nouveau erreur en exécutant la commande dpkg
( mkdir: impossible de créer le répertoire « /var/www/vulture/conf/security-rules »: Le fichier existe
dpkg: erreur de traitement de vulture (--install) :
le sous-processus script post-installation installé a retourné une erreur de sortie d'état 1
Des erreurs ont été rencontrées pendant l'exécution :
vulture
)
peuvez vous m'aider ? merçi

Hors ligne

#4 12-04-2014 03:48:57

david96
Invité

Re : Probleme d'installation vulture sous Debian7

Désinstalle  le paquet et recommence la procédure.

dpkg -r vulture_*.deb


roll j'ai un doute si on mode désinstallation on peut invoquer le jocker *…
Au cas où, ça sera les noms complet, avec la touche TAB (autocomplétion) ça va vite.

Et on réinstalle :

dpkg -i vulture_*.deb

Dernière modification par Invité-2 (12-04-2014 03:51:21)

#5 12-04-2014 09:03:14

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : Probleme d'installation vulture sous Debian7

Salut,

Pourquoi un jocker ?
Tu veux installer soit la 2.0.7 pour amd64, soit celle pour i386.

I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

#6 12-04-2014 09:51:04

david96
Invité

Re : Probleme d'installation vulture sous Debian7

C'est l'installation qui veut ça, c'est courant pour les paquets qui ne sont pas dans les dépôts officiels. smile

#7 12-04-2014 09:59:38

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : Probleme d'installation vulture sous Debian7

comprend pas : les 2 paquets sont explicitement identifiés.

I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

#8 12-04-2014 11:13:35

david96
Invité

Re : Probleme d'installation vulture sous Debian7

Arrête de jouer au chat et à la souris smile Balance le nom du paquet wink

#9 12-04-2014 12:15:32

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : Probleme d'installation vulture sous Debian7

david96 a écrit :

Arrête de jouer au chat et à la souris smile Balance le nom du paquet wink

Je comprends de moins en moins.  sad

Si je ne me trompe pas (je dis bien si), Vulture s'installe sur une architecture, non ? http://www.vultureproject.org/

Pour les paquets deb en question : https://googledrive.com/host/0B73hnOQoT … VGOGNWVTA/


I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

#10 12-04-2014 14:44:04

david96
Invité

Re : Probleme d'installation vulture sous Debian7

Ha bâ voilà, merci pour le lien, je ne l'avais pas vu (lecture en diagonale) tongue… Donc oui, pas besoin de jocker :
si architecture 32 bits :

wget https://googledrive.com/host/0B73hnOQoTupkUkdwM2VGOGNWVTA/vulture_2.0.7_i386.deb


dpkg -i vulture_2.0.7_i386.deb


si architecture 64 bits

https://googledrive.com/host/0B73hnOQoTupkUkdwM2VGOGNWVTA/vulture_2.0.7_amd64.deb


dpkg -i vulture_2.0.7_amd64.deb



En fait le jocker ici représentait la version ; bon sang de bois ! big_smile

Dernière modification par Invité-2 (12-04-2014 14:45:04)

#11 12-04-2014 16:32:13

Henze
Membre
Inscription : 12-04-2014

Re : Probleme d'installation vulture sous Debian7

Merçi les amis ,
comme je vous ai dit que j'ai la même chose à ce lien (http://www.vultureproject.org/docume.../installation/).
Il a été précisé à (Vous devez installer manuellement Apache :: SSLLookup en suivant ces instructions:)
Mais quand j'utilise: sudo apt-get-f install. Je l'ai installé widhout pour l'examiner.
alors quand j'arrive à cette étape (APR_PATH = / usr/include/apr-1.0 # ous apr-1 sur certaines distributions
wget http://search.cpan.org/CPAN/authors/...2.00_04.tar.gz
tar xf Apache-SSLLookup-2.00_04.tar.gz
cd Apache-SSLLookup-2.00_04
perl Makefile.PL CCFLAGS = "-I $ APR_PATH"
faire
make test
make install)
J'ai une erreur de ce genre: Passer blib / lib / Apache / SSLLookup.pm (inchangé)
Courir Mkbootstrap pour Apache :: SSLLookup ()
chmod 644 SSLLookup.bs
cc-c -I/usr/include/apache2 "-I"-O2-g-DVERSION = \ "2.00_04 \"-DXS_VERSION = \ "2.00_04 \"-fPIC "-I/usr/lib/perl/5.14 / CORE "SSLLookup.c
cc: erreur: "I": Aucun fichier ou dossier de ce type
make: *** [SSLLookup.o] Erreur 1

Comment resoudre ce problème ?

Hors ligne

#12 12-04-2014 17:02:23

david96
Invité

Re : Probleme d'installation vulture sous Debian7

alors quand j'arrive à cette étape (APR_PATH = / usr/include/apr-1.0 # ous apr-1 sur certaines distributions


Attention, tu laisses un espace !
Remplace :

APR_PATH = / usr/include/apr-1.0


Par

APR_PATH=/usr/include/apr-1.0

Dernière modification par Invité-2 (12-04-2014 17:02:54)

#13 12-04-2014 18:07:48

Henze
Membre
Inscription : 12-04-2014

Re : Probleme d'installation vulture sous Debian7

Non j'ai pas laissé d'espace lorsque j'ai tapé cette commande !

Hors ligne

#14 12-04-2014 18:37:26

david96
Invité

Re : Probleme d'installation vulture sous Debian7

Le mieux pour que l'on puisse t'aider, c'est de nous faire un copié collé exact de ce que tu fais sur la console wink

Tu as essayé en ne mettant que 1 à la place de 1.0 ?

Dernière modification par Invité-2 (12-04-2014 18:38:02)

#15 12-04-2014 18:46:00

Henze
Membre
Inscription : 12-04-2014

Re : Probleme d'installation vulture sous Debian7

j'ai essayé avec les deux mais c'est le meme probleme ! puisque dans la documentation que je le suive a noté il faut installer  manuellement Apache :: SSLLookup ! mais j'ai pas fais attention ç cette remarque et je l'ai installer avec les independances en faisant apt-get -f install .
je sais pas quesque je dois faire

Hors ligne

Pied de page des forums