Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#26 04-05-2014 19:24:11

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : Mise à jour Virtualbox

Tu la fais une fois que ton sources.list est complet.

I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

#27 04-05-2014 19:31:13

gio
Membre
Lieu : Strasbourg
Distrib. : stable (wheezy)
Noyau : Linux 3.2.0-4-686-pae
(G)UI : Gnome Version 3.4.2
Inscription : 18-09-2013
Site Web

Re : Mise à jour Virtualbox

Voilà qui est fait. (backports et MAJ) Ça a l'air bon.
Je passe ensuite à l'installation des headers de mon noyau, puis de virtualbox ? (Comme indiqué dans ton msg #16)

Dernière modification par gio (04-05-2014 19:31:54)

Hors ligne

#28 04-05-2014 19:35:54

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : Mise à jour Virtualbox

tu as fait

apt-get update


puis

apt-get upgrade


tu vérifieras si tu as bien wheezy 7.5 en regardant

cat /etc/debian_version


Je passe ensuite à l'installation des headers de mon noyau, puis de virtualbox ? (Comme indiqué dans ton msg #16)

oui  smile


I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

#29 04-05-2014 20:27:45

gio
Membre
Lieu : Strasbourg
Distrib. : stable (wheezy)
Noyau : Linux 3.2.0-4-686-pae
(G)UI : Gnome Version 3.4.2
Inscription : 18-09-2013
Site Web

Re : Mise à jour Virtualbox

Ayé j'ai fait tout qu'est ce que tu m'as dit...
Pendant l'install il y a eu un petit fail :

root@BOB:/home/gio# apt-get install linux-headers-$(uname -r|sed 's,[^-]*-[^-]*-,,')
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
linux-headers-686-pae est déjà la plus récente version disponible.
0 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.
root@BOB:/home/gio# apt-get -t wheezy-backports install virtualbox
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Le paquet suivant a été installé automatiquement et n'est plus nécessaire :
  libgsoap2
Veuillez utiliser « apt-get autoremove » pour le supprimer.
Les paquets supplémentaires suivants seront installés :
  libgsoap4 virtualbox-dkms virtualbox-qt
Paquets suggérés :
  virtualbox-guest-additions-iso vde2
Les NOUVEAUX paquets suivants seront installés :
  libgsoap4
Les paquets suivants seront mis à jour :
  virtualbox virtualbox-dkms virtualbox-qt
3 mis à jour, 1 nouvellement installés, 0 à enlever et 95 non mis à jour.
Il est nécessaire de prendre 21,4 Mo dans les archives.
Après cette opération, 18,2 Mo d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer [O/n] ? o
Réception de : 1 http://ftp.fr.debian.org/debian/ wheezy-backports/main libgsoap4 i386 2.8.16-2~bpo70+1 [550 kB]
Réception de : 2 http://ftp.fr.debian.org/debian/ wheezy-backports/contrib virtualbox-qt i386 4.3.10-dfsg-1~bpo70+1 [4 587 kB]
Réception de : 3 http://ftp.fr.debian.org/debian/ wheezy-backports/contrib virtualbox i386 4.3.10-dfsg-1~bpo70+1 [15,7 MB]
Réception de : 4 http://ftp.fr.debian.org/debian/ wheezy-backports/contrib virtualbox-dkms all 4.3.10-dfsg-1~bpo70+1 [557 kB]
21,4 Mo réceptionnés en 19s (1 093 ko/s)                                      
Lecture des fichiers de modifications (« changelog »)... Terminé
Sélection du paquet libgsoap4:i386 précédemment désélectionné.
(Lecture de la base de données... 171029 fichiers et répertoires déjà installés.)
Dépaquetage de libgsoap4:i386 (à partir de .../libgsoap4_2.8.16-2~bpo70+1_i386.deb) ...
Préparation du remplacement de virtualbox-qt 4.1.18-dfsg-2+deb7u3 (en utilisant .../virtualbox-qt_4.3.10-dfsg-1~bpo70+1_i386.deb) ...
Dépaquetage de la mise à jour de virtualbox-qt ...
Préparation du remplacement de virtualbox 4.1.18-dfsg-2+deb7u3 (en utilisant .../virtualbox_4.3.10-dfsg-1~bpo70+1_i386.deb) ...
Dépaquetage de la mise à jour de virtualbox ...
Préparation du remplacement de virtualbox-dkms 4.1.18-dfsg-2+deb7u3 (en utilisant .../virtualbox-dkms_4.3.10-dfsg-1~bpo70+1_all.deb) ...

-------- Uninstall Beginning --------
Module:  virtualbox
Version: 4.1.18
Kernel:  3.2.0-4-686-pae (i686)
-------------------------------------

Status: Before uninstall, this module version was ACTIVE on this kernel.

vboxdrv.ko:
 - Uninstallation
   - Deleting from: /lib/modules/3.2.0-4-686-pae/updates/dkms/
 - Original module
   - No original module was found for this module on this kernel.
   - Use the dkms install command to reinstall any previous module version.


vboxnetadp.ko:
 - Uninstallation
   - Deleting from: /lib/modules/3.2.0-4-686-pae/updates/dkms/
 - Original module
   - No original module was found for this module on this kernel.
   - Use the dkms install command to reinstall any previous module version.


vboxnetflt.ko:
 - Uninstallation
   - Deleting from: /lib/modules/3.2.0-4-686-pae/updates/dkms/
 - Original module
   - No original module was found for this module on this kernel.
   - Use the dkms install command to reinstall any previous module version.


vboxpci.ko:
 - Uninstallation
   - Deleting from: /lib/modules/3.2.0-4-686-pae/updates/dkms/
 - Original module
   - No original module was found for this module on this kernel.
   - Use the dkms install command to reinstall any previous module version.

depmod....

DKMS: uninstall completed.

------------------------------
Deleting module version: 4.1.18
completely from the DKMS tree.
------------------------------
Done.
Dépaquetage de la mise à jour de virtualbox-dkms ...
Traitement des actions différées (« triggers ») pour « man-db »...
Traitement des actions différées (« triggers ») pour « menu »...
Traitement des actions différées (« triggers ») pour « desktop-file-utils »...
Traitement des actions différées (« triggers ») pour « gnome-menus »...
Traitement des actions différées (« triggers ») pour « hicolor-icon-theme »...
Traitement des actions différées (« triggers ») pour « shared-mime-info »...
Unknown media type in type 'all/all'
Unknown media type in type 'all/allfiles'
Unknown media type in type 'uri/mms'
Unknown media type in type 'uri/mmst'
Unknown media type in type 'uri/mmsu'
Unknown media type in type 'uri/pnm'
Unknown media type in type 'uri/rtspt'
Unknown media type in type 'uri/rtspu'
Paramétrage de libgsoap4:i386 (2.8.16-2~bpo70+1) ...
Paramétrage de virtualbox (4.3.10-dfsg-1~bpo70+1) ...
[ ok ] Stopping VirtualBox kernel modules.
[....] Starting VirtualBox kernel modules[....] No suitable module for running k[FAIL found ... failed!
 failed!
invoke-rc.d: initscript virtualbox, action "restart" failed.
Paramétrage de virtualbox-qt (4.3.10-dfsg-1~bpo70+1) ...
Paramétrage de virtualbox-dkms (4.3.10-dfsg-1~bpo70+1) ...
Loading new virtualbox-4.3.10 DKMS files...
Building only for 3.2.0-4-686-pae
Building initial module for 3.2.0-4-686-pae
Done.

vboxdrv:
Running module version sanity check.
 - Original module
   - No original module exists within this kernel
 - Installation
   - Installing to /lib/modules/3.2.0-4-686-pae/updates/dkms/

vboxnetadp.ko:
Running module version sanity check.
 - Original module
   - No original module exists within this kernel
 - Installation
   - Installing to /lib/modules/3.2.0-4-686-pae/updates/dkms/

vboxnetflt.ko:
Running module version sanity check.
 - Original module
   - No original module exists within this kernel
 - Installation
   - Installing to /lib/modules/3.2.0-4-686-pae/updates/dkms/

vboxpci.ko:
Running module version sanity check.
 - Original module
   - No original module exists within this kernel
 - Installation
   - Installing to /lib/modules/3.2.0-4-686-pae/updates/dkms/

depmod....

DKMS: install completed.
[ ok ] Stopping VirtualBox kernel modules.
[ ok ] Starting VirtualBox kernel modules.
Traitement des actions différées (« triggers ») pour « menu »...
 



mais ça a l'air d'être allé jusqu'au bout quand même...

En tout cas j'ai Virtualbox 4.3.10

...par contre je peux plus démarrer une session avec Virtualbox, il me dit :

Échec de l'ouverture de session pour la machine virtuelle Seven.
This VM was configured to use 3D acceleration. However, the 3D support of the host is not working properly and the VM cannot be started. To fix this problem, either fix the host 3D support (update the host graphics driver?) or disable 3D acceleration in the VM settings (VERR_NOT_AVAILABLE).

Code d'erreur :
NS_ERROR_FAILURE (0x80004005)
Composant :
Console
Interface :
IConsole {8ab7c520-2442-4b66-8d74-4ff1e195d2b6}



Dans la configuration, on m'indique :

La machine virtuelle est paramétrée pour utiliser l'accélération graphique matérielle. Cependant le système hôte ne propose actuellement pas cette fonctionnalité. Vous ne pourrez donc pas démarrer la machine.

Dernière modification par gio (04-05-2014 20:43:31)

Hors ligne

#30 04-05-2014 23:01:13

captnfab
Admin-Girafe
Lieu : /dev/random
Distrib. : Debian Stretch/Sid/Rc-Buggy
Noyau : Linux (≥ 4.3)
(G)UI : i3-wm (≥ 4.11)
Inscription : 07-07-2008
Site Web

Re : Mise à jour Virtualbox

Le petit fail est normal, le OK plus bas indique que le fail a été résolu smile

captnfab,
Association Debian-Facile, bépo.
TheDoctor: Your wish is my command… But be careful what you wish for.

Hors ligne

#31 05-05-2014 09:27:47

gio
Membre
Lieu : Strasbourg
Distrib. : stable (wheezy)
Noyau : Linux 3.2.0-4-686-pae
(G)UI : Gnome Version 3.4.2
Inscription : 18-09-2013
Site Web

Re : Mise à jour Virtualbox

Merci...et sinon pour faire marcher Virtualbox je fais comment ?

Dernière modification par gio (05-05-2014 09:27:58)

Hors ligne

#32 05-05-2014 11:20:13

captnfab
Admin-Girafe
Lieu : /dev/random
Distrib. : Debian Stretch/Sid/Rc-Buggy
Noyau : Linux (≥ 4.3)
(G)UI : i3-wm (≥ 4.11)
Inscription : 07-07-2008
Site Web

Re : Mise à jour Virtualbox

Eh bien, deux possibilités : soit tu vas dans la configuration de ta machine virtuelle et tu désactives «utiliser l'accélération 3D», soit tu cherches à comprendre pourquoi VirtualBox ne fournit pas d'accélération 3D.

captnfab,
Association Debian-Facile, bépo.
TheDoctor: Your wish is my command… But be careful what you wish for.

Hors ligne

#33 05-05-2014 12:47:09

gio
Membre
Lieu : Strasbourg
Distrib. : stable (wheezy)
Noyau : Linux 3.2.0-4-686-pae
(G)UI : Gnome Version 3.4.2
Inscription : 18-09-2013
Site Web

Re : Mise à jour Virtualbox

Okay merci ! Ça marche !

Par contre je voulais avoir l'extension Oracle pour avoir l'USB mais dans Ficher > Paramètres ; dans la partie "Extensions" j'ai un petit un point d'exclamation à côté de Oracle VM VirtualBox extension...

Dernière modification par gio (05-05-2014 12:47:22)

Hors ligne

#34 05-05-2014 13:30:44

bendia
Admin stagiaire
Distrib. : Jessie
Noyau : 3.16.0-4-amd64
(G)UI : Gnome + XFCE + Console
Inscription : 20-03-2012
Site Web

Re : Mise à jour Virtualbox

Je crois qu'il te faut installer les extensions invité dans ton système virtualisé pour ça smile

Ben
___________________
La seule question bête, c'est celle qu'on ne pose pas.
file-Re06858991f6f328b4907296ac5cea283

Hors ligne

#35 05-05-2014 16:33:26

gio
Membre
Lieu : Strasbourg
Distrib. : stable (wheezy)
Noyau : Linux 3.2.0-4-686-pae
(G)UI : Gnome Version 3.4.2
Inscription : 18-09-2013
Site Web

Re : Mise à jour Virtualbox

Euh...c'est-à-dire ?

Hors ligne

Pied de page des forums