Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 04-05-2014 18:59:18

Neolex
Membre
Distrib. : Debian 7.0
Noyau : Linux 3.2.0-4-amd64
(G)UI : Gnome 3.4.2.1
Inscription : 02-06-2013

Pas de son (iceweasel) [Resolu]

Bonsoir à tous ,
j'ai un problème , je n'ai pas de son , le son fonctionne seulement quand je fais "tester les hauts parleurs" lorsqu'on entends "front right" et "front left" ...

J'ai eu beau essayé je n'ai pas réussi à avoir le son ,  je ne comprends pas pourquoi ...


Merci d'avance pour votre aide !

Dernière modification par Neolex (11-05-2014 12:30:45)

Hors ligne

#2 04-05-2014 19:05:46

martinux_qc
Administrateur
Lieu : Montréal (Québec)
Distrib. : Sid
Noyau : Linux 4.7.0-1-amd64
(G)UI : XFCE 4.12
Inscription : 12-10-2008

Re : Pas de son (iceweasel) [Resolu]

Salut

Il serait peut-être bon de commencer par consulter le wiki pour tenter de cerner le problème. Si cela ne règle pas le problème, tu pourras toujours revenir en fournissant le plus d'info possible sur ton matériel.

À la prochaine.

"L'éducation vise à former des citoyens pas trop tatas et non pas à envoyer le plus de tatas possible à l'université."
Pierre Foglia (Journaliste à la retraite à La Presse)
Note : au Québec, le mot tata a un sens péjoratif qui sert à désigner une personne un peu idiote ou insignifiante. D'où les expressions familières : Espèce de grand, de gros tata! Être, avoir l'air tata.

Hors ligne

#3 04-05-2014 19:36:14

Neolex
Membre
Distrib. : Debian 7.0
Noyau : Linux 3.2.0-4-amd64
(G)UI : Gnome 3.4.2.1
Inscription : 02-06-2013

Re : Pas de son (iceweasel) [Resolu]

J'ai bien regardé ce wiki sans trouver comment régler mon problème...
lorsque je fais cette commande ça ne fonctionne pas :

atlas@Atlas-Debian:~$ speaker-test -D surround51:0 -c 6 -t 2

speaker-test 1.0.25

Le périphérique de lecture est surround51:0
Les paramètres du flux sont 48000Hz, S16_LE, 6 canaux
La fréquence de la courbe sinus est 440,0000Hz
Le nombre (6) de canaux est indisponible à la lecture: Argument invalide
Échec de la configuration des paramètres matériel: Argument invalide



par contre celle la fonctionne :

speaker-test -D plug:surround51 -c 6 -l 1 -t wav





Je n'ai pas d'idée de que faire d'autre , je suis vraiment bloqué .

Hors ligne

#4 05-05-2014 02:38:14

martinux_qc
Administrateur
Lieu : Montréal (Québec)
Distrib. : Sid
Noyau : Linux 4.7.0-1-amd64
(G)UI : XFCE 4.12
Inscription : 12-10-2008

Re : Pas de son (iceweasel) [Resolu]

Salut

Tu utilises PulseAudio comme serveur de sons ou bien Alsa ? Et, pour info, on peut avoir des détails sur la carte son que tu utilises ?

"L'éducation vise à former des citoyens pas trop tatas et non pas à envoyer le plus de tatas possible à l'université."
Pierre Foglia (Journaliste à la retraite à La Presse)
Note : au Québec, le mot tata a un sens péjoratif qui sert à désigner une personne un peu idiote ou insignifiante. D'où les expressions familières : Espèce de grand, de gros tata! Être, avoir l'air tata.

Hors ligne

#5 07-05-2014 06:15:53

Neolex
Membre
Distrib. : Debian 7.0
Noyau : Linux 3.2.0-4-amd64
(G)UI : Gnome 3.4.2.1
Inscription : 02-06-2013

Re : Pas de son (iceweasel) [Resolu]

je ne sais pas vraiment ce que j'utilise ... comment le savoir ? hmm

atlas@Atlas-Debian:~$ pulseaudio
E: [pulseaudio] pid.c: Daemon already running.
E: [pulseaudio] main.c: Échec de pa_pid_file_create().


atlas@Atlas-Debian:~$ alsa
Usage: /usr/sbin/alsa {unload|reload|force-unload|force-reload|suspend|resume}


atlas@Atlas-Debian:~$ aplay -l
**** Liste des Périphériques Matériels PLAYBACK ****
ALSA lib conf.c:1168:(parse_def) 0 is not a compound
ALSA lib conf.c:1686:(snd_config_load1) _toplevel_:13:13:Argument invalide
ALSA lib conf.c:3406:(config_file_open) /home/atlas/.asoundrc may be old or corrupted: consider to remove or fix it
Erreur de segmentation



et un lspci si ça peut vous aider ... :

atlas@Atlas-Debian:~$ lspci
00:00.0 Host bridge: Intel Corporation Core Processor DRAM Controller (rev 18)
00:01.0 PCI bridge: Intel Corporation Core Processor PCI Express x16 Root Port (rev 18)
00:16.0 Communication controller: Intel Corporation 5 Series/3400 Series Chipset HECI Controller (rev 06)
00:1a.0 USB controller: Intel Corporation 5 Series/3400 Series Chipset USB2 Enhanced Host Controller (rev 06)
00:1b.0 Audio device: Intel Corporation 5 Series/3400 Series Chipset High Definition Audio (rev 06)
00:1c.0 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 1 (rev 06)
00:1c.1 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 2 (rev 06)
00:1c.2 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 3 (rev 06)
00:1c.5 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 6 (rev 06)
00:1d.0 USB controller: Intel Corporation 5 Series/3400 Series Chipset USB2 Enhanced Host Controller (rev 06)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev a6)
00:1f.0 ISA bridge: Intel Corporation Mobile 5 Series Chipset LPC Interface Controller (rev 06)
00:1f.2 SATA controller: Intel Corporation 5 Series/3400 Series Chipset 4 port SATA AHCI Controller (rev 06)
00:1f.3 SMBus: Intel Corporation 5 Series/3400 Series Chipset SMBus Controller (rev 06)
01:00.0 VGA compatible controller: Advanced Micro Devices [AMD] nee ATI Robson CE [AMD Radeon HD 6300 Series]
01:00.1 Audio device: Advanced Micro Devices [AMD] nee ATI Cedar HDMI Audio [Radeon HD 5400/6300 Series]
03:00.0 Network controller: Atheros Communications Inc. AR9285 Wireless Network Adapter (PCI-Express) (rev 01)
05:00.0 System peripheral: JMicron Technology Corp. SD/MMC Host Controller (rev 80)
05:00.2 SD Host controller: JMicron Technology Corp. Standard SD Host Controller (rev 80)
05:00.3 System peripheral: JMicron Technology Corp. MS Host Controller (rev 80)
05:00.4 System peripheral: JMicron Technology Corp. xD Host Controller (rev 80)
05:00.5 Ethernet controller: JMicron Technology Corp. JMC250 PCI Express Gigabit Ethernet Controller (rev 03)
ff:00.0 Host bridge: Intel Corporation Core Processor QuickPath Architecture Generic Non-core Registers (rev 05)
ff:00.1 Host bridge: Intel Corporation Core Processor QuickPath Architecture System Address Decoder (rev 05)
ff:02.0 Host bridge: Intel Corporation Core Processor QPI Link 0 (rev 05)
ff:02.1 Host bridge: Intel Corporation Core Processor QPI Physical 0 (rev 05)
ff:02.2 Host bridge: Intel Corporation Core Processor Reserved (rev 05)
ff:02.3 Host bridge: Intel Corporation Core Processor Reserved (rev 05)

Dernière modification par Neolex (07-05-2014 09:00:31)

Hors ligne

#6 07-05-2014 08:51:18

Invité-5
Banni(e)

Re : Pas de son (iceweasel) [Resolu]

01:00.1 Audio device: Advanced Micro Devices [AMD] nee ATI Cedar HDMI Audio [Radeon HD 5400/6300 Series]


Premièrement tu peux enlever la deuxième moitié de ton lspci puisque c'est la même chose. Que donne ;

apt-cache policy pulseaudio

et

apt-cache policy alsa-base

puis si tu veux l'utiliser alsa

dpkg-reconfigure alsa-base

ensuite suivre => https://debian-facile.org/doc:materiel: … odules-son   Courage.

#7 07-05-2014 09:01:50

Neolex
Membre
Distrib. : Debian 7.0
Noyau : Linux 3.2.0-4-amd64
(G)UI : Gnome 3.4.2.1
Inscription : 02-06-2013

Re : Pas de son (iceweasel) [Resolu]

Effectivement , j'ai édité mon message .
J'essayerais ce que tu m'as dis dès que je rentre chez moi .
Au fait , lorsque je change le son on entends aucun "beep" sur firefox et chromium le son ne fonctionne pas , mais il fonctionne sur VLC ...

Hors ligne

#8 07-05-2014 09:15:40

Invité-5
Banni(e)

Re : Pas de son (iceweasel) [Resolu]

Avec la commande

lspci -vvnn

tu pourras vérifier Audio device et Multimedia audio controller

#9 07-05-2014 19:30:02

Neolex
Membre
Distrib. : Debian 7.0
Noyau : Linux 3.2.0-4-amd64
(G)UI : Gnome 3.4.2.1
Inscription : 02-06-2013

Re : Pas de son (iceweasel) [Resolu]

Voilà je suis rentré chez moi , voici les resultats :

atlas@Atlas-Debian:~$ apt-cache policy pulseaudio
pulseaudio:
  Installé : 2.0-6.1
  Candidat : 2.0-6.1
Table de version :
*** 2.0-6.1 0
        500 http://ftp.fr.debian.org/debian/ wheezy/main amd64 Packages
        500 http://ftp.au.debian.org/debian/ stable/main amd64 Packages
        500 http://http.debian.net/debian/ wheezy/main amd64 Packages
        100 /var/lib/dpkg/status


atlas@Atlas-Debian:~$ apt-cache policy alsa-base
alsa-base:
  Installé : 1.0.25+3~deb7u1
  Candidat : 1.0.25+3~deb7u1
Table de version :
*** 1.0.25+3~deb7u1 0
        500 http://ftp.fr.debian.org/debian/ wheezy/main amd64 Packages
        500 http://ftp.au.debian.org/debian/ stable/main amd64 Packages
        500 http://http.debian.net/debian/ wheezy/main amd64 Packages
        100 /var/lib/dpkg/status



Le reconfigure ne fait rien du tout .

atlas@Atlas-Debian:~$ cat /proc/asound/modules
0 snd_hda_intel
1 snd_hda_intel
2 snd_usb_audio


atlas@Atlas-Debian:~$ lspci -vvnn | grep "Audio device"
00:1b.0 Audio device [0403]: Intel Corporation 5 Series/3400 Series Chipset High Definition Audio [8086:3b56] (rev 06)
01:00.1 Audio device [0403]: Advanced Micro Devices [AMD] nee ATI Cedar HDMI Audio [Radeon HD 5400/6300 Series] [1002:aa68]



Et multimedia audio controller ne trouve rien ...

J'ai essayé de suivre le lien , choisir la carte son etc rien n'a fonctionné hmm .

Par contre alsamixer m'envoie une erreur :

atlas@Atlas-Debian:~$ alsamixer
ALSA lib conf.c:1168:(parse_def) 0 is not a compound
ALSA lib conf.c:1686:(snd_config_load1) _toplevel_:13:13:Argument invalide
ALSA lib conf.c:3406:(config_file_open) /home/atlas/.asoundrc may be old or corrupted: consider to remove or fix it
Erreur de segmentation



Merci de ton aide !

Dernière modification par Neolex (07-05-2014 19:31:02)

Hors ligne

#10 07-05-2014 19:50:21

Invité-5
Banni(e)

Re : Pas de son (iceweasel) [Resolu]

pascal t'envoie le tuto juste pour Intel => http://linuxfr.org/forums/linux-debian- … ian-wheezy

Sinon, reviens nous voir. Je vais dîner.

#11 08-05-2014 09:22:37

Invité-5
Banni(e)

Re : Pas de son (iceweasel) [Resolu]

Premièrement; par curiosité, que fait la ligne   500 http://ftp.au.debian.org/debian/ stable/main amd64 Packages dans ton fichier /etc/apt/sources.list ?

00:1b.0 Audio device [0403]: Intel Corporation 5 Series/3400 Series Chipset High Definition Audio [8086:3b56] (rev 06)
01:00.1 Audio device [0403]: Advanced Micro Devices [AMD] nee ATI Cedar HDMI Audio [Radeon HD 5400/6300 Series] [1002:aa68]

   
Deuxièmement; apparemment tu as plusieurs cartes son (carte son intégrée à ta carte mère + la carte son de ta carte graphique qui sont en conflit +2 snd_usb_audio ?) Avec la commande ;

cat /proc/asound/cards

on va essayer d'avancer le schmilblick, ce qui veut dire "changer l'ordre d'utilisation" A vrai dire l'histoire de pulseaudio installé m’embête un petit peu.

aptitude remove pulseaudio

sinon le son essaye de passer par 2 canaux

Essaye de suivre la solution n° 5 => https://debian-facile.org/doc:materiel: … -solution3 ou revenir à 4 https://debian-facile.org/doc:materiel: … -solution2 (il faudra bien étudier le problème) Courage.

Dernière modification par Invité-5 (08-05-2014 11:25:16)

#12 09-05-2014 11:30:20

Neolex
Membre
Distrib. : Debian 7.0
Noyau : Linux 3.2.0-4-amd64
(G)UI : Gnome 3.4.2.1
Inscription : 02-06-2013

Re : Pas de son (iceweasel) [Resolu]

Euh , je ne crois pas qu'elle soit dans mon sources.lits :

atlas@Atlas-Debian:~$ cat /etc/apt/sources.list

deb http://ftp.fr.debian.org/debian/ wheezy main
deb-src http://ftp.fr.debian.org/debian/ wheezy main

deb http://security.debian.org/ wheezy/updates main
deb-src http://security.debian.org/ wheezy/updates main

# wheezy-updates, previously known as 'volatile'
deb http://ftp.fr.debian.org/debian/ wheezy-updates main
deb-src http://ftp.fr.debian.org/debian/ wheezy-updates main

deb http://ftp.au.debian.org/debian stable main non-free

deb http://www.deb-multimedia.org wheezy main non-free

# iceweasel
    deb http://mozilla.debian.net/ wheezy-backports iceweasel-release


deb http://liveusb.info/multisystem/depot all main
deb-src http://liveusb.info/multisystem/depot all main
# Debian 7 "Wheezy"
deb http://http.debian.net/debian/ wheezy main contrib non-free



Par contre j'ai peur de faire une erreur :

atlas@Atlas-Debian:~$ sudo aptitude remove pulseaudio
[sudo] password for atlas:
Les paquets suivants seront ENLEVÉS :         
  pulseaudio xulrunner-28{u}
0 paquets mis à jour, 0 nouvellement installés, 2 à enlever et 9 non mis à jour.
Il est nécessaire de télécharger 0 o d'archives. Après dépaquetage, 58,5 Mo seront libérés.
Les paquets suivants ont des dépendances non satisfaites :
libcanberra-pulse : Dépend: pulseaudio mais il ne sera pas installé.
pulseaudio-module-x11 : Dépend: pulseaudio mais il ne sera pas installé.
gnome-core : Dépend: pulseaudio mais il ne sera pas installé.
Les actions suivantes permettront de résoudre ces dépendances :

     Supprimer les paquets suivants :                   
1)     gnome                                           
2)     gnome-core                                       
3)     libcanberra-pulse                               
4)     pulseaudio-module-x11                           

     Laisser les dépendances suivantes non satisfaites :
5)     gnome-media recommande pulseaudio               
6)     gnome-settings-daemon recommande pulseaudio     
7)     speech-dispatcher recommande pulseaudio         


Accepter cette solution ? [Y/n/q/?]



j'ai essayé la solution 5 mais je ne suis pas sur de quoi mettre dans le alsa-base.conf , puis j'obtiens :

atlas@Atlas-Debian:~$ sudo update-modules
sudo: update-modules: command not found



C'est vraiment bizarre que le son fonctionne dans VLC , chromium , mais pas iceweasel ... Et dans "son" lorsqu'on modifie le volume on entends pas le "beep" ...

Je suis perdu .

Hors ligne

#13 09-05-2014 13:30:50

Invité-5
Banni(e)

Re : Pas de son (iceweasel) [Resolu]

La commande su (voir) => https://debian-facile.org/doc:systeme:su et sudo => https://debian-facile.org/doc:systeme:sudo Souviens-toi de mon poste #11

cat /proc/asound/cards

#14 09-05-2014 13:56:15

Invité-5
Banni(e)

Re : Pas de son (iceweasel) [Resolu]

#15 09-05-2014 15:21:05

Neolex
Membre
Distrib. : Debian 7.0
Noyau : Linux 3.2.0-4-amd64
(G)UI : Gnome 3.4.2.1
Inscription : 02-06-2013

Re : Pas de son (iceweasel) [Resolu]

Euh je n'ai pas trop compris pourquoi vous avez envoyé les trucs sur la commande su et sudo ? hmm

Dernière modification par Neolex (09-05-2014 15:46:59)

Hors ligne

#16 09-05-2014 15:57:32

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : Pas de son (iceweasel) [Resolu]

pour que tu passes les commandese en superutilisateur soit avec su, soit avec sudo, mais pas en user. smile

"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

En ligne

#17 09-05-2014 16:05:11

Neolex
Membre
Distrib. : Debian 7.0
Noyau : Linux 3.2.0-4-amd64
(G)UI : Gnome 3.4.2.1
Inscription : 02-06-2013

Re : Pas de son (iceweasel) [Resolu]

C'est ce que je fais non ?

Hors ligne

#18 09-05-2014 16:14:36

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : Pas de son (iceweasel) [Resolu]

c'est une sécurité que de les indiquer, en plus de toi, d'autres moins avertis peuvent utiliser ce fil. smile

"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

En ligne

#19 09-05-2014 16:40:08

Neolex
Membre
Distrib. : Debian 7.0
Noyau : Linux 3.2.0-4-amd64
(G)UI : Gnome 3.4.2.1
Inscription : 02-06-2013

Re : Pas de son (iceweasel) [Resolu]

D'accord ,
j'ai beau tout essayer ça ne fonctionne toujours pas  ...

Hors ligne

#20 09-05-2014 17:39:01

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : Pas de son (iceweasel) [Resolu]

Il faut pluls de précisions si tu veux qu'on t'aide. smile

"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

En ligne

#21 09-05-2014 17:51:49

Neolex
Membre
Distrib. : Debian 7.0
Noyau : Linux 3.2.0-4-amd64
(G)UI : Gnome 3.4.2.1
Inscription : 02-06-2013

Re : Pas de son (iceweasel) [Resolu]

Je ne sais pas vraiment quoi donner comme précisions , j'ai un peu tout testé ce qui est proposé sans résoudre le problème

Hors ligne

#22 09-05-2014 18:14:58

Invité-5
Banni(e)

Re : Pas de son (iceweasel) [Resolu]

Par exemple, que retourne la commande citée dans poste#13

Neolex a écrit :

C'est vraiment bizarre que le son fonctionne dans VLC , chromium , mais pas iceweasel


Il faudra changer également le titre de ton topic. Pas de son (Iceweasel) puisque ça change tout.

Dernière modification par Invité-5 (09-05-2014 18:33:39)

#23 09-05-2014 18:40:20

Neolex
Membre
Distrib. : Debian 7.0
Noyau : Linux 3.2.0-4-amd64
(G)UI : Gnome 3.4.2.1
Inscription : 02-06-2013

Re : Pas de son (iceweasel) [Resolu]

Je pensais l'avoir déjà montrée désolé

atlas@Atlas-Debian:~$ cat /proc/asound/cards
0 [Intel          ]: HDA-Intel - HDA Intel
                      HDA Intel at 0xd5200000 irq 46
1 [Generic        ]: HDA-Intel - HD-Audio Generic
                      HD-Audio Generic at 0xd0040000 irq 47
2 [N700           ]: USB-Audio - Logitech Speaker Lapdesk N700
                      Logitech Logitech Speaker Lapdesk N700 at usb-0000:00:1d.0-1.2, full speed

Hors ligne

#24 09-05-2014 19:19:55

Invité-5
Banni(e)

Re : Pas de son (iceweasel) [Resolu]

Comme je disais plus haut

Il faudra changer également le titre de ton topic. Pas de son (Iceweasel) puisque ça change tout.


Ton problème n'est pas le son en général mais juste dans Iceweasel. A ce niveau, tu pourrais éventuellement changer l'ordre d'utilisation de tes deux cartes Intel avec la solution n° 4 pour voir si ça change quelque chose mais je doute.


En même temps jette un coup d'œil ici => https://debian-facile.org/doc:systeme:a … multimedia + flash qui peuvent faire les dégâts.


Peut-être en supprimant le fichier se trouvant dans ton répertoire personnel .mozilla tu arriverais à retrouver le son dans ton navigateur.

rm -rf /home/user/.mozilla

Le répertoire/fichiers en question se régénérera automatiquement à l'ouverture d'Iceweasel. Bonne chance.

Dernière modification par Invité-5 (09-05-2014 19:28:08)

#25 09-05-2014 19:34:47

Neolex
Membre
Distrib. : Debian 7.0
Noyau : Linux 3.2.0-4-amd64
(G)UI : Gnome 3.4.2.1
Inscription : 02-06-2013

Re : Pas de son (iceweasel) [Resolu]

Supprimer le dossier .mozilla ne change rien , je vais voir pour les dépots multimedia et flash ...

Merci de votre aide .

Hors ligne

Pied de page des forums