Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#26 09-05-2014 19:47:58

Neolex
Membre
Distrib. : Debian 7.0
Noyau : Linux 3.2.0-4-amd64
(G)UI : Gnome 3.4.2.1
Inscription : 02-06-2013

Re : Pas de son (iceweasel) [Resolu]

Par contre mes enceintes USB ne sont plus reconnues du tout ...
Elle n'apparaissent plus dans la liste des sortie , ni dans /proc/asound/cards...
Cependant les boutons pour changer le volume etc fonctionne...

Il y aurait t'il un moyen de remettre tout ça par défaut ?  hmm

Dernière modification par Neolex (09-05-2014 19:54:58)

Hors ligne

#27 09-05-2014 20:55:55

Invité-5
Banni(e)

Re : Pas de son (iceweasel) [Resolu]

Je ne connais pas tes enceintes USB (il font peut-être la carte son extérieure en même temps) tu la mets en première position dans le fichier /etc/modprobe.d/alsa-base.conf
https://debian-facile.org/doc:materiel: … -solution2 ou

Solution 4à part Pour l'utiliser une carte son extérieure USB il sera judicieux de changer la valeur options snd-usb-audio index=-2 à 0 puis ajouter


options snd slots=snd-usb-audio,snd-hda-intel

Dernière modification par Invité-5 (10-05-2014 21:49:14)

#28 10-05-2014 18:18:52

Neolex
Membre
Distrib. : Debian 7.0
Noyau : Linux 3.2.0-4-amd64
(G)UI : Gnome 3.4.2.1
Inscription : 02-06-2013

Re : Pas de son (iceweasel) [Resolu]

En fait , je ne peux pas les mettre en première positions car ils ne sont même pas dans /proc/asound/modules ni rien ... neutral
J'aurais mieux fait de pas essayer de régler ces problèmes au final j'ai empiré les choses hmm

Merci pour votre aide !

Hors ligne

#29 10-05-2014 18:22:51

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : Pas de son (iceweasel) [Resolu]

un copie/colle des fichiers de conf et ceux de tes recherches peut-être pour aider à visualiser où tu en es ? smile

"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#30 10-05-2014 18:36:15

Neolex
Membre
Distrib. : Debian 7.0
Noyau : Linux 3.2.0-4-amd64
(G)UI : Gnome 3.4.2.1
Inscription : 02-06-2013

Re : Pas de son (iceweasel) [Resolu]

Pour mes recherches j'ai testé plein de trucs mais rien n'a fonctionné .
Tout d'abord je n'ai pas osé supprimer pulseaudio , car j'ai eu le message suivant :

atlas@Atlas-Debian:~$ sudo aptitude remove pulseaudio
[sudo] password for atlas:
Les paquets suivants seront ENLEVÉS :         
  pulseaudio xulrunner-28{u}
0 paquets mis à jour, 0 nouvellement installés, 2 à enlever et 9 non mis à jour.
Il est nécessaire de télécharger 0 o d'archives. Après dépaquetage, 58,5 Mo seront libérés.
Les paquets suivants ont des dépendances non satisfaites :
libcanberra-pulse : Dépend: pulseaudio mais il ne sera pas installé.
pulseaudio-module-x11 : Dépend: pulseaudio mais il ne sera pas installé.
gnome-core : Dépend: pulseaudio mais il ne sera pas installé.
Les actions suivantes permettront de résoudre ces dépendances :

     Supprimer les paquets suivants :                   
1)     gnome                                           
2)     gnome-core                                       
3)     libcanberra-pulse                               
4)     pulseaudio-module-x11                           

     Laisser les dépendances suivantes non satisfaites :
5)     gnome-media recommande pulseaudio               
6)     gnome-settings-daemon recommande pulseaudio     
7)     speech-dispatcher recommande pulseaudio         


Accepter cette solution ? [Y/n/q/?]



Dois-je "accepter cette solution" ? 


Pour mes fichiers de conf , euh  dites moi si il manque des choses , je ne sais pas trop quoi mettre .

atlas@Atlas-Debian:~$ cat /proc/asound/modules
0 snd_hda_intel
1 snd_hda_intel



atlas@Atlas-Debian:~$ cat /etc/modprobe.d/alsa-base.conf
# autoloader aliases
install sound-slot-0 /sbin/modprobe snd-card-0
install sound-slot-1 /sbin/modprobe snd-card-1
install sound-slot-2 /sbin/modprobe snd-card-2
install sound-slot-3 /sbin/modprobe snd-card-3
install sound-slot-4 /sbin/modprobe snd-card-4
install sound-slot-5 /sbin/modprobe snd-card-5
install sound-slot-6 /sbin/modprobe snd-card-6
install sound-slot-7 /sbin/modprobe snd-card-7
# Cause optional modules to be loaded above generic modules
install snd /sbin/modprobe --ignore-install snd && { /sbin/modprobe --quiet snd-ioctl32 ; /sbin/modprobe --quiet snd-seq ; : ; }
install snd-rawmidi /sbin/modprobe --ignore-install snd-rawmidi && { /sbin/modprobe --quiet snd-seq-midi ; : ; }
install snd-emu10k1 /sbin/modprobe --ignore-install snd-emu10k1 && { /sbin/modprobe --quiet snd-emu10k1-synth ; : ; }
# Keep snd-pcsp from beeing loaded as first soundcard
options snd-pcsp index=-2
# Keep snd-usb-audio from beeing loaded as first soundcard
options snd-usb-audio index=0
# Prevent abnormal drivers from grabbing index 0
options bt87x index=-2
options cx88_alsa index=-2
options snd-atiixp-modem index=-2
options snd-intel8x0m index=-2
options snd-via82xx-modem index=-2

options snd-hda-intel  index=0
options snd-hda-intel model=auto

options snd slots=snd-usb-audio,snd-hda-intel

install sound-slot-**1** modprobe snd-card-0
install sound-slot-**0** modprobe snd-card-1



atlas@Atlas-Debian:~$ cat ./.asoundrc
pcm.pulse {
    type pulse
}
ctl.pulse {
    type pulse
}
pcm.!default {
    type pulse
}
ctl.!default {
    type pulse
}

Hors ligne

#31 10-05-2014 19:39:47

Invité-5
Banni(e)

Re : Pas de son (iceweasel) [Resolu]

neolex a écrit :

Dois-je "accepter cette solution" ?


NON, oublies pour le moment.

En fait , je ne peux pas les mettre en première positions car ils ne sont même pas dans /proc/asound/modules ni rien ..


Le protège-portable N700 n'est pas compatible avec les systèmes d'exploitation Windows 98, Windows ME, Windows 2000, UNIX ou Linux. Et pourtant elle est là ;

atlas@Atlas-Debian:~$ cat /proc/asound/cards
0 [Intel          ]: HDA-Intel - HDA Intel
                      HDA Intel at 0xd5200000 irq 46
1 [Generic        ]: HDA-Intel - HD-Audio Generic
                      HD-Audio Generic at 0xd0040000 irq 47
2 [N700           ]: USB-Audio - Logitech Speaker Lapdesk N700
                      Logitech Logitech Speaker Lapdesk N700 at usb-0000:00:1d.0-1.2, full speed

Dans ton fichier  /etc/modprobe.d/alsa-base.conf tu as mis quatre solutions en même temps alors qu'une seule est autorisée.
1. options snd-hda-intel  index=0
2. options snd-hda-intel model=auto

3. options snd slots=snd-usb-audio,snd-hda-intel

4. install sound-slot-**1** modprobe snd-card-0
    install sound-slot-**0** modprobe snd-card-1
Avec tout ça nous sommes très mal. Je me trompe => http://www.logitech.fr/fr-fr/support/sp … pdesk-n700

Dernière modification par Invité-5 (11-05-2014 08:07:10)

#32 10-05-2014 19:58:51

Neolex
Membre
Distrib. : Debian 7.0
Noyau : Linux 3.2.0-4-amd64
(G)UI : Gnome 3.4.2.1
Inscription : 02-06-2013

Re : Pas de son (iceweasel) [Resolu]

C'est étrange vu qu'il fonctionnait bien jusque maintenant , donc il n'a pas l'air si incompatible que ça ...
par contre maintenant ça fait  :

atlas@Atlas-Debian:~$ cat /proc/asound/cards
0 [Intel          ]: HDA-Intel - HDA Intel
                      HDA Intel at 0xd5200000 irq 46
1 [Generic        ]: HDA-Intel - HD-Audio Generic
                      HD-Audio Generic at 0xd0040000 irq 47




D'accord  j'ai effectivement fait n'importe quoi je vais essayer ces solutions une par une .


J'ai reussi à remettre les haut parleurs par usb ,  je ne sais pas trop comment , voici mon alsa-base.conf :

atlas@Atlas-Debian:~$ cat /etc/modprobe.d/alsa-base.conf
# autoloader aliases
install sound-slot-0 /sbin/modprobe snd-card-0
install sound-slot-1 /sbin/modprobe snd-card-1
install sound-slot-2 /sbin/modprobe snd-card-2
install sound-slot-3 /sbin/modprobe snd-card-3
install sound-slot-4 /sbin/modprobe snd-card-4
install sound-slot-5 /sbin/modprobe snd-card-5
install sound-slot-6 /sbin/modprobe snd-card-6
install sound-slot-7 /sbin/modprobe snd-card-7
# Cause optional modules to be loaded above generic modules
install snd /sbin/modprobe --ignore-install snd && { /sbin/modprobe --quiet snd-ioctl32 ; /sbin/modprobe --quiet snd-seq ; : ; }
install snd-rawmidi /sbin/modprobe --ignore-install snd-rawmidi && { /sbin/modprobe --quiet snd-seq-midi ; : ; }
install snd-emu10k1 /sbin/modprobe --ignore-install snd-emu10k1 && { /sbin/modprobe --quiet snd-emu10k1-synth ; : ; }
# Keep snd-pcsp from beeing loaded as first soundcard
options snd-pcsp index=-2
# Keep snd-usb-audio from beeing loaded as first soundcard
options snd-usb-audio index=-2
# Prevent abnormal drivers from grabbing index 0
options bt87x index=-2
options cx88_alsa index=-2
options snd-atiixp-modem index=-2
options snd-intel8x0m index=-2
options snd-via82xx-modem index=-2

install sound-slot-**1** modprobe snd-card-0
    install sound-slot-**0** modprobe snd-card-1




Par contre le problème de iceweasel n'a pas changé .

Dernière modification par Neolex (10-05-2014 21:15:30)

Hors ligne

#33 10-05-2014 20:15:28

Invité-5
Banni(e)

Re : Pas de son (iceweasel) [Resolu]

Tu ne nous dis pas si t'as les son en général non plus, j’arrête ici.

La documentation sera ton ami. => https://debian-facile.org/doc:systeme:lsusb et plus + plus +plus +

Bon courage. smile

Dernière modification par Invité-5 (10-05-2014 20:35:23)

#34 10-05-2014 21:31:42

Invité-5
Banni(e)

Re : Pas de son (iceweasel) [Resolu]

Neolex a écrit :

J'ai reussi à remettre les haut parleurs par usb ,  je ne sais pas trop comment , voici mon alsa-base.conf :


EDIT ; Que donne à présent

cat /proc/asound/cards

et

 cat /proc/asound/modules


Revois le poste#27

EDIT 2 ;

Par contre le problème de iceweasel n'a pas changé .


aptitude remove iceweasel

puis

rm -rf /home/user/.mozilla

pour purger les dossiers iceweasel de l'user en cours

aptitude clean

pour vider le cache et permettre ainsi de télécharger un paquet iceweasel nouveau.

documentation a écrit :

Si vous n'avez pas besoin de la dernière version d'Iceweasel, contentez-vous de mettre les dépôts security qui fournissent déjà la dernière version ESR (support long terme) d'Iceweasel.


aptitude install iceweasel iceweasel-l10n-fr

Dernière modification par Invité-5 (11-05-2014 08:35:23)

#35 11-05-2014 12:30:20

Neolex
Membre
Distrib. : Debian 7.0
Noyau : Linux 3.2.0-4-amd64
(G)UI : Gnome 3.4.2.1
Inscription : 02-06-2013

Re : Pas de son (iceweasel) [Resolu]

J'ai le son sauf sur iceweasel , et lorsque je change le son dans le fenetre son je n'ai pas le "bip" qui indique le volume du son .

J'ai fais tout ce que tu as dis et le son sur iceweasel re fonctionne , merci beaucoup !!

Hors ligne

Pied de page des forums