Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 19-11-2008 17:53:58

djagh
Membre
Distrib. : lenny
Noyau : 2.6.26-1-686
(G)UI : GNOME 2.22.3
Inscription : 19-11-2008

[resolu avec wicd] probleme intel 3945 a/b/g et lenny

bonjours a tous , je viens de passer a debian lenny et j'ai un petit soucis avec ma connection wifi, j'ai une carte intel 3945 a/b/g sur portable asus et une connection numericable , j'ai installé le firmware iwlwifi 3945 mais j'arrive toujour pas a me connecter , pouvez vous m'aider je vous remercie par avance
djagh@debian:~$ su
Mot de passe :
debian:/home/djagh# iwconfig
lo        no wireless extensions.

eth1      no wireless extensions.

wmaster0  no wireless extensions.

wlan0     IEEE 802.11  ESSID:"NUMERICABLE-6FB5" 
          Mode:Managed  Frequency:2.412 GHz  Access Point: Not-Associated   
          Tx-Power=15 dBm   
          Retry min limit:7   RTS thr:off   Fragment thr=2352 B   
          Encryption key:3C11-24EE-AC38-90D7-****-****-**
          Link Quality:0  Signal level:0  Noise level:0
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

debian:/home/djagh# lspci
00:00.0 Host bridge: Intel Corporation Mobile 945GM/PM/GMS, 943/940GML and 945GT Express Memory Controller Hub (rev 03)
00:01.0 PCI bridge: Intel Corporation Mobile 945GM/PM/GMS, 943/940GML and 945GT Express PCI Express Root Port (rev 03)
00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 02)
00:1c.0 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 1 (rev 02)
00:1c.1 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 2 (rev 02)
00:1c.2 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 3 (rev 02)
00:1d.0 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #1 (rev 02)
00:1d.1 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #2 (rev 02)
00:1d.2 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #3 (rev 02)
00:1d.3 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #4 (rev 02)
00:1d.7 USB Controller: Intel Corporation 82801G (ICH7 Family) USB2 EHCI Controller (rev 02)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev e2)
00:1f.0 ISA bridge: Intel Corporation 82801GBM (ICH7-M) LPC Interface Bridge (rev 02)
00:1f.2 IDE interface: Intel Corporation 82801GBM/GHM (ICH7 Family) SATA IDE Controller (rev 02)
00:1f.3 SMBus: Intel Corporation 82801G (ICH7 Family) SMBus Controller (rev 02)
01:00.0 VGA compatible controller: ATI Technologies Inc M56P [Radeon Mobility X1600]
02:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 01)
03:00.0 Network controller: Intel Corporation PRO/Wireless 3945ABG [Golan] Network Connection (rev 02)
06:01.0 FireWire (IEEE 1394): Ricoh Co Ltd R5C832 IEEE 1394 Controller
06:01.1 SD Host controller: Ricoh Co Ltd R5C822 SD/SDIO/MMC/MS/MSPro Host Adapter (rev 19)
06:01.2 System peripheral: Ricoh Co Ltd R5C843 MMC Host Controller (rev 01)
06:01.3 System peripheral: Ricoh Co Ltd R5C592 Memory Stick Bus Host Adapter (rev 0a)
debian:/home/djagh#

Dernière modification par djagh (21-11-2008 11:51:44)

Hors ligne

#2 19-11-2008 19:16:23

tux12
Membre
Lieu : ./
Distrib. : Squeeze
Noyau : Linux 2.6.32-5-686-bigmem
(G)UI : KDE
Inscription : 27-02-2008

Re : [resolu avec wicd] probleme intel 3945 a/b/g et lenny

Bonjour djagh, et bienvenue.

Ta carte est reconnue et montée, mais pas configurée (il lui manque au moins une IP).
Tu peux nous donner le contenu de ton /etc/network/interfaces? (sans les clés wink )
Tu as un serveur DHCP actif sur ta box?

@+

Hors ligne

#3 20-11-2008 11:17:52

djagh
Membre
Distrib. : lenny
Noyau : 2.6.26-1-686
(G)UI : GNOME 2.22.3
Inscription : 19-11-2008

Re : [resolu avec wicd] probleme intel 3945 a/b/g et lenny

Salut et merci tux12 , oui le dhcp est actif sur mon routeur
voila le contenu d'interfaces:
# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
allow-hotplug eth1
iface eth1 inet dhcp

auto eth1

iface eth0 inet dhcp

auto eth0

iface wlan0 inet dhcp
wireless-key **************************
wireless-essid NUMERICABLE-6FB5

auto wlan0

Hors ligne

#4 20-11-2008 11:42:45

freddec
homo-informaticus du genre linuxo-debianicum
Lieu : Saint Jean d'Y (17)
Distrib. : Branche Stable (Jessie)
Noyau : Linux 3.16.0-4-amd64
(G)UI : XFCE_4.1 (+/- Mate) (+/- Cinnamon)
Inscription : 09-01-2008

Re : [resolu avec wicd] probleme intel 3945 a/b/g et lenny

Salut
J'y connais pas grand chose en wifi, mais il y aurait pas une histoire d'association avec le routeur

iwconfig a écrit :

Mode:Managed  Frequency:2.412 GHz Access Point: Not-Associated


j'ai ça sur la livebox, je l'ai découvert en connectant la wii de mes fils, si je ne met pas la box en mode association à la première connexion de la wii, cela ne marche pas, idem avec le laptop de mon père sous vista.
Ensuite une fois que la première prise de contact est faite c'est sans souci, d'ailleur ensuite les McAdress sont dans une liste des cartes autorisées dans l'interface de gestion wifi de la box.

Voila, je sais pas si ça te sera utile, mais le "not-associated" m'évoque cela


Desktop: Jessie (I5 - 16Go)
Laptop 1: Jessie (HP DV9000, 3Go)
Laptop 2: Jessie (PackardBell TS 44, Core I5, 4Go)
EeePC : Jessie (Atom N450, 2 Go)

Hors ligne

#5 20-11-2008 12:23:54

djagh
Membre
Distrib. : lenny
Noyau : 2.6.26-1-686
(G)UI : GNOME 2.22.3
Inscription : 19-11-2008

Re : [resolu avec wicd] probleme intel 3945 a/b/g et lenny

oui j'y ai pensé mais en fait c'est juste un modem/routeur pour le cable et je n'ai aucune touche sur ce routeur a part une pour la réinitialisation , de plus je me connect dessus sans probleme avec d'autres os (xp/ubuntu....) et avec des appareils mobiles (psp/iphone/win mobile), mais c'est vrai que le probleme doit venir de ce "not associated"....

Hors ligne

#6 20-11-2008 16:41:48

tux12
Membre
Lieu : ./
Distrib. : Squeeze
Noyau : Linux 2.6.32-5-686-bigmem
(G)UI : KDE
Inscription : 27-02-2008

Re : [resolu avec wicd] probleme intel 3945 a/b/g et lenny

Bonjour,

Je suggère de commenter (en ajoutant une '#' en début de ligne) la ligne "auto eth1" du fichier interfaces, puis d'enregistrer le fichier, de débrancher la liaison filaire ethernet et de redémarrer le réseau avec

/etc/init.d/networking restart


.
Le but est bien de ne plus avoir le message " Access Point: Not-Associated". lors d'un iwconfig.

Si ça ne fonctionne toujours pas, vérifie dans l'interface de gestion de ton routeur quel canal (channel) est utilisé par le routeur et ajoute une ligne

wireless-channel numéro_du_canal


avant les deux autres lignes en "wireless-*" du fichier interface. Comme précédemment, il faut redémarrer le réseau (toujours sans la liaison filaire eth) pour que les modifications soient prises en compte.

@+

Hors ligne

#7 20-11-2008 19:43:38

djagh
Membre
Distrib. : lenny
Noyau : 2.6.26-1-686
(G)UI : GNOME 2.22.3
Inscription : 19-11-2008

Re : [resolu avec wicd] probleme intel 3945 a/b/g et lenny

rien a faire ca veut toujours pas voici mon /interfaces:
# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
allow-hotplug eth1
iface eth1 inet dhcp

#auto eth1

iface eth0 inet dhcp

auto eth0

iface wlan0 inet dhcp
wireless-channel 6
wireless-key **************************
wireless-essid NUMERICABLE-6FB5

auto wlan0

et quand je redemarre le reseau voila ce qu'il me met:
djagh@debian:~$ su
Mot de passe :
debian:/home/djagh# gedit /etc/network/interfaces

(gedit:4791): GnomeUI-WARNING **: While connecting to session manager:
Authentication Rejected, reason : None of the authentication protocols specified are supported and host-based authentication failed.
debian:/home/djagh# /etc/init.d/networking restart
Reconfiguring network interfaces...There is already a pid file /var/run/dhclient.wlan0.pid with pid 4637
killed old client process, removed PID file
Internet Systems Consortium DHCP Client V3.1.1
Copyright 2004-2008 Internet Systems Consortium.
All rights reserved.
For info, please visit http://www.isc.org/sw/dhcp/

wmaster0: unknown hardware address type 801
wmaster0: unknown hardware address type 801
Listening on LPF/wlan0/00:18:de:79:42:06
Sending on   LPF/wlan0/00:18:de:79:42:06
Sending on   Socket/fallback
DHCPRELEASE on wlan0 to 192.168.0.1 port 67
Internet Systems Consortium DHCP Client V3.1.1
Copyright 2004-2008 Internet Systems Consortium.
All rights reserved.
For info, please visit http://www.isc.org/sw/dhcp/

wmaster0: unknown hardware address type 801
SIOCSIFADDR: No such device
eth0: ERROR while getting interface flags: No such device
eth0: ERROR while getting interface flags: No such device
wmaster0: unknown hardware address type 801
Bind socket to interface: No such device
Failed to bring up eth0.
Internet Systems Consortium DHCP Client V3.1.1
Copyright 2004-2008 Internet Systems Consortium.
All rights reserved.
For info, please visit http://www.isc.org/sw/dhcp/

wmaster0: unknown hardware address type 801
wmaster0: unknown hardware address type 801
Listening on LPF/wlan0/00:18:de:79:42:06
Sending on   LPF/wlan0/00:18:de:79:42:06
Sending on   Socket/fallback
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 3
DHCPOFFER from 192.168.0.1
DHCPREQUEST on wlan0 to 255.255.255.255 port 67
DHCPACK from 192.168.0.1
bound to 192.168.0.28 -- renewal in 1685 seconds.
if-up.d/mountnfs[wlan0]: waiting for interface eth0 before doing NFS mounts (warning).
done.
debian:/home/djagh#

y aurais pas un "255" en trop devrais pas y avoir un "0" a la place ? de plus pour avoir ma connection cablé je doit décommenter eth1, j'ai essayé aussi de commenter la ligne eth0 mais toujours rien

Hors ligne

#8 20-11-2008 21:54:50

tux12
Membre
Lieu : ./
Distrib. : Squeeze
Noyau : Linux 2.6.32-5-686-bigmem
(G)UI : KDE
Inscription : 27-02-2008

Re : [resolu avec wicd] probleme intel 3945 a/b/g et lenny

Re,

J'ai dit une bêtise précédemment, iwconfig ne donne pas l'IP associée à l'interface (ifconfig le fait). Donc la carte avait peut-être déjà une IP au début du fil, comme elle en a une actuellement; ce qu'indiquent ces lignes:

DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 3
DHCPOFFER from 192.168.0.1
DHCPREQUEST on wlan0 to 255.255.255.255 port 67
DHCPACK from 192.168.0.1
bound to 192.168.0.28 -- renewal in 1685 seconds.


C'est curieux ces problèmes avec le DHCP, on a eu le même ici que mouloud7 a finalement résolu en installant Wicd.

Peux-tu nous donner le résultat de ifconfig -a, de iwlist scan wlan0 et de ping -c 2 192.168.0.1 ?

Je suppose que le 255 en trop dont tu parles concerne les lignes du DHCP ci-dessus. C'est normal, 255.255.255.255 correspond à "toutes les IPs de tous les réseaux", c'est un broadcast qui ne se limite pas aux IPs du réseau auquel appartient la machine qui l'émet. Ça se comprend vu que tant que l'hôte qui doit se voir attribué une IP par DHCP n'a pas obtenu d'infos de la part du serveur DHCP il est bien en peine de connaître le réseau dont il doit faire partie, et donc l'adresse de broadcast associée.
J'espère être clair dans mes explications. big_smile

@+

Hors ligne

#9 21-11-2008 01:08:34

djagh
Membre
Distrib. : lenny
Noyau : 2.6.26-1-686
(G)UI : GNOME 2.22.3
Inscription : 19-11-2008

Re : [resolu avec wicd] probleme intel 3945 a/b/g et lenny

si si j'ai compris mais j'ai relu 2 fois hmm merci pour ton aide, bon là je ne suis pas chez moi je te colle tout ca demain en attendant je vais lire le poste de mouloud7

Hors ligne

#10 21-11-2008 10:55:19

djagh
Membre
Distrib. : lenny
Noyau : 2.6.26-1-686
(G)UI : GNOME 2.22.3
Inscription : 19-11-2008

Re : [resolu avec wicd] probleme intel 3945 a/b/g et lenny

voila ca que donne tes commandes
djagh@debian:~$ su
Mot de passe :
debian:/home/djagh# ifconfig -a
eth1      Link encap:Ethernet  HWaddr 00:18:f3:3f:d3:43 
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:197 errors:0 dropped:0 overruns:0 frame:0
          TX packets:209 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:1000
          RX bytes:141494 (138.1 KiB)  TX bytes:26748 (26.1 KiB)
          Interruption:219 Adresse de base:0x6000

lo        Link encap:Boucle locale 
          inet adr:127.0.0.1  Masque:255.0.0.0
          adr inet6: ::1/128 Scope:Hôte
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:14 errors:0 dropped:0 overruns:0 frame:0
          TX packets:14 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:0
          RX bytes:860 (860.0 B)  TX bytes:860 (860.0 B)

wlan0     Link encap:Ethernet  HWaddr 00:18:de:79:42:06 
          inet adr:192.168.0.31  Bcast:192.168.0.255  Masque:255.255.255.0
          adr inet6: fe80::218:deff:fe79:4206/64 Scope:Lien
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:63 errors:0 dropped:0 overruns:0 frame:0
          TX packets:67 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:1000
          RX bytes:8859 (8.6 KiB)  TX bytes:11460 (11.1 KiB)

wmaster0  Link encap:UNSPEC  HWaddr 00-18-DE-79-42-06-77-6C-00-00-00-00-00-00-00-00 
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

debian:/home/djagh# iwlist scan wlan0
iwlist: unknown command `wlan0' (check 'iwlist --help').
debian:/home/djagh# ping -c 2 192.168.0.1
PING 192.168.0.1 (192.168.0.1) 56(84) bytes of data.
64 bytes from 192.168.0.1: icmp_seq=1 ttl=64 time=56.9 ms
64 bytes from 192.168.0.1: icmp_seq=2 ttl=64 time=5.26 ms

--- 192.168.0.1 ping statistics ---
2 packets transmitted, 2 received, 0% packet loss, time 1004ms
rtt min/avg/max/mdev = 5.269/31.128/56.988/25.860 ms
debian:/home/djagh#

Hors ligne

#11 21-11-2008 11:49:21

djagh
Membre
Distrib. : lenny
Noyau : 2.6.26-1-686
(G)UI : GNOME 2.22.3
Inscription : 19-11-2008

Re : [resolu avec wicd] probleme intel 3945 a/b/g et lenny

yes!!!!!!!!!!!!!!!!!!!!!!!!!

djagh@debian:~$ su
Mot de passe :
debian:/home/djagh# iwconfig
lo        no wireless extensions.

eth1      no wireless extensions.

wmaster0  no wireless extensions.

wlan0     IEEE 802.11  ESSID:"NUMERICABLE-6FB5" 
          Mode:Managed  Frequency:2.437 GHz  Access Point: 00:1A:2B:6A:84:12   
          Bit Rate=54 Mb/s   Tx-Power=15 dBm   
          Retry min limit:7   RTS thr:off   Fragment thr=2352 B   
          Encryption key:*************************
          Link Quality=96/100  Signal level=-32 dBm  Noise level=-127 dBm
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

debian:/home/djagh#

j'ai installé wicd, je confirme il est vraiment nickel,
vraiment merci a toi tux12 on y est arrivé big_smile

Hors ligne

#12 21-11-2008 13:01:28

djagh
Membre
Distrib. : lenny
Noyau : 2.6.26-1-686
(G)UI : GNOME 2.22.3
Inscription : 19-11-2008

Re : [resolu avec wicd] probleme intel 3945 a/b/g et lenny

juste un petit probleme, le boot mais un peu de temps car wicd se charge à la fin du boot , y a t'il un moyen pour qu'il se charge avant que le boot essaye de se connecter sur wlan0 et m'affiche un max de lignes DHCPDISCOVER...................interval......... ?

Hors ligne

#13 21-11-2008 15:16:39

djagh
Membre
Distrib. : lenny
Noyau : 2.6.26-1-686
(G)UI : GNOME 2.22.3
Inscription : 19-11-2008

Re : [resolu avec wicd] probleme intel 3945 a/b/g et lenny

ok j'ai trouvé suffi de commenter les lignes auto eth1 et auto wlan0 dans /etc/network/interfaces, ca me marque une ligne error au boot mais pas de probleme quand wicd se charge donc boot rapide wink de plus sur l'interface de wicd je passe d'une connection a l'autre sans aucun probleme

Dernière modification par djagh (21-11-2008 15:23:05)

Hors ligne

#14 21-11-2008 19:25:13

tux12
Membre
Lieu : ./
Distrib. : Squeeze
Noyau : Linux 2.6.32-5-686-bigmem
(G)UI : KDE
Inscription : 27-02-2008

Re : [resolu avec wicd] probleme intel 3945 a/b/g et lenny

Bonjour,

Apparament ça fonctionnait déjà dans le post #10 (wlan0 à l'IP 192.168.0.31 et le ping répond), donc je suppose sans Wicd. (?)

La commande inconnue (post #10) c'est ma faute, il fallait taper iwlist wlan0 scan. Mais bon, plus la peine vu que ça marche.

Djagh, tu pourrais nous donner ton fichier interfaces actuel stp? Dans ton dernier post tu parles de commenter la ligne "auto eth1", qui l'était déjà dans la version précédente. Donc tu as fait des modifs. J'aimerais savoir ce qu'il en est exactement. Merci.

@+

Hors ligne

#15 22-11-2008 12:07:06

djagh
Membre
Distrib. : lenny
Noyau : 2.6.26-1-686
(G)UI : GNOME 2.22.3
Inscription : 19-11-2008

Re : [resolu avec wicd] probleme intel 3945 a/b/g et lenny

Oui dans le post #10 c'etait sans wicd mais aucun navigateur n'arrivait a m'ouvrir une page et quand je faisais "iwconfig" il y avait toujours ce "not associated" c'est là où j'ai pas compris si on pouvait m'expliquer? Sinon oui j'avais dé-commenté la ligne "auto eth1" car je n'avais plus de reseau filair et il me falait une connection pour recuperer wicd!
Voici actuelement comment est mon "/etc/network/interfaces/"

# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
allow-hotplug eth1
iface eth1 inet dhcp

#auto eth1

iface eth0 inet dhcp

#auto eth0

iface wlan0 inet dhcp
wireless-channel 6
wireless-key **************************
wireless-essid NUMERICABLE-6FB5

#auto wlan0

Dernière modification par djagh (22-11-2008 12:08:44)

Hors ligne

#16 22-11-2008 18:11:13

tux12
Membre
Lieu : ./
Distrib. : Squeeze
Noyau : Linux 2.6.32-5-686-bigmem
(G)UI : KDE
Inscription : 27-02-2008

Re : [resolu avec wicd] probleme intel 3945 a/b/g et lenny

Bonjour djagh,

Non je ne saurais pas t'expliquer, c'est justement ce que cherche à comprendre, et la raison pour laquelle je souhaitais avoir ton fichier interfaces actuel.
On voit la même chose dans ce post de mouloud7, à savoir l'interface wifi possède une IP attribuée par DHCP, mais est toujours "not associated".

Je finirais bien par trouver. Merci de ton retour. smile

Hors ligne

Pied de page des forums