Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 03-06-2014 15:17:27

Erlen
Membre
Distrib. : Jessie
Noyau : 3.16.0-4-amd64
(G)UI : openbox
Inscription : 16-04-2014

[Résolu] Pas de wifi à la sortie de veille

Bonjour,

J'ai une carte wifi Broadcom Corporation BCM4313. À la sortie de veille, je n'arrive pas à me reconnecter au wifi. C'est un problème que j'ai aussi sous windows, je le règle en désactivant depuis mon clavier le wifi et en redémarrant. C'est ce que j'ai fais mais cela ne fonctionne pas. J'ai redémarré Network-manager, mais aussi networking mais sans succès. Pour l'instant je suis obligé de redémarré linux !
Si quelqu'un a une solution, je suis preneur.
Merci

Dernière modification par Erlen (06-06-2014 13:20:20)

Hors ligne

#2 03-06-2014 17:08:18

sogal
Black Metal Modo
Distrib. : Debian Testing
Noyau : 4.7
(G)UI : Gnome
Inscription : 09-05-2013
Site Web

Re : [Résolu] Pas de wifi à la sortie de veille

Salut,
As-tu essayé de redémarrer ton périphérique wi-fi en ligne de commande?

ip link set wlan0 up


(en partant du principe qu'il s'appele bien wlan0)
Sinon voir du côté de rfkill.


Machine perso : Thinkpad x230 Debian Stretch | Machine pro : Thinpad T450 openSUSE Leap 42.2

Hors ligne

#3 04-06-2014 17:45:46

Erlen
Membre
Distrib. : Jessie
Noyau : 3.16.0-4-amd64
(G)UI : openbox
Inscription : 16-04-2014

Re : [Résolu] Pas de wifi à la sortie de veille

Après avoir testé, ça ne marche pas ! Network manager tourne toujours dans le vide.

Hors ligne

#4 04-06-2014 19:09:20

sogal
Black Metal Modo
Distrib. : Debian Testing
Noyau : 4.7
(G)UI : Gnome
Inscription : 09-05-2013
Site Web

Re : [Résolu] Pas de wifi à la sortie de veille

Hors problème de rédémarrage, ça fonctionne bien? Ça ne peut pas venir du pilote donc?
Eventuellement as-tu essayé avec un autre gestionnaire de connexion style wicd?
Que donne la sortie de iwconfig en sortie de veille?

Machine perso : Thinkpad x230 Debian Stretch | Machine pro : Thinpad T450 openSUSE Leap 42.2

Hors ligne

#5 06-06-2014 01:43:25

Erlen
Membre
Distrib. : Jessie
Noyau : 3.16.0-4-amd64
(G)UI : openbox
Inscription : 16-04-2014

Re : [Résolu] Pas de wifi à la sortie de veille

Alors utiliser wicd ne change rien. Par contre ça n'ai pas que lié à la sortie de veille. Si je déconnecte manuellement le wifi j'ai exactement le même problème, c'est à dire il est impossible de reconnecter le wifi.
Quand j'exécute une commande sudo j'ai :

sudo: unable to resolve host tutu


et voici le résultat de iwconfig

eth0      no wireless extensions.

lo        no wireless extensions.

wlan0     IEEE 802.11abg  ESSID:"Livebox-AAAA"  
          Mode:Managed  Frequency:2.462 GHz  Access Point: Not-Associated  
          Tx-Power=200 dBm  
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
 



Visiblement mes paramètres de connexion déconnent
puisque au lancement j'ai ça

eth0      no wireless extensions.

lo        no wireless extensions.

wlan0     IEEE 802.11abg  ESSID:"Livebox-AAAA"  
          Mode:Managed  Frequency:2.462 GHz  Access Point: 1A:11:1A:11:1A:A1  
          Bit Rate=58.5 Mb/s   Tx-Power=200 dBm  
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
          Link Quality=48/70  Signal level=-62 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0
 

Hors ligne

#6 06-06-2014 13:19:55

Erlen
Membre
Distrib. : Jessie
Noyau : 3.16.0-4-amd64
(G)UI : openbox
Inscription : 16-04-2014

Re : [Résolu] Pas de wifi à la sortie de veille

Donc j'ai trouvé. À cause de ma carte wifi lors de l'installation je n'ai pas configurer automatiquement internet et le wifi. Il manquait dans

/etc/network/interfaces


les lignes

auto wlan0
#iface wlan0 inet dhcp
 


À noté que j'ai commenté la deuxième parce qu'elle fait planté le wifi. La première est suffisante, mais tous le monde rajoute la deuxième.
Après une petite recherche je n'ai pas trouvé l'intérêt de cette deuxième ligne.

Hors ligne

#7 06-06-2014 14:36:57

captnfab
Admin-Girafe
Lieu : /dev/random
Distrib. : Debian Stretch/Sid/Rc-Buggy
Noyau : Linux (≥ 4.3)
(G)UI : i3-wm (≥ 4.11)
Inscription : 07-07-2008
Site Web

Re : [Résolu] Pas de wifi à la sortie de veille

\o/

La première ligne indique de démarrer l'interface wlan0 automatiquement
La deuxième indique que c'est une interface à configurer via DHCP et que c'est ifupdown qui s'en charge.
À noter que si tu utilises NetworkManager ou Wicd, la 2e ligne doit effectivement être commentée (et je dirais que la première aussi).

captnfab,
Association Debian-Facile, bépo.
TheDoctor: Your wish is my command… But be careful what you wish for.

Hors ligne

#8 06-06-2014 15:08:55

Erlen
Membre
Distrib. : Jessie
Noyau : 3.16.0-4-amd64
(G)UI : openbox
Inscription : 16-04-2014

Re : [Résolu] Pas de wifi à la sortie de veille

Non surtout pas la première sinon à la moindre déconnexion network-manager est incapable de se reconnecter au wifi.

Hors ligne

#9 06-06-2014 15:28:47

captnfab
Admin-Girafe
Lieu : /dev/random
Distrib. : Debian Stretch/Sid/Rc-Buggy
Noyau : Linux (≥ 4.3)
(G)UI : i3-wm (≥ 4.11)
Inscription : 07-07-2008
Site Web

Re : [Résolu] Pas de wifi à la sortie de veille

C'est un comportement étonnant, je ne suis pas sûr de savoir dans quelle mesure c'est un bug et dans quelle mesure c'est une fonctionnalité smile

captnfab,
Association Debian-Facile, bépo.
TheDoctor: Your wish is my command… But be careful what you wish for.

Hors ligne

Pied de page des forums